Audio Stream Missing from Output File

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
digifuzzy
Posts: 2
Joined: Thu Jun 10, 2021 6:17 pm

Audio Stream Missing from Output File

Post by digifuzzy »

Description of problem or question:
Any attempt to encode produces a file missing an audio stream in the output.

Rebuilding handbrake and dependencies from source did not alter observations.
Reviewing log file produced an indication related to audio stream:

Code: Select all

encavcodecaudio: avcodec_send_frame failed
Term appears numerous times in log file. Web search with this term led to a reddit post where multiple individuals were reporting same observation. One reporter commented that based on their experience and usage of handbrake problem was related to recent update to ffmpeg version. A few persons reported downgradind ffmpeg version from 4.4 to 4.3.2 resolved the reported problem. Downgrading ffmpeg locally resolved missing audio stream.

Suspect that changes to ffmpeg handling of audio streams may not have been incorporated yet into handbrake.

Steps to reproduce the problem (If Applicable):
Always occurs when used.

HandBrake version (e.g., 1.0.0):
1.3.3
ffmpeg version: 4.4

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Gentoo X86_64 - kernel 5.10.27

HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

Handbrake Version: 1.3.3 (2021061000)
[02:42:38] gtkgui: Modified Preset: /General/Fast 720p30
[02:42:38] Starting work at: Thu Jun 10 02:42:38 2021

[02:42:38] 1 job(s) to process
[02:42:38] json job:
{
    "Audio": {
        "AudioList": [
            {
                "Bitrate": 160,
                "CompressionLevel": -1.0,
                "DRC": 0.0,
                "DitherMethod": "auto",
                "Encoder": "fdk_aac",
                "Gain": 0.0,
                "Mixdown": "stereo",
                "Name": "Stereo",
                "NormalizeMixLevel": false,
                "PresetEncoder": "fdk_aac",
                "Quality": -3.0,
                "Samplerate": 0,
                "Track": 0
            }
        ],
        "CopyMask": [
            "copy:aac"
        ],
        "FallbackEncoder": "fdk_aac"
    },
    "Destination": {
        "AlignAVStart": true,
        "ChapterList": [
            {
                "Duration": {
                    "Hours": 0,
                    "Minutes": 1,
                    "Seconds": 58,
                    "Ticks": 10649430
                },
                "Name": "00:00:00.000"
            },
            {
                "Duration": {
                    "Hours": 0,
                    "Minutes": 7,
                    "Seconds": 16,
                    "Ticks": 39219120
                },
                "Name": "00:01:58.243"
            },
            {
                "Duration": {
                    "Hours": 0,
                    "Minutes": 11,
                    "Seconds": 38,
                    "Ticks": 62815230
                },
                "Name": "00:09:14.095"
            },
            {
                "Duration": {
                    "Hours": 0,
                    "Minutes": 9,
                    "Seconds": 6,
                    "Ticks": 49106610
                },
                "Name": "00:20:51.959"
            },
            {
                "Duration": {
                    "Hours": 0,
                    "Minutes": 13,
                    "Seconds": 48,
                    "Ticks": 74549430
                },
                "Name": "00:29:57.587"
            },
            {
                "Duration": {
                    "Hours": 0,
                    "Minutes": 0,
                    "Seconds": 30,
                    "Ticks": 2678400
                },
                "Name": "00:43:45.998"
            }
        ],
        "ChapterMarkers": true,
        "File": "/home/user/Videos/output.mp4",
        "InlineParameterSets": false,
        "Mp4Options": {
            "IpodAtom": false,
            "Mp4Optimize": false
        },
        "Mux": "m4v"
    },
    "Filters": {
        "FilterList": [
            {
                "ID": 3,
                "Settings": {
                    "block-height": "16",
                    "block-thresh": "40",
                    "block-width": "16",
                    "filter-mode": "2",
                    "mode": "3",
                    "motion-thresh": "1",
                    "spatial-metric": "2",
                    "spatial-thresh": "1"
                }
            },
            {
                "ID": 4,
                "Settings": {
                    "mode": "7"
                }
            },
            {
                "ID": 6,
                "Settings": {
                    "mode": 2,
                    "rate": "27000000/900000"
                }
            },
            {
                "ID": 12,
                "Settings": {
                    "crop-bottom": 0,
                    "crop-left": 0,
                    "crop-right": 0,
                    "crop-top": 0,
                    "height": 720,
                    "width": 1280
                }
            }
        ]
    },
    "Metadata": {
        "Name": "NCIS.S02E01.See.No.Evil"
    },
    "PAR": {
        "Den": 1,
        "Num": 1
    },
    "SequenceID": 0,
    "Source": {
        "Angle": 0,
        "Path": "/home/user/Videos/input.mkv",
        "Range": {
            "End": 6,
            "Start": 1,
            "Type": "chapter"
        },
        "Title": 1
    },
    "Subtitle": {
        "Search": {
            "Burn": true,
            "Default": false,
            "Enable": true,
            "Forced": true
        },
        "SubtitleList": []
    },
    "Video": {
        "ColorFormat": 0,
        "ColorMatrix": 1,
        "ColorPrimaries": 1,
        "ColorRange": 1,
        "ColorTransfer": 1,
        "Encoder": "x264",
        "Level": "3.1",
        "Options": "",
        "Preset": "fast",
        "Profile": "main",
        "QSV": {
            "AsyncDepth": 4,
            "Decode": false
        },
        "Quality": 21.0,
        "Tune": "",
        "Turbo": false,
        "TwoPass": false
    }
}
[02:42:38] CPU: 
[02:42:38]  - logical processor count: 8
[02:42:38] hb_scan: path=/home/user/Videos/input.mkv, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
disc.c:333: failed opening UDF image /home/user/Videos/input.mkv
disc.c:437: error opening file BDMV/index.bdmv
disc.c:437: error opening file BDMV/BACKUP/index.bdmv
bluray.c:2646: nav_get_title_list(/home/user/Videos/input.mkv/) failed
[02:42:38] bd: not a bd - trying as a stream/file instead
libdvdread: DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav: vm: vm: failed to read VIDEO_TS.IFO
[02:42:38] dvd: not a dvd - trying as a stream/file instead
Input #0, matroska,webm, from '/home/user/Videos/input.mkv':
  Metadata:
    CREATION_TIME   : 2020-03-01T14:47:21Z
    ENCODER         : Lavf57.7.2
  Duration: 00:44:15.76, start: 0.000000, bitrate: 3026 kb/s
  Chapters:
    Chapter #0:0: start 0.000000, end 118.327000
      Metadata:
        title           : 00:00:00.000
    Chapter #0:1: start 118.327000, end 554.095000
      Metadata:
        title           : 00:01:58.243
    Chapter #0:2: start 554.095000, end 1252.042000
      Metadata:
        title           : 00:09:14.095
    Chapter #0:3: start 1252.042000, end 1797.671000
      Metadata:
        title           : 00:20:51.959
    Chapter #0:4: start 1797.671000, end 2625.998000
      Metadata:
        title           : 00:29:57.587
    Chapter #0:5: start 2625.998000, end 2655.737000
      Metadata:
        title           : 00:43:45.998
  Stream #0:0: Video: h264 (Main), yuv420p(tv, bt709, progressive), 1280x720 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 180k tbc (default)
  Stream #0:1(eng): Audio: aac (LC), 48000 Hz, stereo, fltp (default)
    Metadata:
      title           : Stereo
  Stream #0:2(eng): Subtitle: ass
[02:42:38] scan: decoding previews for title 1
[02:42:38] scan: audio 0x1: aac, rate=48000Hz, bitrate=1 English (AAC LC) (2.0 ch)
[02:42:38] scan: 10 previews, 1280x720, 23.976 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[02:42:38] libhb: scan thread found 1 valid title(s)
[02:42:38] Skipping subtitle scan.  No suitable subtitle tracks.
[02:42:38] Starting Task: Encoding Pass
[02:42:38] Skipping crop/scale filter
[02:42:38] job configuration:
[02:42:38]  * source
[02:42:38]    + /home/user/Videos/input.mkv
[02:42:38]    + title 1, chapter(s) 1 to 6
[02:42:38]    + container: matroska,webm
[02:42:38]    + data rate: 3026 kbps
[02:42:38]  * destination
[02:42:38]    + /home/user/Videos/output.mp4
[02:42:38]    + container: MPEG-4 (libavformat)
[02:42:38]      + align initial A/V stream timestamps
[02:42:38]      + chapter markers
[02:42:38]  * video track
[02:42:38]    + decoder: h264
[02:42:38]    + filters
[02:42:38]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[02:42:38]      + Decomb (mode=39)
[02:42:38]      + Framerate Shaper (mode=2:rate=27000000/900000)
[02:42:38]        + frame rate: 23.976 fps -> peak rate limited to 30.000 fps
[02:42:38]    + Output geometry
[02:42:38]      + storage dimensions: 1280 x 720
[02:42:38]      + pixel aspect ratio: 1 : 1
[02:42:38]      + display dimensions: 1280 x 720
[02:42:38]    + encoder: H.264 (libx264)
[02:42:38]      + preset:  fast
[02:42:38]      + profile: main
[02:42:38]      + level:   3.1
[02:42:38]      + quality: 21.00 (RF)
[02:42:38]      + color profile: 1-1-1
[02:42:38]  * audio track 1
[02:42:38]    + name: Stereo
[02:42:38]    + decoder: English (AAC LC) (2.0 ch) (track 1, id 0x1)
[02:42:38]      + samplerate: 48000 Hz
[02:42:38]    + mixdown: Stereo
[02:42:38]    + dither: triangular
[02:42:38]    + encoder: AAC (libfdk_aac)
[02:42:38]      + bitrate: 160 kbps, samplerate: 48000 Hz
[02:42:38] sync: expecting 63674 video frames
[02:42:38] encx264: min-keyint: 24, keyint: 240
[02:42:38] encx264: encoding at constant RF 21.000000
[02:42:38] encx264: unparsed options: level=3.1:ref=2:8x8dct=0:weightp=1:subme=6:vbv-bufsize=14000:vbv-maxrate=14000:rc-lookahead=30
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast LZCNT SSSE3 SSE4.2 AVX XOP FMA4
x264 [info]: profile Main, level 3.1, 4:2:0, 8-bit
[02:42:38] sync: first pts video is 0
[02:42:38] sync: "00:00:00.000" (1) at frame 1 time 0
[02:42:38] sync: first pts audio 0x1 is 0
[02:42:38] encavcodecaudio: avcodec_send_frame failed
... above line repeats to end of log file (> 3M # of lines)
[02:53:51] encavcodecaudio: avcodec_send_frame failed
[02:53:51] work: average encoding speed for job is 49.817905 fps
[02:53:51] comb detect: heavy 135 | light 77 | uncombed 33285 | total 33497
[02:53:51] decomb: deinterlaced 135 | blended 77 | unfiltered 33276 | total 33488
[02:53:51] vfr: 33481 frames output, 0 dropped and 0 duped for CFR/PFR
[02:53:51] vfr: lost time: 0 (0 frames)
[02:53:51] vfr: gained time: 0 (0 frames) (0 not accounted for)
[02:53:51] aac-decoder done: 65620 frames, 0 decoder errors
[02:53:51] h264-decoder done: 33553 frames, 0 decoder errors
[02:53:51] sync: got 33512 frames, 63674 expected
[02:53:51] sync: framerate min 23.976 fps, max 23.976 fps, avg 23.976 fps
x264 [info]: frame I:713   Avg QP:17.65  size: 76348
x264 [info]: frame P:9502  Avg QP:20.29  size: 20114
x264 [info]: frame B:23218 Avg QP:21.92  size:  8186
x264 [info]: consecutive B-frames:  4.1%  8.7%  3.4% 83.8%
x264 [info]: mb I  I16..4: 33.5%  0.0% 66.5%
x264 [info]: mb P  I16..4: 12.2%  0.0%  7.3%  P16..4: 46.8% 15.6%  6.2%  0.0%  0.0%    skip:11.8%
x264 [info]: mb B  I16..4:  6.4%  0.0%  0.7%  B16..8: 36.4%  6.7%  0.4%  direct:14.5%  skip:34.9%  L0:43.2% L1:49.8% BI: 7.0%
x264 [info]: coded y,uvDC,uvAC intra: 39.6% 80.2% 32.7% inter: 11.6% 41.0% 2.5%
x264 [info]: i16 v,h,dc,p: 37% 19% 19% 25%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 25% 19% 19%  6%  7%  7%  6%  6%  4%
x264 [info]: i8c dc,h,v,p: 51% 20% 21%  7%
x264 [info]: Weighted P-Frames: Y:1.1% UV:0.6%
x264 [info]: ref P L0: 71.6% 28.4%
x264 [info]: ref B L0: 86.2% 13.8%
x264 [info]: ref B L1: 96.8%  3.2%
x264 [info]: kb/s:2499.22
[02:53:51] mux: track 0, 33432 frames, 435580392 bytes, 2499.04 kbps, fifo 4096
[02:53:51] mux: track 1, 0 frames, 0 bytes, 0.00 kbps, fifo 8
[02:53:51] Finished work at: Thu Jun 10 02:53:51 2021

[02:53:52] libhb: work result = 1
User avatar
s55
HandBrake Team
Posts: 9981
Joined: Sun Dec 24, 2006 1:05 pm

Re: Audio Stream Missing from Output File

Post by s55 »

ffmpeg 4.4 is not supported by HandBrake 1.3.3

Note, HandBrake ships ffmpeg statically linked in, so if your version of HandBrake is using system ffmpeg, then it's blacklisted build and shouldn't be used as it'll also be missing all our patches for ffmpeg so other functionality will also be broken regardless.
digifuzzy
Posts: 2
Joined: Thu Jun 10, 2021 6:17 pm

Re: Audio Stream Missing from Output File

Post by digifuzzy »

Will forward this information to package maintainer.
Thank you.
Post Reply