Procedure to install QSV?

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
hand123
Posts: 3
Joined: Sat Dec 19, 2020 7:41 pm

Procedure to install QSV?

Post by hand123 »

Description of problem or question:
Newbie and un experimented command line user, I am looking for a complete procedure to install the QSV plugin on Handbrake 1.3.3 Linux mint 20.

Steps to reproduce the problem (If Applicable):
#1. I installed the Handbrake PPA to get the 1.3.3 revision in synaptic.
#2. Installed the 1.3.3 revision in synaptic. (not the flatpak in software manager)
#3. I downloaded the QSV plugin from the following address
https://handbrake.fr/rotation.php?file= ... 64.flatpak
#4. In the terminal I did this to install the file: flatpak install --Plugin.HandBrake.IntelMediaSDK-1.3.3-x86_64.flatpak
--> I had a confirmation in the terminal that the .flatpak file was installed successfully.
#5. But I don't see the QSV encoder in the handbrake "video" section.

I have these options only in the "video encoder" roll down menu.
h.264
h.264 (10 bit)
h.265
h.265 (10 bit)
h.265 (12 bit)
Mpeg 4
Mpeg 2

HandBrake version (e.g., 1.0.0):
1.3.3

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):

Code: Select all

System:
  Kernel: 5.4.0-52-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 wm: muffin 4.6.3 dm: LightDM 1.30.0 
  Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME B360M-A v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 2603 date: 10/11/2019 
CPU:
  Topology: 6-Core model: Intel Core i5-8400 bits: 64 type: MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 33599 
  Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e92 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.8 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.4.0-52-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 2.06 TiB used: 966.84 GiB (45.8%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS250G2B0C-00PXH0 
  size: 232.89 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 211070WD 
  scheme: GPT 
  ID-2: /dev/sda vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 0001 
  ID-3: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0 
  size: 14.41 GiB serial: <filter> scheme: MBR 
Partition:
  ID-1: / size: 227.74 GiB used: 10.76 GiB (4.7%) fs: ext4 
  dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 27.8 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/brandonsnider-cdrtools-focal.list 
  1: deb http://ppa.launchpad.net/brandonsnider/cdrtools/ubuntu focal main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
  Active apt repos in: /etc/apt/sources.list.d/stebbins-handbrake-releases-focal.list 
  1: deb http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu focal main
  Active apt repos in: /etc/apt/sources.list.d/tehnick-direct-connect-focal.list 
  1: deb http://ppa.launchpad.net/tehnick/dict/ubuntu focal main
Info:
  Processes: 247 Uptime: 46m Memory: 15.48 GiB used: 1.99 GiB (12.8%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38 

HandBrake Activity Log ***required*** (see How-to get an activity log)

I did nothing so far so there is no activity log.
rollin_eng
Veteran User
Posts: 3708
Joined: Wed May 04, 2011 11:06 pm

Re: Procedure to install QSV?

Post by rollin_eng »

hand123
Posts: 3
Joined: Sat Dec 19, 2020 7:41 pm

Re: Procedure to install QSV?

Post by hand123 »

rollin_eng wrote: Sat Dec 19, 2020 9:40 pm Could try this:

https://handbrake.fr/docs/en/1.3.0/deve ... buntu.html
Ok hello!

Thanks for the information, I read the procedure but I have this question to validate if I understand correctly. The link you gave me is a page to install dependencies in order to build Handbrake just after (It's not clear for me yet if building handbrake = installing handbrake) .

At the end of the procedure they write:
Ubuntu is now prepared to build HandBrake.

First, should I uninstal the current Handbrake 1.3.3 from synaptic then start the procedure of installing the dependencies manually then building Handbrake manually after?

Or I can just install the dependencies to add the missing ones? While keeping the Handbrake installation from synaptic?
hand123
Posts: 3
Joined: Sat Dec 19, 2020 7:41 pm

Re: Procedure to install QSV?

Post by hand123 »

Ok someone showed me how to do it so I'll conclude at least.

2020-12-21
Beginners notes so some things might be wrong but ultimately, it worked, I can now transcode with QVS with Mint 20.

Previously I tried to install the QSV Flatpak package with Handbrake installed from synaptic +PPA version 1.3.3. The QSV plugin is not compatible with handbrake installed from Synaptic, that's why we suspect it didn't worked. The intel plugin flatpak It's compatible with handbrake installed from the Flatpak in software source. (Only?)

I kept the handbrake PPA anyway and uninstalled handbrake 1.3.3 from synaptic first.

Then I installed flatpak handbrake from the software manager. (2.7gb installation in my case against 52mb for the Synaptic installation)

Then I had to install quick sync plugin downloaded from this address
https://handbrake.fr/rotation.php?file= ... 64.flatpak

By simply double clicking the file. Perhaps there was a small terminal procedure before but I can't remember, I think I just double clicked the file and it installed.
HandBrake.IntelMediaSDK-1.3.3-x86_64.flatpak

So now it works, I have the encoders H.244 (Intel QVS) and H256 (Intel QVS) in the video tab of handbrake in "video encoder" for Mint 20 Cinnamon.

============
OBSERVATIONS:
I tested it a bit yesterday and today encoding with the CPU and GPU is very fast but I am not going to use these encoders because the file size are simply way too large.

CPU only test:
Converting one MPG file 166mb total with H.265 (Non QSV) encoder with a quality factor of RF25 I get a final file of 10.9 mb file with frankly a very similar video quality as the original file.

QSS test:
Converting one MPG file 166mb total with H.265 (Intel QSV) encoder with a quality factor of ICQ28 I get a final file of 14.7mb but the video quality is noticeably inferior then the original file, while the file size, it's much larger, on a 3 gb file the difference is massive.

I'll keep using the regular CPU only encoders H.265 and H.264, wait a bit longer, the old encoders are still on the top of their game in my opinion.
Post Reply