Intel Hardware Accelerated Codecs not Listed

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
mrzippy
Posts: 6
Joined: Thu Apr 02, 2020 4:20 pm

Intel Hardware Accelerated Codecs not Listed

Post by mrzippy »

Description of problem or question:
I do not see hardware accelerated codecs offered, I can see hardware acceleration is available through VA-API although I don't believe Handbrake uses this library to access Intel Hardware Acceleration. Is there something I need to install to get this to work in handbrake?

Apologies I am a Linux novice, but I have done a lot of searching and can't find the answer. The Totem video player uses the hardware acceleration, VA-API lists the codecs supported too. Processor is the Celeron J4105 that supports the stated formats in the VA-INFO output according to Intel.

Steps to reproduce the problem (If Applicable):
Installed latest version of Handbrake.

HandBrake version (e.g., 1.0.0):
1.3.1

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Ubuntu 19.10

HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

Handbrake Log
[17:25:45] gtkgui: HandBrake 1.3.1 (2020020500) - Linux x86_64 - https://handbrake.fr
Cannot load libnvidia-encode.so.1
[17:25:45] hb_init: starting libhb thread
[17:25:45] hb_init: starting libhb thread
[17:25:45] hb_init: starting libhb thread

VA-API Info
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_4
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.5 (libva 2.5.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Gemini Lake - 2.3.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSliceLP
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointEncSliceLP
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointEncSliceLP
      VAProfileH264MultiviewHigh      :	VAEntrypointVLD
      VAProfileH264MultiviewHigh      :	VAEntrypointEncSlice
      VAProfileH264StereoHigh         :	VAEntrypointVLD
      VAProfileH264StereoHigh         :	VAEntrypointEncSlice
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc
      VAProfileJPEGBaseline           :	VAEntrypointVLD
      VAProfileJPEGBaseline           :	VAEntrypointEncPicture
      VAProfileVP8Version0_3          :	VAEntrypointVLD
      VAProfileVP8Version0_3          :	VAEntrypointEncSlice
      VAProfileHEVCMain               :	VAEntrypointVLD
      VAProfileHEVCMain               :	VAEntrypointEncSlice
      VAProfileHEVCMain10             :	VAEntrypointVLD
      VAProfileHEVCMain10             :	VAEntrypointEncSlice
      VAProfileVP9Profile0            :	VAEntrypointVLD
      VAProfileVP9Profile0            :	VAEntrypointEncSlice
      VAProfileVP9Profile2            :	VAEntrypointVLD

Woodstock
Veteran User
Posts: 3661
Joined: Tue Aug 27, 2013 6:39 am

Re: Intel Hardware Accelerated Codecs not Listed

Post by Woodstock »

What source are you using for Handbrake? The intel QSV libraries ONLY available in the Nightly Builds section, under "Other distros". Look for Plugin.HandBrake.IntelMediaSDK*.

mrzippy
Posts: 6
Joined: Thu Apr 02, 2020 4:20 pm

Re: Intel Hardware Accelerated Codecs not Listed

Post by mrzippy »

I've tried installing via: -

1. Adding PPA for release Handbrake
2. Adding PPA for snapshot Handbrake
3. Via FlatPak including downloading the QSV plugin.

Unless there is something I have to do when I download the QSV plugin?

mrzippy
Posts: 6
Joined: Thu Apr 02, 2020 4:20 pm

Re: Intel Hardware Accelerated Codecs not Listed

Post by mrzippy »

Scrub that, just tried via FlatPak again, including the plugin and it worked this time!

Thanks for the help, I now see QSV options!

mrzippy
Posts: 6
Joined: Thu Apr 02, 2020 4:20 pm

Re: Intel Hardware Accelerated Codecs not Listed

Post by mrzippy »

Cancel that, it fails to encode when selecting the QSV codec.

I have pasted the last part of the activity log, can anyone help?

Code: Select all

[16:23:13] scan: supported video decoders: avcodec qsv
[16:23:13] libhb: scan thread found 1 valid title(s)
[16:23:13] Starting Task: Encoding Pass
[16:23:13] job configuration:
[16:23:13]  * source
[16:23:13]    + /media/media_hd/xxx.mkv
[16:23:13]    + title 1, chapter(s) 2 to 2
[16:23:13]    + container: matroska,webm
[16:23:13]    + data rate: 25600 kbps
[16:23:13]  * destination
[16:23:13]    + /home/neil/Videos/xxx.m4v
[16:23:13]    + container: MPEG-4 (libavformat)
[16:23:13]  * video track
[16:23:13]    + decoder: h264
[16:23:13]    + filters
[16:23:13]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[16:23:13]      + Decomb (mode=39)
[16:23:13]      + Framerate Shaper (mode=2:rate=27000000/900000)
[16:23:13]        + frame rate: 23.976 fps -> peak rate limited to 30.000 fps
[16:23:13]      + Crop and Scale (width=960:height=540:crop-top=138:crop-bottom=138:crop-left=0:crop-right=0)
[16:23:13]        + source: 1920 * 1080, crop (138/138/0/0): 1920 * 804, scale: 960 * 540
[16:23:13]    + Output geometry
[16:23:13]      + storage dimensions: 960 x 540
[16:23:13]      + pixel aspect ratio: 90 : 67
[16:23:13]      + display dimensions: 1289 x 540
[16:23:13]    + encoder: H.264 (Intel Media SDK)
[16:23:13]      + preset:  balanced
[16:23:13]      + profile: auto
[16:23:13]      + level:   auto
[16:23:13]      + quality: 20.00 (ICQ)
[16:23:13]      + color profile: 1-1-1
[16:23:13]  * audio track 1
[16:23:13]    + name: Surround 5.1
[16:23:13]    + decoder: English (DTS-HD MA) (5.1 ch) (track 1, id 0x1)
[16:23:13]      + samplerate: 48000 Hz
[16:23:13]    + mixdown: Stereo
[16:23:13]    + dither: triangular
[16:23:13]    + encoder: AAC (libavcodec)
[16:23:13]      + bitrate: 160 kbps, samplerate: 48000 Hz
[16:23:13]  * audio track 2
[16:23:13]    + name: Surround 5.1
[16:23:13]    + decoder: English (DTS-HD MA) (5.1 ch) (track 1, id 0x1)
[16:23:13]      + samplerate: 48000 Hz
[16:23:13]    + mixdown: 5.1 Channels
[16:23:13]    + dither: triangular
[16:23:13]    + encoder: AC3 (libavcodec)
[16:23:13]      + bitrate: 640 kbps, samplerate: 48000 Hz
[16:23:13] sync: expecting 10005 video frames
[16:23:13] hb_display_init: using VA driver 'iHD'
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/intel-vaapi-driver/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_5
libva info: va_openDriver() returns 0
[16:23:13] encqsvInit: using encode-only path
[16:23:13] encqsvInit: H.264/AVC High profile @ level 3.1
[16:23:13] encqsvInit: TargetUsage 4 AsyncDepth 4
[16:23:13] encqsvInit: GopRefDist 3 GopPicSize 24 NumRefFrame 1
[16:23:13] encqsvInit: BFramesMax 2 BRefType off
[16:23:13] encqsvInit: RateControlMethod ICQ ICQQuality 20
[16:23:13] sync: first pts video is 0
[16:23:13] sync: first pts audio 0x1 is 360
[16:23:13] sync: first pts audio 0x1 is 360
[16:23:13] sync: "Chapter 2" (2) at frame 3 time 7507
[16:23:14] qsv_enc_init: using 'hardware (1) via VAAPI' implementation, API: 1.30
[16:23:14] encqsv: MFXVideoENCODE_EncodeFrameAsync failed (-21)
[16:23:14] encqsv: MFXVideoENCODE_EncodeFrameAsync failed (-21)
[16:23:14] work: average encoding speed for job is 0.000000 fps
[16:23:14] comb detect: heavy 0 | light 9 | uncombed 31 | total 40
[16:23:15] decomb: deinterlaced 0 | blended 5 | unfiltered 26 | total 31
[16:23:15] vfr: 24 frames output, 0 dropped and 0 duped for CFR/PFR
[16:23:15] vfr: lost time: 0 (0 frames)
[16:23:15] vfr: gained time: 0 (0 frames) (0 not accounted for)
[16:23:15] dca-decoder done: 373 frames, 0 decoder errors
[16:23:15] dca-decoder done: 373 frames, 0 decoder errors
[16:23:15] h264-decoder done: 92 frames, 0 decoder errors
[16:23:15] sync: got 56 frames, 10005 expected
[16:23:15] sync: framerate min 23.976 fps, max 23.976 fps, avg 23.976 fps
[16:23:15] mux: track 0, 5 frames, 145801 bytes, 499.39 kbps, fifo 8
[16:23:15] mux: track 1, 108 frames, 45571 bytes, 156.09 kbps, fifo 128
[16:23:15] mux: track 2, 72 frames, 184320 bytes, 631.32 kbps, fifo 128
[16:23:15] Finished work at: Fri Apr  3 16:23:15 2020

[16:23:15] libhb: work result = 4

Woodstock
Veteran User
Posts: 3661
Joined: Tue Aug 27, 2013 6:39 am

Re: Intel Hardware Accelerated Codecs not Listed

Post by Woodstock »

Do you have a log from using x264 instead of QSV? It seems strange that it can only see 56 frames of the input. You are not using QSV to decode the file, so the problem of a corrupted read is less likely.

User avatar
JohnAStebbins
HandBrake Team
Posts: 5581
Joined: Sat Feb 09, 2008 7:21 pm

Re: Intel Hardware Accelerated Codecs not Listed

Post by JohnAStebbins »

I just downloaded and installed the HandBrake flatpak and the MediaSDK pluging from the nightly builds page and they are working fine for me.
I tried to reproduce you're particular video settings as closely as possible including resolution and pixel aspect in case the encoder was choking on a particular setting.

May be a bad interaction with your particular hardware?

Code: Select all

Handbrake Version: 20200329142321-9394acb-master (2020032901)
[09:57:38] gtkgui: Modified Preset: /General/Fast 1080p30
[09:57:38] Starting work at: Fri Apr  3 09:57:38 2020

[09:57:38] 1 job(s) to process
[09:57:38] json job:
{
    "Audio": {
        "AudioList": [
            {
                "Bitrate": 160,
                "CompressionLevel": -1.0,
                "DRC": 0.0,
                "DitherMethod": "auto",
                "Encoder": "av_aac",
                "Gain": 0.0,
                "Mixdown": "stereo",
                "NormalizeMixLevel": false,
                "PresetEncoder": "av_aac",
                "Quality": -3.0,
                "Samplerate": 0,
                "Track": 0
            }
        ],
        "CopyMask": [
            "copy:aac"
        ],
        "FallbackEncoder": "av_aac"
    },
    "Destination": {
        "AlignAVStart": true,
        "ChapterList": [
            {
                "Duration": {
                    "Hours": 0,
                    "Minutes": 9,
                    "Seconds": 38,
                    "Ticks": 52099416
                },
                "Name": "Chapter 1"
            }
        ],
        "ChapterMarkers": false,
        "File": "/home/jstebbins/Videos/Big Buck Bunny - 1080p24.m4v",
        "InlineParameterSets": false,
        "Mp4Options": {
            "IpodAtom": false,
            "Mp4Optimize": false
        },
        "Mux": "m4v"
    },
    "Filters": {
        "FilterList": [
            {
                "ID": 3,
                "Settings": {
                    "block-height": "16",
                    "block-thresh": "40",
                    "block-width": "16",
                    "filter-mode": "2",
                    "mode": "3",
                    "motion-thresh": "1",
                    "spatial-metric": "2",
                    "spatial-thresh": "1"
                }
            },
            {
                "ID": 4,
                "Settings": {
                    "mode": "7"
                }
            },
            {
                "ID": 6,
                "Settings": {
                    "mode": 2,
                    "rate": "27000000/900000"
                }
            },
            {
                "ID": 12,
                "Settings": {
                    "crop-bottom": 138,
                    "crop-left": 0,
                    "crop-right": 0,
                    "crop-top": 138,
                    "height": 540,
                    "width": 960
                }
            }
        ]
    },
    "Metadata": {
        "Name": "Big Buck Bunny - 1080p24"
    },
    "PAR": {
        "Den": 67,
        "Num": 90
    },
    "SequenceID": 0,
    "Source": {
        "Angle": 0,
        "Path": "/home/jstebbins/Videos/Samples/Big Buck Bunny - 1080p24.ts",
        "Range": {
            "End": 1,
            "Start": 1,
            "Type": "chapter"
        },
        "Title": 1
    },
    "Subtitle": {
        "Search": {
            "Burn": true,
            "Default": false,
            "Enable": false,
            "Forced": false
        },
        "SubtitleList": []
    },
    "Video": {
        "ColorFormat": 0,
        "ColorMatrix": 1,
        "ColorPrimaries": 1,
        "ColorRange": 1,
        "ColorTransfer": 1,
        "Encoder": "qsv_h264",
        "Level": "auto",
        "Options": "",
        "Preset": "balanced",
        "Profile": "auto",
        "QSV": {
            "AsyncDepth": 4,
            "Decode": false
        },
        "Quality": 16.0,
        "Tune": "",
        "Turbo": false,
        "TwoPass": false
    }
}
[09:57:38] CPU: Intel(R) Core(TM) i9-9880H CPU @ 2.30GHz
[09:57:38]  - Intel microarchitecture Kaby Lake
[09:57:38]  - logical processor count: 16
[09:57:38] Intel Quick Sync Video support: yes
[09:57:38]  - Intel Media SDK hardware: API 1.30 (minimum: 1.3)
[09:57:38]  - H.264 encoder: yes
[09:57:38]     - preferred implementation: hardware (any) via ANY
[09:57:38]     - capabilities (hardware):  breftype icq+la+i+downs vsinfo opt1 opt2+mbbrc+extbrc+trellis+ib_adapt+nmpslice
[09:57:38]  - H.265 encoder: yes (8bit: yes, 10bit: yes)
[09:57:38]     - preferred implementation: hardware (any) via ANY
[09:57:38]     - capabilities (hardware):  bpyramid icq vsinfo opt1
[09:57:38] hb_scan: path=/home/jstebbins/Videos/Samples/Big Buck Bunny - 1080p24.ts, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
disc.c:323: failed opening UDF image /home/jstebbins/Videos/Samples/Big Buck Bunny - 1080p24.ts
disc.c:424: error opening file BDMV/index.bdmv
disc.c:424: error opening file BDMV/BACKUP/index.bdmv
bluray.c:2585: nav_get_title_list(/home/jstebbins/Videos/Samples/Big Buck Bunny - 1080p24.ts/) failed
[09:57:38] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[09:57:38] dvd: not a dvd - trying as a stream/file instead
[09:57:38] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[09:57:38] Found the following PIDS
[09:57:38]     Video PIDS : 
[09:57:38]       0x1011 type H.264 (0x1b)
[09:57:38]     Audio PIDS : 
[09:57:38]       0x1100 type MPEG2 (0x4)
[09:57:38]     Subtitle PIDS : 
[09:57:38]     Other PIDS : 
[09:57:38]       0x1001 type Unknown (0xff) (PCR)
[09:57:38] stream id 0x1100 (type 0x4 substream 0x0) audio 0x1100
[09:57:38] scan: decoding previews for title 1
[09:57:38] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[09:57:38] scan: audio 0x1100: mp2, rate=48000Hz, bitrate=128000 Unknown (MPEG) (2.0 ch) (128 kbps)
[09:57:38] stream: 226 good frames, 0 errors (0%)
[09:57:38] scan: 10 previews, 1920x1080, 24.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[09:57:38] scan: supported video decoders: avcodec qsv
[09:57:39] libhb: scan thread found 1 valid title(s)
[09:57:39] Starting Task: Encoding Pass
[09:57:39] job configuration:
[09:57:39]  * source
[09:57:39]    + /home/jstebbins/Videos/Samples/Big Buck Bunny - 1080p24.ts
[09:57:39]    + title 1, chapter(s) 1 to 1
[09:57:39]  * destination
[09:57:39]    + /home/jstebbins/Videos/Big Buck Bunny - 1080p24.m4v
[09:57:39]    + container: MPEG-4 (libavformat)
[09:57:39]      + align initial A/V stream timestamps
[09:57:39]  * video track
[09:57:39]    + decoder: h264
[09:57:39]      + bitrate 200 kbps
[09:57:39]    + filters
[09:57:39]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[09:57:39]      + Decomb (mode=39)
[09:57:39]      + Framerate Shaper (mode=2:rate=27000000/900000)
[09:57:39]        + frame rate: 24.000 fps -> peak rate limited to 30.000 fps
[09:57:39]      + Crop and Scale (width=960:height=540:crop-top=138:crop-bottom=138:crop-left=0:crop-right=0)
[09:57:39]        + source: 1920 * 1080, crop (138/138/0/0): 1920 * 804, scale: 960 * 540
[09:57:39]    + Output geometry
[09:57:39]      + storage dimensions: 960 x 540
[09:57:39]      + pixel aspect ratio: 90 : 67
[09:57:39]      + display dimensions: 1289 x 540
[09:57:39]    + encoder: H.264 (Intel Media SDK)
[09:57:39]      + preset:  balanced
[09:57:39]      + profile: auto
[09:57:39]      + level:   auto
[09:57:39]      + quality: 16.00 (ICQ)
[09:57:39]      + color profile: 1-1-1
[09:57:39]  * audio track 1
[09:57:39]    + decoder: Unknown (MPEG) (2.0 ch) (128 kbps) (track 1, id 0x1100)
[09:57:39]      + bitrate: 128 kbps, samplerate: 48000 Hz
[09:57:39]    + mixdown: Stereo
[09:57:39]    + dither: triangular
[09:57:39]    + encoder: AAC (libavcodec)
[09:57:39]      + bitrate: 160 kbps, samplerate: 48000 Hz
[09:57:39] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[09:57:39] sync: expecting 13893 video frames
[09:57:39] hb_display_init: using VA driver 'iHD'
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/intel-vaapi-driver/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_5
libva info: va_openDriver() returns 0
[09:57:39] encqsvInit: using encode-only path
[09:57:39] encqsvInit: H.264/AVC High profile @ level 3.1
[09:57:39] encqsvInit: TargetUsage 4 AsyncDepth 4
[09:57:39] encqsvInit: GopRefDist 3 GopPicSize 24 NumRefFrame 1
[09:57:39] encqsvInit: BFramesMax 2 BRefType off
[09:57:39] encqsvInit: RateControlMethod ICQ ICQQuality 16
[09:57:39] sync: first pts video is 0
[09:57:39] sync: first pts audio 0x1100 is 0
[09:57:39] qsv_enc_init: using 'hardware (1) via VAAPI' implementation, API: 1.30
[09:59:02] hb_ts_stream_decode - eof
[09:59:02] reader: done. 1 scr changes
[09:59:03] work: average encoding speed for job is 170.142532 fps
[09:59:03] comb detect: heavy 363 | light 1463 | uncombed 12487 | total 14313
[09:59:03] decomb: deinterlaced 363 | blended 1463 | unfiltered 12487 | total 14313
[09:59:03] vfr: 14313 frames output, 0 dropped and 0 duped for CFR/PFR
[09:59:03] vfr: lost time: 0 (0 frames)
[09:59:03] vfr: gained time: 0 (0 frames) (0 not accounted for)
[09:59:03] stream: 14313 good frames, 0 errors (0%)
[09:59:03] mp2-decoder done: 24856 frames, 0 decoder errors
[09:59:03] h264-decoder done: 14313 frames, 0 decoder errors
[09:59:03] sync: got 14313 frames, 13893 expected
[09:59:03] sync: framerate min 24.000 fps, max 24.000 fps, avg 24.000 fps
[09:59:03] mux: track 0, 14313 frames, 232132126 bytes, 3112.82 kbps, fifo 1024
[09:59:03] mux: track 1, 27964 frames, 11974074 bytes, 160.57 kbps, fifo 2048
[09:59:03] Finished work at: Fri Apr  3 09:59:03 2020

[09:59:03] libhb: work result = 0

User avatar
Rodeo
HandBrake Team
Posts: 12531
Joined: Tue Mar 03, 2009 8:55 pm

Re: Intel Hardware Accelerated Codecs not Listed

Post by Rodeo »

mrzippy wrote:
Fri Apr 03, 2020 3:28 pm

Code: Select all

[16:23:14] encqsv: MFXVideoENCODE_EncodeFrameAsync failed (-21)
[16:23:14] encqsv: MFXVideoENCODE_EncodeFrameAsync failed (-21)
Can't remember what -21 means off the top of my head, but it's gotta be the relevant error.

mrzippy
Posts: 6
Joined: Thu Apr 02, 2020 4:20 pm

Re: Intel Hardware Accelerated Codecs not Listed

Post by mrzippy »

Hi

I am using a BD rip as the source and the Apple 540p Surround preset.

Below is the log from the x264 encode of the same file, hopefully I got the relevant bit.

I see it's using AVC QSV to decode, so that seems to be working.

Code: Select all

[15:57:26] scan: decoding previews for title 1
[15:57:26] scan: audio 0x1: dca, rate=48000Hz, bitrate=1 English (DTS-HD MA) (5.1 ch)
[15:57:26] scan: audio 0x2: dca, rate=48000Hz, bitrate=1536000 English (DTS) (5.1 ch) (1536 kbps)
[15:57:27] scan: 10 previews, 1920x1080, 23.976 fps, autocrop = 138/138/0/0, aspect 16:9, PAR 1:1
[15:57:27] scan: supported video decoders: avcodec qsv
[15:57:27] libhb: scan thread found 1 valid title(s)
[15:57:27] Starting Task: Encoding Pass
[15:57:27] job configuration:
[15:57:27]  * source
[15:57:27]    + /media/media_hd/Kids Movies (TV)/xxx.mkv
[15:57:27]    + title 1, chapter(s) 2 to 2
[15:57:27]    + container: matroska,webm
[15:57:27]    + data rate: 25600 kbps
[15:57:27]  * destination
[15:57:27]    + /home/neil/Videos/xxx.m4v
[15:57:27]    + container: MPEG-4 (libavformat)
[15:57:27]  * video track
[15:57:27]    + decoder: h264
[15:57:27]    + filters
[15:57:27]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[15:57:27]      + Decomb (mode=39)
[15:57:27]      + Framerate Shaper (mode=2:rate=27000000/900000)
[15:57:27]        + frame rate: 23.976 fps -> peak rate limited to 30.000 fps
[15:57:27]      + Crop and Scale (width=960:height=540:crop-top=138:crop-bottom=138:crop-left=0:crop-right=0)
[15:57:27]        + source: 1920 * 1080, crop (138/138/0/0): 1920 * 804, scale: 960 * 540
[15:57:27]    + Output geometry
[15:57:27]      + storage dimensions: 960 x 540
[15:57:27]      + pixel aspect ratio: 90 : 67
[15:57:27]      + display dimensions: 1289 x 540
[15:57:27]    + encoder: H.264 (libx264)
[15:57:27]      + preset:  medium
[15:57:27]      + options: qpmin=4:cabac=0:ref=2:b-pyramid=none:weightb=0:weightp=0:vbv-maxrate=9500:vbv-bufsize=9500
[15:57:27]      + profile: high
[15:57:27]      + level:   3.1
[15:57:27]      + quality: 20.00 (RF)
[15:57:27]      + color profile: 1-1-1
[15:57:27]  * audio track 1
[15:57:27]    + name: Surround 5.1
[15:57:27]    + decoder: English (DTS-HD MA) (5.1 ch) (track 1, id 0x1)
[15:57:27]      + samplerate: 48000 Hz
[15:57:27]    + mixdown: Stereo
[15:57:27]    + dither: triangular
[15:57:27]    + encoder: AAC (libavcodec)
[15:57:27]      + bitrate: 160 kbps, samplerate: 48000 Hz
[15:57:27]  * audio track 2
[15:57:27]    + name: Surround 5.1
[15:57:27]    + decoder: English (DTS-HD MA) (5.1 ch) (track 1, id 0x1)
[15:57:27]      + samplerate: 48000 Hz
[15:57:27]    + mixdown: 5.1 Channels
[15:57:27]    + dither: triangular
[15:57:27]    + encoder: AC3 (libavcodec)
[15:57:27]      + bitrate: 640 kbps, samplerate: 48000 Hz
[15:57:27] sync: expecting 10005 video frames
[15:57:27] encx264: min-keyint: 24, keyint: 240
[15:57:27] encx264: encoding at constant RF 20.000000
[15:57:27] encx264: unparsed options: qpmin=4:cabac=0:ref=2:b-pyramid=none:weightb=0:weightp=0:vbv-maxrate=9500:vbv-bufsize=9500:level=3.1
x264 [info]: using SAR=90/67
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
x264 [info]: profile High, level 3.1, 4:2:0, 8-bit
[15:57:27] sync: first pts video is 0
[15:57:27] sync: first pts audio 0x1 is 360
[15:57:27] sync: first pts audio 0x1 is 360
[15:57:27] sync: "Chapter 2" (2) at frame 3 time 7507

mrzippy
Posts: 6
Joined: Thu Apr 02, 2020 4:20 pm

Re: Intel Hardware Accelerated Codecs not Listed

Post by mrzippy »

I also just tested my Intel Media Stack installation from this site: -

https://github.com/Intel-Media-SDK/Medi ... -on-Ubuntu

Code: Select all

export LIBVA_DRIVER_NAME=iHD
wget https://fate-suite.libav.org/h264-conformance/AUD_MW_E.264

# Decode H.264 video stream w/ maximum speed
/usr/share/mfx/samples/sample_decode h264 -i AUD_MW_E.264

# Decode H.264 video stream and dump output YUV
/usr/share/mfx/samples/sample_decode h264 -i AUD_MW_E.264 -o AUD_MW_E.yuv -i420
# You can verify the result comparing with the following checksum:
# sha1sum AUD_MW_E.yuv
e17a3f8cfeeeb1cc46218c3c797d24dd84e82b59  AUD_MW_E.yuv

# Encode H.264 stream w/ Low Power encoder on gen9+ (skl+)
/usr/share/mfx/samples/sample_encode h264 \
  -w 176 -h 144 -f 30 -cqp -qpi 30 -qpp 30 -qpb 30 -qsv-ff  \
  -i AUD_MW_E.yuv -o encoded_AUD_MW_E.264
The checksum I get is different to the one shown, which indicates something is wrong doesn't it?

Post Reply