Unable to build HandBrake 1.3.0 on Ubuntu 16.04 (unsupported)

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
nhyone
Bright Spark User
Posts: 248
Joined: Fri Jul 24, 2015 4:13 am

Unable to build HandBrake 1.3.0 on Ubuntu 16.04 (unsupported)

Post by nhyone »

No Github account. Tried to create one, but it doesn't seem to like my password.

Am unable to compile on Ubuntu 16.04:

Code: Select all

/mnt/work/sources/HandBrake-1.3.0$ ./configure
probe: build tuple...(pass) x86_64-pc-linux-gnu
find: ar...(pass) /usr/bin/ar
find: cp...(pass) /bin/cp
find: gm4...(pass) /usr/bin/m4
find: mkdir...(pass) /bin/mkdir
find: gpatch...(pass) /usr/bin/patch
find: rm...(pass) /bin/rm
find: ranlib...(pass) /usr/bin/ranlib
find: strip...(pass) /usr/bin/strip
find: gtar...(pass) /bin/tar
find: python3...(pass) /sirius/tools2/bin/python3
find: gcc...(pass) /usr/bin/gcc
find: gmake...(pass) /usr/bin/make
find: autoconf...(pass) /usr/bin/autoconf
find: automake...(pass) /usr/bin/automake
find: libtool...(pass) /usr/bin/libtool
find: lipo...(fail) not found
find: pkg-config...(pass) /usr/bin/pkg-config
find: meson...(fail) not found
  : name[0] = meson
ERROR: unable to continue; configure stop.
lipo seems to be from Apple's toolchain?

User avatar
Ritsuka
HandBrake Team
Posts: 1107
Joined: Fri Jan 12, 2007 11:29 am

Re: HandBrake 1.3.0 comment Thread

Post by Ritsuka »

Yes, lipo if from Apple's toolchain, but it's not required on Ubuntu.
You need to install meson (required by the av1 decoder).

nhyone
Bright Spark User
Posts: 248
Joined: Fri Jul 24, 2015 4:13 am

Re: HandBrake 1.3.0 comment Thread

Post by nhyone »

Ritsuka wrote:
Sun Nov 10, 2019 7:30 am
Yes, lipo if from Apple's toolchain, but it's not required on Ubuntu.
You need to install meson (required by the av1 decoder).
I see, my mistake. Unfortunately, meson is outdated on Ubuntu 16.04:

Code: Select all

version probe: meson 0.47.0...(fail) 0.29.0
ERROR: minimum required meson version is 0.47.0 and /usr/bin/meson is 0.29.0
Trying to hack it doesn't work cos the syntax has changed.

Same for nasm:

Code: Select all

version probe: nasm 2.13.0...(fail) 0.0.0
ERROR: minimum required nasm version is 2.13.0 and /usr/bin/nasm is 0.0.0
The actual version is 2.11.08.

nhyone
Bright Spark User
Posts: 248
Joined: Fri Jul 24, 2015 4:13 am

Re: HandBrake 1.3.0 comment Thread

Post by nhyone »

Long story short, meson and nasm must be up-to-date (newer than what Ubuntu 16.04 offers). It doesn't work if version checking is bypassed.

Other missing packages can be installed normally.

User avatar
BradleyS
Moderator
Posts: 1766
Joined: Thu Aug 09, 2007 12:16 pm

Re: HandBrake 1.3.0 comment Thread

Post by BradleyS »

The last version officially supported on Ubuntu 16.04 was HandBrake 1.1.2: https://handbrake.fr/docs/en/1.3.0/tech ... ments.html

Bypassing version checks seems ill-advised. Nasm 2.13 or later and Meson 0.47.0 or later are certainly required! Hence the version checks.

nhyone
Bright Spark User
Posts: 248
Joined: Fri Jul 24, 2015 4:13 am

Re: HandBrake 1.3.0 comment Thread

Post by nhyone »

BradleyS wrote:
Sun Nov 10, 2019 9:29 am
Bypassing version checks seems ill-advised. Nasm 2.13 or later and Meson 0.47.0 or later are certainly required! Hence the version checks.
I'm optimistic. :wink:

In any case, if the latest meson (0.52.999) and nasm (2.14.02) are installed, it is possible to build the command-line version (no GUI, didn't try) of HandBrake 1.3.0 on Ubuntu 16.04.

The reason I'm want HB 1.3.0 is that I encountered a bug in HB 1.2.2. But I just found that it is not fixed (it is supposed to be). Will log an issue soon.

User avatar
BradleyS
Moderator
Posts: 1766
Joined: Thu Aug 09, 2007 12:16 pm

Re: Unable to build HandBrake 1.3.0 on Ubuntu 16.04 (unsupported)

Post by BradleyS »

Split topic and moved to *nix forum on account of 1.3.0 thread directions: "Please refrain from posting bugs or support requests in this thread."

Post Reply