Alpine dep missing

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
jerrad
New User
Posts: 1
Joined: Tue Sep 10, 2019 6:55 pm

Alpine dep missing

Post by jerrad » Tue Sep 10, 2019 7:04 pm

Description of problem or question:

Hello all, thanks for your time. I have been searching for this dep required by handbrake in the alpine build but been unable. the error is:

ERROR: unsatisfiable constraints:
so:libx265.so.169 (missing):
required by: handbrake-1.2.2-r1[so:libx265.so.169]

I have tried all these packages with no success
apk --no-cache add build-base x265-dev x264-dev x265 x264-libs x265-libs

These are the repos that it is using

http://dl-cdn.alpinelinux.org/alpine/edge/main" >> /etc/apk/repositories \
http://dl-cdn.alpinelinux.org/alpine/edge/community" >> /etc/apk/repositories \
http://dl-cdn.alpinelinux.org/alpine/edge/testing" >> /etc/apk/repositories \

Steps to reproduce the problem (If Applicable):

apk add handbrake



HandBrake version (e.g., 1.0.0):

handbrake-1.2.2-r1


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):

LinuxAlpine


HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

Please replace this text with the contents of your log file between the two code tags - OR -  provide a pastebin URL in place of these 3 lines.

User avatar
s55
HandBrake Team
Posts: 9524
Joined: Sun Dec 24, 2006 1:05 pm

Re: Alpine dep missing

Post by s55 » Tue Sep 10, 2019 7:11 pm

Try the flatpak build from our site. Save you a lot of drama.

We don't support broken 3rd party builds.

Post Reply