No Sound on Tumbleweed

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
leofich98
Posts: 1
Joined: Fri Aug 16, 2019 5:36 pm

No Sound on Tumbleweed

Post by leofich98 » Fri Aug 16, 2019 6:13 pm

Description of problem or question:
Since update from 1.2.1 to 1.2.2 sound source is identified
but no sound encoding except pass through

Steps to reproduce the problem (If Applicable):
Unfortunately yes, with every possible source: mp4, mkv, iso,

HandBrake version (e.g., 1.0.0):
1.2.2

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
openSUSE tumbleweed up-to-date with
packman repo for multimedia (vlc, codecs, ffmpeg, gstreamer e.t.c)

HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

Handbrake Version: 1.2.2 (2019022600)
[17:59:03] gtkgui: Modified Custom Preset: /My Presets/720x404-mp4
[17:59:03] 1 job(s) to process
[17:59:03] json job:
{
    "Audio": {
        "AudioList": [
            {
                "Bitrate": 64,
                "CompressionLevel": -1.0,
                "DRC": 1.675,
                "DitherMethod": "auto",
                "Encoder": "av_aac",
                "Gain": 0.5,
                "Mixdown": "mono",
                "NormalizeMixLevel": false,
                "PresetEncoder": "av_aac",
                "Quality": -3.0,
                "Samplerate": 0,
                "Track": 0
            }
        ],
        "CopyMask": [
            "copy:mp3",
            "copy:aac",
            "copy:ac3",
            "copy:dts",
            "copy:dtshd"
        ],
        "FallbackEncoder": "ac3"
    },
    "Destination": {
        "AlignAVStart": false,
        "ChapterList": [
            {
                "Name": ""
            }
        ],
        "ChapterMarkers": false,
        "File": "/home/user/media-videos/2019-08-12/2019-08-11/Elementary.mp4",
        "InlineParameterSets": false,
        "Mp4Options": {
            "IpodAtom": false,
            "Mp4Optimize": false
        },
        "Mux": "m4v"
    },
    "Filters": {
        "FilterList": [
            {
                "ID": 6,
                "Settings": {
                    "mode": 1
                }
            },
            {
                "ID": 11,
                "Settings": {
                    "crop-bottom": 0,
                    "crop-left": 0,
                    "crop-right": 0,
                    "crop-top": 0,
                    "height": 404,
                    "width": 720
                }
            }
        ]
    },
    "Metadata": {
        "Name": "Elementary"
    },
    "PAR": {
        "Den": 1,
        "Num": 1
    },
    "SequenceID": 0,
    "Source": {
        "Angle": 0,
        "Path": "/home/user/media-videos/2019-08-12/Elementary.mkv",
        "Range": {
            "End": 1,
            "Start": 1,
            "Type": "chapter"
        },
        "Title": 1
    },
    "Subtitle": {
        "Search": {
            "Burn": true,
            "Default": false,
            "Enable": false,
            "Forced": false
        },
        "SubtitleList": []
    },
    "Video": {
        "Bitrate": 450,
        "ColorMatrix": 6,
        "ColorPrimaries": 5,
        "ColorTransfer": 1,
        "Encoder": "x264",
        "Level": "4.0",
        "Options": "",
        "Preset": "medium",
        "Profile": "main",
        "QSV": {
            "AsyncDepth": 4,
            "Decode": false
        },
        "Tune": "",
        "Turbo": true,
        "TwoPass": true
    }
}
[17:59:03] CPU: Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz
[17:59:03]  - Intel microarchitecture Kaby Lake
[17:59:03]  - logical processor count: 12
[17:59:03] hb_scan: path=/home/user/media-videos/2019-08-12/Elementary.mkv, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
disc.c:323: failed opening UDF image /home/user/media-videos/2019-08-12/Elementary.mkv
disc.c:424: error opening file BDMV/index.bdmv
disc.c:424: error opening file BDMV/BACKUP/index.bdmv
bluray.c:2573: nav_get_title_list(/home/user/media-videos/2019-08-12/Elementary.mkv/) failed
[17:59:03] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.0
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[17:59:03] dvd: not a dvd - trying as a stream/file instead
Input #0, matroska,webm, from '/home/user/media-videos/2019-08-12/Elementary.mkv':
  Metadata:
    encoder         : libebml v1.3.6 + libmatroska v1.4.9
    creation_time   : 2019-08-10T09:00:38.000000Z
  Duration: 00:40:28.58, start: 0.000000, bitrate: 921 kb/s
    Stream #0:0: Video: h264 (High), yuv420p(progressive), 720x404, SAR 1:1 DAR 180:101, 25 fps, 25 tbr, 1k tbn, 50 tbc (default)
    Metadata:
      BPS-eng         : 535897
      DURATION-eng    : 00:40:28.560000000
      NUMBER_OF_FRAMES-eng: 60714
      NUMBER_OF_BYTES-eng: 162682508
      _STATISTICS_WRITING_APP-eng: mkvmerge v31.0.0 ('Dolores In A Shoestand') 64-bit
      _STATISTICS_WRITING_DATE_UTC-eng: 2019-08-10 09:00:38
      _STATISTICS_TAGS-eng: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
    Stream #0:1(ger): Audio: ac3, 48000 Hz, 5.1(side), fltp, 384 kb/s (default)
    Metadata:
      BPS-eng         : 384000
      DURATION-eng    : 00:40:28.576000000
      NUMBER_OF_FRAMES-eng: 75893
      NUMBER_OF_BYTES-eng: 116571648
      _STATISTICS_WRITING_APP-eng: mkvmerge v31.0.0 ('Dolores In A Shoestand') 64-bit
      _STATISTICS_WRITING_DATE_UTC-eng: 2019-08-10 09:00:38
      _STATISTICS_TAGS-eng: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
[17:59:03] scan: decoding previews for title 1
[17:59:03] scan: audio 0x1: ac3, rate=48000Hz, bitrate=384000 Deutsch (AC3) (5.1 ch)
[17:59:04] scan: 10 previews, 720x404, 25,000 fps, autocrop = 0/0/0/18, aspect 16:9, PAR 1:1
[17:59:04] libhb: scan thread found 1 valid title(s)
[17:59:04] starting job
[17:59:04] job configuration:
[17:59:04]  * source
[17:59:04]    + /home/user/media-videos/2019-08-12/Elementary.mkv
[17:59:04]    + title 1, chapter(s) 1 to 1
[17:59:04]    + container: matroska,webm
[17:59:04]    + data rate: 921 kbps
[17:59:04]  * destination
[17:59:04]    + /home/user/media-videos/2019-08-12/2019-08-11/Elementary rc.mp4
[17:59:04]    + container: MPEG-4 (libavformat)
[17:59:04]  * video track
[17:59:04]    + decoder: h264
[17:59:04]    + filters
[17:59:04]      + Framerate Shaper (mode=1)
[17:59:04]        + frame rate: 25,000 fps -> constant 25,000 fps
[17:59:04]      + Crop and Scale (width=720:height=404:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[17:59:04]        + source: 720 * 404, crop (0/0/0/0): 720 * 404, scale: 720 * 404
[17:59:04]    + Output geometry
[17:59:04]      + storage dimensions: 720 x 404
[17:59:04]      + pixel aspect ratio: 1 : 1
[17:59:04]      + display dimensions: 720 x 404
[17:59:04]    + encoder: H.264 (libx264)
[17:59:04]      + preset:  medium
[17:59:04]      + profile: main
[17:59:04]      + level:   4.0
[17:59:04]      + bitrate: 450 kbps, pass: 1
[17:59:04]      + fast first pass
[17:59:04]      + options: ref=1:8x8dct=0:me=dia:trellis=0
[17:59:04]                 analyse=i4x4 (if originally enabled, else analyse=none)
[17:59:04]                 subq=2 (if originally greater than 2, else subq unchanged)
[17:59:04]      + color profile: 5-1-6
[17:59:04]  * audio track 1
[17:59:04]    + decoder: Deutsch (AC3) (5.1 ch) (track 1, id 0x1)
[17:59:04]      + bitrate: 384 kbps, samplerate: 48000 Hz
[17:59:04]    + mixdown: Mono
[17:59:04]    + gain: 0dB
[17:59:04]    + dynamic range compression: 1,675000
[17:59:04]    + dither: triangular
[17:59:04]    + encoder: AAC (libavcodec)
[17:59:04]      + bitrate: 64 kbps, samplerate: 48000 Hz
[17:59:04] sync: expecting 60714 video frames
[17:59:04] encx264: encoding at average bitrate 450
[17:59:04] encx264: unparsed options: level=4.0:8x8dct=0:vbv-bufsize=25000:vbv-maxrate=20000
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x264 [info]: profile Main, level 4.0
[17:59:04] hb_audio_resample_update: swr_init() failed (Das Argument ist ungültig)
[17:59:04] decavcodec: hb_audio_resample_update() failed
repeated many times
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
repeated many times
[17:59:04] sync: first pts video is 0
[17:59:04] sync: Chapter 1 at frame 1 time 0
[17:59:04] decavcodec: hb_audio_resample_update() failed
repeated many times
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
repeated many times
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
repeated many times
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:04] decavcodec: hb_audio_resample_update() failed
[17:59:04] decavcodec: hb_audio_resample_update() failed
repeated many times
[17:59:04] decavcodec: hb_audio_resample_update() failed
[17:59:04] decavcodec: hb_audio_resample_update() failed
[17:59:04] decavcodec: hb_audio_resample_update() failed
[17:59:04] decavcodec: hb_audio_resample_update() failed
[17:59:04] decavcodec: hb_audio_resample_update() failed
[17:59:04] decavcodec: hb_audio_resample_update() failed
[17:59:04] decavcodec: hb_audio_resample_update() failed
[17:59:04] decavcodec: hb_audio_resample_update() failed
[17:59:04] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[17:59:06] hb_audio_resample_update: swr_init() failed (Das Argument ist ungültig)
[17:59:06] Last error repeated 1292 times
[17:59:06] hb_audio_resample_update: swr_init() failed (Das Argument ist ungültig)
[17:59:06] decavcodec: hb_audio_resample_update() failed
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[17:59:06] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f746000f7c0] Requested input sample rate 0 is invalid
[SWR @ 0x7f742800c500] Requested input sample rate 0 is invalid
[18:01:50] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f742800c400] Requested input sample rate 0 is invalid
[18:01:50] decavcodec: hb_audio_resample_update() failed
[SWR @ 0x7f742800c500] Requested input sample rate 0 is invalid
[18:01:50] decavcodec: hb_audio_resample_update() failed
[18:01:51] work: average encoding speed for job is 565,097778 fps
[18:01:51] vfr: 60714 frames output, 0 dropped and 0 duped for CFR/PFR
[18:01:51] vfr: lost time: 0 (0 frames)
[18:01:51] vfr: gained time: 0 (0 frames) (0 not accounted for)
[18:01:51] ac3-decoder done: 0 frames, 0 decoder errors
[18:01:51] h264-decoder done: 60714 frames, 0 decoder errors
[18:01:51] sync: got 60714 frames, 60714 expected
[18:01:51] sync: framerate min 25,000 fps, max 25,000 fps, avg 25,000 fps
x264 [info]: frame I:747   Avg QP:14,59  size: 37945
x264 [info]: frame P:20568 Avg QP:17,52  size:  3913
x264 [info]: frame B:39399 Avg QP:21,77  size:   703
x264 [info]: consecutive B-frames:  1,9% 33,6%  3,4% 61,1%
x264 [info]: mb I  I16..4: 17,9%  0,0% 82,1%
x264 [info]: mb P  I16..4:  1,7%  0,0%  1,6%  P16..4: 39,7% 13,4%  7,4%  0,0%  0,0%    skip:36,2%
x264 [info]: mb B  I16..4:  0,1%  0,0%  0,1%  B16..8: 29,7%  1,8%  0,3%  direct: 0,7%  skip:67,2%  L0:40,5% L1:55,8% BI: 3,8%
x264 [info]: coded y,uvDC,uvAC intra: 62,3% 78,0% 53,0% inter: 5,2% 12,6% 0,4%
x264 [info]: i16 v,h,dc,p: 47% 19% 14% 20%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 32% 17% 14%  6%  7%  7%  6%  6%  5%
x264 [info]: i8c dc,h,v,p: 52% 17% 25%  6%
x264 [info]: Weighted P-Frames: Y:0,9% UV:0,2%
x264 [info]: ref P L0: 68,5%  8,1% 15,8%  7,5%  0,1%
x264 [info]: ref B L0: 87,9%  9,6%  2,4%
x264 [info]: ref B L1: 96,7%  3,3%
x264 [info]: kb/s:449,75
[18:01:51] mux: track 0, 60714 frames, 136500184 bytes, 449,64 kbps, fifo 32768
[18:01:51] mux: track 1, 0 frames, 0 bytes, 0,00 kbps, fifo 8
[18:01:51] libhb: work result = 0


User avatar
JohnAStebbins
HandBrake Team
Posts: 5442
Joined: Sat Feb 09, 2008 7:21 pm

Re: No Sound on Tumbleweed

Post by JohnAStebbins » Fri Aug 16, 2019 6:22 pm

You are using an unsupported build of HandBrake that is linked against an incompatible version of ffmpeg's libswresample. This is very common of distro builds. They modify our build system and break things in unpredictable ways. See https://handbrake.fr/docs/en/latest/get ... brake.html

My recommendation is build HandBrake yourself from source or use our Flatpak releases. There is an official HandBrake release on Flathub and there are nightly build flatpaks on HandBrake's nightly build download page https://handbrake.fr/nightly.php

Post Reply