Page 1 of 1

Crashing when trying to encode x265

Posted: Mon Jul 15, 2019 4:45 am
by StringSaber
Description of problem or question:

Attempting to convert .m2ts (encoded as H264 and ripped from a blu ray .iso) into a .mp4 with x265 encoding. Handbrake crashes after several minutes when it is estimated to take ~50 min.


Steps to reproduce the problem (If Applicable):


HandBrake version (e.g., 1.0.0):
1.2.1 (x86_64)



Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Pop Os 19.04



HandBrake Activity Log ***required*** (see How-to get an activity log)

https://pastebin.com/Rp0UQCLP

Re: Crashing when trying to encode x265

Posted: Tue Oct 01, 2019 2:23 pm
by LouieLouie
I'm running 1.2.2 and I seem to be getting H.265 aborts when I try encoding some larger videos I've extracted from MakeMKV. I'll try to post the activity log ASAP.

Re: Crashing when trying to encode x265

Posted: Tue Oct 01, 2019 2:28 pm
by Woodstock
Where did you obtain the copy of handbrake? If it wasn't from a link on the official handbrake download site, you probably have a modified-to-not-work version.

Re: Crashing when trying to encode x265

Posted: Wed Oct 02, 2019 3:01 pm
by LouieLouie
The version (1.2.2) I'm using is packaged by Mageia and has been running well on 2 different AMD platforms.
Using x265 on other files has yielded beautiful results so I'm trying to narrow down if it's this 43Gb MakeMKV version of "Dances With Wolves" or what.
I would test encode the first 2 chapters fine but when encoding the whole movie it stumbles in chapter 2 so I'm trying chapters 2 & 3 now.
Plus I'll test on the other slower machine. I'll submit logs when I have repeatable results.
Thank you.
-LouieLouie

Re: Crashing when trying to encode x265

Posted: Wed Oct 02, 2019 7:24 pm
by Rodeo
When you get a repeatable crash on a short sample, we will still ask you to build HandBrake from source to make sure it's not an issue introduced by the packager, just in case.

https://handbrake.fr/docs/en/latest/dev ... linux.html

Re: Crashing when trying to encode x265

Posted: Wed Oct 02, 2019 8:31 pm
by mduell
You should contact Mageia for support for their broken build.

Re: Crashing when trying to encode x265

Posted: Wed Oct 02, 2019 9:33 pm
by LouieLouie
I would like to apologize for joining this thread:
After installing the sensors package and monitoring CPU, GPU & M-Board, I noticed that the temps fell when I took the side of the case off and transcoding would continue just fine - about 6 deg C was all it took.
I suspect the one rear case fan that is blowing into machine should be an exhaust instead (my son built this box :roll: ) so I will exit this thread and thank the Handbrake team for a great product.
-LouieLouie