Page 1 of 1

AAC encoding broken & can't save presets

Posted: Tue Jan 08, 2019 8:20 pm
by cbmoviewather
With 1.2.0 on Ubuntu 18.04, AAC encoding now produces a stuttering soundtrack. Handbrake is installed from the official repositories. I've uninstalled, purged, and reinstalled, same issue. Secondary problem, I can no longer save custom presets. :

Select input media, set audio track to encode with AAC. Listen to results. Cry. Log and sample with AAC and AC3 of same track available at link below:

HB 1.2.0 from official HB repository:

Ubuntu 18.04 LTS:

HandBrake Activity Log ***required*** (see How-to get an activity log) ... sp=sharing

Re: AAC encoding broken & can't save presets

Posted: Fri Jan 11, 2019 2:48 pm
by fprietog
AAC problem sounds like:

So problem is solved in nightly releases. Use this repo if you wanna try: ... -snapshots

I cannot help about the presets problem. It partially works for me: presets are saved but with some settings missing.

Re: AAC encoding broken & can't save presets

Posted: Fri Jan 11, 2019 6:44 pm
by cbmoviewather
Yep, that sounds like the problem, though with more technical detail than I understand. I'll grab a nightly build when I get some time.

The presets issue is very odd. I initially thought it was a permissions issue, but I checked and .config/ghb/presets.json was at 664 after I wiped and reinstalled Handbrake. I pulled an older (pre 12-22) file from my backups, and now it seems to work, but the file has a more restrictive 644 on it. Go figure. Something definitely wonky with saving presets on a clean install, but I've worked around it.

Thanks for the help.