Handbrake not starting Opensuse Leap15

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
hornetster
Posts: 2
Joined: Thu Oct 25, 2018 10:37 am

Handbrake not starting Opensuse Leap15

Post by hornetster » Thu Oct 25, 2018 12:23 pm

Description of problem or question:
Opensuse Leap15 X64 - Fully patched (25/10/2018)
Handbrake V1.1.2-lp150.1.4-x86_64 (Updated today: 25/10/18 - Issue apparent for 'a while')
Start handbrake, takes a while (1min+) and finally get black/blank screen. Nothing happens...

Steps to reproduce the problem (If Applicable):
Try to start Handbrake.

HandBrake version (e.g., 1.0.0):
Handbrake V1.1.2-lp150.1.4-x86_64 (Updated today: 25/10/18 - Issue apparent for 'a while')

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Opensuse Leap15 X64 - Fully patched (25/10/2018)

HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

[20:30:49] gtkgui: HandBrake 1.1.2 (2018090700) - Linux x86_64 - https://handbrake.fr
[20:30:49] hb_init: starting libhb thread
[20:30:49] hb_init: starting libhb thread
[20:30:49] hb_init: starting libhb thread

** (ghb:4363): WARNING **: AT-SPI: Could not obtain desktop path or name


** (ghb:4363): WARNING **: atk-bridge: get_device_events_reply: unknown signature

** (ghb:4363): WARNING **: atk-bridge: get_device_events_reply: unknown signature

** (ghb:4363): WARNING **: atk-bridge: GetRegisteredEvents returned message with unknown signature
Link to results of ghb -x https://www.dropbox.com/s/tn9o9bbs3mfja ... s.txt?dl=0

User avatar
s55
HandBrake Team
Posts: 9361
Joined: Sun Dec 24, 2006 1:05 pm

Re: Handbrake not starting Opensuse Leap15

Post by s55 » Thu Oct 25, 2018 7:18 pm

Sorry, we don't support 3rd party builds of HandBrake on Linux.
Please see https://handbrake.fr/docs/en/latest/get ... brake.html

User avatar
JohnAStebbins
HandBrake Team
Posts: 5260
Joined: Sat Feb 09, 2008 7:21 pm

Re: Handbrake not starting Opensuse Leap15

Post by JohnAStebbins » Thu Oct 25, 2018 8:01 pm

Hmm, the "Warning about broken third-party builds" section should either just link to release and snapshot download pages or add links to flatpak releases and snapshots that are available from the respective download pages. The we should be pointing all non-ubuntu/debian linux users to the flatpaks.

User avatar
JohnAStebbins
HandBrake Team
Posts: 5260
Joined: Sat Feb 09, 2008 7:21 pm

Re: Handbrake not starting Opensuse Leap15

Post by JohnAStebbins » Thu Oct 25, 2018 8:03 pm

We should probably also have a link to HandBrake on flathub somewhere.
https://flathub.org/apps/details/fr.handbrake.ghb

hornetster
Posts: 2
Joined: Thu Oct 25, 2018 10:37 am

Re: Handbrake not starting Opensuse Leap15

Post by hornetster » Sun Oct 28, 2018 2:11 am

Thanks for that...
Just as an update, I uninstalled Handrake from the package manager, and reinstalled from source (bit of a challenge - lots of missing requirements...), and it still appeared not to work - could only get a blank window to appear.
As a test, logged out and logged back in to a Gnome session (had been using Plasma), and it worked. So, was gong to try and figure this out, logged out, and logged back in to Plasma, and..... it worked!!
So I begin to suspect there was some sort of corruption in my display setup in plasma, and changing session manager has somehow corrected that?? (and yes, had rebooted many, many times...)
Wouldn't have a clue!! but at least it is now working....

Post Reply