Page 1 of 1

No audio track in target video

Posted: Sat Mar 10, 2018 9:21 am
by punchcutter
Description of problem or question
I've been trying to convert a .mov file (Quicktime, I think) to mp4, and reduce the file size, and although the video converts fine, the result always has no audio track in it. I am watching with a utility called mpv on Linux, and it shows me that there is no audio track. I have tried every possible manner of tweaking the settings and cannot get audio to be copied over to the result. I have noticed in the activity log, there is a line that says

Code: Select all

scan: removing audio 0x1 because no bitrate found
I wonder if this is the key to the problem. Thanks in advance for any help.

Steps to reproduce the problem (If Applicable)

HandBrake version (e.g., 1.0.0)

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.3 High Sierra, Windows 10 Creators Update)
Gentoo Linux

Error message text or screenshot (If Applicable)

Provide a URL from any image hosting site.

HandBrake Activity Log ***required*** (see How-to get an activity log)

Re: No audio track in target video

Posted: Sat Mar 10, 2018 4:30 pm
by Woodstock
Where did you obtain the handbrake version? Was it compiled from the official archive, or a package found on Gentoo? Most, if not all, packages found on distribution-specific libraries have issues, because they're built either with components removed due to the political license leanings of the distribution, or built to use system libraries that are not up-to-date with necessary patches.

The GUI did not pass any audio to the encode phase. Can we see the scan log as well?

Re: No audio track in target video

Posted: Sat Mar 10, 2018 10:10 pm
by punchcutter
Handbrake came from Gentoo's package management (portage). If I want the "official" version, I guess I have to build it from source myself, eh? Looks like you don't have binaries for download, but if you did, they probably wouldn't work right, either, I guess.

Any chance that running the CLI version might work for me with the build that I already have? If you could suggest the CLI options to use, that would be helpful. My main goal is to convert .mov to h.264/mp4 and reduce the file size as much as possible. Slight loss of video and audio quality is acceptable.

About the scan log... I don't find anything under ~/.config/ghb with that name, and here is the only other log I can find. It was called Activity log:
Please note that the above Activity log is from a different encoding run than the previous log I posted, but I don't guess it'll make any difference, because the results are always the same...
Thanks for the help.

Re: No audio track in target video

Posted: Sat Mar 10, 2018 11:04 pm
by s55
Using the CLI won't help you. You'll need to compile the latest git from source if you want this to work.

Re: No audio track in target video

Posted: Sat Mar 10, 2018 11:42 pm
by Woodstock
From the scan log:
Stream #0:1(eng): Audio: pcm_u8 (raw / 0x20776172), 8000 Hz, 1 channels, u8, 64 kb/s (default)
There was a problem with mono PCM audio in the 1.0.x series in any case (stereo or higher is fine), so you definitely need to build from the nightly/git source.

Re: No audio track in target video

Posted: Sun Mar 11, 2018 12:33 am
by punchcutter
OK, thanks for the confirm. I'll give it a try.

Re: No audio track in target video

Posted: Mon Mar 12, 2018 5:34 am
by punchcutter
Um, so I've looked around the website for instructions about using the nightly builds, or links to the place to get them, but didn't really find anything, so I guess I just clone the repo from Github? Also I've taken a quick look in the repo, and don't see any build instructions. Just do configure, and then make? Am I missing where the instructions are? Haven't had a chance to try yet, but thought I'd check for possible pitfalls before I do. Might be a good idea to add an INSTALL file to the top level with basic guidance on building. Thanks.

Edit: Cloned and compiling now.
OK... compile finished and have a working hb. It was simple, but I still think having an INSTALL file is a good idea :D

Re: No audio track in target video

Posted: Mon Mar 12, 2018 3:52 pm
by mduell

First hit on most major search engines for "handbrake nightly"

Re: No audio track in target video

Posted: Sat Mar 17, 2018 8:42 am
by punchcutter
Building the latest code worked - great results. Thanks again.

@mduell: Yes, I found that page before. But look closely at that page. Unless I'm fairly stupid, it doesn't tell me how to get the nightly code. I'm running Linux, but not Ubuntu. I expected to find a link to a tarball of the source, but I can find no such thing there. I followed the Ubuntu link to John Stebbins' page, just for kicks, but I couldn't really find anything useful there either. So I cloned the latest repo from Github, and that worked for me. But it still doesn't correspond to the word "nightly" for me. You could help users by taking a fresh look at your web site from the viewpoint of someone like me who is technically capable, but not familiar with your project at all, and make appropriate changes.

Thanks again for an excellent piece of software.