Page 1 of 1

HandBrakeCLI got 0 frames

Posted: Sat Nov 18, 2017 5:33 am
by camerondevine
Please detail your question or problem in as much detail as possible:

I am attempting to convert a DVD to an MPEG4 file. At first I tried to convert the DVD all at once, but this only got the first 15 minutes or so. Then I started trying to get each chapter individually. The dvd has 13 chapters on the main title. The first three work just fine, but the rest don't.

Tell us about your environment. What version of HandBrake? What version of Linux / Unix are you running. etc.

I am running HandBrakeCLI built from source, specifically commit 17a4bb, on Ubuntu Server 16.04.

Code: Select all

cameron@server:~/HandBrake/build$ uname -a
Linux server 4.4.0-98-generic #121-Ubuntu SMP Tue Oct 10 14:24:03 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
If there was any exception or error displayed, please copy it and paste it here:

From the log there is the line,

Code: Select all

[23:14:02] sync: got 0 frames, 15394 expected
which is definitely a problem, and shortly before it the line,

Code: Select all

[23:14:02] reader: done. 0 scr changes
which may be a problem but I haven't been able to find anything about what scr means.

Please include the scan or encode log:

The log for chapter 4 which doesn't work, https://pastebin.com/52tF894M
The log for chapter 3 which does work, https://pastebin.com/J3uf53EN

Re: HandBrakeCLI got 0 frames

Posted: Sat Nov 18, 2017 8:23 am
by rollin_eng

Re: HandBrakeCLI got 0 frames

Posted: Sat Nov 18, 2017 3:20 pm
by Woodstock
What happens if you use an actual ripper on the disk, like MakeMKV, or make an ISO file of the disk with 'dd'?

It appears that there is a read error on the disk in the title you're trying to extract, but the way you're using handbrake, it only knows that the data stopped flowing.

Re: HandBrakeCLI got 0 frames

Posted: Sat Nov 18, 2017 11:33 pm
by camerondevine
I first made an ISO of the DVD using the command,

Code: Select all

dd if=/dev/cdrom of=DVD.iso bs=64k
then I installed handbrake-cli from the PPA mentioned above. Finally I tried encoding the ISO image of the DVD. Again this failed. The log for this attempt can be found here, https://pastebin.com/7K4EmU2x

Thank you for taking the time to help me.

Re: HandBrakeCLI got 0 frames

Posted: Sun Nov 19, 2017 12:36 am
by Woodstock
Did dd complete without error? Unless told to skip errors, dd will exit as soon as it hits a read error, and the output file will not be as big as the DVD.

I suspect the file is corrupt, because libdvdcss found SOME CSS keys, but couldn't find others; that is a highly unusual situation, if the image is complete and readable. Try adding 'noerror' to the dd command line, and see if you get a larger file. It still might not be readable (dd will insert zeros where the errors occurred), but it will give an indication of what the problem is.

Have you cleaned the disk?

Re: HandBrakeCLI got 0 frames

Posted: Sun Nov 19, 2017 12:25 pm
by rollin_eng
Try ripping with makemkv first.

Re: HandBrakeCLI got 0 frames

Posted: Mon Nov 20, 2017 1:49 am
by camerondevine
makemkv appears to be a GUI application, however the computer I have with a DVD drive is a headless server.

I tried using dd with the noerror option and got a ton of messages like,

Code: Select all

dd: error reading '/dev/cdrom': Input/output error
9801+244 records in
9801+244 records out
650313728 bytes (650 MB, 620 MiB) copied, 5132.42 s, 127 kB/s
I again tried using HandBrake on chapter 4 and again got 0 frames.

I then cleaned the DVD and ran dd to get the ISO image of the DVD. This again produced many errors like before, and resulted in a smaller image (strange). I then tried HandBrake on the resulting ISO which again failed, but with different output, https://pastebin.com/jaR2XGFj

Re: HandBrakeCLI got 0 frames

Posted: Mon Nov 20, 2017 7:58 am
by Rodeo
You could use makemkvcon, unfortunately it's mostly undocumented.

But as far as reading encrypted discs directly with HandBrake, you're bound to run into various limitations and bugs which we simply don't have the resources (time, access to DVD discs and so on) to look into.

Re: HandBrakeCLI got 0 frames

Posted: Mon Nov 20, 2017 3:13 pm
by Woodstock
Well, dd confirmed that there was a problem with the disk itself. And that probably could be "fixed" as simply as cleaning the disk. It does not take much finger oil or abrasion to scatter the laser "too much".

If simple cleaning didn't work, there are "other methods". I have often resorted to waxing a disk to get it to read properly. But that requires care, because some waxes have carriers that are harmful to the plastic used in DVDs and BDs, and you can't leave too much wax on the surface, or you risk contaminating your drive.

If the drive in the server is a Blu-ray, see if you can borrow a DVD drive. The lasers in DVD and BD are different, and I have encountered several DVDs over the years that BD players can't read, but a DVD player has no issue with.