With upcoming changes to data protection and privacy laws in Europe coming into effect soon, we thought this would be a good time to remind everyone that we do have a privacy policy.
This applies to all users and visitors world-wide.

We have made a few changes to the language to make it clearer in relation to this new regulation but fundamentally, the terms and your rights are unchanged.

If you have any questions about this, please feel free to ask in the General Forum

Segfault when loading SRT

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
Segfault
Posts: 15
Joined: Sat Jun 17, 2017 3:08 am

Segfault when loading SRT

Post by Segfault » Sun Jun 25, 2017 12:11 am

Is Handbrake supposed to handle SRT in MKV container? When I load an MKV file with SRT muxed into it and choose Passthru first I get a warning "this is not a regular file" and if I proceed with "Start Encoding" Handbrake crashes with segmentation fault.

Running version 1.0.7 64-bit on Gentoo.

It would really be nice to pass the subtitles without having to remux the file with mkvtoolnix.

User avatar
BradleyS
Moderator
Posts: 1279
Joined: Thu Aug 09, 2007 12:16 pm

Re: Segfault when loading SRT

Post by BradleyS » Sun Jun 25, 2017 12:45 am

If you're using the ebuild, it's known broken. Long story about packagers who don't care if software actually works after it's compiled.

Linux build instructions are here, with Gentoo dependencies: https://handbrake.fr/docs/en/1.0.0/deve ... linux.html

Provide an activity log from a supported build and we can help further. ;)

mduell
Veteran User
Posts: 5953
Joined: Sat Apr 21, 2007 8:54 pm

Re: Segfault when loading SRT

Post by mduell » Sun Jun 25, 2017 12:55 am

Ignored the requirements in bold underlined red text on a pink background at the top of the page... remarkable arrogance.

Segfault
Posts: 15
Joined: Sat Jun 17, 2017 3:08 am

Re: Segfault when loading SRT

Post by Segfault » Sun Jun 25, 2017 2:50 am

Thank you for your responses. Will dig into this when I get a chance.

Segfault
Posts: 15
Joined: Sat Jun 17, 2017 3:08 am

Re: Segfault when loading SRT

Post by Segfault » Sun Oct 08, 2017 8:28 pm

OK, I tried to build it today. It errored out.

Code: Select all

/usr/x86_64-pc-linux-gnu/gcc-bin/7.2.0/gcc -std=gnu99 -pipe -fmessage-length=0 -Wall -g0 -O3 -mfpmath=sse -msse2 -DUSE_LIBAV_AAC -D__LIBHB__ -DUSE_PTHREAD -DSYS_LINUX -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_X265 -DHAS_STRERROR_R -DARCH_X86_64 -I./libhb/ -I./contrib/include -I/usr/include/libxml2 -c ../libhb/audio_resample.c -o libhb/audio_resample.o
In file included from ../libhb/common.h:14:0,
                 from ../libhb/audio_resample.c:10:
../libhb/hb_dict.h:13:10: fatal error: jansson.h: No such file or directory
 #include <jansson.h>
          ^~~~~~~~~~~
compilation terminated.
make: *** [../libhb/module.rules:12: libhb/audio_resample.o] Error 1
Building on Gentoo 64 bit, sources from git.

User avatar
BradleyS
Moderator
Posts: 1279
Joined: Thu Aug 09, 2007 12:16 pm

Re: Segfault when loading SRT

Post by BradleyS » Sun Oct 08, 2017 10:10 pm

Okay, did you emerge jansson when you installed the other dependencies according to the documentation?

Segfault
Posts: 15
Joined: Sat Jun 17, 2017 3:08 am

Re: Segfault when loading SRT

Post by Segfault » Sun Oct 08, 2017 10:52 pm

Whoops, I think I missed that. I just pulled git and ran configure, it did not complain about anything missing. Then I tried make and saw it downloading bundled stuff. So I figured it won't use anything I already had in system. I see I was wrong ...

Post Reply