Strange behaviour

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
markherring
Posts: 1
Joined: Mon Jun 12, 2017 2:16 pm

Strange behaviour

Post by markherring »

Running Handbrake V1.0.4 on Linux Mint 18.2

I have just ripped the DVD Hurt Locker. When I selected Open source the dialog showed me the correct folder and then clicking open the analysis of the DVD completed and the output file name was automatically set to Hurt Locker.m4v. Once the rip was finished I closed down Handbrake and ejected the DVD. I then inserted the DVD Star Trek Into Darkness and opened Handbrake again. The CD/DVD icon on the Desktop immediately updated to show the correct DVD title, however, when I click Open Source in Handbrake it shows Hurt Locker. If I click Open, the analysis happens, the preview window in the bottom right shows a still from Star Trek and all Chapters are correct. The title of the output file shows Hurt Locker.m4v. This seems to happen each time I change DVD's. The subsequent RIP also works fine.

Is there any way to stop this?

Regards,

Mark
User avatar
JohnAStebbins
HandBrake Team
Posts: 5583
Joined: Sat Feb 09, 2008 7:21 pm

Re: Strange behaviour

Post by JohnAStebbins »

It's been ages since I've tried to do a transcode direct from disc. I'll try to reproduce the behaviour you're seeing when I get a chance. In the interim, could you please supply a HandBrake scan log. That *might* tell us something.
rgk24
New User
Posts: 1
Joined: Sun Jun 25, 2017 2:19 am

Re: Strange behaviour

Post by rgk24 »

I've noticed this too. though not whilst ripping from DVD. If I've previously converted two AVI's in folder A into MP4's and the destination has been set to Folder A, when I then try and convert some subsequent AVI's in Folder B the destination is always set to Folder A. I have "automatically name output files" ticked on with a format of "Source". The only way to get them into folder B is to overtype the destination and then the destination is forever set to Folder B. Handbrake seems to be completely ignoring the Auto Naming option.

I think the file types and quantities are irrelevant.

I'm running Mac OS El Capitan 10.11.16 and Handbrake Version 1.0.7 (2017040900)

Any suggestions.
User avatar
JohnAStebbins
HandBrake Team
Posts: 5583
Joined: Sat Feb 09, 2008 7:21 pm

Re: Strange behaviour

Post by JohnAStebbins »

I think what you are seeing is a failure of either the automounter of your OS or the communication between the automounter and GTK. I'm assuming the "Hurt Locker" that was shown in the "Open Source" dialog is the volume label it shows in the left hand pane for mounted volumes. If the OS fails to properly unmount the volume when it is ejected (or fails to communicate currently mounted volumes to gtk), you would still see this label in the dialog.

I can't speak for OSX, but I would imagine it could be a similar type of issue.
Post Reply