Handbrake keeps crashing

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
Levan
Posts: 18
Joined: Thu Jan 24, 2013 10:39 am

Handbrake keeps crashing

Post by Levan » Mon Mar 09, 2015 6:17 pm

I installed handbrake on ubuntu 14.04

With using this ppa

https://launchpad.net/~stebbins/+archiv ... -snapshots

Code: Select all

sudo add-apt-repository ppa:stebbins/handbrake-snapshots

Code: Select all

sudo apt-get update

Code: Select all

sudo apt-get install handbrake-gtk
However when I try to render it crashes.

Code: Select all

[22:09:51] gtkgui: HandBrake svn6980 (2015030901) - Linux x86_64 - https://handbrake.fr
[22:09:51] hb_init: starting libhb thread
[22:09:51] hb_init: starting libhb thread
[22:09:51] hb_init: starting libhb thread

(ghb:3908): Gdk-WARNING **: gdk_window_set_icon_list: icons too large
libdvdread: Encrypted DVD support unavailable.
[22:10:05] CPU: Intel(R) Core(TM)2 Duo CPU     E7500  @ 2.93GHz
[22:10:05]  - logical processor count: 2
[22:10:05] hb_scan: path=/home/levan/Desktop/1.wmv, title_index=0
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening /home/levan/Desktop/1.wmv/BDMV/index.bdmv
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening /home/levan/Desktop/1.wmv/BDMV/BACKUP/index.bdmv
libbluray/bluray.c:2182: nav_get_title_list(/home/levan/Desktop/1.wmv) failed
[22:10:05] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[22:10:05] dvd: not a dvd - trying as a stream/file instead
Input #0, asf, from '/home/levan/Desktop/1.wmv':
  Metadata:
    WM/ToolName     : TMPGEnc 4.0 XPress Version. 4.2.3.193
    WMFSDKVersion   : 12.0.7600.16385
    WMFSDKNeeded    : 0.0.0.0000
    IsVBR           : 0
    DeviceConformanceTemplate: MP@HL
  Duration: 00:07:01.80, start: 0.000000, bitrate: 3635 kb/s
    Stream #0.0(eng): Audio: wmav2, 48000 Hz, 2 channels, fltp, 128 kb/s
    Stream #0.1(eng): Video: wmv3 (Main), yuv420p, 1280x720, 3500 kb/s, 25 fps, 1k tbn
[22:10:05] scan: decoding previews for title 1
[22:10:05] scan: audio 0x0: wmav2, rate=48000Hz, bitrate=128016 English (wmav2) (2.0 ch)
[22:10:05] scan: 10 previews, 1280x720, 25,000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[22:10:05] libhb: scan thread found 1 valid title(s)
libdvdread: Encrypted DVD support unavailable.
[22:11:03] gtkgui: Modified Preset: Regular->Normal
[22:11:03] 1 job(s) to process
[22:11:03] CPU: Intel(R) Core(TM)2 Duo CPU     E7500  @ 2.93GHz
[22:11:03]  - logical processor count: 2
[22:11:03] hb_scan: path=/home/levan/Desktop/1.wmv, title_index=1
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening /home/levan/Desktop/1.wmv/BDMV/index.bdmv
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening /home/levan/Desktop/1.wmv/BDMV/BACKUP/index.bdmv
libbluray/bluray.c:2182: nav_get_title_list(/home/levan/Desktop/1.wmv) failed
[22:11:03] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[22:11:03] dvd: not a dvd - trying as a stream/file instead
Input #0, asf, from '/home/levan/Desktop/1.wmv':
  Metadata:
    WM/ToolName     : TMPGEnc 4.0 XPress Version. 4.2.3.193
    WMFSDKVersion   : 12.0.7600.16385
    WMFSDKNeeded    : 0.0.0.0000
    IsVBR           : 0
    DeviceConformanceTemplate: MP@HL
  Duration: 00:07:01.80, start: 0.000000, bitrate: 3635 kb/s
    Stream #0.0(eng): Audio: wmav2, 48000 Hz, 2 channels, fltp, 128 kb/s
    Stream #0.1(eng): Video: wmv3 (Main), yuv420p, 1280x720, 3500 kb/s, 25 fps, 1k tbn
[22:11:03] scan: decoding previews for title 1
[22:11:03] scan: audio 0x0: wmav2, rate=48000Hz, bitrate=128016 English (wmav2) (2.0 ch)
[22:11:04] scan: 10 previews, 1280x720, 25,000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[22:11:04] libhb: scan thread found 1 valid title(s)
Any ideas on how to fix it ??

User avatar
JohnAStebbins
HandBrake Team
Posts: 5441
Joined: Sat Feb 09, 2008 7:21 pm

Re: Handbrake keeps crashing

Post by JohnAStebbins » Tue Mar 10, 2015 12:20 am

Your log only shows a scan. It may be helpful to also see the encode log. Encode logs are all stored to file, so you should be able to supply one even when it crashes. On linux they get stored to ~/.config/ghb/EncodeLogs

mod16
Posts: 78
Joined: Sun Jan 12, 2014 11:10 am

Re: Handbrake keeps crashing

Post by mod16 » Tue Mar 10, 2015 12:06 pm

Having the same problem since updating to the latest PPA version.
Last version I used (and worked) was about 3-4 days older.

I get a segmentation fault as soon as I press the Start button:

Code: Select all

[...]
(null): set_preview_button_image ()
(null): ghb_reload_queue
(null): ghb_file_menu_add_dvd()
(null): update_queue_list ()
(null): update_queue_list ()
(null): update_queue_list ()
(null): update_queue_list ()
(null): update_queue_list ()
(null): update_queue_list ()
(null): col width 981 alloc width 1005
(null): start_next_job
(null): ghb_inhibit_gsm()
(null): submit_job
(null): ghb_audio_is_passthru () 

(null): find_queue_job
(null): col width 981 alloc width 1005  <-- last message, then I try to start the encoding process
Segmentation fault
Last lines in encode log:

Code: Select all

[12:59:51] Allocated 4705280 bytes of buffers on this pass and Freed 4705280 bytes, 0 bytes leaked
[12:59:51] thread 7f1998e36700 exited ("scan")
[12:59:51] thread 7f1998e36700 joined ("scan")
[12:59:51] libhb: scan thread found 1 valid title(s)
No more messages - the GUI just closes.

Levan
Posts: 18
Joined: Thu Jan 24, 2013 10:39 am

Re: Handbrake keeps crashing

Post by Levan » Tue Mar 10, 2015 5:14 pm

JohnAStebbins wrote:Your log only shows a scan. It may be helpful to also see the encode log. Encode logs are all stored to file, so you should be able to supply one even when it crashes. On linux they get stored to ~/.config/ghb/EncodeLogs
Here but different video

Code: Select all

Handbrake Version: 6982svn (2015031001)
[21:13:40] gtkgui: Modified Preset: Regular->Normal
[21:13:40] 1 job(s) to process
[21:13:40]  - logical processor count: 2
[21:13:40] hb_scan: path=/media/levan/BEEA60D8EA608E89/Downloads/2/1.mkv, title_index=1
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening /media/levan/BEEA60D8EA608E89/Downloads/2/1.mkv/BDMV/index.bdmv
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening /media/levan/BEEA60D8EA608E89/Downloads/2/1.mkv/BDMV/BACKUP/index.bdmv
libbluray/bluray.c:2182: nav_get_title_list(/media/levan/BEEA60D8EA608E89/Downloads/2/1.mkv) failed
[21:13:40] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[21:13:40] dvd: not a dvd - trying as a stream/file instead
Input #0, matroska,webm, from '/media/levan/BEEA60D8EA608E89/Downloads/2/1.mkv':
  Duration: 00:42:33.98, start: 0.000000, bitrate: N/A
    Stream #0.0(eng): Video: h264 (High), yuv420p, 1920x1078, PAR 1:1 DAR 960:539, 23,98 fps, 1k tbn, 47,95 tbc (default)
    Stream #0.1: Audio: ac3, 48000 Hz, 5.1, fltp, 448 kb/s (default)
    Stream #0.2: Subtitle: [0][0][0][0] / 0x0000 (default)
[21:13:40] scan: decoding previews for title 1
[21:13:40] scan: audio 0x1: ac3, rate=48000Hz, bitrate=448000 Unknown (AC3) (5.1 ch)
[21:13:41] scan: 10 previews, 1920x1078, 23,976 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[21:13:41] libhb: scan thread found 1 valid title(s)

User avatar
JohnAStebbins
HandBrake Team
Posts: 5441
Joined: Sat Feb 09, 2008 7:21 pm

Re: Handbrake keeps crashing

Post by JohnAStebbins » Wed Mar 11, 2015 1:49 am

Unfortunately, the log isn't very helpful. It's going to require the assistance of someone who can reproduce that problem and can rebuild with debug information enabled.

If you have a short sample I can use to reproduce the problem, I can do this.

Levan
Posts: 18
Joined: Thu Jan 24, 2013 10:39 am

Re: Handbrake keeps crashing

Post by Levan » Wed Mar 11, 2015 10:55 am

JohnAStebbins wrote:Unfortunately, the log isn't very helpful. It's going to require the assistance of someone who can reproduce that problem and can rebuild with debug information enabled.

If you have a short sample I can use to reproduce the problem, I can do this.
Well when it comes to sample file it is easy '' every file I tried but for example''

Here is one

https://www.sendspace.com/file/biuxo8

Code: Select all

Handbrake Version: 6982svn (2015031001)
[14:53:17] gtkgui: Preset: Regular->Normal
[14:53:17] 1 job(s) to process
[14:53:17]  - logical processor count: 2
[14:53:17] hb_scan: path=/home/levan/kdenlive/untitled.mp4, title_index=1
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening /home/levan/kdenlive/untitled.mp4/BDMV/index.bdmv
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening /home/levan/kdenlive/untitled.mp4/BDMV/BACKUP/index.bdmv
libbluray/bluray.c:2182: nav_get_title_list(/home/levan/kdenlive/untitled.mp4) failed
[14:53:17] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[14:53:17] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/home/levan/kdenlive/untitled.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2mp41
    encoder         : Lavf54.20.4
  Duration: 00:00:05.14, start: 0.000000, bitrate: 1196 kb/s
    Stream #0.0(und): Video: mpeg4 (Simple Profile), yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], 1093 kb/s, 30 fps, 30 tbn, 30 tbc (default)
    Stream #0.1(und): Audio: mp3, 44100 Hz, 2 channels, s16p, 127 kb/s (default)
[14:53:17] scan: decoding previews for title 1
[14:53:17] scan: audio 0x1: mp3, rate=44100Hz, bitrate=127998 Unknown (MP3) (2.0 ch)
[14:53:18] scan: 10 previews, 1920x1080, 30,000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[14:53:18] libhb: scan thread found 1 valid title(s)

mod16
Posts: 78
Joined: Sun Jan 12, 2014 11:10 am

Re: Handbrake keeps crashing

Post by mod16 » Wed Mar 11, 2015 1:02 pm

JohnAStebbins wrote:Unfortunately, the log isn't very helpful. It's going to require the assistance of someone who can reproduce that problem and can rebuild with debug information enabled.
I'm willing to help but don't know how (exactly) to build with debug info on and/or how/where to obtain the needed information/messages?
I already have the latest source checked out and the default build process works fine.

I also can confirm that the application crashes every time I try to encode something (it seems it doesn't matter what).

User avatar
JohnAStebbins
HandBrake Team
Posts: 5441
Joined: Sat Feb 09, 2008 7:21 pm

Re: Handbrake keeps crashing

Post by JohnAStebbins » Wed Mar 11, 2015 2:45 pm

How embarrassing :oops:

I did *all* my testing with sources that have subtitles *and* with the foreign audio search setting enabled. Use a source without subtitles or disable foreign audio search and the crash is easily reproduced :lol:

And fixed http://trac.handbrake.fr/changeset/6983 :mrgreen:

mod16
Posts: 78
Joined: Sun Jan 12, 2014 11:10 am

Re: Handbrake keeps crashing

Post by mod16 » Wed Mar 11, 2015 4:02 pm

JohnAStebbins wrote:And fixed http://trac.handbrake.fr/changeset/6983 :mrgreen:
Thank you! :)

Already encoding. ;) (built rev6983 manually)

BTW: I reloaded a queue which I saved using the last PPA build, but only 5 of 9 jobs were restored. Maybe a side effect of the bug, I don't know - just wanted to mention it.

User avatar
JohnAStebbins
HandBrake Team
Posts: 5441
Joined: Sat Feb 09, 2008 7:21 pm

Re: Handbrake keeps crashing

Post by JohnAStebbins » Thu Mar 12, 2015 1:41 am

It only reloads queue items it thinks didn't finish. Somehow those 4 items got marked as complete.

Post Reply