Issues with CLI on Ubuntu 14.04

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
Activity Log is required for support requests. See Must Read: How To Get Questions Answered on These Forums for details
zane131
Posts: 3
Joined: Wed May 07, 2014 2:22 am

Issues with CLI on Ubuntu 14.04

Postby zane131 » Wed May 07, 2014 3:10 am

I have a clean install of Ubuntu GNOME 14.04 and installed Handbrake (GUI and CLI) from Ubuntu's Software Center. I can successfully converted videos with the GUI using multiple presets. Unfortunately, I am unable to get the CLI to work. All of the presets give me the following:

Code: Select all

ERROR: Invalid audio codec: 0x100


I experimented by overriding the audio encoder with the -E option. I got the same error code as above with faac and copy:aac. Then, I tried all of the other audio encoders listed in HandbrakeCLI --help and got the following error:

Code: Select all

ERROR: MP4 muxer disabled, exiting


Any help would be appreciated.

TedJ
Veteran User
Posts: 5388
Joined: Wed Feb 20, 2008 11:25 pm

Re: Issues with CLI on Ubuntu 14.04

Postby TedJ » Wed May 07, 2014 6:49 am

You're trying to encode to MP4 and Ubuntu in their infinite wisdom have removed MP4 support in their builds. Download from handbrake.fr and install manually.

zane131
Posts: 3
Joined: Wed May 07, 2014 2:22 am

Re: Issues with CLI on Ubuntu 14.04

Postby zane131 » Thu May 08, 2014 3:13 am

Thanks for pointing this out. I didn't pick up on it yesterday. It's irritating that they stripped the mp4 support from the version available in the Ubuntu repos. Any thoughts on where to report this?

The ppa listed on handbrake.fr doesn't support 14.04. Looks like it hasn't been updated for close to a year.

Code: Select all

W: Failed to fetch http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/trusty/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/trusty/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

After more searching on the all powerful Google, I found a solution here: http://iloveubuntu.net/handbrake-099-la ... e-universe

Simply install the raring debs manually from here: https://launchpad.net/~stebbins/+archiv ... ld/4589165

Then run the following after installing the debs or they will be updated to the cut down version from the Ubuntu repos.

Code: Select all

sudo apt-mark hold handbrake-gtk handbrake-cli

TedJ
Veteran User
Posts: 5388
Joined: Wed Feb 20, 2008 11:25 pm

Re: Issues with CLI on Ubuntu 14.04

Postby TedJ » Thu May 08, 2014 9:44 am

No, you'll need to use the nightly builds for 14.04 although we're hoping for the next stable release shortly.

The reason mp4 was stripped from the Ubuntu repos was because the library used for muxing mp4 (mp4v2) is not distributed under a GPL compatible licence. We're switching to libavformat for the next release to address this problem.

zane131
Posts: 3
Joined: Wed May 07, 2014 2:22 am

Re: Issues with CLI on Ubuntu 14.04

Postby zane131 » Sat Jun 07, 2014 4:20 am

TedJ wrote:... although we're hoping for the next stable release shortly.

Just checking up on this because it has been a while. Anyone know when this will be put in the stable release or where to check?

User avatar
s55
HandBrake Team
Posts: 8219
Joined: Sun Dec 24, 2006 1:05 pm

Re: Issues with CLI on Ubuntu 14.04

Postby s55 » Sat Jun 07, 2014 9:22 am

There is no ETA. The news page on the site will be the firs place to be updated when we hit 1.0

Dapsol
Posts: 6
Joined: Sat Aug 30, 2014 4:53 pm

Re: Issues with CLI on Ubuntu 14.04

Postby Dapsol » Sat Aug 30, 2014 5:13 pm

Hi,

i've installed HandBrake-cli on Debian Wheezy from "deb http://cdn.debian.net/debian wheezy-backports main", and i'm getting the exact same error:

Code: Select all

ERROR: MP4 muxer disabled, exiting


Any tips on how to fix this would be very welcome :-)


(reason to get a nightly build is because it can handle subtitles in blu-rays..)

User avatar
s55
HandBrake Team
Posts: 8219
Joined: Sun Dec 24, 2006 1:05 pm

Re: Issues with CLI on Ubuntu 14.04

Postby s55 » Sat Aug 30, 2014 8:04 pm

Uninstall that, and install the official nightly. That is not a nightly. That is just a deliberately broken version they ship to annoy us.

Dapsol
Posts: 6
Joined: Sat Aug 30, 2014 4:53 pm

Re: Issues with CLI on Ubuntu 14.04

Postby Dapsol » Sun Aug 31, 2014 9:19 am

Ok thanks, but is it possible to build the nightly on Debian Wheezy?

I've tried building from source and i get a build error:

Code: Select all

sudo apt-get install checkinstall build-essential subversion yasm build-essential autoconf libtool \
zlib1g-dev libbz2-dev libogg-dev libtheora-dev libvorbis-dev \
libsamplerate-dev libxml2-dev libfribidi-dev libfreetype6-dev \
libfontconfig1-dev libass-dev intltool libglib2.0-dev libdbus-glib-1-dev \
libgtk2.0-dev libgudev-1.0-dev libwebkit-dev libnotify-dev \
libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev libappindicator-dev

svn checkout svn://svn.handbrake.fr/HandBrake/trunk hb-trunk
cd hb-trunk
./configure --launch --disable-gtk


Last lines of build.txt :

Code: Select all

  :  /bin/mkdir -p '/home/david/scripts/hb-trunk/build/contrib/include/libbluray'
  :  /usr/bin/install -c -m 644 file/filesystem.h libbluray/bdnav/clpi_data.h libbluray/bdnav/meta_data.h libbluray/bluray-version.h libbluray/bluray.h libbluray/decoders/overlay.h libbluray/keys.h util/log_control.h '/home/david/scripts/hb-trunk/build/contrib/include/libbluray'
  : make[3]: Leaving directory `/home/david/scripts/hb-trunk/build/contrib/libbluray/libbluray-0.5.0/src'
  : make[2]: Leaving directory `/home/david/scripts/hb-trunk/build/contrib/libbluray/libbluray-0.5.0/src'
  : make[2]: Entering directory `/home/david/scripts/hb-trunk/build/contrib/libbluray/libbluray-0.5.0'
  : make[3]: Entering directory `/home/david/scripts/hb-trunk/build/contrib/libbluray/libbluray-0.5.0'
  : make[3]: Nothing to be done for `install-exec-am'.
  : make[3]: Nothing to be done for `install-data-am'.
  : make[3]: Leaving directory `/home/david/scripts/hb-trunk/build/contrib/libbluray/libbluray-0.5.0'
  : make[2]: Leaving directory `/home/david/scripts/hb-trunk/build/contrib/libbluray/libbluray-0.5.0'
  : make[1]: Leaving directory `/home/david/scripts/hb-trunk/build/contrib/libbluray/libbluray-0.5.0'
  : touch contrib/libbluray/.stamp.install
  : /usr/bin/gcc -std=gnu99 -pipe -fmessage-length=0 -Wall -g0 -O3 -DUSE_LIBAV_AAC -D__LIBHB__ -DUSE_PTHREAD -DSYS_LINUX -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_X265 -DARCH_X86_64 -I./libhb/ -I./contrib/include -c ../libhb/audio_remap.c -o libhb/audio_remap.o
  : /usr/bin/gcc -std=gnu99 -pipe -fmessage-length=0 -Wall -g0 -O3 -DUSE_LIBAV_AAC -D__LIBHB__ -DUSE_PTHREAD -DSYS_LINUX -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_X265 -DARCH_X86_64 -I./libhb/ -I./contrib/include -c ../libhb/audio_resample.c -o libhb/audio_resample.o
  : /usr/bin/gcc -std=gnu99 -pipe -fmessage-length=0 -Wall -g0 -O3 -DUSE_LIBAV_AAC -D__LIBHB__ -DUSE_PTHREAD -DSYS_LINUX -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_X265 -DARCH_X86_64 -I./libhb/ -I./contrib/include -c ../libhb/batch.c -o libhb/batch.o
  : /usr/bin/gcc -std=gnu99 -pipe -fmessage-length=0 -Wall -g0 -O3 -DUSE_LIBAV_AAC -D__LIBHB__ -DUSE_PTHREAD -DSYS_LINUX -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_X265 -DARCH_X86_64 -I./libhb/ -I./contrib/include -c ../libhb/bd.c -o libhb/bd.o
  : /usr/bin/gcc -std=gnu99 -pipe -fmessage-length=0 -Wall -g0 -O3 -DUSE_LIBAV_AAC -D__LIBHB__ -DUSE_PTHREAD -DSYS_LINUX -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_X265 -DARCH_X86_64 -I./libhb/ -I./contrib/include -c ../libhb/colormap.c -o libhb/colormap.o
  : /usr/bin/gcc -std=gnu99 -pipe -fmessage-length=0 -Wall -g0 -O3 -DUSE_LIBAV_AAC -D__LIBHB__ -DUSE_PTHREAD -DSYS_LINUX -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_X265 -DARCH_X86_64 -I./libhb/ -I./contrib/include -c ../libhb/common.c -o libhb/common.o
  : ../libhb/common.c:16:18: fatal error: x264.h: No such file or directory
  : compilation terminated.
  : make: *** [libhb/common.o] Error 1
-------------------------------------------------------------------------------
time end: Sun Aug 31 10:30:20 2014
duration: 29 minutes, 47 seconds (1787.29s)
result: FAILURE (code 2)
-------------------------------------------------------------------------------
Build is finished!
Last edited by Dapsol on Sat Sep 06, 2014 5:00 pm, edited 1 time in total.

User avatar
JohnAStebbins
HandBrake Team
Posts: 4730
Joined: Sat Feb 09, 2008 7:21 pm

Re: Issues with CLI on Ubuntu 14.04

Postby JohnAStebbins » Sun Aug 31, 2014 1:54 pm

You need to read the build documentation in doc/BUILD-Linux. You are missing packages that are required in order to build handbrake.

Dapsol
Posts: 6
Joined: Sat Aug 30, 2014 4:53 pm

Re: Issues with CLI on Ubuntu 14.04

Postby Dapsol » Sun Aug 31, 2014 3:28 pm

Thanks for pointing me in the right direction, i've installed the packages listed in the 'BUILD-Linux' file (for Ubuntu) but still getting the same error when building.

User avatar
JohnAStebbins
HandBrake Team
Posts: 4730
Joined: Sat Feb 09, 2008 7:21 pm

Re: Issues with CLI on Ubuntu 14.04

Postby JohnAStebbins » Sun Aug 31, 2014 9:33 pm

You are missing libx264-dev which is certainly listed in the BUILD-Linux file.

Dapsol
Posts: 6
Joined: Sat Aug 30, 2014 4:53 pm

Re: Issues with CLI on Ubuntu 14.04

Postby Dapsol » Sun Aug 31, 2014 9:53 pm

Oops, sorry you are right. The BUILD-Linux file is a bit confusing i think, it says:
To install these packages:
sudo apt-get install subversion yasm build-essential autoconf libtool \
zlib1g-dev libbz2-dev libogg-dev libtheora-dev libvorbis-dev \
libsamplerate-dev libxml2-dev libfribidi-dev libfreetype6-dev \
libfontconfig1-dev libass-dev libmp3lame-dev intltool libglib2.0-dev \
libdbus-glib-1-dev libgtk-3-dev libgudev-1.0-dev libwebkitgtk-3.0-dev \
libnotify-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev \
libappindicator-dev


However, this list seems not 100% complete, because as you said there are other packages listed as well a few lines above this text :o
So now i installed these, and i have a successful build :-) Thank you for your assistance, i'm not used to doing this stuff so...

Code: Select all

apt-get install subversion yasm build-essential autoconf libtool zlib1g-dev libbz2-dev libxml2-dev libogg-dev libvorbis-dev libsamplerate-dev libfribidi-dev libfreetype6-dev libfontconfig1-dev libass-dev libmp3lame-dev libx264-dev intltool libglib2.0-dev libdbus-glib-1-dev libgtk-3-dev libgudev-1.0-dev libwebkitgtk-3.0-dev libnotify-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libappindicator-dev libtheora-dev

User avatar
JohnAStebbins
HandBrake Team
Posts: 4730
Joined: Sat Feb 09, 2008 7:21 pm

Re: Issues with CLI on Ubuntu 14.04

Postby JohnAStebbins » Mon Sep 01, 2014 2:16 pm

Ah, thanks for pointing out the documentation error. Will fix that.


Return to “*nix”