Unable to compile under Debian Testing

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
Kavey
Posts: 9
Joined: Mon Nov 09, 2015 9:48 pm

Unable to compile under Debian Testing

Post by Kavey » Fri Apr 06, 2018 10:54 pm

Description of problem or question:
I'm running Debian Testing and recently I am not able to compile Handbrake from source.

I'm sure this is due to a change that was made upstream for encx264 but I have no idea how to get this working again with Handbrake.


Steps to reproduce the problem (If Applicable):
Run through the instructions to compile



HandBrake version (e.g., 1.0.0):
1.0.7



Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Debian Testing
$ uname -a
Linux kavern 4.15.0-2-amd64 #1 SMP Debian 4.15.11-1 (2018-03-20) x86_64 GNU/Linux


Code: Select all

In file included from ../libhb/encx264.h:14:0,
                 from ../libhb/encx264.c:14:
../libhb/h264_common.h:16:21: warning: duplicate ‘const’ declaration specifier [-Wduplicate-decl-specifier]
 static const int    const    hb_h264_level_values[] = {     -1,    10,    9,    11,    12,    13,    20,    21,    22,    30,    31,    32,    40,    41,    42,    50,    51,    52,     0, };
                     ^~~~~
../libhb/encx264.c: In function ‘hb_x264_global_init’:
../libhb/encx264.c:154:46: error: ‘x264_bit_depth’ undeclared (first use in this function); did you mean ‘x264_lib_open’?
     x264_apis[0].bit_depth                 = x264_bit_depth;
                                              ^~~~~~~~~~~~~~
                                              x264_lib_open
../libhb/encx264.c:154:46: note: each undeclared identifier is reported only once for each function it appears in
../libhb/module.rules:12: recipe for target 'libhb/encx264.o' failed
make: *** [libhb/encx264.o] Error 1

User avatar
BradleyS
Moderator
Posts: 1325
Joined: Thu Aug 09, 2007 12:16 pm

Re: Unable to compile under Debian Testing

Post by BradleyS » Mon Apr 09, 2018 12:08 pm

Try with git master head or the recently released 1.1.0. Both are significantly newer.

See also: https://handbrake.fr/docs/en/latest/dev ... ebian.html

Kavey
Posts: 9
Joined: Mon Nov 09, 2015 9:48 pm

Re: Unable to compile under Debian Testing

Post by Kavey » Fri Apr 13, 2018 11:02 pm

Thanks. I did manage to get it compiled using the source from github. I think 1.0.7 was still the released version at the time and I am just not as familiar with git as I probably should be. I tend to stick with packages that are available unless there's a specific need to build from source (in this case the Debian packages don't handle Blu-ray subtitles correctly) and even then I tend to stick with the stable releases.

Post Reply