Wrong Length (40%) on Import

Archive of historical bug reports.
Please use the GitHub link above to report issues.
Forum rules
*******************************

Please be aware we are now using GitHub for issue tracking and feature requests.

- This forum is now closed to new topics.
- Existing topics will remain open for a short while as the transition over occurs.
*******************************
Post Reply
hq7878
Posts: 2
Joined: Fri Jun 30, 2017 3:24 am

Wrong Length (40%) on Import

Post by hq7878 » Fri Jun 30, 2017 3:36 am

Please describe the problem in as much detail as possible:
My video is 9 hours 34 minutes and it shows up under the title as 13 hours 18 minutes. It does this both as a TS and AVI file.

Image

What are the steps to reproduce this problem:
Happens when I import the file.

What version of HandBrake you are running:
This is using Nightly (2017062801) 64bit because the 1.0.7 (2017040900) would scan the title 100% and free for over an hour.

What operating system and version and you running (e.g. OSX 10.11, Windows 7, Ubuntu 14):
Windows 10, 64bit
Where did you download HandBrake from? handbrake.fr or somewhere else?
.fr
If there was any error, exception or crash report displayed, please copy it and paste it here:

Please include the scan or encode log:

Code: Select all

 To make the log easier to read, please paste your log here between the code brackets, or use a pastebin website. 

rollin_eng
Veteran User
Posts: 2881
Joined: Wed May 04, 2011 11:06 pm

Re: Wrong Length (40%) on Import

Post by rollin_eng » Fri Jun 30, 2017 8:06 am

Could you please post your logs, instructions can be found here:

viewtopic.php?f=6&t=31236

mduell
Veteran User
Posts: 6153
Joined: Sat Apr 21, 2007 8:54 pm

Re: Wrong Length (40%) on Import

Post by mduell » Fri Jun 30, 2017 3:37 pm

Forum rules
READ ME before posting bugs

hq7878
Posts: 2
Joined: Fri Jun 30, 2017 3:24 am

Re: Wrong Length (40%) on Import

Post by hq7878 » Sat Jul 01, 2017 3:33 pm

Here is the code.
I have successfully converted others videos in this series but they were only an hour or two. This video is over 9 hours long.

Code: Select all

HandBrake Nightly 20170627162138-da26ad0-master (2017062801) - 64bit
OS: Microsoft Windows NT 10.0.14393.0 - 64bit
CPU: Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz
Ram: 12147 MB, 
GPU Information:
  Intel(R) HD Graphics 520 - 21.20.16.4590
Screen: 1920x1080
Temp Dir: C:\Users\Kevin Cortese DDS\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake Nightly
Data Dir: C:\Users\Kevin Cortese DDS\AppData\Roaming\HandBrake Team\HandBrake\1.1.0.0

-------------------------------------------

[11:31:42] hb_init: starting libhb thread
[11:31:42] hb_init: starting libhb thread
[11:31:42] hb_init: starting libhb thread
[11:31:42] hb_init: starting libhb thread
[11:31:43] hb_init: starting libhb thread
[11:31:43] hb_init: starting libhb thread
[11:31:52] hb_init: starting libhb thread

 # Starting Scan ...

[11:31:52] CPU: Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz
[11:31:52]  - Intel microarchitecture Skylake
[11:31:52]  - logical processor count: 4
[11:31:52] Intel Quick Sync Video support: yes
[11:31:52]  - Intel Media SDK hardware: API 1.21 (minimum: 1.3)
[11:31:52]  - H.264 encoder: yes
[11:31:52]     - preferred implementation: hardware (any)
[11:31:52]     - capabilities (hardware):  breftype icq+la+i+downs vsinfo opt1 opt2+mbbrc+extbrc+trellis+ib_adapt+nmpslice
[11:31:52]  - H.265 encoder: yes (8bit: yes, 10bit: no)
[11:31:52]     - preferred implementation: hardware (any)
[11:31:52]     - capabilities (hardware):  bpyramid vsinfo opt1
[11:31:52] hb_scan: path=C:\Del\GKIC HANDBRAKE\video_3G_PFB.TS, title_index=0
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:274: failed opening UDF image C:\Del\GKIC HANDBRAKE\video_3G_PFB.TS
src/libbluray/disc/disc.c:352: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:352: error opening file BDMV\BACKUP\index.bdmv
[11:31:52] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[11:31:52] dvd: not a dvd - trying as a stream/file instead
[11:31:52] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[11:31:52] Found the following PIDS
[11:31:52]     Video PIDS :
[11:31:52]       0x100 type H.264 (0x1b) (PCR)
[11:31:52]     Audio PIDS :
[11:31:52]       0x101 type AAC (0xf)
[11:31:52]     Subtitle PIDS :
[11:31:52]     Other PIDS :
[11:31:52] stream id 0x101 (type 0xf substream 0x0) audio 0x101
[11:31:52] scan: decoding previews for title 1
[11:31:52] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[11:31:53] scan: audio 0x101: aac, rate=48000Hz, bitrate=98625 Unknown (AAC) (2.0 ch)
[11:31:53] stream: 12 good frames, 0 errors (0%)
[11:31:53] scan: 10 previews, 1280x720, 29.970 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[11:31:53] scan: supported video decoders: avcodec qsv
[11:31:53] libhb: scan thread found 1 valid title(s)

 # Processing Scan Information ...


 # Scan Finished ...

  

mduell
Veteran User
Posts: 6153
Joined: Sat Apr 21, 2007 8:54 pm

Re: Wrong Length (40%) on Import

Post by mduell » Sat Jul 01, 2017 4:16 pm

Your TS probably contains errors that HB doesn't cope with. Try VideoReDo's Quick Stream Fix.

Post Reply