Can't scannig MPEG-TS

Report and discuss *new*, *consistent*, *reproducible* bugs here
Post Reply
kdantas
Posts: 5
Joined: Sun Sep 27, 2015 5:03 pm

Can't scannig MPEG-TS

Post by kdantas » Tue Feb 07, 2017 5:54 pm

Please describe the problem in as much detail as possible:

Handbrake don´t open the file. It keeps scanning without stopping.

Mediainfo log:

Code: Select all

Geral
Nome completo                            : H:\Amor.e.Sexo.mpeg
Formato                                  : MPEG-TS
Perfil do Formato                        : No PAT/PMT
Tamanho do arquivo                       : 5.49 GiB
Duração                                  : 55 min 27s
Taxa de Bits Total, Modo                 : Variável
Taxa de Bits Total                       : 14.2 Mb/s

Vídeo
ID                                       : 49 (0x31)
Formato                                  : AVC
Formato/Informações                      : Advanced Video Codec
Perfil do Formato                        : High@L4
Conf do Formato, CABAC                   : Sim
Conf do Formato, Quadros de Ref.         : 4 quadros
Duração                                  : 55 min 27s
Largura                                  : 1 920 pixels
Altura                                   : 1 080 pixels
Proporção da imagem                      : 16:9
Taxa de quadros                          : 29.970 (30000/1001) FPS
ColorSpace                               : YUV
ChromaSubsampling/String                 : 4:2:0
BitDepth/String                          : 8 bits
Tipo de Scan                             : Entrelaçado
Ordem do Scan                            : Primeiro a área superior
colour_range                             : Limited
colour_primaries                         : BT.709
transfer_characteristics                 : BT.709
matrix_coefficients                      : BT.709

Áudio
ID                                       : 51 (0x33)
Formato                                  : AAC
Formato/Informações                      : Advanced Audio Codec
Perfil do Formato                        : HE-AAC / LC
Modo de Multiplexação                    : LATM
Duração                                  : 55 min 27s
Modo da taxa de bits                     : Variável
Nº de canais                             : 2 canais
Posições dos canais                      : Front: L R
Taxa de amostragem                       : 48.0 kHz / 24.0 kHz
Taxa de quadros                          : 23.438 FPS (1024 spf)
Atraso do Video                          : -868 ms
What are the steps to reproduce this problem:

At the beggining, when trying to open the file, handbrake keep scanning without stopping.

What version of HandBrake you are running:

1.0.2

What operating system and version and you running (e.g. OSX 10.11, Windows 7, Ubuntu 14):

Windows 8.1

If there was any exception or error displayed, please copy it and paste it here:

No, because the program do not stop. It keeps scanning without stopping. I have to close forced.

Please include the scan or encode log:

Code: Select all

HandBrake 1.0.2 (2017012200) - 64bit
OS: Microsoft Windows NT 6.3.9600.0 - 64bit
CPU: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
Ram: 8071 MB, 
GPU Information:
  Intel(R) HD Graphics 4000 - 10.18.10.3958
  AMD Radeon HD 7500M/7600M Series - 13.251.9001.1001
Screen: 1366x768
Temp Dir: C:\Users\Kleber\AppData\Local\Temp\
Install Dir: C:\HandBrake
Data Dir: C:\Users\Kleber\AppData\Roaming\HandBrake Team\HandBrake\1.0.2.0

-------------------------------------------

[14:07:05] hb_init: starting libhb thread
[14:07:05] hb_init: starting libhb thread
[14:07:05] hb_init: starting libhb thread
[14:07:05] hb_init: starting libhb thread
[14:30:17] hb_init: starting libhb thread

 # Starting Scan ...

[14:30:17] CPU: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
[14:30:17]  - Intel microarchitecture Ivy Bridge
[14:30:17]  - logical processor count: 4
[14:30:17] Intel Quick Sync Video support: yes
[14:30:17]  - Intel Media SDK hardware: API 1.4 (minimum: 1.3)
[14:30:17]  - H.264 encoder: yes
[14:30:17]     - preferred implementation: hardware (any)
[14:30:17]     - capabilities (hardware):  vsinfo opt1
[14:30:17]  - H.265 encoder: no
[14:30:17] hb_scan: path=H:\Amor.[0].mpeg.trp.ts, title_index=0
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:274: failed opening UDF image H:\Amor.[0].mpeg.trp.ts
src/libbluray/disc/disc.c:352: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:352: error opening file BDMV\BACKUP\index.bdmv
[14:30:17] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[14:30:17] dvd: not a dvd - trying as a stream/file instead
[14:30:17] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[14:30:17] hb_ts_stream_find_pids - end of file

PaulF
Posts: 58
Joined: Thu Nov 21, 2013 7:15 am

Re: Can't scannig MPEG-TS

Post by PaulF » Mon Mar 06, 2017 3:51 am

I run Hanbrake on TV show transport streams every day with no problems.

I found a couple differences:
Me
HandBrake 1.0.3 (2017022500) - 64bit
You
HandBrake 1.0.2 (2017012200) - 64bit

Me
[19:29:01] - Intel microarchitecture Haswell
You
[14:30:17] - Intel microarchitecture Ivy Bridge

It's quite annoying that my old core i7 is that much slower than your core i5

After the last line in your log my log starts some video warnings for the video PID from the h.264 encoder(not Intel). They may be trying to find a video PID. Only a guess. Mediainfo seems to find it.

mduell
Veteran User
Posts: 5525
Joined: Sat Apr 21, 2007 8:54 pm

Re: Can't scannig MPEG-TS

Post by mduell » Mon Mar 06, 2017 4:05 am

Try fixing the TS with VideoReDo's Quick Stream Fix before feeding it to HB.

kdantas
Posts: 5
Joined: Sun Sep 27, 2015 5:03 pm

Re: Can't scannig MPEG-TS

Post by kdantas » Mon Mar 06, 2017 1:51 pm

mduell wrote:
Mon Mar 06, 2017 4:05 am
Try fixing the TS with VideoReDo's Quick Stream Fix before feeding it to HB.
Really, If I save a copy of my file with VideoReDo, it works normally with HB.

Post Reply