Corrupt encoded video with 1.0.1 (1.0.0 aswell)

Archive of historical bug reports.
Please use the GitHub link above to report issues.
Forum rules
*******************************
Please be aware we are now using GitHub for issue tracking and feature requests.
- This section of the forum is now closed to new topics.

*******************************
Post Reply
oRBIT2002
Posts: 74
Joined: Sun Nov 01, 2009 11:22 am

Corrupt encoded video with 1.0.1 (1.0.0 aswell)

Post by oRBIT2002 » Mon Jan 02, 2017 8:22 pm

Please describe the problem in as much detail as possible:
My output video looks corrupt in several players. The problems comes and goes through the encoded file.. I attach a cropped screenshot.
Image

What are the steps to reproduce this problem:
I used this sourcefile (see below). It's a 4K-file. I tried encoding both at x264 or x265. Equally bad result

Code: Select all

Format                                   : MPEG-4
Format profile                           : Base Media / Version 2
Codec ID                                 : mp42
File size                                : 475 MiB
Duration                                 : 1mn 13s
Overall bit rate mode                    : Variable
Overall bit rate                         : 54.5 Mbps
Encoded date                             : UTC 2017-01-01 19:38:13
Tagged date                              : UTC 2017-01-01 19:38:13
Writing application                      : TMPGEnc MPEG Smart Renderer 5 Version 5.0.7.9

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L5.1
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 2 frames
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 1mn 13s
Bit rate mode                            : Variable
Bit rate                                 : 54.3 Mbps
Maximum bit rate                         : 60.0 Mbps
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 29.970 fps
Standard                                 : Component
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.218
Stream size                              : 473 MiB (100%)
Encoded date                             : UTC 2017-01-01 19:38:13
Tagged date                              : UTC 2017-01-01 19:38:13
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : IEC 61966-2-4
Matrix coefficients                      : BT.709

Audio
ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : HE-AAC / LC
Codec ID                                 : 40
Duration                                 : 1mn 13s
Bit rate mode                            : Variable
Bit rate                                 : 223 Kbps
Maximum bit rate                         : 288 Kbps
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz / 24.0 KHz
Compression mode                         : Lossy
Stream size                              : 1.94 MiB (0%)
Encoded date                             : UTC 2017-01-01 19:38:13
Tagged date                              : UTC 2017-01-01 19:38:13

What version of HandBrake you are running:
1.0.1

What operating system and version and you running (e.g. OSX 10.11, Windows 7, Ubuntu 14):
Windows 10, x64
If there was any exception or error displayed, please copy it and paste it here:

Please include the scan or encode log:

Code: Select all

HandBrake 1.0.1 (2016122900) - 64bit
OS: Microsoft Windows NT 10.0.14393.0 - 64bit
CPU: Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz
Ram: 8131 MB, 
GPU Information:
  NVIDIA GeForce GTX 650 - 21.21.13.6909
Screen: 1920x1080
Temp Dir: C:\Users\Morgan\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake
Data Dir: C:\Users\Morgan\AppData\Roaming\HandBrake Team\HandBrake\1.0.1.0

-------------------------------------------


# Starting Encode ...

[21:13:08] hb_init: starting libhb thread
[21:13:08] 1 job(s) to process
[21:13:08] json job:
{
  "Audio": {
    "AudioList": [
      {
        "DRC": 0.0,
        "Encoder": 1073807360,
        "Gain": 0.0,
        "Mixdown": -1,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      1073807360,
      1073743872,
      1074003968,
      1073750016,
      1090519040,
      1074790400,
      1074266112,
      1107296256
    ],
    "FallbackEncoder": 2048
  },
  "Destination": {
    "ChapterList": [
      {
        "Name": "Chapter 1"
      }
    ],
    "ChapterMarkers": true,
    "File": "M:\\Videokamera - klara\\2017\\2017-01-01 På utflykt.mp4",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": false
    },
    "Mux": 131072
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 11,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "0",
          "crop-right": "0",
          "crop-top": "0",
          "height": "1080",
          "width": "1920"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "1"
        }
      }
    ]
  },
  "PAR": {
    "Num": 1,
    "Den": 1
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "time",
      "Start": 0,
      "End": 1800000
    },
    "Title": 1,
    "Path": "M:\\Videokamera - Rådata\\2017\\2017-01-01 Utflykt\\2017-01-01 På Utflykt.4K.RAW.mp4"
  },
  "Subtitle": {
    "Search": {
      "Burn": true,
      "Default": false,
      "Enable": true,
      "Forced": false
    },
    "SubtitleList": []
  },
  "Video": {
    "Encoder": 65536,
    "Level": "4.1",
    "Bitrate": 15000,
    "TwoPass": true,
    "Turbo": true,
    "ColorMatrixCode": 0,
    "Options": "",
    "Preset": "slow",
    "Profile": "high",
    "OpenCL": false,
    "HWDecode": false,
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[21:13:08] CPU: Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz
[21:13:08]  - Intel microarchitecture Haswell
[21:13:08]  - logical processor count: 4
[21:13:08] OpenCL: library not available
[21:13:08] Intel Quick Sync Video support: no
[21:13:08] hb_scan: path=M:\Videokamera - Rådata\2017\2017-01-01 Utflykt\2017-01-01 På Utflykt.4K.RAW.mp4, title_index=1
src/libbluray/disc/disc.c:274: failed opening UDF image M:\Videokamera - RÃ¥data\2017\2017-01-01 Utflykt\2017-01-01 PÃ¥ Utflykt.4K.RAW.mp4
src/libbluray/disc/disc.c:352: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:352: error opening file BDMV\BACKUP\index.bdmv
[21:13:08] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[21:13:08] dvd: not a dvd - trying as a stream/file instead
[h264 @ 0000023deb1f84c0] reference picture missing during reorder
[h264 @ 0000023deb1f84c0] reference picture missing during reorder
[h264 @ 0000023deb1f84c0] Missing reference picture
[h264 @ 0000023deb1f84c0] Missing reference picture
[h264 @ 0000023deb1f84c0] reference picture missing during reorder
[h264 @ 0000023deb1f84c0] reference picture missing during reorder
[h264 @ 0000023deb1f84c0] Missing reference picture
[h264 @ 0000023deb1f84c0] Missing reference picture
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'M:\Videokamera - RÃ¥data\2017\2017-01-01 Utflykt\2017-01-01 PÃ¥ Utflykt.4K.RAW.mp4':
  Metadata:
    major_brand     : mp42
    minor_version   : 0
    compatible_brands: mp42isomavc1
    creation_time   : 2017-01-01 19:38:13
  Duration: 00:01:13.08, start: 0.000000, bitrate: 54500 kb/s
    Stream #0:0(und): Video: h264 (High) [avc1 / 0x31637661]
      yuv420p, tv, bt709/bt709/iec61966-2-4
      3840x2160 [PAR 1:1 DAR 16:9], 54285 kb/s
      29.97 fps, 60k tbn (default)
    Metadata:
      creation_time   : 2017-01-01 19:38:13
      handler_name    : Video Media Handler
      encoder         : AVC Coding
    Stream #0:1(und): Audio: aac (HE-AAC) [mp4a / 0x6134706D]
      48000 Hz, stereo, fltp, 222 kb/s (default)
    Metadata:
      creation_time   : 2017-01-01 19:38:13
      handler_name    : Sound Media Handler
[21:13:08] scan: decoding previews for title 1
[h264 @ 0000023df69484c0] reference picture missing during reorder
[h264 @ 0000023df69484c0] reference picture missing during reorder
[h264 @ 0000023df69484c0] Missing reference picture
[h264 @ 0000023df69484c0] Missing reference picture
[h264 @ 0000023df69484c0] reference picture missing during reorder
[h264 @ 0000023df69484c0] reference picture missing during reorder
[h264 @ 0000023df69484c0] Missing reference picture
[h264 @ 0000023df69484c0] Missing reference picture
[21:13:09] scan: audio 0x1: aac, rate=48000Hz, bitrate=222687 Unknown (AAC) (2.0 ch)
[21:13:12] scan: 10 previews, 3840x2160, 29.970 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[21:13:12] scan: supported video decoders: avcodec qsv
[21:13:12] libhb: scan thread found 1 valid title(s)
[21:13:12] Skipping subtitle scan.  No suitable subtitle tracks.
[21:13:12] starting job
[21:13:12] work: only 1 chapter, disabling chapter markers
[21:13:12] job configuration:
[21:13:12]  * source
[21:13:12]    + M:\Videokamera - Rådata\2017\2017-01-01 Utflykt\2017-01-01 På Utflykt.4K.RAW.mp4
[21:13:12]    + title 1, start 00:00:0.00 stop 00:00:20.00
[21:13:12]    + container: mov,mp4,m4a,3gp,3g2,mj2
[21:13:12]    + data rate: 54500 kbps
[21:13:12]  * destination
[21:13:12]    + M:\Videokamera - klara\2017\2017-01-01 På utflykt.mp4
[21:13:12]    + container: MPEG-4 (libavformat)
[21:13:12]  * video track
[21:13:12]    + decoder: h264
[21:13:12]      + bitrate 54285 kbps
[21:13:12]    + filters
[21:13:12]      + Framerate Shaper (mode=1)
[21:13:12]        + frame rate: 29.970 fps -> constant 29.970 fps
[21:13:12]      + Crop and Scale (width=1920:height=1080:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[21:13:12]        + source: 3840 * 2160, crop (0/0/0/0): 3840 * 2160, scale: 1920 * 1080
[21:13:12]    + Output geometry
[21:13:12]      + storage dimensions: 1920 x 1080
[21:13:12]      + pixel aspect ratio: 1 : 1
[21:13:12]      + display dimensions: 1920 x 1080
[21:13:12]    + encoder: H.264 (libx264)
[21:13:12]      + preset:  slow
[21:13:12]      + profile: high
[21:13:12]      + level:   4.1
[21:13:12]      + bitrate: 15000 kbps, pass: 1
[21:13:12]      + fast first pass
[21:13:12]      + options: ref=1:8x8dct=0:me=dia:trellis=0
[21:13:12]                 analyse=i4x4 (if originally enabled, else analyse=none)
[21:13:12]                 subq=2 (if originally greater than 2, else subq unchanged)
[21:13:12]  * audio track 1
[21:13:12]    + decoder: Unknown (AAC) (2.0 ch) (track 1, id 0x1)
[21:13:12]      + bitrate: 222 kbps, samplerate: 48000 Hz
[21:13:12]    + AAC Passthru
[h264 @ 0000023dfa69d9c0] reference picture missing during reorder
[h264 @ 0000023dfa69d9c0] reference picture missing during reorder
[h264 @ 0000023dfa69d9c0] Missing reference picture
[h264 @ 0000023dfa69d9c0] Missing reference picture
[h264 @ 0000023dfa69d9c0] reference picture missing during reorder
[h264 @ 0000023dfa69d9c0] reference picture missing during reorder
[h264 @ 0000023dfa69d9c0] Missing reference picture
[h264 @ 0000023dfa69d9c0] Missing reference picture
[21:13:12] sync: expecting 629 video frames
[21:13:12] encx264: min-keyint: 30, keyint: 300
[21:13:12] encx264: encoding at average bitrate 15000
[21:13:12] encx264: unparsed options: ref=4:level=4.1:b-adapt=2:direct=auto:subme=8:me=umh:vbv-maxrate=62500:vbv-bufsize=78125:rc-lookahead=50
x264 [info]: using SAR=1/1
x264 [warning]: VBV bitrate (62500) > level limit (50000)
x264 [warning]: VBV buffer (78125) > level limit (62500)
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 AVX2 LZCNT BMI2
x264 [info]: profile Main, level 4.1
[21:13:13] sync: first pts video is 0
[21:13:13] sync: "Chapter 1" (1) at frame 1 time 0
[21:13:13] sync: first pts audio 0x1 is 0
[21:13:36] sync: reached audio 0x1 pts 1800960, exiting early
[21:13:36] sync: reached video pts 1801800, exiting early
[21:13:37] work: average encoding speed for job is 26.735104 fps
[21:13:37] vfr: 600 frames output, 0 dropped and 0 duped for CFR/PFR
[21:13:37] vfr: lost time: 0 (0 frames)
[21:13:37] vfr: gained time: 0 (0 frames) (0 not accounted for)
[21:13:37] aac-decoder done: 528 frames, 0 decoder errors
[21:13:37] h264-decoder done: 672 frames, 0 decoder errors
[21:13:37] sync: got 600 frames, 629 expected
[21:13:37] sync: framerate min 29.970 fps, max 29.970 fps, avg 29.970 fps
x264 [info]: frame I:3     Avg QP:22.07  size:596762
x264 [info]: frame P:189   Avg QP:28.10  size:148103
x264 [info]: frame B:408   Avg QP:33.10  size: 19455
x264 [info]: consecutive B-frames:  2.5%  9.0% 34.5% 54.0%
x264 [info]: mb I  I16..4:  1.0%  0.0% 99.0%
x264 [info]: mb P  I16..4:  7.7%  0.0%  0.0%  P16..4: 85.6%  0.0%  0.0%  0.0%  0.0%    skip: 6.7%
x264 [info]: mb B  I16..4:  0.5%  0.0%  0.0%  B16..8: 20.9%  0.0%  0.0%  direct: 8.9%  skip:69.6%  L0:26.8% L1:39.0% BI:34.1%
x264 [info]: final ratefactor: 24.31
x264 [info]: direct mvs  spatial:99.3% temporal:0.7%
x264 [info]: coded y,uvDC,uvAC intra: 94.9% 69.4% 37.1% inter: 27.3% 8.4% 1.1%
x264 [info]: i16 v,h,dc,p: 13% 15% 55% 16%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 12% 16% 14%  8% 10%  8% 12%  7% 13%
x264 [info]: i8c dc,h,v,p: 56% 21% 18%  6%
x264 [info]: Weighted P-Frames: Y:14.3% UV:7.4%
x264 [info]: kb/s:15072.60
[21:13:37] starting job
[21:13:37] work: only 1 chapter, disabling chapter markers
[21:13:37] job configuration:
[21:13:37]  * source
[21:13:37]    + M:\Videokamera - Rådata\2017\2017-01-01 Utflykt\2017-01-01 På Utflykt.4K.RAW.mp4
[21:13:37]    + title 1, start 00:00:0.00 stop 00:00:20.00
[21:13:37]    + container: mov,mp4,m4a,3gp,3g2,mj2
[21:13:37]    + data rate: 54500 kbps
[21:13:37]  * destination
[21:13:37]    + M:\Videokamera - klara\2017\2017-01-01 På utflykt.mp4
[21:13:37]    + container: MPEG-4 (libavformat)
[21:13:37]  * video track
[21:13:37]    + decoder: h264
[21:13:37]      + bitrate 54285 kbps
[21:13:37]    + filters
[21:13:37]      + Framerate Shaper (mode=1)
[21:13:37]        + frame rate: 29.970 fps -> constant 29.970 fps
[21:13:37]      + Crop and Scale (width=1920:height=1080:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[21:13:37]        + source: 3840 * 2160, crop (0/0/0/0): 3840 * 2160, scale: 1920 * 1080
[21:13:37]    + Output geometry
[21:13:37]      + storage dimensions: 1920 x 1080
[21:13:37]      + pixel aspect ratio: 1 : 1
[21:13:37]      + display dimensions: 1920 x 1080
[21:13:37]    + encoder: H.264 (libx264)
[21:13:37]      + preset:  slow
[21:13:37]      + profile: high
[21:13:37]      + level:   4.1
[21:13:37]      + bitrate: 15000 kbps, pass: 2
[21:13:37]  * audio track 1
[21:13:37]    + decoder: Unknown (AAC) (2.0 ch) (track 1, id 0x1)
[21:13:37]      + bitrate: 222 kbps, samplerate: 48000 Hz
[21:13:37]    + AAC Passthru
[h264 @ 0000023d9c85b960] reference picture missing during reorder
[h264 @ 0000023d9c85b960] reference picture missing during reorder
[h264 @ 0000023d9c85b960] Missing reference picture
[h264 @ 0000023d9c85b960] Missing reference picture
[h264 @ 0000023d9c85b960] reference picture missing during reorder
[h264 @ 0000023d9c85b960] reference picture missing during reorder
[h264 @ 0000023d9c85b960] Missing reference picture
[h264 @ 0000023d9c85b960] Missing reference picture
[21:13:38] sync: expecting 600 video frames
[21:13:38] encx264: min-keyint: 30, keyint: 300
[21:13:38] encx264: encoding at average bitrate 15000
[21:13:38] encx264: unparsed options: ref=4:level=4.1:b-adapt=2:direct=auto:subme=8:me=umh:vbv-maxrate=62500:vbv-bufsize=78125:rc-lookahead=50
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 AVX2 LZCNT BMI2
x264 [info]: profile High, level 4.1
[21:13:39] sync: first pts video is 0
[21:13:39] sync: "Chapter 1" (1) at frame 1 time 0
[21:13:39] sync: first pts audio 0x1 is 0
[21:14:27] sync: reached audio 0x1 pts 1800960, exiting early
[21:14:27] sync: reached video pts 1801800, exiting early
[21:14:29] work: average encoding speed for job is 12.521982 fps
[21:14:30] vfr: 600 frames output, 0 dropped and 0 duped for CFR/PFR
[21:14:30] vfr: lost time: 0 (0 frames)
[21:14:30] vfr: gained time: 0 (0 frames) (0 not accounted for)
[21:14:30] aac-decoder done: 575 frames, 0 decoder errors
[21:14:30] h264-decoder done: 723 frames, 0 decoder errors
[21:14:30] sync: got 600 frames, 600 expected
[21:14:30] sync: framerate min 29.970 fps, max 29.970 fps, avg 29.970 fps
x264 [info]: frame I:3     Avg QP:25.50  size:464503
x264 [info]: frame P:189   Avg QP:28.11  size:149744
x264 [info]: frame B:408   Avg QP:32.83  size: 19751
x264 [info]: consecutive B-frames:  2.5%  9.0% 34.5% 54.0%
x264 [info]: mb I  I16..4:  1.3% 65.7% 32.9%
x264 [info]: mb P  I16..4:  0.2%  5.9%  3.3%  P16..4: 36.2% 23.8% 23.4%  0.0%  0.0%    skip: 7.2%
x264 [info]: mb B  I16..4:  0.0%  0.3%  0.2%  B16..8: 34.2%  8.2%  4.3%  direct: 3.9%  skip:48.9%  L0:41.2% L1:47.2% BI:11.6%
x264 [info]: 8x8 transform intra:62.7% inter:51.2%
x264 [info]: direct mvs  spatial:100.0% temporal:0.0%
x264 [info]: coded y,uvDC,uvAC intra: 95.6% 79.7% 45.3% inter: 25.5% 11.7% 1.6%
x264 [info]: i16 v,h,dc,p: 30% 19% 20% 31%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu:  9%  8%  5% 10% 14% 12% 16% 10% 15%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 10%  8%  5%  9% 14% 13% 14% 11% 15%
x264 [info]: i8c dc,h,v,p: 48% 25% 15% 13%
x264 [info]: Weighted P-Frames: Y:14.3% UV:7.4%
x264 [info]: ref P L0: 62.8% 20.0%  9.9%  6.4%  0.8%  0.0%
x264 [info]: ref B L0: 84.3% 12.3%  3.4%
x264 [info]: ref B L1: 94.7%  5.3%
x264 [info]: kb/s:15086.28
[21:14:30] mux: track 0, 600 frames, 37753275 bytes, 15061.12 kbps, fifo 256
[21:14:30] mux: track 1, 469 frames, 557016 bytes, 222.21 kbps, fifo 256
[21:14:30] libhb: work result = 0

# Encode Completed ...


Woodstock
Veteran User
Posts: 3154
Joined: Tue Aug 27, 2013 6:39 am

Re: Corrupt encoded video with 1.0.1 (1.0.0 aswell)

Post by Woodstock » Mon Jan 02, 2017 11:37 pm

Are the corrupted sections always at the same point, regardless of the player? That is, if it occurs at 1:43 on player X, player Y will have the same corruption at 1:43.

ashleylai87
Posts: 33
Joined: Tue Jul 30, 2013 3:54 am

Re: Corrupt encoded video with 1.0.1 (1.0.0 aswell)

Post by ashleylai87 » Tue Jan 03, 2017 3:12 am

oRBIT2002 , can you upload your 475 MiB source video?

ashleylai87
Posts: 33
Joined: Tue Jul 30, 2013 3:54 am

Re: Corrupt encoded video with 1.0.1 (1.0.0 aswell)

Post by ashleylai87 » Tue Jan 03, 2017 3:13 am

ashleylai87 wrote:oRBIT2002 , can you upload your 475 MiB source video?
Send it to handbrake developer memberlist.php?mode=viewprofile&u=25178

oRBIT2002
Posts: 74
Joined: Sun Nov 01, 2009 11:22 am

Re: Corrupt encoded video with 1.0.1 (1.0.0 aswell)

Post by oRBIT2002 » Tue Jan 03, 2017 10:29 am

Yes, errors always occurs at the same location no matter what player. Since this video contains material of my kids I am not that interested in sharing it online.. Can we solve it in some other way perhaps?

I tried encoding it with an old Handbrake Nightly build and didn't get the errors btw...

User avatar
s55
HandBrake Team
Posts: 9501
Joined: Sun Dec 24, 2006 1:05 pm

Re: Corrupt encoded video with 1.0.1 (1.0.0 aswell)

Post by s55 » Tue Jan 03, 2017 11:45 am

That's odd. I don't think we've fixed anything like this since 1.0.1

The h264 decoder is spitting out quite a few errors with your source. Do you get these same errors with the nightly?


Edit: Sorry, "OLD" nightly. Fair enough. Probably pre-libav12. I suspect we have a decoder bug in libav maybe.

User avatar
JohnAStebbins
HandBrake Team
Posts: 5420
Joined: Sat Feb 09, 2008 7:21 pm

Re: Corrupt encoded video with 1.0.1 (1.0.0 aswell)

Post by JohnAStebbins » Tue Jan 03, 2017 5:25 pm

oRBIT2002 wrote:... Since this video contains material of my kids I am not that interested in sharing it online.. Can we solve it in some other way perhaps?
Can you try shooting some sample videos with the same camera and see if the issue can be reproduced with less sensitive footage?

oRBIT2002
Posts: 74
Joined: Sun Nov 01, 2009 11:22 am

Re: Corrupt encoded video with 1.0.1 (1.0.0 aswell)

Post by oRBIT2002 » Tue Jan 03, 2017 7:38 pm

Okay, I think I've located the issue.. Handbrake doesn't always seem to like mp4-files created by "TMPG Smart Rendererer 5" (an usually excellent application for merging/cutting/editing videos without recoding). I'm under the impression that the above mentioned application is usually very strict when generating files concerning standards etc., but perhaps they're having an issue... (?)

Here's an example file (our christmastree btw... :)
https://dl.dropboxusercontent.com/u/259 ... ed.raw.mp4 (165MB)
At about position 00:07 there's a cut..

Check out my recoded version of the same clip with Handbrake. There's distortions at that point.
https://dl.dropboxusercontent.com/u/259 ... .raw-1.mp4 (40MB)

mduell
Veteran User
Posts: 6589
Joined: Sat Apr 21, 2007 8:54 pm

Re: Corrupt encoded video with 1.0.1 (1.0.0 aswell)

Post by mduell » Tue Jan 03, 2017 8:36 pm

Try running the files through VideoReDo's Quick Stream Fix after TMPG SR and before HandBrake.

User avatar
JohnAStebbins
HandBrake Team
Posts: 5420
Joined: Sat Feb 09, 2008 7:21 pm

Re: Corrupt encoded video with 1.0.1 (1.0.0 aswell)

Post by JohnAStebbins » Tue Jan 03, 2017 10:26 pm

Thanks for the sample. I'll have a closer look when I have some time.

Post Reply