Fails to encode some Bluray

Archive of historical bug reports.
Please use the GitHub link above to report issues.
Forum rules
*******************************
Please be aware we are now using GitHub for issue tracking and feature requests.
- This section of the forum is now closed to new topics.

*******************************
Number8
Posts: 62
Joined: Fri Dec 26, 2014 11:46 am

Re: Fails to encode some Bluray

Post by Number8 » Wed Dec 21, 2016 12:42 pm

So I encoded again 5 episodes with Decomb set to Off. Guess what, no failures. Based on previous experiences, I should have 1 or 2.
I will encode again this all season (13 episodes) and report back of any issues.

Number8
Posts: 62
Joined: Fri Dec 26, 2014 11:46 am

Re: Fails to encode some Bluray

Post by Number8 » Wed Dec 21, 2016 8:05 pm

So a new batch was started and unfortunalely some of the files failed to be encoded. I had for the first time a run time error that popped up :
handbrakecli.exe R6025 Pure virtual function call

maxim_d33
Bright Spark User
Posts: 173
Joined: Mon Mar 21, 2011 12:02 pm

Re: Fails to encode some Bluray

Post by maxim_d33 » Wed Dec 21, 2016 10:21 pm

if you see handbrakecli.exe - it looks that you are not using nightly but 10.5 build

https://nuage.rabate.fr:5001/sharing/RaowrCGiB does not contain much information - can you make sure to have like 1s of video ?

Number8
Posts: 62
Joined: Fri Dec 26, 2014 11:46 am

Re: Fails to encode some Bluray

Post by Number8 » Thu Dec 22, 2016 5:11 am

indeed this the regular build I''lol do a test with the nightly build
I'm not surprised it does not contain much of information since this file is the result of the encoding process that quits at the very beginning. May be I did not understand your need. I will send you a slice of the file when there are no HB premature exit

Number8
Posts: 62
Joined: Fri Dec 26, 2014 11:46 am

Re: Fails to encode some Bluray

Post by Number8 » Thu Dec 22, 2016 6:54 am


Number8
Posts: 62
Joined: Fri Dec 26, 2014 11:46 am

Re: Fails to encode some Bluray

Post by Number8 » Thu Dec 22, 2016 8:15 am

So I encoded again a batch 13 episodes with the nightly build. The first two have been encoded without any errors (I did not play yet the files). All others (which is a different behavior compared to the regular build), failed (see one of the logs). There no Handbrake exit in the log, it says encode is completed (which is obviously not), the Queue windows displays a yellow icon with an exclamation mark and the file are roughly 1MB (see a sample here: https://nuage.rabate.fr:5001/sharing/KsrTtZUy8

Code: Select all

HandBrake Nightly 20161220230236-6a39cca-master (2016122101) - 32bit
OS: Microsoft Windows NT 10.0.14393.0 - 64bit
CPU: Intel(R) Core(TM) i5-6260U CPU @ 1.80GHz
Ram: 8081 MB, 
GPU Information:
  Intel(R) Iris(TM) Graphics 540 - 21.20.16.4552
Screen: 2560x1440
Temp Dir: C:\Users\MEDIA\AppData\Local\Temp\
Install Dir: C:\Program Files (x86)\HandBrake Nightly
Data Dir: C:\Users\MEDIA\AppData\Roaming\HandBrake Team\HandBrake\1.0.0.0

-------------------------------------------


# Starting Encode ...

[08:49:08] hb_init: starting libhb thread
[08:49:08] 1 job(s) to process
[08:49:08] json job:
{
  "Audio": {
    "AudioList": [
      {
        "DRC": 0.0,
        "Encoder": 1125984256,
        "Gain": 0.0,
        "Mixdown": -1,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 2,
        "DitherMethod": 0
      },
      {
        "DRC": 0.0,
        "Encoder": 1125984256,
        "Gain": 0.0,
        "Mixdown": -1,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 3,
        "DitherMethod": 0
      },
      {
        "DRC": 0.0,
        "Encoder": 1125984256,
        "Gain": 0.0,
        "Mixdown": -1,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 0,
        "DitherMethod": 0
      },
      {
        "DRC": 0.0,
        "Encoder": 1125984256,
        "Gain": 0.0,
        "Mixdown": -1,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 1,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      1073743872,
      1074003968,
      1073750016,
      1090519040,
      1074790400,
      1107296256
    ],
    "FallbackEncoder": 2048
  },
  "Destination": {
    "ChapterList": [
      {
        "Name": "Chapter 1"
      },
      {
        "Name": "Chapter 2"
      },
      {
        "Name": "Chapter 3"
      },
      {
        "Name": "Chapter 4"
      },
      {
        "Name": "Chapter 5"
      },
      {
        "Name": "Chapter 6"
      },
      {
        "Name": "Chapter 7"
      },
      {
        "Name": "Chapter 8"
      },
      {
        "Name": "Chapter 9"
      }
    ],
    "ChapterMarkers": true,
    "File": "Z:\\TV Shows\\Battlestar-BR(x265)\\Saison 1\\Battlestar Galactica - s01e03 - Révolution.mkv",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": false
    },
    "Mux": 2097152
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 11,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "2",
          "crop-right": "2",
          "crop-top": "0",
          "height": "1080",
          "width": "1920"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "1"
        }
      }
    ]
  },
  "PAR": {
    "Num": 479,
    "Den": 480
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "chapter",
      "Start": 1,
      "End": 9
    },
    "Title": 9,
    "Path": "G:\\"
  },
  "Subtitle": {
    "Search": {
      "Burn": false,
      "Default": false,
      "Enable": false,
      "Forced": false
    },
    "SubtitleList": [
      {
        "Burn": false,
        "Default": false,
        "Forced": false,
        "ID": 2,
        "Offset": 0,
        "Track": 1
      },
      {
        "Burn": false,
        "Default": false,
        "Forced": false,
        "ID": 3,
        "Offset": 0,
        "Track": 2
      }
    ]
  },
  "Video": {
    "Encoder": 256,
    "Level": "auto",
    "TwoPass": false,
    "Turbo": false,
    "ColorMatrixCode": 0,
    "Options": "",
    "Preset": "balanced",
    "Profile": "auto",
    "Quality": 20.0,
    "OpenCL": false,
    "HWDecode": false,
    "QSV": {
      "Decode": true,
      "AsyncDepth": 0
    }
  }
}
[08:49:08] CPU: Intel(R) Core(TM) i5-6260U CPU @ 1.80GHz
[08:49:08]  - Intel microarchitecture Skylake
[08:49:08]  - logical processor count: 4
[08:49:08] OpenCL device #1: Intel(R) Corporation Intel(R) Iris(TM) Graphics 540
[08:49:08]  - OpenCL version: 2.0
[08:49:08]  - driver version: 21.20.16.4552
[08:49:08]  - device type:    GPU
[08:49:08]  - supported:      YES
[08:49:08] Intel Quick Sync Video support: yes
[08:49:08]  - Intel Media SDK hardware: API 1.19 (minimum: 1.3)
[08:49:08]  - H.264 encoder: yes
[08:49:08]     - preferred implementation: hardware (any)
[08:49:08]     - capabilities (hardware):  breftype icq+la+i+downs vsinfo opt1 opt2+mbbrc+extbrc+trellis+ib_adapt+nmpslice
[08:49:08]  - H.265 encoder: yes
[08:49:08]     - preferred implementation: hardware (any)
[08:49:08]     - capabilities (hardware):  bpyramid vsinfo opt1
[08:49:08] hb_scan: path=G:\, title_index=9
[08:49:08] scan: BD has 35 title(s)
[08:49:08] bd: scanning title 9
[08:49:08] bd: playlist 00014.MPLS
[08:49:08] bd: duration is 00:43:45 (2625372 ms)
[08:49:08] bd: video id=0x1011, stream type=VC-1, format 1080p
[08:49:08] bd: aspect = 16:9
[08:49:08] bd: audio id=0x711100, lang=Francais (DTS), 3cc=fra
[08:49:08] bd: audio id=0x1100, lang=Francais (DTS-HD MA), 3cc=fra
[08:49:08] bd: audio id=0x711101, lang=English (DTS), 3cc=eng
[08:49:08] bd: audio id=0x1101, lang=English (DTS-HD MA), 3cc=eng
[08:49:08] bd: audio id=0x1102, lang=English (AC3), 3cc=eng
[08:49:08] bd: subtitle id=0x1200, lang=Francais, 3cc=fra
[08:49:08] bd: subtitle id=0x1201, lang=Francais, 3cc=fra
[08:49:08] bd: subtitle id=0x1202, lang=English, 3cc=eng
[08:49:08] bd: subtitle id=0x1203, lang=Nederlands, 3cc=nld
[08:49:08] bd: subtitle id=0x1204, lang=Francais, 3cc=fra
[08:49:08] bd: subtitle id=0x1205, lang=Francais, 3cc=fra
[08:49:08] bd: subtitle id=0x1206, lang=Francais, 3cc=fra
[08:49:08] bd: subtitle id=0x1207, lang=dansk, 3cc=dan
[08:49:08] bd: subtitle id=0x1208, lang=norsk, 3cc=nor
[08:49:08] bd: subtitle id=0x1209, lang=suomi, 3cc=fin
[08:49:08] bd: subtitle id=0x120a, lang=svenska, 3cc=swe
[08:49:08] bd: chap 1 packet=768, 36036 ms
[08:49:08] bd: chap 2 packet=76531200, 525525 ms
[08:49:08] bd: chap 3 packet=1860588096, 359942 ms
[08:49:08] bd: chap 4 packet=3165817728, 587712 ms
[08:49:08] bd: chap 5 packet=5113747008, 547797 ms
[08:49:08] bd: chap 6 packet=6958381056, 524398 ms
[08:49:08] bd: chap 7 packet=8774583360, 37871 ms
[08:49:08] bd: chap 8 packet=8813842560, 6047 ms
[08:49:08] bd: chap 9 packet=8819499072, 41 ms
[08:49:08] bd: title 9 has 9 chapters
[08:49:08] scan: decoding previews for title 9
[08:49:08] scan: title angle(s) 1
[08:49:08] scan: audio 0x711100: dca, rate=48000Hz, bitrate=1536000 Francais (DTS) (5.1 ch)
[08:49:08] scan: audio 0x1100: dca, rate=48000Hz, bitrate=1536000 Francais (DTS-HD MA) (5.1 ch)
[08:49:08] scan: audio 0x711101: dca, rate=48000Hz, bitrate=1536000 English (DTS) (5.1 ch)
[08:49:08] scan: audio 0x1101: dca, rate=48000Hz, bitrate=1536000 English (DTS-HD MA) (5.1 ch)
[08:49:08] scan: audio 0x1102: ac3, rate=48000Hz, bitrate=192000 English (AC3) (2.0 ch)
[08:49:10] scan: 10 previews, 1920x1080, 23.976 fps, autocrop = 0/0/2/2, aspect 16:9, PAR 1:1
[08:49:10] stream: 6 good frames, 0 errors (0%)
[08:49:10] libhb: scan thread found 1 valid title(s)
[08:49:10] starting job
[08:49:10] Auto Passthru: allowed codecs are AC3, E-AC3, TrueHD, DTS, DTS-HD, FLAC
[08:49:10] Auto Passthru: fallback is AC3
[08:49:10] Auto Passthru: using DTS Passthru for track 1
[08:49:10] Auto Passthru: using DTS-HD Passthru for track 2
[08:49:10] Auto Passthru: using DTS Passthru for track 3
[08:49:10] Auto Passthru: using DTS-HD Passthru for track 4
[08:49:10] job configuration:
[08:49:10]  * source
[08:49:10]    + G:\
[08:49:10]    + title 9, chapter(s) 1 to 9
[08:49:10]  * destination
[08:49:10]    + Z:\TV Shows\Battlestar-BR(x265)\Saison 1\Battlestar Galactica - s01e03 - Révolution.mkv
[08:49:10]    + container: Matroska (libavformat)
[08:49:10]      + chapter markers
[08:49:10]  * video track
[08:49:10]    + decoder: vc1
[08:49:10]      + bitrate 200 kbps
[08:49:10]    + filters
[08:49:10]      + Framerate Shaper (mode=1)
[08:49:10]        + frame rate: 23.976 fps -> constant 23.976 fps
[08:49:10]      + Crop and Scale (width=1920:height=1080:crop-top=0:crop-bottom=0:crop-left=2:crop-right=2)
[08:49:10]        + source: 1920 * 1080, crop (0/0/2/2): 1916 * 1080, scale: 1920 * 1080
[08:49:10]    + Output geometry
[08:49:10]      + storage dimensions: 1920 x 1080
[08:49:10]      + pixel aspect ratio: 479 : 480
[08:49:10]      + display dimensions: 1916 x 1080
[08:49:10]    + encoder: H.264 (Intel Media SDK)
[08:49:10]      + preset:  balanced
[08:49:10]      + profile: auto
[08:49:10]      + level:   auto
[08:49:10]      + quality: 20.00 (ICQ)
[08:49:10]  * subtitle track 1, Francais (track 1, id 0x1201) Picture [PGS] -> Passthrough
[08:49:10]  * subtitle track 2, English (track 2, id 0x1202) Picture [PGS] -> Passthrough
[08:49:10]  * audio track 1
[08:49:10]    + decoder: English (DTS) (5.1 ch) (track 3, id 0x711101)
[08:49:10]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[08:49:10]    + DTS Passthru
[08:49:10]  * audio track 2
[08:49:10]    + decoder: English (DTS-HD MA) (5.1 ch) (track 4, id 0x1101)
[08:49:10]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[08:49:10]    + DTS-HD Passthru
[08:49:10]  * audio track 3
[08:49:10]    + decoder: Francais (DTS) (5.1 ch) (track 1, id 0x711100)
[08:49:10]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[08:49:10]    + DTS Passthru
[08:49:10]  * audio track 4
[08:49:10]    + decoder: Francais (DTS-HD MA) (5.1 ch) (track 2, id 0x1100)
[08:49:10]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[08:49:10]    + DTS-HD Passthru
[08:49:10] sync: expecting 62945 video frames
[08:49:10] encqsvInit: using encode-only path
[08:49:10] encqsvInit: H.264/AVC High profile @ level 4.0
[08:49:10] encqsvInit: TargetUsage 4 AsyncDepth 3
[08:49:10] encqsvInit: GopRefDist 3 GopPicSize 24 NumRefFrame 1
[08:49:10] encqsvInit: BFramesMax 2 BRefType off
[08:49:10] encqsvInit: RateControlMethod ICQ ICQQuality 20
[08:49:10] sync: first pts video is 0
[08:49:10] sync: "Chapter 1" (1) at frame 1 time 0
[08:49:10] sync: first pts audio 0x711101 is 0
[08:49:10] sync: first pts audio 0x1101 is 0
[08:49:10] sync: first pts audio 0x711100 is 0
[08:49:10] sync: first pts audio 0x1100 is 0
[08:49:10] qsv_enc_init: using 'hardware (1)' implementation, API: 1.19
Error code -17,	hb_qsv_wait_on_sync	602
[08:49:10] work: average encoding speed for job is 0.000000 fps
[08:49:11] vfr: 29 frames output, 0 dropped and 0 duped for CFR/PFR
[08:49:11] vfr: lost time: 0 (0 frames)
[08:49:11] vfr: gained time: 0 (0 frames) (0 not accounted for)
[08:49:11] stream: 221 good frames, 0 errors (0%)
[08:49:11] dca-decoder done: 219 frames, 0 decoder errors
[08:49:11] dca-decoder done: 219 frames, 0 decoder errors
[08:49:11] dca-decoder done: 219 frames, 0 decoder errors
[08:49:11] dca-decoder done: 219 frames, 0 decoder errors
[08:49:11] vc1-decoder done: 72 frames, 0 decoder errors
[08:49:11] sync: got 32 frames, 62945 expected
[08:49:11] sync: framerate min 23.974 fps, max 23.981 fps, avg 23.976 fps
[08:49:11] mux: track 0, 3 frames, 645 bytes, 3.75 kbps, fifo 8
[08:49:11] mux: track 1, 123 frames, 247476 bytes, 1438.42 kbps, fifo 128
[08:49:11] mux: track 2, 122 frames, 257664 bytes, 1497.64 kbps, fifo 128
[08:49:11] mux: track 3, 122 frames, 245464 bytes, 1426.73 kbps, fifo 128
[08:49:11] mux: track 4, 122 frames, 255332 bytes, 1484.08 kbps, fifo 128
[08:49:11] mux: track 5, 0 frames, 0 bytes, 0.00 kbps, fifo 8
[08:49:11] mux: track 6, 0 frames, 0 bytes, 0.00 kbps, fifo 8
[08:49:11] libhb: work result = 4

# Encode Completed ...


maxim_d33
Bright Spark User
Posts: 173
Joined: Mon Mar 21, 2011 12:02 pm

Re: Fails to encode some Bluray

Post by maxim_d33 » Mon Dec 26, 2016 7:13 pm

Number8 wrote:Here is a 30 seconds sample: https://nuage.rabate.fr:5001/sharing/0jsVOSs81
hmm, this seems to be not vc1 sample but transcoded into h264 already?

these problems comes from vc1 sample but I cannot reproduce it yet - no sample...

Number8
Posts: 62
Joined: Fri Dec 26, 2014 11:46 am

Re: Fails to encode some Bluray

Post by Number8 » Mon Dec 26, 2016 8:06 pm

Oh sorry for that, I did not noticed you'd prefer a vc1 sample. Indeed what I provided is an H264 sample. I'll keep you posted. I could arrange to make one ISO downlable. I have a 200Mb upload link. Is it workable on your side?

maxim_d33
Bright Spark User
Posts: 173
Joined: Mon Mar 21, 2011 12:02 pm

Re: Fails to encode some Bluray

Post by maxim_d33 » Tue Dec 27, 2016 7:39 pm

sure and not problems ,
I can download any size - just fine for me

Number8
Posts: 62
Joined: Fri Dec 26, 2014 11:46 am

Re: Fails to encode some Bluray

Post by Number8 » Tue Dec 27, 2016 9:15 pm

All right I will arrange that hopefully tomorrow

Number8
Posts: 62
Joined: Fri Dec 26, 2014 11:46 am

Re: Fails to encode some Bluray

Post by Number8 » Wed Dec 28, 2016 6:10 pm

@ maxim_d33: I PM you the link to download the ISO file.

maxim_d33
Bright Spark User
Posts: 173
Joined: Mon Mar 21, 2011 12:02 pm

Re: Fails to encode some Bluray

Post by maxim_d33 » Thu Dec 29, 2016 12:36 am

thanks, should check it shortly..

Number8
Posts: 62
Joined: Fri Dec 26, 2014 11:46 am

Re: Fails to encode some Bluray

Post by Number8 » Mon Jan 09, 2017 2:56 pm

@ maxim_d33: I PM a new link and new information

Post Reply