Scan of ISO never finishes

Archive of historical bug reports.
Please use the GitHub link above to report issues.
Forum rules
*******************************

Please be aware we are now using GitHub for issue tracking and feature requests.

- This forum is now closed to new topics.
- Existing topics will remain open for a short while as the transition over occurs.
*******************************
Post Reply
FrostByte
Posts: 61
Joined: Sat Dec 12, 2015 7:16 pm

Scan of ISO never finishes

Post by FrostByte » Mon Apr 11, 2016 1:16 pm

Please describe the problem in as much detail as possible:
With the last two nightly builds I've been having a problem scanning ISOs. I've tried several ISOs and the counter gets to 100%, but the circle keeps spinning and never stops. Clicking cancel doesn't do anything. Has to end the task to kill the process to make it go away.

What are the steps to reproduce this problem:
Assign iso to virtual drive
Start HB
Select iso from popup
Scan counter goes up to 100% but never stops spinning

What version of HandBrake you are running:
697553a, also got problem with 8e62703

Fell back to fd32646 which is the last build which works for me

What operating system and version and you running (e.g. OSX 10.11, Windows 7, Ubuntu 14):
Win10 1511, 64-bit

If there was any exception or error displayed, please copy it and paste it here:
N/A, spinner just never stops and box doesn't go away

Please include the scan or encode log:
Scan log using build 697553a
http://pastebin.com/2AVdMP12

Scan log using same input and build fd32646
http://pastebin.com/7yCmHkjd

FrostByte
Posts: 61
Joined: Sat Dec 12, 2015 7:16 pm

Re: Scan of ISO never finishes

Post by FrostByte » Fri Apr 15, 2016 10:43 am

Posting a picture to better explain the issue. As mentioned after reading iso the scan window never closes creating the never ending scan log as posted above. In the picture you can see it gets to 100% and does populate all the information into the boxes, but the only way to get rid of the scan window is to close HB

Current release problem occurs with: HandBrake-20160415-dc0c8ac_x86_64-Win_GUI
Last release without the issue: HandBrake-20160408-fd32646_x86_64-Win_GUI

Image

rollin_eng
Veteran User
Posts: 2942
Joined: Wed May 04, 2011 11:06 pm

Re: Scan of ISO never finishes

Post by rollin_eng » Fri Apr 15, 2016 10:53 am

How are you creating the ISO's?

FrostByte
Posts: 61
Joined: Sat Dec 12, 2015 7:16 pm

Re: Scan of ISO never finishes

Post by FrostByte » Fri Apr 15, 2016 11:00 am

I'm using DVDfab

rollin_eng
Veteran User
Posts: 2942
Joined: Wed May 04, 2011 11:06 pm

Re: Scan of ISO never finishes

Post by rollin_eng » Fri Apr 15, 2016 11:17 am

From a troubleshooting point of view do you get the same issue with a DVD ISO?

How about if you copy the data from your mounted ISO to a hard drive, then scan it?

FrostByte
Posts: 61
Joined: Sat Dec 12, 2015 7:16 pm

Re: Scan of ISO never finishes

Post by FrostByte » Fri Apr 15, 2016 1:05 pm

Ok, I think I have all those scenarios (and more) covered here getting the same result with scans not finishing using the most recent nightly builds and then using the same input using the last nightly where I don't have this issue. All ISOs created using the most current registered version of DVDfab

1. The first set of scans are all using HandBrake-20160415-dc0c8ac_x86_64-Win_GUI which doesn't close scan window after reaching 100%

Game of Thrones ISO mounted DVD to virtual drive where scan didn't close window
http://pastebin.com/[Censored]

Game of Thrones copied DVD structure from ISO to hard drive where scan didn't close window
http://pastebin.com/krQBqCLq

The Good Dinosaur ISO mounted BD to virtual drive where scan didn't close window
http://pastebin.com/RMwUUwEd

The Good Dinosaur copied BD structure from ISO to hard drive where scan didn't close window
http://pastebin.com/a0uKSWR7

2. The second set of scans are all using HandBrake-20160408-fd32646_x86_64-Win_GUI which is closing the scan window after reaching 100%

Game of Thrones DVD mounted ISO to virtual drive where completed scan closes window when done
http://pastebin.com/hTyBLWrm

Game of Thrones DVD ISO encoding a 10 second preview
http://pastebin.com/wTJFxVDt

The Good Dinosaur BD mounted ISO to virtual drive where completed scan closes window when done
http://pastebin.com/yt7JBmjQ

FrostByte
Posts: 61
Joined: Sat Dec 12, 2015 7:16 pm

Re: Scan of ISO never finishes

Post by FrostByte » Fri Apr 15, 2016 1:15 pm

Had to recreate the first link in the post above because the forum censored the randomly created link from pastebin

Game of Thrones ISO mounted DVD to virtual drive where scan didn't close window
http://pastebin.com/7H1ujrjg

rollin_eng
Veteran User
Posts: 2942
Joined: Wed May 04, 2011 11:06 pm

Re: Scan of ISO never finishes

Post by rollin_eng » Fri Apr 15, 2016 1:27 pm

I am able to scan a DVD folder structure using the 20160415 nightly, mine was created using anydvd.

Do you get the same issue opening a single file?

FrostByte
Posts: 61
Joined: Sat Dec 12, 2015 7:16 pm

Re: Scan of ISO never finishes

Post by FrostByte » Fri Apr 15, 2016 2:22 pm

Ok, I guess I'm having a bigger problem than I thought. Creating a passthru/remux single file mkv using both DVDfab or Makemkv the scan also will not close that window after reaching 100% when opening with nightly HandBrake-20160415-dc0c8ac_x86_64-Win_GUI.

As soon as I fall back to nightly HandBrake-20160408-fd32646_x86_64-Win_GUI (or the release version 10.5) then HB closes the scan window after reaching 100% with no issues

User avatar
s55
HandBrake Team
Posts: 9314
Joined: Sun Dec 24, 2006 1:05 pm

Re: Scan of ISO never finishes

Post by s55 » Fri Apr 15, 2016 6:30 pm

There isn't actually anything different between those two builds that would cause this behavior.

Your log shows a completed and successful scan which is odd, so it has to be GUI. Then again, I can't reproduce either :S

FrostByte
Posts: 61
Joined: Sat Dec 12, 2015 7:16 pm

Re: Scan of ISO never finishes

Post by FrostByte » Fri Apr 15, 2016 6:55 pm

Lol. Unfortunately, I agree with everything you said :p Very odd indeed. I even tried removing my dual monitor setup and video card just in case HB wasn't liking them anymore, but no luck.

There was that one scan in my first post where it kept repeating "Stopping scan" until I killed HB, but none of the other logs show that now.

It does seem to finish the scan like you said and it populates the filename which is like either the last thing it usually does right before the white box disappears or populates right after the box goes away. It just doesn't go away for me in builds after fd32646 though.

I appreciate you all looking at it. I guess I'll just keep trying newer builds hoping something magic happens or someone else can reproduce.

Thanks all

fervid
Posts: 10
Joined: Sat Jun 07, 2014 10:57 pm

Re: Scan of ISO never finishes

Post by fervid » Sun Apr 17, 2016 11:45 pm

I had the issue at first when upgrading from HandBrake-af25ef9_x86_64-Win_GUI to the latest. Mine hung at 90% though for ISO and any video file. I reverted back for a bit then tried uninstalling on my own and making sure the folders were gone. I still had a weird stray entry in Add/Remove Programs area, but when I installed latest again it seems to read fine. I also deleted my user preset too, but I think it worked before that.

FrostByte
Posts: 61
Joined: Sat Dec 12, 2015 7:16 pm

Re: Scan of ISO never finishes

Post by FrostByte » Mon Apr 18, 2016 1:10 am

Fantastic, I'm in. I ended up removing the nightly HandBrake-20160408-fd32646_x86_64-Win_GUI I was using AND also the Handbrake 10.5 entry that was in the installed programs list. Never had this issue until recently, but it seems removing everything was the trick. Thanks fervid

Post Reply