[Fixed] Subtitle Presets

Archive of historical bug reports.
Please use the GitHub link above to report issues.
Forum rules
*******************************
Please be aware we are now using GitHub for issue tracking and feature requests.
- This section of the forum is now closed to new topics.

*******************************
Post Reply
DrXenos
Bright Spark User
Posts: 256
Joined: Sat Mar 16, 2013 1:19 pm

[Fixed] Subtitle Presets

Post by DrXenos »

The latest build doesn't load the subtitle track selection behavior preset correctly. I looked in the C# code and the line to load that item is commented out ("JsonPresetFactory.cs", line# 362).

Thanks.
DrXenos
Bright Spark User
Posts: 256
Joined: Sat Mar 16, 2013 1:19 pm

Re: Subtitle Presets

Post by DrXenos »

I'm not a C# guy, but I replaced the commented out line with:

Code: Select all

            preset.SubtitleTrackBehaviours.SelectedBehaviour = EnumHelper<SubtitleBehaviourModes>.GetValue(importedPreset.SubtitleTrackSelectionBehavior);
and it seems to work.

Thanks.
User avatar
s55
HandBrake Team
Posts: 9960
Joined: Sun Dec 24, 2006 1:05 pm

Re: Subtitle Presets

Post by s55 »

Cool. I'll try fix are the weekend if I have time.

p.s If you find a bug, better posting in the bugs forum as I don't always follow every discussion on the windows forum.

Moving to bugs.
DrXenos
Bright Spark User
Posts: 256
Joined: Sat Mar 16, 2013 1:19 pm

Re: Subtitle Presets

Post by DrXenos »

OK, sorry. I will do so next time.
User avatar
s55
HandBrake Team
Posts: 9960
Joined: Sun Dec 24, 2006 1:05 pm

Re: [Fixed] Subtitle Presets

Post by s55 »

Fixed: https://github.com/HandBrake/HandBrake/ ... 65490c172f

Couple of other things in there I will need to tidy up in there with Audio and other options, but I'll sort that when i get back home.
Lazyncoder
Regular User
Posts: 63
Joined: Wed Dec 17, 2014 11:19 am

Re: [Fixed] Subtitle Presets

Post by Lazyncoder »

there's so many things wrong with the preset system. I'm waiting for it to finish the moving process from "user_presets.json", then I report all the bugs i've found.
DrXenos
Bright Spark User
Posts: 256
Joined: Sat Mar 16, 2013 1:19 pm

Re: [Fixed] Subtitle Presets

Post by DrXenos »

Thank you, s55!
kulle
Posts: 1
Joined: Tue Dec 22, 2015 9:51 am

Re: [Fixed] Subtitle Presets

Post by kulle »

Is there still problems with the preset system, or is all taken care of? :)
User avatar
s55
HandBrake Team
Posts: 9960
Joined: Sun Dec 24, 2006 1:05 pm

Re: [Fixed] Subtitle Presets

Post by s55 »

I'm not actively working on anything presets right now so if there are issues, please report them.
DrXenos
Bright Spark User
Posts: 256
Joined: Sat Mar 16, 2013 1:19 pm

Re: [Fixed] Subtitle Presets

Post by DrXenos »

I am not seeing any issues with the presets.
Navvie
Regular User
Posts: 58
Joined: Sun Mar 27, 2011 10:19 pm

Re: [Fixed] Subtitle Presets

Post by Navvie »

Windows 64bit, nightly, 7f39ee6.

With regard to user presets, the following aren't currently saving or loading properly between program restarts.

Eg. Anything you set up and save as an existing or new user-preset doesn't work when the program is restarted.

MKV/MP4 container type
Subtitle defaults
User avatar
s55
HandBrake Team
Posts: 9960
Joined: Sun Dec 24, 2006 1:05 pm

Re: [Fixed] Subtitle Presets

Post by s55 »

Found the Container issue. Fixed in https://github.com/HandBrake/HandBrake/ ... 3ec0f2b8ac

Don't see the subtitle defaults one though. It seems tor reload them correctly. (bar a small issue with the "(any)" language)
User avatar
s55
HandBrake Team
Posts: 9960
Joined: Sun Dec 24, 2006 1:05 pm

Re: [Fixed] Subtitle Presets

Post by s55 »

p.s if you find new issues, please raise a new thread since this one is marked as closed.
Post Reply