[Linux GUI] App crashes while selecting AAC quality level

Archive of historical bug reports.
Please use the GitHub link above to report issues.
Forum rules
*******************************

Please be aware we are now using GitHub for issue tracking and feature requests.

- This forum is now closed to new topics.
- Existing topics will remain open for a short while as the transition over occurs.
*******************************
Post Reply
mod16
Posts: 78
Joined: Sun Jan 12, 2014 11:10 am

[Linux GUI] App crashes while selecting AAC quality level

Post by mod16 » Fri May 08, 2015 3:08 pm

The application constantly closes/crashes if I want to select a quality level for AAC VBR.

What exactly happens:
1.) Edit the track settings (AAC FDK encoder already selected or select it)
2.) Click on "quality" for setting VBR quality
3.) Click on (still greyed out) icon for quality level selection
3.) Slider appears, but can't be slided/used/moved in any way
4.) Click on "bitrate" in the background (dialog window) to escape the situation (but slider still won't close)
5.) Click on drop-down-menu to choose constant quality - it "opens" (but graphics are bugged, see screenshot)
6.) After 1-2s app closes without GUI error messages

Console shows:

Code: Select all

[...]
(null): ghb_check_dependency() AudioTrackBitrateEnable
(null): ghb_audio_list_refresh_selected ()
(null): ghb_audio_is_passthru () 

Segmentation fault
Activity log just stops (no error messages).

If not reproducible on other systems: Maybe related Ubuntu/Unity 14.04 libs (which I'm still using)?

I also recall having repeatedly the problem, that the slider appeared somewhere else on the screen (above the actual app main window). Maybe this is related somehow, maybe not...

Constant quality selection works fine (as it did before).

Image

mduell
Veteran User
Posts: 6106
Joined: Sat Apr 21, 2007 8:54 pm

Re: [Linux GUI] App crashes while selecting AAC quality level

Post by mduell » Fri May 08, 2015 4:46 pm


User avatar
JohnAStebbins
HandBrake Team
Posts: 5181
Joined: Sat Feb 09, 2008 7:21 pm

Re: [Linux GUI] App crashes while selecting AAC quality level

Post by JohnAStebbins » Fri May 08, 2015 10:42 pm

What version of gtk are you using. I'm on fedora 21 with gtk 3.14. In some earlier versions of gtk, I experienced odd crashes related to sliders. I think it was version 3.12. At the time I could consistently reproduce a crash by first clicking on a combo box, then clicking on a slider. Any combo box fillowed by any slider provoked a crash in gtk.

I'll load up a Ubuntu 14.04 vm when I have a bit of time and see if it's reproducible there. But I can't reproduce it currently here.

User avatar
JohnAStebbins
HandBrake Team
Posts: 5181
Joined: Sat Feb 09, 2008 7:21 pm

Re: [Linux GUI] App crashes while selecting AAC quality level

Post by JohnAStebbins » Fri May 08, 2015 10:44 pm

Forgot to mention, I just worked around it by *not* clicking on the slider and instead, hovered over the slider button and used the mouse scroll wheel to to change the value.

mod16
Posts: 78
Joined: Sun Jan 12, 2014 11:10 am

Re: [Linux GUI] App crashes while selecting AAC quality level

Post by mod16 » Sat May 09, 2015 3:53 pm

I also tried to use the mouse wheel, but the slider is frozen solid.

Tried it on my laptop (also running Ubuntu 14.04): Same issue.

GTK version seems to be an older one:

Code: Select all

$ dpkg -l libgtk2.0-0 libgtk-3-0
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  libgtk-3-0:amd 3.10.8-0ubun amd64        GTK+ graphical user interface lib
ii  libgtk2.0-0:am 2.24.23-0ubu amd64        GTK+ graphical user interface lib
Maybe other users using 14.04 can confirm this.

(At least for me it's not really an issue, just wanted to report it.)

Post Reply