Subtitle Presets Not Saved/Used on Add all titles

Archive of historical bug reports.
Please use the GitHub link above to report issues.
Forum rules
Please be aware we are now using GitHub for issue tracking and feature requests.
- This section of the forum is now closed to new topics.

Post Reply
Posts: 1
Joined: Sun Sep 21, 2014 1:13 am

Subtitle Presets Not Saved/Used on Add all titles

Post by knservis » Sun Sep 21, 2014 1:24 am


Handbrake 0.10 Beta 4 (Version 6403svn x86_64 (2014091301)) on OSX 10.9.5

this may just be the fact that the UI does not make obvious how the subtitle defaults are saved and used but here is the problematic behaviour:

1. I click on Subtitles > Configure Defaults.
2. I Change the default to include all subtitles (Behaviour: "All matching", Labuages: "Any", Add closed captions: true, Add foreign audio search: true).
3. Click done. (Clicking Change Defaults again confirms that the settings are still there).
4. Click File > Add all titles to queue.

1. The subtitles settings are cleared form the window.
2. There is no subtitle section in the queue window, meaning the defaults were not used.

Expected behaviour:
1. The subtitles settings are unchanged.
2. The queue is populated with items configured with the new defaults.

This may be a user error or just a bug. If it is a user error, the UI should probably be more explicit about the workflow to save and use subtitle defaults.


User avatar
HandBrake Team
Posts: 1064
Joined: Fri Jan 12, 2007 11:29 am

Re: Subtitle Presets Not Saved/Used on Add all titles

Post by Ritsuka » Sun Sep 21, 2014 6:00 am

I think "Add all titles to queue" uses the selected preset, not the current settings. So a workaround is to first save a preset and select it. I'll try to fix the behaviour.

Veteran User
Posts: 2691
Joined: Thu Jan 22, 2009 8:04 pm

Re: Subtitle Presets Not Saved/Used on Add all titles

Post by Smithcraft » Wed Sep 24, 2014 12:07 pm

I believe that is the way Handbrake is designed to work, and it's also the same with the audio streams.


Post Reply