Set a Bitrate limit when using CQ

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
linuxlad
Posts: 7
Joined: Mon Mar 22, 2021 3:42 am

Set a Bitrate limit when using CQ

Post by linuxlad »

HB 1.3.3 (2020061300)

When using "Constant Quality"; is it possible to set in the "advanced options" a max of bitrate to use?
In other words, set a bitrate limit.
mduell
Veteran User
Posts: 7439
Joined: Sat Apr 21, 2007 8:54 pm

Re: Set a Bitrate limit when using CQ

Post by mduell »

Sure, with vbv-maxrate and vbv-bufsize.
linuxlad
Posts: 7
Joined: Mon Mar 22, 2021 3:42 am

Re: Set a Bitrate limit when using CQ

Post by linuxlad »

Thanks,

After several trial-runs, I found that encoding 720p@RF20 and RF19 provided the best balance of quality, file size, and encode times. The problem was that encoding 1080p remuxed files while maintaining a 1:1 resolution would result in files been too large, however, I will test the vbv-maxrate and vbv-bufsize parameters for only 1080p output.

I found the parameter arguments notes to use here:

https://handbrake.fr/docs/en/latest/tec ... esets.html
mduell
Veteran User
Posts: 7439
Joined: Sat Apr 21, 2007 8:54 pm

Re: Set a Bitrate limit when using CQ

Post by mduell »

With an RF that low, you're better off with keeping the 1080p frame size and going to an RF in the low 20s.

Although encode time will be slower unless you pick a faster preset; about one faster on the list should do it.
linuxlad
Posts: 7
Joined: Mon Mar 22, 2021 3:42 am

Re: Set a Bitrate limit when using CQ

Post by linuxlad »

I did, I went back to maintaining the frame@1080 after those six files@720 completed.

For some reason those six files re-encoded with a higher bitrate than the source (13.5mb/s) when everything else I have re-coded using the same profile/settings ended up well below the source bitrate/size which is why these particular six files would have definitely required a limit/constraint using the vbv-maxrate while using the same 1080-profile.
Post Reply