Saving in wrong format

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
cp6
Posts: 2
Joined: Fri Oct 16, 2020 1:49 am

Saving in wrong format

Post by cp6 »

Description of problem or question:


When I try to convert a DVD into a MP4 format, it converts it to a M4V format. I even tried to see if I could take the converted M4V file and tryy converting it into the MP4 format this also did not work.

Steps to reproduce the problem (If Applicable):
I just opened the drive and added the folder and selected MP4 as my file type.



HandBrake version (e.g., 1.0.0):

1.3.3


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):

Windows 10


HandBrake Activity Log ***required*** (see How-to get an activity log)
The activity log includes 2 dvd discs that I tried converting to mp4 and also the m4v file I tried to convert mp4.

Code: Select all

HandBrake 1.3.3 (2020061300)
OS: Microsoft Windows NT 10.0.18362.0
CPU: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz
Ram: 8084 MB, 
GPU Information:
  Intel(R) HD Graphics Family - 20.19.15.4642
Screen: 1366x768
Temp Dir: C:\Users\Cathy\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake
Data Dir: C:\Users\Cathy\AppData\Roaming\HandBrake

-------------------------------------------


# Starting Encode ...

[09:41:49] base preset: Fast 1080p30 (Modified)
[21:41:49] hb_init: starting libhb thread
[21:41:49] Starting work at: Thu Oct 15 21:41:49 2020
[21:41:49] 1 job(s) to process
[21:41:49] json job:
{
  "Audio": {
    "AudioList": [
      {
        "Bitrate": 160,
        "DRC": 0.0,
        "Encoder": "av_aac",
        "Gain": 0.0,
        "Mixdown": 4,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Name": "Stereo",
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      "copy:aac",
      "copy:ac3",
      "copy:dtshd",
      "copy:dts",
      "copy:eac3",
      "copy:flac",
      "copy:mp3",
      "copy:truehd"
    ],
    "FallbackEncoder": "ac3"
  },
  "Destination": {
    "ChapterList": [
      {
        "Name": "Chapter 1"
      },
      {
        "Name": "Chapter 2"
      },
      {
        "Name": "Chapter 3"
      },
      {
        "Name": "Chapter 4"
      },
      {
        "Name": "Chapter 5"
      },
      {
        "Name": "Chapter 6"
      },
      {
        "Name": "Chapter 7"
      },
      {
        "Name": "Chapter 8"
      }
    ],
    "ChapterMarkers": true,
    "AlignAVStart": false,
    "File": "C:\\Users\\Cathy\\Documents\\Family Videos\\Disc 2 - MP4\\Video Ts-1-1.m4v",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": false
    },
    "Mux": "av_mp4"
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 4,
        "Settings": {
          "mode": "7"
        }
      },
      {
        "ID": 3,
        "Settings": {
          "block-height": "16",
          "block-thresh": "40",
          "block-width": "16",
          "filter-mode": "2",
          "mode": "3",
          "motion-thresh": "1",
          "spatial-metric": "2",
          "spatial-thresh": "1"
        }
      },
      {
        "ID": 12,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "0",
          "crop-right": "0",
          "crop-top": "0",
          "height": "478",
          "width": "706"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "2",
          "rate": "27000000/900000"
        }
      }
    ]
  },
  "PAR": {
    "Num": 8,
    "Den": 9
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "chapter",
      "Start": 1,
      "End": 8
    },
    "Title": 1,
    "Path": "C:\\Users\\Cathy\\Documents\\Family Videos\\Disc 2 - Dec 1992 - Dec 1993\\Video Ts-1.m4v"
  },
  "Subtitle": {
    "Search": {
      "Burn": true,
      "Default": false,
      "Enable": true,
      "Forced": true
    },
    "SubtitleList": []
  },
  "Video": {
    "Encoder": "x264",
    "Level": "auto",
    "TwoPass": false,
    "Turbo": false,
    "ColorMatrixCode": 0,
    "Options": "",
    "Preset": "fast",
    "Profile": "auto",
    "Quality": 22.0,
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[21:41:49] CPU: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz
[21:41:49]  - Intel microarchitecture Haswell
[21:41:49]  - logical processor count: 4
[21:41:49] Intel Quick Sync Video support: yes
[21:41:49]  - Intel Media SDK hardware: API 1.20 (minimum: 1.3)
[21:41:49]  - H.264 encoder: yes
[21:41:49]     - preferred implementation: hardware (any) via D3D11
[21:41:49]     - capabilities (hardware):  breftype icq+la+i+downs vsinfo opt1 opt2+mbbrc+extbrc+trellis+ib_adapt+nmpslice
[21:41:49]  - H.265 encoder: no
[21:41:49] hb_scan: path=C:\Users\Cathy\Documents\Family Videos\Disc 2 - Dec 1992 - Dec 1993\Video Ts-1.m4v, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:323: failed opening UDF image C:\Users\Cathy\Documents\Family Videos\Disc 2 - Dec 1992 - Dec 1993\Video Ts-1.m4v
src/libbluray/disc/disc.c:424: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:424: error opening file BDMV\BACKUP\index.bdmv
src/libbluray/bluray.c:2585: nav_get_title_list(C:\Users\Cathy\Documents\Family Videos\Disc 2 - Dec 1992 - Dec 1993\Video Ts-1.m4v\) failed
[21:41:49] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[21:41:49] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'C:\Users\Cathy\Documents\Family Videos\Disc 2 - Dec 1992 - Dec 1993\Video Ts-1.m4v':
  Metadata:
    major_brand     : mp42
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    creation_time   : 2020-10-15T22:34:24.000000Z
    encoder         : HandBrake 1.3.3 2020061300
  Duration: 01:00:14.29, start: 0.000000, bitrate: 2257 kb/s
    Chapter #0:0: start 0.000000, end 480.547000
    Metadata:
      title           : Chapter 1
    Chapter #0:1: start 480.547000, end 961.027000
    Metadata:
      title           : Chapter 2
    Chapter #0:2: start 961.027000, end 1441.507000
    Metadata:
      title           : Chapter 3
    Chapter #0:3: start 1441.507000, end 1921.987000
    Metadata:
      title           : Chapter 4
    Chapter #0:4: start 1921.987000, end 2402.467000
    Metadata:
      title           : Chapter 5
    Chapter #0:5: start 2402.467000, end 2882.947000
    Metadata:
      title           : Chapter 6
    Chapter #0:6: start 2882.947000, end 3363.427000
    Metadata:
      title           : Chapter 7
    Chapter #0:7: start 3363.427000, end 3604.067000
    Metadata:
      title           : Chapter 8
    Stream #0:0(und): Video: h264 (Main) (avc1 / 0x31637661), yuv420p(tv, smpte170m/smpte170m/bt709), 706x478 [SAR 8:9 DAR 2824:2151], 2094 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 180k tbc (default)
    Metadata:
      creation_time   : 2020-10-15T22:34:24.000000Z
      handler_name    : VideoHandler
    Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 160 kb/s (default)
    Metadata:
      creation_time   : 2020-10-15T22:34:24.000000Z
      handler_name    : Stereo
      title           : Stereo
    Stream #0:2(eng): Data: bin_data (text / 0x74786574)
    Metadata:
      creation_time   : 2020-10-15T22:34:24.000000Z
      handler_name    : SubtitleHandler
[21:41:49] scan: decoding previews for title 1
[21:41:49] scan: audio 0x1: aac, rate=48000Hz, bitrate=160133 Unknown (AAC LC) (2.0 ch) (160 kbps)
[21:41:49] scan: 10 previews, 706x478, 29.970 fps, autocrop = 0/0/0/0, aspect 1.31:1, PAR 8:9
[21:41:49] scan: supported video decoders: avcodec qsv
[21:41:49] libhb: scan thread found 1 valid title(s)
[21:41:49] Skipping subtitle scan.  No suitable subtitle tracks.
[21:41:49] Starting Task: Encoding Pass
[21:41:49] Skipping crop/scale filter
[21:41:49] job configuration:
[21:41:49]  * source
[21:41:49]    + C:\Users\Cathy\Documents\Family Videos\Disc 2 - Dec 1992 - Dec 1993\Video Ts-1.m4v
[21:41:49]    + title 1, chapter(s) 1 to 8
[21:41:49]    + container: mov,mp4,m4a,3gp,3g2,mj2
[21:41:49]    + data rate: 2257 kbps
[21:41:49]  * destination
[21:41:49]    + C:\Users\Cathy\Documents\Family Videos\Disc 2 - MP4\Video Ts-1-1.m4v
[21:41:49]    + container: MPEG-4 (libavformat)
[21:41:49]      + chapter markers
[21:41:49]  * video track
[21:41:49]    + decoder: h264
[21:41:49]      + bitrate 2094 kbps
[21:41:49]    + filters
[21:41:49]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[21:41:49]      + Decomb (mode=39)
[21:41:49]      + Framerate Shaper (mode=2:rate=27000000/900000)
[21:41:49]        + frame rate: 29.970 fps -> peak rate limited to 30.000 fps
[21:41:49]    + Output geometry
[21:41:49]      + storage dimensions: 706 x 478
[21:41:49]      + pixel aspect ratio: 8 : 9
[21:41:49]      + display dimensions: 627 x 478
[21:41:49]    + encoder: H.264 (libx264)
[21:41:49]      + preset:  fast
[21:41:49]      + profile: auto
[21:41:49]      + level:   auto
[21:41:49]      + quality: 22.00 (RF)
[21:41:49]      + color profile: 6-1-6
[21:41:49]  * audio track 1
[21:41:49]    + name: Stereo
[21:41:49]    + decoder: Unknown (AAC LC) (2.0 ch) (160 kbps) (track 1, id 0x1)
[21:41:49]      + bitrate: 160 kbps, samplerate: 48000 Hz
[21:41:49]    + mixdown: Stereo
[21:41:49]    + dither: none
[21:41:49]    + encoder: AAC (libavcodec)
[21:41:49]      + bitrate: 160 kbps, samplerate: 48000 Hz
[21:41:49] sync: expecting 108320 video frames
[21:41:49] encx264: min-keyint: 30, keyint: 300
[21:41:49] encx264: encoding at constant RF 22.000000
[21:41:49] encx264: unparsed options: ref=2:weightp=1:subme=6:rc-lookahead=30
x264 [info]: using SAR=8/9
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x264 [info]: profile High, level 3.0, 4:2:0, 8-bit
[21:41:49] sync: first pts video is 0
[21:41:49] sync: "Chapter 1" (1) at frame 1 time 0
[21:41:49] sync: first pts audio 0x1 is 0
[21:46:06] sync: "Chapter 2" (2) at frame 14407 time 43261218
[21:50:23] sync: "Chapter 3" (3) at frame 28807 time 86504418
[21:55:03] sync: "Chapter 4" (4) at frame 43207 time 129747618
[21:58:28] sync: "Chapter 5" (5) at frame 57607 time 172990818
[22:02:54] sync: "Chapter 6" (6) at frame 72007 time 216234018
[22:07:07] sync: "Chapter 7" (7) at frame 86407 time 259477218
[22:11:27] sync: "Chapter 8" (8) at frame 100807 time 302720418
[22:13:39] reader: done. 1 scr changes
[22:13:41] work: average encoding speed for job is 56.513805 fps
[22:13:41] comb detect: heavy 33 | light 499 | uncombed 107483 | total 108015
[22:13:41] decomb: deinterlaced 33 | blended 499 | unfiltered 107483 | total 108015
[22:13:41] vfr: 108015 frames output, 0 dropped and 0 duped for CFR/PFR
[22:13:41] vfr: lost time: 0 (0 frames)
[22:13:41] vfr: gained time: 0 (0 frames) (0 not accounted for)
[22:13:41] aac-decoder done: 169419 frames, 0 decoder errors
[22:13:41] h264-decoder done: 108015 frames, 0 decoder errors
[22:13:41] sync: got 108015 frames, 108320 expected
[22:13:41] sync: framerate min 29.970 fps, max 29.970 fps, avg 29.970 fps
x264 [info]: frame I:637   Avg QP:18.90  size: 26735
x264 [info]: frame P:28823 Avg QP:23.33  size: 13947
x264 [info]: frame B:78555 Avg QP:26.61  size:  4747
x264 [info]: consecutive B-frames:  1.9%  2.8%  1.8% 93.5%
x264 [info]: mb I  I16..4: 26.6% 31.3% 42.0%
x264 [info]: mb P  I16..4:  3.0% 10.6%  6.8%  P16..4: 39.5% 22.9%  9.7%  0.0%  0.0%    skip: 7.5%
x264 [info]: mb B  I16..4:  1.7%  3.3%  1.8%  B16..8: 28.9% 12.4%  1.5%  direct:19.0%  skip:31.4%  L0:39.5% L1:41.6% BI:18.9%
x264 [info]: 8x8 transform intra:49.5% inter:38.8%
x264 [info]: coded y,uvDC,uvAC intra: 63.2% 60.7% 13.2% inter: 25.1% 27.2% 0.6%
x264 [info]: i16 v,h,dc,p: 41% 24% 17% 18%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 16% 25% 24%  4%  5%  6%  7%  5%  7%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 18% 33% 11%  5%  7%  6%  8%  5%  7%
x264 [info]: i8c dc,h,v,p: 55% 21% 18%  6%
x264 [info]: Weighted P-Frames: Y:14.2% UV:4.2%
x264 [info]: ref P L0: 68.9% 31.1%
x264 [info]: ref B L0: 84.1% 15.9%
x264 [info]: ref B L1: 96.4%  3.6%
x264 [info]: kb/s:1757.88
[22:13:42] mux: track 0, 108015 frames, 791920076 bytes, 1752.85 kbps, fifo 8192
[22:13:42] mux: track 1, 169420 frames, 72377253 bytes, 160.20 kbps, fifo 16384
[22:13:42] Finished work at: Thu Oct 15 22:13:42 2020
[22:13:42] libhb: work result = 0

# Encode Completed ...


rollin_eng
Veteran User
Posts: 3558
Joined: Wed May 04, 2011 11:06 pm

Re: Saving in wrong format

Post by rollin_eng »

M4V and MP4 are the same.

You can set the default to MP4 in the preferences or just rename the files yourself.
cp6
Posts: 2
Joined: Fri Oct 16, 2020 1:49 am

Re: Saving in wrong format

Post by cp6 »

The problem I was having was editing it in a program that needed mp4. I do have it set to mp4 but it is saving as m4v. I did discover they are the same and changed the file type. I am hoping that does not degrade the file at all. Thanks for your help.
Woodstock
Veteran User
Posts: 3790
Joined: Tue Aug 27, 2013 6:39 am

Re: Saving in wrong format

Post by Woodstock »

Code: Select all

rename SomeRandomFile.m4v SomeRandomFile.mp4
No degradation whatsoever. And if the software is "limited" by file extension, rather than checking the file itself, that's [fill in your own adjectives].

In Preferences->Output files, you can tell handbrake to always use the .mp4 extension.

The reason .m4v is the default is that some older Apple software and devices will disable certain features if the extension isn't .m4v.
musicvid
Veteran User
Posts: 3717
Joined: Sat Jun 27, 2009 1:19 am

Re: Saving in wrong format

Post by musicvid »

m4v had chapter support for older apple devices.
mp4 now has chapter support for all devices.
that is the ONLY DIFFERENCE.
the extensions are interchangeable.
Please do not waste another second of your existence belaboring this.
Post Reply