Banding/quality issues in 8-bit modes

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
oRBIT2002
Regular User
Posts: 83
Joined: Sun Nov 01, 2009 11:22 am

Banding/quality issues in 8-bit modes

Post by oRBIT2002 »

I did some encoding tests with Handbrake 1.3.2. The reason is that I'm seeing very obvious banding issues in my encodes (well from time to time, in older versions aswell). I think the encodes almost looks broken sometimes. I noticed the problems goes away completely if I encode in 10-bit modes instead of 8-bit. My question is, should it look like this in 8-bit modes really?
I've tried encoding a portion of a blu-ray movie below. I've using medium mode, constant quality in h.265 and h.264 (CPU-modes). 8-bit modes looks average in both h.265 and h.264 but, 10-bit modes looks good.
Here are the examples I've done (below). I think there's a very large quality difference between 8-bit and 10-bit modes that was slightly unexpected?
https://www.dropbox.com/s/py8qf07j3nuza ... t.rar?dl=0
musicvid
Veteran User
Posts: 3689
Joined: Sat Jun 27, 2009 1:19 am

Re: Banding/quality issues in 8-bit modes

Post by musicvid »

If you render 8 bit from 10 bit source, there will be banding. That one is etched in stone.

The downsample/dither algorithm used in Handbrake is the best in the business. My two expen$ive NLEs cant touch it, and I recommend Handbrake instead for downsampling conversions.

You may be particularly sensitive, or you may be misattributing something else you see as banding. I will look at your samples.
oRBIT2002
Regular User
Posts: 83
Joined: Sun Nov 01, 2009 11:22 am

Re: Banding/quality issues in 8-bit modes

Post by oRBIT2002 »

But I’ve encoded from a blu-ray and that’s a 8-bit source right?
musicvid
Veteran User
Posts: 3689
Joined: Sat Jun 27, 2009 1:19 am

Re: Banding/quality issues in 8-bit modes

Post by musicvid »

Correct. And encoding to 8 bit output should result in no additional color banding. I'll look at what you uploaded.
musicvid
Veteran User
Posts: 3689
Joined: Sat Jun 27, 2009 1:19 am

Re: Banding/quality issues in 8-bit modes

Post by musicvid »

There is no visible difference in banding.
The 8 bit samples do appear to be a bit softer, and to investigate, we would need the required encode logs for each render, properly identified, along with a source sample. Without a reference, how on earth would we know if there even is banding?
oRBIT2002
Regular User
Posts: 83
Joined: Sun Nov 01, 2009 11:22 am

Re: Banding/quality issues in 8-bit modes

Post by oRBIT2002 »

Hm I upgraded VLC and now and I can't see the problems anymore, so perhaps it was an issue with my VLC-setup then...
Post Reply