H264 Intel Quick sync video

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
OliverS
Posts: 3
Joined: Sun Dec 22, 2019 6:22 pm

Re: H264 Intel Quick sync video

Post by OliverS »

kata40 wrote: Thu Oct 17, 2019 7:25 pm 1. I have an i9 7900x processor and when I convert it comes to x264 intel quick sync video, although the processors on socket 2066 do not have integrated graphics.
Can anyone explain why that setting appears there?
2. version 1.2.2
3. log files
HandBrake 1.2.2 (2019022300)
OS: Microsoft Windows NT 10.0.18999.0
CPU: Intel(R) Core(TM) i9-7900X CPU @ 3.30GHz
Ram: 32459 MB,
GPU Information:
NVIDIA GeForce RTX 2080 Ti - 26.21.14.3648
Screen: 3840x2160
Temp Dir: C:\Users\Cata\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake
Data Dir: C:\Users\Cata\AppData\Roaming\HandBrake

-------------------------------------------


# Starting Encode ...

[22:11:52] hb_init: starting libhb thread
[22:11:52] 1 job(s) to process
[22:11:52] json job:
{
"Audio": {
"AudioList": [
{
"Bitrate": 160,
"DRC": 0.0,
"Encoder": "ac3",
"Gain": 0.0,
"Mixdown": 4,
"NormalizeMixLevel": false,
"Samplerate": 0,
"Track": 2,
"DitherMethod": 0
}
],
"CopyMask": [
"copy:aac",
"copy:ac3",
"copy:dtshd",
"copy:dts",
"copy:eac3",
"copy:flac",
"copy:mp3",
"copy:truehd"
],
"FallbackEncoder": "ac3"
},
"Destination": {
"ChapterList": [
{
"Name": "Chapter 1"
}
],
"ChapterMarkers": true,
"AlignAVStart": false,
"File": "E:\\3Sat Hd Berliner Philharmoniker - Waldbuhne 2016-1.mkv",
"Mp4Options": {
"IpodAtom": false,
"Mp4Optimize": false
},
"Mux": "mkv"
},
"Filters": {
"FilterList": [
{
"ID": 11,
"Settings": {
"crop-bottom": "0",
"crop-left": "0",
"crop-right": "0",
"crop-top": "0",
"height": "720",
"width": "1280"
}
},
{
"ID": 6,
"Settings": {
"mode": "2",
"rate": "27000000/1080000"
}
}
]
},
"PAR": {
"Num": 1,
"Den": 1
},
"Metadata": {},
"SequenceID": 0,
"Source": {
"Angle": 1,
"Range": {
"Type": "chapter",
"Start": 1,
"End": 1
},
"Title": 1,
"Path": "D:\\Download\\Terminate\\3sat HD_Berliner Philharmoniker - Waldbuhne 2016.ts"
},
"Subtitle": {
"Search": {
"Burn": false,
"Default": false,
"Enable": false,
"Forced": false
},
"SubtitleList": []
},
"Video": {
"Encoder": "qsv_h264",
"Level": "3.1",
"Bitrate": 2700,
"TwoPass": false,
"Turbo": false,
"ColorMatrixCode": 0,
"Options": "",
"Preset": "balanced",
"Profile": "main",
"QSV": {
"Decode": false,
"AsyncDepth": 0
}
}
}
[22:11:52] CPU: Intel(R) Core(TM) i9-7900X CPU @ 3.30GHz
[22:11:52] - logical processor count: 20
[22:11:52] Intel Quick Sync Video support: yes
[22:11:52] - Intel Media SDK software: API 1.19 (minimum: 1.3)
[22:11:52] - H.264 encoder: yes
[22:11:52] - preferred implementation: software (null)
[22:11:52] - capabilities (software): bpyramid vsinfo opt1 opt2
[22:11:52] - H.265 encoder: no
[22:11:52] hb_scan: path=D:\Download\Terminate\3sat HD_Berliner Philharmoniker - Waldbuhne 2016.ts, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:323: failed opening UDF image D:\Download\Terminate\3sat HD_Berliner Philharmoniker - Waldbuhne 2016.ts
src/libbluray/disc/disc.c:424: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:424: error opening file BDMV\BACKUP\index.bdmv
[22:11:52] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.0
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: usps tracking
libdvdnav: vm: failed to read VIDEO_TS.IFO
[22:11:52] dvd: not a dvd - trying as a stream/file instead
[22:11:52] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[22:11:52] Found the following PIDS
[22:11:52] Video PIDS :
[22:11:52] 0x196e type H.264 (0x1b) (PCR)
[22:11:52] Audio PIDS :
[22:11:52] 0x1978 type MPEG1 (0x3)
[22:11:52] 0x1979 type MPEG1 (0x3)
[22:11:52] 0x197a type AC3 (0x81)
[22:11:52] 0x197b type MPEG1 (0x3)
[22:11:52] Subtitle PIDS :
[22:11:52] Other PIDS :
[22:11:52] stream id 0x1978 (type 0x3 substream 0x0) audio 0x1978
[22:11:52] stream id 0x1979 (type 0x3 substream 0x0) audio 0x1979
[22:11:52] stream id 0x197a (type 0x81 substream 0x0) audio 0x197a
[22:11:52] stream id 0x197b (type 0x3 substream 0x0) audio 0x197b
[22:11:52] scan: decoding previews for title 1
[22:11:52] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[22:11:52] scan: audio 0x1979: mp2, rate=48000Hz, bitrate=128000 Unknown (MPEG) (2.0 ch)
[22:11:52] scan: audio 0x1978: mp2, rate=48000Hz, bitrate=128000 Deutsch (MPEG) (2.0 ch)
[22:11:52] scan: audio 0x197a: ac3, rate=48000Hz, bitrate=448000 Deutsch (AC3) (2.0 ch)
[22:11:52] scan: audio 0x197b: mp2, rate=48000Hz, bitrate=128000 Unknown (MPEG) (2.0 ch)
[22:11:52] stream: 20 good frames, 0 errors (0%)
[22:11:52] scan: 10 previews, 1280x720, 50.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[22:11:52] scan: supported video decoders: avcodec qsv
[22:11:52] libhb: scan thread found 1 valid title(s)
[22:11:52] starting job
[22:11:52] work: only 1 chapter, disabling chapter markers
[22:11:52] job configuration:
[22:11:52] * source
[22:11:52] + D:\Download\Terminate\3sat HD_Berliner Philharmoniker - Waldbuhne 2016.ts
[22:11:52] + title 1, chapter(s) 1 to 1
[22:11:52] * destination
[22:11:52] + E:\3Sat Hd Berliner Philharmoniker - Waldbuhne 2016-1.mkv
[22:11:52] + container: Matroska (libavformat)
[22:11:52] * video track
[22:11:52] + decoder: h264
[22:11:52] + bitrate 200 kbps
[22:11:52] + filters
[22:11:52] + Framerate Shaper (mode=2:rate=27000000/1080000)
[22:11:52] + frame rate: 50.000 fps -> peak rate limited to 25.000 fps
[22:11:52] + Crop and Scale (width=1280:height=720:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[22:11:52] + source: 1280 * 720, crop (0/0/0/0): 1280 * 720, scale: 1280 * 720
[22:11:52] + Output geometry
[22:11:52] + storage dimensions: 1280 x 720
[22:11:52] + pixel aspect ratio: 1 : 1
[22:11:52] + display dimensions: 1280 x 720
[22:11:52] + encoder: H.264 (Intel Media SDK)
[22:11:52] + preset: balanced
[22:11:52] + profile: main
[22:11:52] + level: 3.1
[22:11:52] + bitrate: 2700 kbps, pass: 0
[22:11:52] + color profile: 1-1-1
[22:11:52] * audio track 1
[22:11:52] + decoder: Deutsch (AC3) (2.0 ch) (track 3, id 0x197a)
[22:11:52] + bitrate: 448 kbps, samplerate: 48000 Hz
[22:11:52] + mixdown: Stereo
[22:11:52] + dither: none
[22:11:52] + encoder: AC3 (libavcodec)
[22:11:52] + bitrate: 160 kbps, samplerate: 48000 Hz
[22:11:52] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[22:11:52] sync: expecting 414709 video frames
[22:11:52] encqsvInit: using encode-only path
[22:11:52] encqsvInit: H.264/AVC Main profile @ level 3.1
[22:11:52] encqsvInit: TargetUsage 4 AsyncDepth 0
[22:11:52] encqsvInit: GopRefDist 3 GopPicSize 25 NumRefFrame 2
[22:11:52] encqsvInit: BFramesMax 2 BRefType off
[22:11:52] encqsvInit: RateControlMethod VBR TargetKbps 2700 MaxKbps 16800 BufferSizeInKB 2100 InitialDelayInKB 2100
[22:11:52] sync: first pts video is 40829
[22:11:52] sync: first pts audio 0x197a is 0
[22:11:53] qsv_enc_init: using 'software (null)' implementation, API: 1.19

# Encode Stopped

[22:24:51] work: average encoding speed for job is 268.037109 fps
[22:24:51] vfr: 104347 frames output, 104346 dropped and 0 duped for CFR/PFR
[22:24:51] vfr: lost time: 0 (0 frames)
[22:24:51] vfr: gained time: 0 (0 frames) (0 not accounted for)
[22:24:51] stream: 208802 good frames, 0 errors (0%)
[22:24:51] ac3-decoder done: 130479 frames, 0 decoder errors
[22:24:51] h264-decoder done: 208767 frames, 0 decoder errors
[22:24:51] sync: got 208710 frames, 414709 expected
[22:24:51] sync: framerate min 25.000 fps, max 50.000 fps, avg 50.000 fps
[22:24:51] mux: track 0, 104333 frames, 1408603111 bytes, 2699.51 kbps, fifo 1024
[22:24:51] mux: track 1, 130449 frames, 83487360 bytes, 160.00 kbps, fifo 2048
[22:24:51] libhb: work result = 1

# Encode Completed ...
I was also facing the same but thanks to everyone in this thread it got fixed.


THanks and Regards,
Oliver
kata40
Regular User
Posts: 64
Joined: Sun Nov 25, 2018 6:47 pm

Re: H264 Intel Quick sync video

Post by kata40 »

Other than the fact that I had to use invenc for encoding, encoding with the processor, I didn't succeed, going bad.
What fix did you find and apply?
Post Reply