Fix for .net Framework 4.7.1 error

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
hammer_gaidin
New User
Posts: 1
Joined: Fri May 24, 2019 2:53 pm

Fix for .net Framework 4.7.1 error

Post by hammer_gaidin » Fri May 24, 2019 2:56 pm

Description of problem or question:
When attempting to run 1.2.2, presented with error that application requires .net 4.7.1. Even though system has a newer version.

HandBrake version (e.g., 1.0.0):
1.2.2

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Window 10 v1809

Fix

Open up the file "HandBrake.exe.config" in your favorite text editor (you must run the editor as admin).

Change: <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.7.1"/>

To: <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.7.2"/>


This corrected the issue for me. Hopefully, this will help someone else.

Post Reply