Page 1 of 1

x86_32 support

Posted: Sat Apr 13, 2019 3:08 am
by masteruser82841
Description of problem or question:


I can't run this soft on 32bit processor


Steps to reproduce the problem (If Applicable):


Run latest version on Windows 8 32bit


HandBrake version (e.g., 1.0.0):


1.2.2


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):


Windows 8 32bit

Posted: Sat Apr 13, 2019 9:05 am
by masteruser82841
Please, return x32 support, and if can, Windows 7 support.

My emulator (wine) in exagear don't support 64 bit.
https://cs5-2.4pda.to/15967899/Screensh ... 8b53ccc322

Screenshot from 1.0.7 version, newer dont work

Re: x86_32 support

Posted: Sat Apr 13, 2019 9:57 am
by s55
The current versions of HandBrake are not compatible with 32bit systems and this is not something that will change. Support has been permanently removed now.

Windows 7 64bit, is however supported. Windows 8 (needs to be 8.1) to be supported under 64bit.
1.0.7 was the last version to support 32bit.

Re: x86_32 support

Posted: Sat Apr 13, 2019 10:07 am
by masteruser82841
s55 wrote:
Sat Apr 13, 2019 9:57 am
The current versions of HandBrake are not compatible with 32bit systems and this is not something that will change. Support has been permanently removed now.

Windows 7 64bit, is however supported. Windows 8 (needs to be 8.1) to be supported under 64bit.
1.0.7 was the last version to support 32bit.
Explain the reason for removing 32bit support

Re: x86_32 support

Posted: Sat Apr 13, 2019 11:26 am
by s55
Putting out software that has a high probability of crashing (due to out of memory errors) and is no longer tested at all by us, is not respectful to our users. Before we dropped 32bit support, we were getting quite a lot of performance and memory related complaints.

Second, The 32bit userbase was too small to justifiy spending very limited resources on supporting.

Finally, there is nothing stopping folks from using the older versions of HandBrake. We simply won't offer support for them now.

There are plenty of other good reasons but at the end of the day, your choices are to use an old version, or move to another software package that still has support.

Re: x86_32 support

Posted: Sat Apr 13, 2019 2:26 pm
by Woodstock
If you're running an emulator to get Windows, why aren't you compiling handbrake in your native 64 bit environment?

Oh, wait - ExaGear - You're running an x86 emulator on an unsupported processor (ARM)... You really have performance issues...

Re: x86_32 support

Posted: Fri May 03, 2019 8:39 pm
by masteruser82841
s55 wrote:
Sat Apr 13, 2019 11:26 am
Putting out software that has a high probability of crashing (due to out of memory errors) and is no longer tested at all by us, is not respectful to our users. Before we dropped 32bit support, we were getting quite a lot of performance and memory related complaints.

Second, The 32bit userbase was too small to justifiy spending very limited resources on supporting.

Finally, there is nothing stopping folks from using the older versions of HandBrake. We simply won't offer support for them now.

There are plenty of other good reasons but at the end of the day, your choices are to use an old version, or move to another software package that still has support.
Can I compile latest version of source code for 32bit?

Re: x86_32 support

Posted: Fri May 03, 2019 8:42 pm
by s55
Nope. 1.0.7 will still work ok so you should use that.