SRT files: extended ASCII characters (é è ï) removed?

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
JayDee
Posts: 1
Joined: Sat Jan 26, 2019 3:11 pm

SRT files: extended ASCII characters (é è ï) removed?

Post by JayDee » Sat Jan 26, 2019 3:24 pm

Description of problem or question:

Hi guys, I'm trying to add subtitles to some video files. In Dutch (in French too, I know), we use extended ASCII characters such as ï, é, è etc. But so far I always see them removed from the subtitles (SRT) I try to add to the video. Initially, I thought this happened at the playback device (Dreambox-type STB running Enigma2), but it also appears on subs i've burned-in the video.

For example: Hé (Dutch for Hey!), would show as H . Apparently the extended ASCII characters are simply ignored.


Steps to reproduce the problem (If Applicable):

Just take a video and import an SRT file as subtitle. choose UTF-8 (often default already). Save as MP4 or MKV (no difference).
When ticking the Burn In-box, you'll see the missing characters in your video.
When not ticking the Burn In-box, you'll first need to select the subtitle on some playback devices / players and then you'll see the missing characters.

HandBrake version (e.g., 1.0.0):

My Handbake says 0.10.5.0 64bit version


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):

Windows 7 Home Premium x64

User avatar
JohnAStebbins
HandBrake Team
Posts: 5346
Joined: Sat Feb 09, 2008 7:21 pm

Re: SRT files: extended ASCII characters (é è ï) removed?

Post by JohnAStebbins » Sat Jan 26, 2019 4:03 pm

First upgrade HandBrake. 0.10.5 is so old I can't even recall what sorts of bugs might have existed.
Second post an activity log. If there were errors logged, it may give us more of a clue.

But, you are most likely setting the wrong character code set for SRT input. Are you certain that your SRT files were produced with UTF-8?

Post Reply