Why CPU is high utilitzation even with h/w encode and decode enabled

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
takayo72
New User
Posts: 1
Joined: Wed Jan 16, 2019 12:24 am

Why CPU is high utilitzation even with h/w encode and decode enabled

Post by takayo72 » Wed Jan 16, 2019 12:31 am

Description of problem or question:
I enabled nvidia for encoder and quick sync for decoder in option.
I found that cpu utilization is still 9X - 100%
intel iGPU is 5X % utilization
nvidia gpu (1070) is around 20% utilization

From utilization percentage, the gpu decoder and encoder is working.
But why the cpu is still high usage and gpu usage is pretty low


HandBrake version :

1.2.0


Operating system and version:
Win10 x64 build 1803

User avatar
s55
HandBrake Team
Posts: 9522
Joined: Sun Dec 24, 2006 1:05 pm

Re: Why CPU is high utilitzation even with h/w encode and decode enabled

Post by s55 » Wed Jan 16, 2019 7:43 pm

See the Performance Seciton: https://handbrake.fr/docs/en/1.2.0/tech ... o-vce.html


Even if you offload decode. a/v sync, filters, audio, subtitle processing, muxing etc all happen on the CPU.
Filters will be be biggest bottleneck.

mduell
Veteran User
Posts: 6630
Joined: Sat Apr 21, 2007 8:54 pm

Re: Why CPU is high utilitzation even with h/w encode and decode enabled

Post by mduell » Wed Jan 16, 2019 11:44 pm

An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.

Post Reply