Page 1 of 1

HB error when using QSV (Error Code -17)

Posted: Mon Nov 05, 2018 7:48 am
by tjsuominen
Description of problem or question:
A MKV video I attempt to encode using H.264 (Intel QSV) fails with an Error code -17, hb_qsv_wait_on_sync 602. Encoded three files, this happened only to one of the (two successful ones with QSV).

Steps to reproduce the problem (If Applicable):
While encoding the file, HB encode stops (time is running, but no progress).


HandBrake version (e.g., 1.0.0):
HandBrake 1.1.2 (2018090500) - 64bit


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Windows 10 (1803)


HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

https://pastebin.com/gUf90W4e
Other
I do realize this has been discussed earlier (ref. https://github.com/HandBrake/HandBrake/issues/660, yet I'm just wondering is my HW / Intel HD Graphics drivers "outdated"? Those (check the log) are the latest available for my configuration.

Re: HB error when using QSV (Error Code -17)

Posted: Mon Nov 05, 2018 8:12 am
by s55
At some point in the near future, we are looking at adding an option to force QuickSync to use DirectX9 rather than 11 to improve another situation where there is issues. I don't think it'll resolve this but it may make it less likely to occur.

Unfortunately, given these parts are discontinued by Intel, we are limited in options

Re: HB error when using QSV (Error Code -17)

Posted: Mon Nov 05, 2018 8:43 am
by tjsuominen
OK, thx a lot for response. This happened to me now for the 1st time and if it's very random, yeah, I can just use another encoding method in such case. Yet interested in evaluating the DirectX9 option when available.

Appreciated.

//Timo