DTS-HD MA 7.1 not detected

HandBrake for Windows support
Forum rules
Activity Log is required for support requests. See Must Read: How To Get Questions Answered on These Forums for details
Post Reply
mitul1983
Posts: 3
Joined: Tue Feb 14, 2017 7:21 pm

DTS-HD MA 7.1 not detected

Post by mitul1983 » Tue Feb 14, 2017 7:28 pm

Please detail your question or problem in as much detail as possible:

I have a video file with 7.1 DTS-HD MA audio. However, Handbrake only detects 5.1 channel and so the option to encode to 7.1 Channel AAC is not available.

MediaInfo shows:
Audio #4
ID : 4355 (0x1103)
Menu ID : 1 (0x1)
Format : DTS
Format/Info : Digital Theater Systems
Format profile : MA / Core
Mode : 16
Format settings, Endianness : Big
Muxing mode : Stream extension
Codec ID : 134
Duration : 1 h 55 min
Bit rate mode : Variable / Constant
Bit rate : Unknown / 768 kb/s
Channel(s) : 8 channels / 6 channels
Channel positions : Front: L C R, Side: L R, Back: L R, LFE / Front: L C R, Side: L R, LFE
Sampling rate : 48.0 kHz
Frame rate : 93.750 FPS (512 spf)
Bit depth : 16 bits
Compression mode : Lossless / Lossy
Language : English

Can I force 7.1 somehow?

Tell us about your environment. What version of HandBrake? What version of Windows are you running. etc.
1.0.2 2017012200 - 64 bit

If there was any exception or error displayed, please copy it and paste it here:
N/A

Please include the scan or encode log:

Code: Select all

 
HandBrake 1.0.2 (2017012200) - 64bit
OS: Microsoft Windows NT 10.0.14393.0 - 64bit
CPU: Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz
Ram: 16307 MB, 
GPU Information:
  Radeon (TM) RX 480 Graphics - 21.19.411.0
Screen: 1920x1200
-------------------------------------------

 # Starting Scan ...

[12:35:36] CPU: Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz
[12:35:36]  - Intel microarchitecture Haswell
[12:35:36]  - logical processor count: 12
[12:35:36] Intel Quick Sync Video support: no
[12:35:36] hb_scan: path=M:\X\BDMV\STREAM, title_index=0
src/libbluray/disc/disc.c:352: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:352: error opening file BDMV\BACKUP\index.bdmv
[12:35:36] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread: Can't open M:\X\BDMV\STREAM for reading
libdvdread: Device M:\X\BDMV\STREAM inaccessible, CSS authentication not available.
libdvdread:DVDOpenFilePath:findDVDFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFilePath:findDVDFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[12:35:36] dvd: not a dvd - trying as a stream/file instead
[12:35:36] batch: scanning M:\X\BDMV\STREAM\00000.m2ts
[12:35:36] file is MPEG Transport Stream with 192 byte packets offset 4 bytes
[12:35:36] Found the following PIDS
[12:35:36]     Video PIDS :
[12:35:36]       0x1011 type MPEG2 (0x2)
[12:35:36]     Audio PIDS :
[12:35:36]       0x1100 type AC3 (0x81)
[12:35:36]       0x1101 type DTS-HD MA (0x86)
[12:35:36]       0x1102 type DTS-HD MA (0x86)
[12:35:36]       0x1103 type DTS-HD MA (0x86)
[12:35:36]       0x1104 type AC3 (0x81)
[12:35:36]     Subtitle PIDS :
[12:35:36]       0x1200 type PGS Subtitle (0x90)
[12:35:36]       0x1201 type PGS Subtitle (0x90)
[12:35:36]     Other PIDS :
[12:35:36]       0x1001 type Unknown (0xff) (PCR)
[12:35:36] stream id 0x1100 (type 0x81 substream 0x0) audio 0x1100
[12:35:36] stream id 0x1101 (type 0x86 substream 0x71) audio 0x711101
[12:35:36] stream id 0x1101 (type 0x86 substream 0x0) audio 0x1101
[12:35:36] stream id 0x1102 (type 0x86 substream 0x71) audio 0x711102
[12:35:36] stream id 0x1102 (type 0x86 substream 0x0) audio 0x1102
[12:35:36] stream id 0x1103 (type 0x86 substream 0x71) audio 0x711103
[12:35:36] stream id 0x1103 (type 0x86 substream 0x0) audio 0x1103
[12:35:36] stream id 0x1104 (type 0x81 substream 0x0) audio 0x1104
[12:35:36] stream id 0x1200 (type 0x90 substream 0x0) subtitle 0x1200
[12:35:36] stream id 0x1201 (type 0x90 substream 0x0) subtitle 0x1201
[12:35:41] scan: decoding previews for title 1 (M:\X\BDMV\STREAM\00000.m2ts)
[12:35:41] file is MPEG Transport Stream with 192 byte packets offset 4 bytes
[12:35:41] scan: audio 0x1100: ac3, rate=48000Hz, bitrate=384000 ??????? (AC3) (5.1 ch)
[12:35:41] scan: audio 0x1104: ac3, rate=48000Hz, bitrate=640000 English (AC3) (5.1 ch) (Dolby Digital EX)
[12:35:41] scan: audio 0x711101: dca, rate=48000Hz, bitrate=768000 ??????? (DTS) (5.1 ch)
[12:35:41] scan: audio 0x1101: dca, rate=48000Hz, bitrate=768000 ??????? (DTS-HD MA) (5.1 ch)
[12:35:41] scan: audio 0x711102: dca, rate=48000Hz, bitrate=768000 ??????? (DTS) (5.1 ch)
[12:35:41] scan: audio 0x1102: dca, rate=48000Hz, bitrate=768000 ??????? (DTS-HD MA) (5.1 ch)
[12:35:41] scan: audio 0x711103: dca, rate=48000Hz, bitrate=768000 English (DTS) (5.1 ch)
[12:35:41] scan: audio 0x1103: dca, rate=48000Hz, bitrate=768000 English (DTS-HD MA) (5.1 ch)
[12:35:42] stream: 9 good frames, 0 errors (0%)
[12:35:42] scan: 10 previews, 1920x1080, 23.976 fps, autocrop = 134/134/2/2, aspect 16:9, PAR 1:1
[12:35:42] libhb: scan thread found 1 valid title(s)

 # Scan Finished ...

Woodstock
Veteran User
Posts: 2052
Joined: Tue Aug 27, 2013 6:39 am

Re: DTS-HD MA 7.1 not detected

Post by Woodstock » Tue Feb 14, 2017 9:24 pm

Without the encode portion of the log, we don't know if you told handbrake to pass the 7.1 track through or if you told it to encode it as something else.

I remember references here that the current audio encoders in handbrake have an issue with 7.1 audio, and can only output 5.1. If that's still true, it can't be fixed (except for using pass-through) until library is updated to handle it.

mitul1983
Posts: 3
Joined: Tue Feb 14, 2017 7:21 pm

Re: DTS-HD MA 7.1 not detected

Post by mitul1983 » Tue Feb 14, 2017 9:42 pm

I did not actually proceed to encode it since it was only detected as 5.1 and the AAC mixdown dropdown only had an option for 5.1. I expect that if 7.1 was detected, an option for 7.1 would be available in that dropdown.

I tried the nightly and the issue persists so I guess it won't be resolved any time soon. Is there a possible workaround that you know of? Maybe create an AAC 7.1 audio file using some tool and then mux the files together?

Thanks

Woodstock
Veteran User
Posts: 2052
Joined: Tue Aug 27, 2013 6:39 am

Re: DTS-HD MA 7.1 not detected

Post by Woodstock » Wed Feb 15, 2017 1:28 am

You can always tell handbrake to pass it through - the current version can do DTS-HD pass through. I prefer NOT to recode audio if I don't have to.

User avatar
Rodeo
HandBrake Team
Posts: 11636
Joined: Tue Mar 03, 2009 8:55 pm

Re: DTS-HD MA 7.1 not detected

Post by Rodeo » Wed Feb 15, 2017 1:33 am

Our decoder doesn't fully support DTS-HD, so if you want the full lossless track with all channels, your only option is to pass it through. HandBrake will pass the complete audio bitstream through, regardless of how many channels are actually detected by the decoder.

mitul1983
Posts: 3
Joined: Tue Feb 14, 2017 7:21 pm

Re: DTS-HD MA 7.1 not detected

Post by mitul1983 » Fri Mar 03, 2017 9:27 pm

Okay, thanks

Post Reply