With upcoming changes to data protection and privacy laws in Europe coming into effect soon, we thought this would be a good time to remind everyone that we do have a privacy policy.
This applies to all users and visitors world-wide.

We have made a few changes to the language to make it clearer in relation to this new regulation but fundamentally, the terms and your rights are unchanged.

If you have any questions about this, please feel free to ask in the General Forum

H.264(Intel QSV) SOMETIMES won't preview file, refuses to fully encode

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
Code-E
Posts: 10
Joined: Sun Dec 11, 2016 11:52 pm

H.264(Intel QSV) SOMETIMES won't preview file, refuses to fully encode

Post by Code-E » Mon Dec 12, 2016 12:09 am

Recently found out that H.264(Intel QSV) may give faster encode speeds, so I've been messing around with it for youtube stuff. But as I said in the title, sometimes it will preview the file...sometimes it won't and it doesn't want to fully encode ever.

I have limited experience reading logs like this, but I was able to grab a few guesses.

It seems to recognize that I'm using an .avi file, but I may have the wrong version of "Intel Media SK hardware", or I don't have libavcodec (which I could swear I do).

Normally I'd go about fixing this myself, but I don't know much about this topic and I don't want to break anything!

Thanks!

As a side note, does anyone know if Intel QSV works well with YouTube?
For the regular x264 I have the extra options 'keyint=15:bframes=2' which is supposed to be in line with their recommended settings. But I can't add those options on Intel QSV.

I'm running Windows 10 with Handbrake 0.10.5.0

The error was: "Unable to find the preview file. Either The file was deleted or the encode failed. Check the activity log for details." I didn't get an error after starting the encode. It just stopped and didn't put out any file.


Code: Select all

HandBrake 0.10.5.0 - 64bit Version
OS: Microsoft Windows NT 6.2.9200.0 - 64bit
CPU: Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz
Ram: 8058 MB, 
GPU Information:
  Intel(R) HD Graphics 520 - 10.18.15.4248
  NVIDIA GeForce 940M - 21.21.13.7563
Screen: 1920x1080
Temp Dir: C:\Users\cwbla\AppData\Local\Temp\
Install Dir: C:\Program Files\Handbrake
Data Dir: C:\Users\cwbla\AppData\Roaming\HandBrake Team\HandBrake\0.10.5.0

-------------------------------------------
CLI Query:  -i "C:\Users\cwbla\Videos\youre in space.avi" -t 1 --angle 1 -c 1 -o "C:\Users\cwbla\Videos\Youre In Space-1.mp4"  -f mp4  -O  -w 1280 -l 720 --crop 0:0:0:0 --modulus 2 -e qsv_h264 -q 23 --cfr -a 1 -E av_aac -6 stereo -R 48 -B 192 -D 0 --gain 0 --audio-fallback ac3 --markers="C:\Users\cwbla\AppData\Local\Temp\Youre In Space-1-1-chapters.csv" --encoder-preset=quality --encoder-level="4.0"  --encoder-profile=high  --verbose=1

[15:47:01] hb_init: starting libhb thread
HandBrake 0.10.5 (2016021100) - MinGW x86_64 - https://handbrake.fr
4 CPUs detected
Opening C:\Users\cwbla\Videos\youre in space.avi...
[15:47:01] CPU: Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz
[15:47:01]  - logical processor count: 4
[15:47:01] OpenCL device #1: Intel(R) Corporation Intel(R) HD Graphics 520
[15:47:01]  - OpenCL version: 2.0 
[15:47:01]  - driver version: 10.18.15.4248
[15:47:01]  - device type:    GPU
[15:47:01]  - supported:      YES
[15:47:01] OpenCL device #2: NVIDIA Corporation GeForce 940M
[15:47:01]  - OpenCL version: 1.2 CUDA
[15:47:01]  - driver version: 375.63
[15:47:01]  - device type:    GPU
[15:47:01]  - supported:      no
[15:47:01] Intel Quick Sync Video support: yes
[15:47:01]  - Intel Media SDK hardware: API 1.16 (minimum: 1.3)
[15:47:01]  - H.264 encoder: yes
[15:47:01]     - preferred implementation: hardware (any)
[15:47:01]  - H.265 encoder: no
[15:47:01] hb_scan: path=C:\Users\cwbla\Videos\youre in space.avi, title_index=1
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening C:\Users\cwbla\Videos\youre in space.avi/BDMV/index.bdmv
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening C:\Users\cwbla\Videos\youre in space.avi/BDMV/BACKUP/index.bdmv
libbluray/bluray.c:2182: nav_get_title_list(C:\Users\cwbla\Videos\youre in space.avi) failed
[15:47:01] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[15:47:01] dvd: not a dvd - trying as a stream/file instead
Input #0, avi, from 'C:\Users\cwbla\Videos\youre in space.avi':
  Metadata:
    encoder         : Lavf55.19.104
  Duration: 00:12:11.50, start: 0.000000, bitrate: 19071 kb/s
    Stream #0.0: Video: h264 (High 4:4:4 Predictive), yuv420p, 1280x720 [PAR 1:1 DAR 16:9], 30 fps, 30 tbn, 60 tbc
    Stream #0.1: Audio: pcm_s16le, 48000 Hz, 1 channels, s16, 768 kb/s
[15:47:01] scan: decoding previews for title 1
[15:47:01] scan: audio 0x1: pcm_s16le, rate=48000Hz, bitrate=768000 Unknown (pcm_s16le) (1.0 ch)
Scanning title 1 of 1, preview 2, 20.00 %
Scanning title 1 of 1, preview 9, 90.00 %[15:47:01] scan: 10 previews, 1280x720, 30.000 fps, autocrop = 48/48/292/292, aspect 16:9, PAR 1:1
[15:47:01] libhb: scan thread found 1 valid title(s)
+ title 1:
  + stream: C:\Users\cwbla\Videos\youre in space.avi
  + duration: 00:12:11
  + size: 1280x720, pixel aspect: 1/1, display aspect: 1.78, 30.000 fps
  + autocrop: 48/48/292/292
  + support opencl: yes
  + support hwd: yes
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 00:12:11
  + audio tracks:
    + 1, Unknown (pcm_s16le) (1.0 ch) (iso639-2: und)
  + subtitle tracks:
Reading chapter markers from file C:\Users\cwbla\AppData\Local\Temp\Youre In Space-1-1-chapters.csv
[15:47:01] 1 job(s) to process
[15:47:01] starting job
[15:47:01] do_job: QSV: full path, removing unsupported filter 'Framerate Shaper'
[15:47:01] work: sanitizing track 1 mixdown Stereo to Mono
[15:47:01] sync: expecting 21945 video frames
[15:47:01] work: only 1 chapter, disabling chapter markers
[15:47:01] job configuration:
[15:47:01]  * source
[15:47:01]    + C:\Users\cwbla\Videos\youre in space.avi
[15:47:01]    + title 1, chapter(s) 1 to 1
[15:47:01]    + container: avi
[15:47:01]    + data rate: 19071 kbps
[15:47:01]  * destination
[15:47:01]    + C:\Users\cwbla\Videos\Youre In Space-1.mp4
[15:47:01]    + container: MPEG-4 (libavformat)
[15:47:01]      + optimized for HTTP streaming (fast start)
[15:47:01]  * video track
[15:47:01]    + decoder: h264_qsv
[15:47:01]    + dimensions: 1280 * 720, mod 2
[15:47:01]    + encoder: H.264 (Intel Media SDK)
[15:47:01]      + preset:  quality
[15:47:01]      + profile: high
[15:47:01]      + level:   4.0
[15:47:01]      + quality: 23.00 (ICQ)
[15:47:01]  * audio track 1
[15:47:01]    + decoder: Unknown (pcm_s16le) (1.0 ch) (track 1, id 0x1)
[15:47:01]      + bitrate: 768 kbps, samplerate: 48000 Hz
[15:47:01]    + mixdown: Mono
[15:47:01]    + encoder: AAC (libavcodec)
[15:47:01]      + bitrate: 192 kbps, samplerate: 48000 Hz
[15:47:02] reader: first SCR 0 id 0x0 DTS 0
Error code -15,	ff_qsv_dec_init	293
[15:47:02] decavcodecvInit: avcodec_open failed
ERROR: Failure to initialise thread 'Video decoder (libavcodec)'
[15:47:02] reader: done. 1 scr changes
[15:47:02] libhb: work result = 3
Encode failed (error 3).
HandBrake has exited.


Post Reply