Soft subtitles not in correct position

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
Zypher
Posts: 3
Joined: Mon Nov 30, 2015 1:54 pm

Soft subtitles not in correct position

Post by Zypher » Mon Nov 30, 2015 2:11 pm

Hi,

I use MakeMKV to rip blu-ray discs to MKV with one subtitle track.

When I open the MKV file in handbrake and use the MKV container and add a subtitle track, that is NOT burned-in, then the subtitles will appear too high up on the video.
If I choose to burn-in the track it is in the correct position. If I use MP4 (burned-in subtitle) it also works fine.

This happens to all the blu-ray discs I have tried.

How do I get soft subtitles to be in the correct position and not higher up, than on the original video?

Tried the latest nightly build yesterday with same problem. For playback I use VLC 2.2.1.

Thanks.

rollin_eng
Veteran User
Posts: 3163
Joined: Wed May 04, 2011 11:06 pm

Re: Soft subtitles not in correct position

Post by rollin_eng » Mon Nov 30, 2015 2:39 pm

Could you please post your logs, instructions can be found here:

viewtopic.php?f=6&t=31236

Woodstock
Veteran User
Posts: 3213
Joined: Tue Aug 27, 2013 6:39 am

Re: Soft subtitles not in correct position

Post by Woodstock » Mon Nov 30, 2015 6:42 pm

VLC is known to have issues with displaying some VOBSUB and PGS subtitles on cropped video. Your logs will show if this is the case in your situation, or if there is something else at work.

GregiBoy
Veteran User
Posts: 908
Joined: Sat Feb 12, 2011 9:23 pm

Re: Soft subtitles not in correct position

Post by GregiBoy » Tue Dec 01, 2015 2:01 am

Could be the autocropping also.

Zypher
Posts: 3
Joined: Mon Nov 30, 2015 1:54 pm

Re: Soft subtitles not in correct position

Post by Zypher » Tue Dec 01, 2015 4:06 pm

Thanks for your reply.
I have now attached the log from one om my tests.
I dont think its a flaw with VLC player as Burned-in subtitles displays normally.
Also when playing the original MKV there is no problem.

It seems like the subtitles are liftet one line further up from the button.
Last edited by Zypher on Tue Dec 01, 2015 8:16 pm, edited 1 time in total.

User avatar
JohnAStebbins
HandBrake Team
Posts: 5442
Joined: Sat Feb 09, 2008 7:21 pm

Re: Soft subtitles not in correct position

Post by JohnAStebbins » Tue Dec 01, 2015 5:17 pm

Zypher wrote: I dont think its a flaw with VLC player as Burned-in subtitles displays normally.
Actually, this is exactly why we think it is a known VLC issue. Burned in subtitles are rendered by HandBrake into the video during encoding. Soft subtitles are rendered by VLC during playback.
Zypher wrote: Also when playing the original MKV there is no problem.
This is why we needed to see your log. The original MKV is full frame (includes black borders top and bottom). HandBrake automatically crops these black borders. It is this cropping that confuses VLC. The original subtitle positions were relative to the uncropped image. VLC *should* be able to compensate for this cropping since the original uncropped dimensions are stored in the subtitle header information. But it uses a very stupid and simplistic calculation to place subtitles that assumes the difference in image size is only due to scaling.

If you must use VLC for playback and want the subtitles to appear in the correct position, you will have to disable cropping. As an alternative, you could use some other app for playback that does the right thing (e.g. kodi a.k.a. xbmc).

Zypher
Posts: 3
Joined: Mon Nov 30, 2015 1:54 pm

Re: Soft subtitles not in correct position

Post by Zypher » Tue Dec 01, 2015 8:34 pm

Thank you so much.

Yes of course, it really make sense. I was too concerned with the original MKV file not having any issues with VLC player, that I thought it had to be handbrake that did the miscalculation.

I think I will try a different playback app then.

Post Reply