Subtitles ASS vs UTF-8

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Locked
sl7008

Subtitles ASS vs UTF-8

Post by sl7008 » Fri Dec 26, 2014 6:56 pm

When I create an MKV file with embedded subtitles the result looks perfect in VLC but the subtitles do not display correctly on my Panasonic TV. On the TV, each subtitle is prefixed by a long string of characters which I believe should determine the timing but should not be displayed. This appears to be a new problem, but I am unsure which version of Handbrake first introduced it. When I look inside the MKV container, it appears that the subtitles have been included as ASS files, whereas they used to be included as UTF-8. UTF-8 works fine both in VLC and on my Panasonic TV, but ASS fails to display properly on the TV. I do select UTF-8 on the Handbrake Subtitles tab, but this seems to be ignored. I have pasted a copy of the log on http://pastebin.com/be4WzrsB.
Please advise whether I have made some mistake or whether this is a fault in the most recent version of Handbrake. If the former, please advise what I need to do differently, if the latter, please advise when the fault might be fixed.

TedJ
Veteran User
Posts: 5388
Joined: Wed Feb 20, 2008 11:25 pm

Re: Subtitles ASS vs UTF-8

Post by TedJ » Sun Dec 28, 2014 10:17 am

Code: Select all

The.Americans.S01.Season.1.720p.HDTV.x264-PublicHD\The Americans S01 E02 - The Clock.mkv
Rule #3 violation, locking thread.

Locked