Cannot see OpenCL checkbox on output settings

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
mzarate
Posts: 6
Joined: Wed Jul 30, 2014 4:46 pm

Cannot see OpenCL checkbox on output settings

Post by mzarate »

I just installed handbrake 0.9.9.5530 64bit, when opening it i thought i would find an opencl "checkbox" to enable support but its not showing me that option.

I have a Radeon R9 290X with the latest stable drivers installed, windows 8.1.

Also if i add opencl=1 to the x264 advanced settings it says unknown suboption in the encoding logs.

Any help is appreciated.
User avatar
s55
HandBrake Team
Posts: 9904
Joined: Sun Dec 24, 2006 1:05 pm

Re: Cannot see OpenCL checkbox on output settings

Post by s55 »

0.9.9 does not support OpenCL. Only available in the nightly builds
mzarate
Posts: 6
Joined: Wed Jul 30, 2014 4:46 pm

Re: Cannot see OpenCL checkbox on output settings

Post by mzarate »

Thank you, it works now, i can see my gpu activity at 100%.

Unfortunately i didn't get much of a performance advantage with / without using opencl with my settings. I gained around 2-3 FPS AVG more with OpenCL.
ashleylai87
Posts: 33
Joined: Tue Jul 30, 2013 3:54 am

Re: Cannot see OpenCL checkbox on output settings

Post by ashleylai87 »

Radeon R9 290X ?
Not sure if I might break any forum rules.....but your GPU may support AMD VCE for transcoding purpose.
Hardware based transcoder like Intel Quicksync. Except VCE is slower than Quicksync.

http://bluesky23.yu-nagi.com/en/AsVideoConv.html
Download the appropriate 32 or 64 bits.
Next, visit https://github.com/Nevcairiel/LAVFilters/releases and install the appropriate 32 or 64 bits during the installation.
If you choose 32bit version os AsVideoConv, please remember to choose 32bit filters for lavfilter as well.

When you run AsVideoConv, go to the video filter settings and choose the lavfilters as default for video,audio and splitter.
Note: please tick the 'gpu decoding' at AsVideoConv and select 'dxva (native) ' in lavfilter video option.
If you plan to resize the output video, go to DXVA Preprocessor of AsVideoConv and select resize, then enter the resolution.

Remember to select AMD VCE Encoder (edit: you can play around with VCE encoder setting) at AsVideoConv.

Anyway, it is easy to use, got around 90fps (best quality profile) when encoding ripped raw pure 40gb bluray.mp4/mkv to different h264 resolution etc.
User avatar
s55
HandBrake Team
Posts: 9904
Joined: Sun Dec 24, 2006 1:05 pm

Re: Cannot see OpenCL checkbox on output settings

Post by s55 »

OpenCL is not going to bring large advances in performance. In fact in some situations it's slower than pure CPU.

The opencl code in HB is good for about a 5% improvement in optimal circumstances. x264 opencl lookahead works best with lower lookahead values of around 20 iirc, but again, nothing earth shattering.
mzarate
Posts: 6
Joined: Wed Jul 30, 2014 4:46 pm

Re: Cannot see OpenCL checkbox on output settings

Post by mzarate »

ashleylai87 wrote:Radeon R9 290X ?
Not sure if I might break any forum rules.....but your GPU may support AMD VCE for transcoding purpose.
Hardware based transcoder like Intel Quicksync. Except VCE is slower than Quicksync.

http://bluesky23.yu-nagi.com/en/AsVideoConv.html
Download the appropriate 32 or 64 bits.
Next, visit https://github.com/Nevcairiel/LAVFilters/releases and install the appropriate 32 or 64 bits during the installation.
If you choose 32bit version os AsVideoConv, please remember to choose 32bit filters for lavfilter as well.

When you run AsVideoConv, go to the video filter settings and choose the lavfilters as default for video,audio and splitter.
Note: please tick the 'gpu decoding' at AsVideoConv and select 'dxva (native) ' in lavfilter video option.
If you plan to resize the output video, go to DXVA Preprocessor of AsVideoConv and select resize, then enter the resolution.

Remember to select AMD VCE Encoder (edit: you can play around with VCE encoder setting) at AsVideoConv.

Anyway, it is easy to use, got around 90fps (best quality profile) when encoding ripped raw pure 40gb bluray.mp4/mkv to different h264 resolution etc.

I tried this method and it worked, got around 50 fps avg from a 50mbps XAVCS HD raw file but the output looks very grainy and full of noise, i tried tweaking the amd vce h264 settings but always got the same result.
mzarate
Posts: 6
Joined: Wed Jul 30, 2014 4:46 pm

Re: Cannot see OpenCL checkbox on output settings

Post by mzarate »

Well, just an update, i managed somehow to fix the quality issue, not sure which setting >)

The quality seems okay but the levels of compression you can achieve without sacrificing quality using x264 is way superior than this codec from what i can tell, i guess at 75 fps encoding speed something has to be sacrificed.

The other issue i found with AMD VCE is that when i play the encoded video the first few frames start acting up, like skipping and then it plays smoothly. Happens only within the first second or so.
ashleylai87
Posts: 33
Joined: Tue Jul 30, 2013 3:54 am

Re: Cannot see OpenCL checkbox on output settings

Post by ashleylai87 »

mzarate wrote:Well, just an update, i managed somehow to fix the quality issue, not sure which setting >)

The quality seems okay but the levels of compression you can achieve without sacrificing quality using x264 is way superior than this codec from what i can tell, i guess at 75 fps encoding speed something has to be sacrificed.

The other issue i found with AMD VCE is that when i play the encoded video the first few frames start acting up, like skipping and then it plays smoothly. Happens only within the first second or so.
Quality section;
Try turning on B-Frame/Pyramid. It increase the quality and compression efficiency.
Btw, you sure the program is using VCE chip? If not configured properly, it might fall back to shaders based encoding instead of VCE.
Hmm, try check your GPU utilization using GPU-Z.

Anyway, there was a powerpoint slide about VCE performance, http://www.slideshare.net/DevCentralAMD ... aledmammou
Read page 16 of the slides. Since you select 'balanced' profile and your video input may be 1080p, probably around 80fps. Since that slide applies to original VCE 1.0, probably VCE 2.0 of yours might be slower few fps due to additional quality settings such as SVC (temporal) + B-pictures + DEM improvements.

If you want speed rather than quality, go for VCE. Beggar can't be chooser.....eh wait, R9 290X?! This is no beggar! May I know your CPU model? If you use Intel, then you can use Quicksync(QSV) which is 3 times faster than VCE. Nightly version of handbrake support QSV.
Depending on your CPU, you may get higher encoding fps and quality in software x264 than VCE.

The second issue is probably caused by the driver. I don't have my old VCE system anymore, so can't no longer test it.



EDIT: you mentioned grainy video, do you set the amount of bitrate appropriately? I can't remember if there is constant quality mode.
mzarate
Posts: 6
Joined: Wed Jul 30, 2014 4:46 pm

Re: Cannot see OpenCL checkbox on output settings

Post by mzarate »

Hey ashleylai87, thanks for the tip with the intel QSV. I've managed to enable it with the "fake display" trick on windows and encoding speeds are insane (300-400fps avg) depending on settings. I have a Core i7 4770K Intel CPU.

The only issue i think i'm having with this codec is using the filters. I get the following from the encode log:

[07:52:26] 1 job(s) to process
[07:52:26] starting job
[07:52:26] do_job: QSV: full path, removing unsupported filter 'Framerate Shaper'
[07:52:26] do_job: QSV: full path, removing unsupported filter 'Denoise (hqdn3d)'

I'm assuming something is wrong there.
User avatar
Rodeo
HandBrake Team
Posts: 12679
Joined: Tue Mar 03, 2009 8:55 pm

Re: Cannot see OpenCL checkbox on output settings

Post by Rodeo »

It's not wrong, it's just telling you what it's doing and why.

If you want to use decomb or change the framerate with QSV, you've got to disable QSV-accelerated decoding in Tools > Options somewhere. There'll be a speed hit (though most of the speed decrease would come from actually running combing detection).

Adding support for decomb with QSV-accelerated decoding is on my TO-DO list for the next release, though again, decomb will be a bottleneck, even if we have QSV-ccelerated decoding on.
mzarate
Posts: 6
Joined: Wed Jul 30, 2014 4:46 pm

Re: Cannot see OpenCL checkbox on output settings

Post by mzarate »

Perfect! I went to tools / options / video and disabled QuickSync decoding and my filters are working now. I did not see much of an impact on encoding speed after that, i'm very happy with the QSV encoding results, i think i found the sweet spot for my 1080p xavc s hd raw files.

I appreciate everyone's help, hope this thread helps someone else =)
ashleylai87
Posts: 33
Joined: Tue Jul 30, 2013 3:54 am

Re: Cannot see OpenCL checkbox on output settings

Post by ashleylai87 »

mzarate wrote:Perfect! I went to tools / options / video and disabled QuickSync decoding and my filters are working now. I did not see much of an impact on encoding speed after that, i'm very happy with the QSV encoding results, i think i found the sweet spot for my 1080p xavc s hd raw files.

I appreciate everyone's help, hope this thread helps someone else =)
Well, disabling qsv decoding will increase CPU usage, not like it will have any impact on your system.

Hmm, why dont you choose normal x264 and select superfast or very fast preset. More or less same fps during encoding, but with better quality and smaller file size.
Post Reply