hi, Voyager Interlace

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
Registered55
Regular User
Posts: 121
Joined: Thu Apr 14, 2011 4:04 pm

hi, Voyager Interlace

Post by Registered55 »

the log does show that Handbrake is catching a lot of the frames, but on playback every now and then (particularly around the eyes and lips) interlacing can be seen but only in the formentioned areas.... in other words the frame is not interlaced, but there is interlacing in parts of the frame.


i'm trying to find a frame now to show..... it happens quite rare, but is detectable on close ups with faces (when it happens...it can't be missed) irritating

doing tests now on small clips (voyager)

NOTE... problem has not been seen on DS9 or TNG...emmmm

# CLI Query: -i "M:\VIDEO_TS" -t 2 -c 4 -o "H:\VIDEOFINISHED\Stax\EU_107310-2.mkv" -f mkv --detelecine --decomb -w 720 --loose-anamorphic -e x264 -q 23 -a 1 -E faac -6 dpl2 -R Auto -B 80 -D 1 -x b-adapt=2:rc-lookahead=50:direct=auto:me=umh:merange=32 --verbose=1
# User Query: False


[23:37:23] yadif thread started for segment 0
[23:37:23] yadif thread started for segment 1
[23:37:23] yadif thread started for segment 2
[23:37:23] yadif thread started for segment 3
[23:37:23] decomb thread started for segment 0
[23:37:23] decomb thread started for segment 1
[23:37:23] decomb thread started for segment 2
[23:37:23] decomb thread started for segment 3
[23:37:23] encx264: encoding with stored aspect 208384/193725
[23:37:23] encx264: Encoding at constant RF 23.000000
x264 [info]: using SAR=52096/48431
x264 [info]: using cpu capabilities: MMX2 SSE2Fast FastShuffle SSEMisalign LZCNT
[23:37:23] reader: first SCR 86140946 id 224 DTS 86163054
[23:37:23] mpeg2: "" (4) at frame 0 time 3600
x264 [info]: profile High, level 3.1
No accelerated IMDCT transform found
[23:37:24] output track 0: ac3 in sync after skipping 672 bytes
[23:37:24] sync: first pts is 2880
[23:41:27] reader: end of chapter 4 (media 4) reached at media chapter 5
[23:41:27] reader: done. 1 scr changes
[23:41:29] work: average encoding speed for job is 39.195679 fps
[23:41:29] sync: got 9569 frames, 9586 expected
[23:41:29] mpeg2 done: 9569 frames
[23:41:29] render: lost time: 61200 (17 frames)
[23:41:29] render: gained time: 61200 (59 frames) (0 not accounted for)
[23:41:29] render: average dropped frame duration: 3600
x264 [info]: frame I:72 Avg QP:19.58 size: 20176 PSNR Mean Y:46.88 U:48.68 V:49.56 Avg:47.49 Global:47.34
x264 [info]: frame P:2662 Avg QP:22.36 size: 5727 PSNR Mean Y:45.05 U:47.66 V:48.61 Avg:45.82 Global:45.57
x264 [info]: frame B:6817 Avg QP:24.71 size: 1535 PSNR Mean Y:44.55 U:47.02 V:48.21 Avg:45.32 Global:45.02
x264 [info]: consecutive B-frames: 1.1% 3.0% 18.2% 77.8%
x264 [info]: mb I I16..4: 17.2% 70.5% 12.3%
x264 [info]: mb P I16..4: 2.3% 5.5% 0.7% P16..4: 40.5% 10.0% 7.3% 0.0% 0.0% skip:33.7%
x264 [info]: mb B I16..4: 0.1% 0.3% 0.0% B16..8: 39.1% 2.0% 0.3% direct: 1.0% skip:57.2% L0:40.8% L1:56.9% BI: 2.3%
x264 [info]: 8x8 transform intra:65.4% inter:86.5%
x264 [info]: direct mvs spatial:100.0% temporal:0.0%
x264 [info]: coded y,uvDC,uvAC intra: 51.3% 63.9% 27.7% inter: 8.7% 13.5% 0.7%
x264 [info]: i16 v,h,dc,p: 40% 21% 5% 34%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 22% 15% 22% 6% 7% 8% 7% 7% 7%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 28% 19% 18% 5% 7% 7% 6% 5% 4%
x264 [info]: i8c dc,h,v,p: 55% 17% 22% 7%
x264 [info]: Weighted P-Frames: Y:9.7% UV:5.8%
x264 [info]: ref P L0: 60.3% 12.7% 19.6% 6.8% 0.6%
x264 [info]: ref B L0: 88.8% 9.1% 2.1%
x264 [info]: ref B L1: 95.4% 4.6%
x264 [info]: SSIM Mean Y:0.9813864 (17.302db)
x264 [info]: PSNR Mean Y:44.710 U:47.214 V:48.331 Avg:45.476 Global:45.182 kb/s:567.69
[23:41:29] mux: track 0, 9551 frames, 27157396 bytes, 567.61 kbps, fifo 8
[23:41:29] mux: track 1, 17936 frames, 3824859 bytes, 79.94 kbps, fifo 256
[23:41:29] decomb: deinterlaced 13 | blended 3 | unfiltered 9535 | total 9551
[23:41:29] libhb: work result = 0
Rip done!
HandBrake has exited.



EDIT

http://imageshare.web.id/images/xur4c9t ... 3bkc1i.jpg

look at the nose, lips and eyes....and the right badge. (all mentioned parts are in a state of motion)

definitely interlacing.... please help...my DVD boxset version is on hold now i have seen this.

can i use custom settings in the decomb filter....or more to the point...how could i adjust the decomb to help with this.
Registered55
Regular User
Posts: 121
Joined: Thu Apr 14, 2011 4:04 pm

Re: hi, Voyager Interlace

Post by Registered55 »

ok, i'm planning to mess around with decomb settings.... because of the small area the interlace is (lips, eyes and mouth...and small other objects), perhaps that's why decomb is missing it,

i checked this page

https://trac.handbrake.fr/wiki/Decomb

handbrake defaults are

1 : 2 : 6 : 9 : 80 : 16 : 16

however

https://trac.handbrake.fr/browser/trunk/libhb/decomb.c

Defaults:
7:2:6:9:80:16:16: (10:20:20:4:2:50:24:1:-1)


i need accurate defaults (baseline) if i am to try and tweak the decomb to catch the interlacing in the frames a little better,

can someone verify that 1 : 2 : 6 : 9 : 80 : 16 : 16 are in fact the defaults currently in use by 0.9.5.

thanks.
User avatar
Rodeo
HandBrake Team
Posts: 12746
Joined: Tue Mar 03, 2009 8:55 pm

Re: hi, Voyager Interlace

Post by Rodeo »

Registered55
Regular User
Posts: 121
Joined: Thu Apr 14, 2011 4:04 pm

Re: hi, Voyager Interlace

Post by Registered55 »

excellent, thankyou, any advise where to begin,

i'm thinking starting with Spatial Threshold: numbers. warm, hot...COLD LOL
Registered55
Regular User
Posts: 121
Joined: Thu Apr 14, 2011 4:04 pm

Re: hi, Voyager Interlace

Post by Registered55 »

in the coustome field in decomb, i put in,

1 : 2 : 6 : 9 : 80 : 16 : 16

decomb: deinterlaced 1868 | blended 0 | unfiltered 5406 | total 7274

then i tried (wanted to make sure i really did have the ability to influence the decomb)

1 : 1 : 6 : 20 : 15 : 4 : 8

it gave me this !

decomb: deinterlaced 1868 | blended 0 | unfiltered 5406 | total 7274

question,

am i doing it right, if i change the numbers does that have direct influence over the decomb, and wouldn't the results be different?
Registered55
Regular User
Posts: 121
Joined: Thu Apr 14, 2011 4:04 pm

Re: hi, Voyager Interlace

Post by Registered55 »

out of curiosity, i turned off decomb, and turned on De-interlace (SLOWER)

the results are astounding, the image is far superior, and no interlacing of any kind,

time is against me, and the fact that

1 : 2 : 6 : 9 : 80 : 16 : 16
made no difference to the decomb compared too
1 : 1 : 6 : 20 : 15 : 4 : 8

makes me think that i'm not suited to the task, Decomb maybe more intelligent in deciding what type of and when to de-interlace, but like humans is fallible, and makes mistakes.

only i couldn't find any tests around on google to determine how often and is there a pattern to when it makes those mistakes.

but the fact that it can make mistakes (in its current form) is by itself worrying for us PAL users.

i am new to this, and i don't pretend to understand the mechanics of this stuff, all i can do is comment on results.

i really would like to get feed back, and even someone to tell me your doing it wrong do this "-", because i am aware of how destructive de-interlacers can be (seen Staxrip many times destroy certain projects "Harry Potter" films for example).

nothing would please me more than getting decomb working (but making the correct decisions).

EDIT

1 : 2 : 6 : 9 : 80 : 32 : 32
decomb: deinterlaced 1868 | blended 0 | unfiltered 5406 | total 7274

again no change.
Registered55
Regular User
Posts: 121
Joined: Thu Apr 14, 2011 4:04 pm

Re: hi, Voyager Interlace

Post by Registered55 »

getting there, i think the spaces in between the colons were screwing things up,

1:2:6:7:40:16:16

decomb: deinterlaced 2273 | blended 0 | unfiltered 5001 | total 7274 (eyes and lips good, that right badge better but still some interlacing going on)

1:2:6:7:40:24:24

decomb: deinterlaced 2319 | blended 0 | unfiltered 4955 | total 7274 (as above, badge a lot better, only about seven frames had interlacing and there were very fine)

1:2:6:7:40:8:8 (far less, not good)

i'm not going to put any more numbers up, need to look into this and do a lot of tests, i only put this here to show new comers like myself who may want to tweak there decomb too, and perhaps hope that experts here will .... maybe have a look at things....LOL.
Registered55
Regular User
Posts: 121
Joined: Thu Apr 14, 2011 4:04 pm

Re: hi, Voyager Interlace

Post by Registered55 »

i thought it would take days,

did it for voyager anyway, i'm sure these numbers could cause problems for other material.

again i don't understand the intricacies behind the meaning of these numbers, but the results are promising.

1:2:6:7:40:20:20 (80 still had 3 frames in badge, 40 has no interlaced frame anywhere i can see in the 5 minute clip)

decomb: deinterlaced 2321 | blended 0 | unfiltered 4953 | total 7274


i'm going to settle for these, again i just don't have the time for all this messing about LOL.

i would be the 1st to admit these numbers are very rough, and should be taken as such.

time for bed.
Registered55
Regular User
Posts: 121
Joined: Thu Apr 14, 2011 4:04 pm

Re: hi, Voyager Interlace

Post by Registered55 »

one last refinement, in an attempt to bring my numbers back in line with default (this is good for many reasons)
I decided to play around and do some tests, I wasn't happy how the numbers i had chosen were so different to the defaults and started thinking could I achieve the same output results but with decomb settings matching the defaults.

with the exception that I can't get the blended frames back, (I'm thinking that maybe the blended frames are responsible for the interlacing frames sneaking through) I have managed to get the numbers closer to the defaults.

this is a different clip to what was used in previous posts.


deinterlaced 2248 | blended 641 | unfiltered 6183 | total 9072 Default Decomb


deinterlaced 3032 | blended 0 | unfiltered 6040 | total 9072 1:2:6:9:80:24:24

again i don't know what this all means, but i do believe that the blended frames are in fact responsible in part at least for the interlace frames sneaking through when using default decomb setting in Handbrake. One can't help seeing how close the numbers are above when adding the blended frames to the deinterlaced frame count.

i will be using 1:2:6:9:80:24:24 for many TV shows (especially Sci-fi stuff) and see how these numbers hold up, but they should be fine when seeing how close they are to the defaults.

NOTE i forgot to mention that i went back to some DS9 episodes and started to look for interlacing, now i know what i'm looking for i did in fact see some but very few interlace frames that sneaked into some encodes (my eyes seems to be learning what to look for now....lol) again blended frames, 1:2:6:9:80:24:24 has resolved the issue, and yes the blended frames were replaced with deinterlacing (the numbers were again very close)

it must have something todo with how Startrek was processed for DVD PAL conversion.

could anyone explain what is happening/difference between ....16:16 to ....24:24 i would love to know.
User avatar
Rodeo
HandBrake Team
Posts: 12746
Joined: Tue Mar 03, 2009 8:55 pm

Re: hi, Voyager Interlace

Post by Rodeo »

Registered55 wrote:with the exception that I can't get the blended frames back
That would perhaps be because you disabled blending?
Registered55 wrote:could anyone explain what is happening/difference between ....16:16 to ....24:24 i would love to know.
https://trac.handbrake.fr/wiki/Decomb#options

The block threshold is the same (80 combed pixels) but you changed the block size (24x24 pixels instead of 16x16 pixels). The threshold is reached more often because the blocks are larger.
Registered55
Regular User
Posts: 121
Joined: Thu Apr 14, 2011 4:04 pm

Re: hi, Voyager Interlace

Post by Registered55 »

not sure what actually turns off blended frames,

Decomb set to Default 641 Blended frames,

1-2-6-7-40-16-16
1-2-6-9-40-16-16
1-2-6-9-60-16-16
1-2-6-9-70-16-16
1-2-6-9-20-16-16
1-2-6-9-80-24-24
1-2-6-7-80-24-24

all of the above had no Blended frames (except for Default),

in fact every combination i have tried in the Decomb Custom always has 0 blended?

thanks for the info about block size, does make sense to me, thanks for no going all technical on me. (i have read the guide many times, but the info has trouble being filed correctly in my mind)

time is against me unfortunately, I would of love to experiment even more on this (with a broader range of material...i found myself actually enjoying fiddling around with Decomb)
User avatar
Rodeo
HandBrake Team
Posts: 12746
Joined: Tue Mar 03, 2009 8:55 pm

Re: hi, Voyager Interlace

Post by Rodeo »

Registered55 wrote:not sure what actually turns off blended frames,

Decomb set to Default 641 Blended frames,

1-2-6-7-40-16-16
1-2-6-9-40-16-16
1-2-6-9-60-16-16
1-2-6-9-70-16-16
1-2-6-9-20-16-16
1-2-6-9-80-24-24
1-2-6-7-80-24-24

all of the above had no Blended frames (except for Default),

in fact every combination i have tried in the Decomb Custom always has 0 blended?
You have all the information, you just didn't bother to read it.
Registered55 wrote:can someone verify that 1 : 2 : 6 : 9 : 80 : 16 : 16 are in fact the defaults currently in use by 0.9.5.
Again, https://trac.handbrake.fr/browser/tags/ ... b/decomb.c
Registered55
Regular User
Posts: 121
Joined: Thu Apr 14, 2011 4:04 pm

Re: hi, Voyager Interlace

Post by Registered55 »

"You have all the information, you just didn't bother to read it."

i find that remark extremely rude and insulting, reading and understanding...there is a difference.

there are many things i read, and know, but just because i can read and ergo know, doesn't mean i can understand or conceptualise what i have read or seen.

anyway, i have found your remark...quite hurtful... so forget it, i'm done
User avatar
Rodeo
HandBrake Team
Posts: 12746
Joined: Tue Mar 03, 2009 8:55 pm

Re: hi, Voyager Interlace

Post by Rodeo »

Rodeo wrote:
Registered55 wrote:can someone verify that 1 : 2 : 6 : 9 : 80 : 16 : 16 are in fact the defaults currently in use by 0.9.5.
Again, https://trac.handbrake.fr/browser/tags/ ... b/decomb.c
Since you brought up this topic in another thread, let me be more specific.

In your first post, you noted a contradiction between the Wiki and the HandBrake source code:
Registered55 wrote:ok, i'm planning to mess around with decomb settings.... because of the small area the interlace is (lips, eyes and mouth...and small other objects), perhaps that's why decomb is missing it,

i checked this page

https://trac.handbrake.fr/wiki/Decomb

handbrake defaults are

1 : 2 : 6 : 9 : 80 : 16 : 16

however

https://trac.handbrake.fr/browser/trunk/libhb/decomb.c

Defaults:
7:2:6:9:80:16:16: (10:20:20:4:2:50:24:1:-1)


i need accurate defaults (baseline) if i am to try and tweak the decomb to catch the interlacing in the frames a little better,

can someone verify that 1 : 2 : 6 : 9 : 80 : 16 : 16 are in fact the defaults currently in use by 0.9.5.

thanks.
I then directed you to the page that was applicable to 0.9.5, since you specifically asked about that version:
Had you bothered to read it (which you did for the version in trunk, as per your second post in this very topic), or at the very least the second segment (lines 12-26, which list the parameters), you would have noticed lines 24 and 25:

Code: Select all

Defaults:
    7:2:6:9:80:16:16:10:20:20:4:2:50:24:1:-1
None of the parameters are explained on those two lines, but you don't really need that to determine that the defaults are not 1 : 2 : 6 : 9 : 80 : 16 : 16, do you?

The fact that you were using mode 1 rather than the then-default of 7, actually explains your other issue (blend disabled), as explained on lines 36-46 of the file I had linked you to:

Code: Select all

These modes can be layered. For example, Yadif (1) + EEDI2 (8) = 9,
which will feed EEDI2 interpolations to yadif.

** Working combos:
 1: Just yadif
 2: Just blend
 3: Switch between yadif and blend
 4: Just cubic interpolate
 5: Cubic->yadif
 6: Switch between cubic and blend
 7: Switch between cubic->yadif and blend
P.S. I'm really sorry to learn about your reading disability - and yes, that's rude.
Post Reply