Playing m4v with "Soft Subtitles" in iTunes

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
casperse
Posts: 26
Joined: Sat Apr 09, 2011 2:12 pm

Playing m4v with "Soft Subtitles" in iTunes

Post by casperse »

Hi All

I was going crazy trying to get soft subtitles working with m4v and also getting the correct "Char Code" getting Æ,Ø,Å showing up...(Solved by opening the srt file in textpad and saving it in UTF-8 --- :wink: stupid users!)
But no matter what I did it never worked when playing (Only used iTunes) until I tried using Quicktime then it worked! - also using VLC player then it worked!

iTunes gives me the possibility to select the subtitles but it always stays in "OFF" never showing the subtitles?
My iTunes version is the latest version (Windows)....

Also if I use iSubtitles (Mac OS on VMware in Windows?) can I then change things like font and size? or is that fixed in the Apple players?

Thanks for your help!
User avatar
Rodeo
HandBrake Team
Posts: 12572
Joined: Tue Mar 03, 2009 8:55 pm

Re: Playing m4v with "Soft Subtitles" in iTunes

Post by Rodeo »

This is weird - if it works in QuickTime, it should work in iTunes. In any case, it sounds like an iTunes bug.
casperse
Posts: 26
Joined: Sat Apr 09, 2011 2:12 pm

Re: Playing m4v with "Soft Subtitles" in iTunes

Post by casperse »

So the most important thing this should work on the iPad if Quicktime can show the subtitles correct? (-;
User avatar
Rodeo
HandBrake Team
Posts: 12572
Joined: Tue Mar 03, 2009 8:55 pm

Re: Playing m4v with "Soft Subtitles" in iTunes

Post by Rodeo »

casperse wrote:So the most important thing this should work on the iPad if Quicktime can show the subtitles correct? (-;
Maybe. Only way to know is to try.
FaiT
Posts: 47
Joined: Wed Mar 23, 2011 9:54 pm

Re: Playing m4v with "Soft Subtitles" in iTunes

Post by FaiT »

Yeah, occasionally I have the same problem. I have an ipod touch 4th gen which plays subs fine, every media player (vlc, mpc, potplayer, mplayer, etc...) plays the subs but not itunes. It's wierd and obviously an itunes bug but I don't care as long as it synchs to my ipod.
Post Reply