No AC3 5.1 on some blu rays?

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
awtlaw
Posts: 4
Joined: Wed Sep 15, 2010 5:47 pm

No AC3 5.1 on some blu rays?

Post by awtlaw »

I use handbrake to encode blu ray movies. When I encode the blu rays I always use high profile for the preset and I change the container to MKV and check large file size. Using the high profile preset there should be AC3 5.1 surround sound in the videos, but i am finding that some of my finished files only have stereo sound. Is this because the particular blu ray doesn't have ac3 sound originally or am I doing something wrong? If it is because the blu ray doesn't have ac3 on it is there anyway I can change the settings to get 5.1 for those blu rays. Here is a list of the blu rays that i have this problem with getting the ac3 passthru:
Fast & Furious
Forest Gump
Lord Of The Rings - All 3
Marley & Me
Mr & Mrs Smith
Notorious
The Blind Side
The Book OF Eli
The Bourne Identity - All 3
The Karate Kid
Walk The Line
X-Men The Last Stand
Cop Out


Code: Select all

### CLI Query:  -i "M:\Pictures\Family\Ayden Samuel\Videos\08-14-10 - Surprised Face.MP4" -t 1 -c 1 -o "C:\Users\dolla\Desktop\08-14-10 - Surprised Face.m4v" -f mp4 -X 848 -l 480 -e x264 -b 800 -a 1 -E faac -6 dpl2 -R 48 -B 160 -D 0.0 --markers="C:\Users\dolla\AppData\Local\Temp\08-14-10 - Surprised Face-1-chapters.csv" -x level=30:bframes=0:cabac=0:ref=1:vbv-maxrate=768:vbv-bufsize=2000:analyse=all:me=umh:no-fast-pskip=1:subq=6:8x8dct=0:trellis=0:weightb=0:mixed-refs=1 -v 1

### User Query: False

#########################################

[17:00:50] hb_init: checking cpu count
[17:00:50] hb_init: starting libhb thread
HandBrake 0.9.4 (2009112300) - MinGW i386 - http://handbrake.fr
4 CPUs detected
Opening M:\Pictures\Family\Ayden Samuel\Videos\08-14-10 - Surprised Face.MP4...
[17:00:50] hb_scan: path=M:\Pictures\Family\Ayden Samuel\Videos\08-14-10 - Surprised Face.MP4, title_index=1
[17:00:50] scan: trying to open with libdvdread
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[17:00:50] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'M:\Pictures\Family\Ayden Samuel\Videos\08-14-10 - Surprised Face.MP4':
  Duration: 00:02:11.08, start: 0.-100133, bitrate: 8694 kb/s
    Stream #0.0(jpn): Video: h264, yuv420p, 1280x720, 30 tbr, 7500 tbn, 15k tbc
    Stream #0.1(jpn): Audio: aac, 44100 Hz, stereo, s16
[17:00:50] scan: decoding previews for title 1
Scanning title 1...
[17:00:50] scan: 10 previews, 1280x720, 30.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[17:00:50] scan: title (0) job->width:1280, job->height:720
[17:00:51] libhb: scan thread found 1 valid title(s)
+ title 1:
  + vts 0, ttn 0, cells 0->0 (0 blocks)
  + angle(s) 0
  + duration: 00:02:11
  + size: 1280x720, pixel aspect: 1/1, display aspect: 1.78, 30.000 fps
  + autocrop: 0/0/0/0
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 00:02:11
  + audio tracks:
    + 1, Japanese (AAC) (iso639-2: jpn)
  + subtitle tracks:
Reading chapter markers from file C:\Users\dolla\AppData\Local\Temp\08-14-10 - Surprised Face-1-chapters.csv
[17:00:51] 1 job(s) to process
[17:00:51] starting job
[17:00:51] work: sanitizing track 0 mixdown Dolby Pro Logic II to Stereo
[17:00:51] job configuration:
[17:00:51]  * source
[17:00:51]    + M:\Pictures\Family\Ayden Samuel\Videos\08-14-10 - Surprised Face.MP4
[17:00:51]    + title 1, chapter(s) 1 to 1
[17:00:51]    + container: mov,mp4,m4a,3gp,3g2,mj2
[17:00:51]    + data rate: 8694 kbps
[17:00:51]  * destination
[17:00:51]    + C:\Users\dolla\Desktop\08-14-10 - Surprised Face.m4v
[17:00:51]    + container: MPEG-4 (.mp4 and .m4v)
[17:00:51]      + chapter markers
[17:00:51]  * video track
[17:00:51]    + decoder: h264
[17:00:51]    + frame rate: same as source (around 30.000 fps)
[17:00:51]    + dimensions: 1280 * 720 -> 848 * 480, crop 0/0/0/0
[17:00:51]    + encoder: x264
[17:00:51]      + options: level=30:bframes=0:cabac=0:ref=1:vbv-maxrate=768:vbv-bufsize=2000:analyse=all:me=umh:no-fast-pskip=1:subq=6:8x8dct=0:trellis=0:weightb=0:mixed-refs=1
[17:00:51]      + bitrate: 800 kbps, pass: 0
[17:00:51]  * audio track 0
[17:00:51]    + decoder: Japanese (AAC) (track 1, id 1)
[17:00:51]    + mixdown: Stereo
[17:00:51]    + encoder: faac
[17:00:51]      + bitrate: 160 kbps, samplerate: 48000 Hz
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[17:00:51] dvd: not a dvd - trying as a stream/file instead
[17:00:51] encx264: keyint-min: 30, keyint-max: 300
x264 [warning]: MB rate (47700) > level limit (40500)
x264 [info]: using cpu capabilities: MMX2 SSE2Fast FastShuffle SSEMisalign LZCNT
[17:00:51] reader: first SCR 0 id 0 DTS -12012
x264 [warning]: max bitrate less than average bitrate, ignored.
x264 [info]: profile Baseline, level 3.0
[17:00:51] sync: expecting 3962 video frames
[17:00:53] sync: first pts is 899
[17:02:06] reader: done. 1 scr changes
[17:02:11] sync: got 3929 frames, 3962 expected
[17:02:11] work: average encoding speed for job is 49.881718 fps
[17:02:13] mux: track 0, 3929 frames, 12999388 bytes, 794.26 kbps, fifo 64
[17:02:13] mux: track 1, 6138 frames, 2617594 bytes, 159.93 kbps, fifo 1024
[17:02:13] h264-decoder done: 3930 frames, 0 decoder errors, 0 drops
[17:02:13] render: lost time: 0 (0 frames)
[17:02:13] render: gained time: 0 (0 frames) (0 not accounted for)
x264 [info]: frame I:30    Avg QP:25.44  size: 10451  PSNR Mean Y:44.74 U:47.36 V:47.87 Avg:45.49 Global:45.27
x264 [info]: frame P:3899  Avg QP:28.29  size:  3254  PSNR Mean Y:41.31 U:43.40 V:44.73 Avg:42.04 Global:41.93
x264 [info]: mb I  I16..4: 63.5%  0.0% 36.5%
x264 [info]: mb P  I16..4:  3.0%  0.0%  0.6%  P16..4: 61.0%  7.9%  1.3%  0.0%  0.0%    skip:26.1%
x264 [info]: final ratefactor: 26.25
x264 [info]: coded y,uvDC,uvAC intra: 15.0% 48.3% 8.6% inter: 3.2% 29.9% 0.1%
x264 [info]: i16 v,h,dc,p: 23% 21% 13% 42%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 18% 16% 32%  6%  8%  7%  7%  4%  2%
x264 [info]: SSIM Mean Y:0.9629397
x264 [info]: PSNR Mean Y:41.337 U:43.429 V:44.758 Avg:42.062 Global:41.947 kb/s:794.12
[17:02:13] aac-decoder done: 0 frames, 0 decoder errors, 0 drops
[17:02:13] libhb: work result = 0

Rip done!
HandBrake has exited.

User avatar
JohnAStebbins
HandBrake Team
Posts: 5583
Joined: Sat Feb 09, 2008 7:21 pm

Re: No AC3 5.1 on some blu rays?

Post by JohnAStebbins »

Well, apparently these blurays were previously encoded with something else since your input file is an mp4.
Your input doesn't have ac3 audio. So there will be no ac3 in the output. ac3 output is passthru only, so it requires that the input have an ac3 track. Hell, your input doesn't even have 5.1 audio at all. You can't make something from nothing.
awtlaw
Posts: 4
Joined: Wed Sep 15, 2010 5:47 pm

Re: No AC3 5.1 on some blu rays?

Post by awtlaw »

My bad I posted the wrong code. Here is the log from Fast & Furious.

Code: Select all

### CLI Query:  -i "C:\Users\dolla\Desktop\Output\Blu Ray\MainMovie\FAST_AND_FURIOUS\BDMV\STREAM\00010.m2ts" -t 1 -c 1 -o "C:\Users\dolla\Desktop\Fast And Furious.mkv"  -f mkv -4  -w 1920 --loose-anamorphic  --detelecine --decomb -e x264 -q 20 -a 1,1 -E faac,ac3 -6 dpl2,auto -R 48,Auto -B 160,auto -D 0.0,0.0 --markers="C:\Users\dolla\AppData\Local\Temp\Fast And Furious-1-chapters.csv" -x b-adapt=2:rc-lookahead=50 -v 1
### User Query: False
#########################################
[11:17:04] hb_init: checking cpu count
[11:17:04] hb_init: starting libhb thread
HandBrake svn3293 (2010051301) - MinGW i386 - http://handbrake.fr
4 CPUs detected
Opening C:\Users\dolla\Desktop\Output\Blu Ray\MainMovie\FAST_AND_FURIOUS\BDMV\STREAM\00010.m2ts...
[11:17:04] hb_scan: path=C:\Users\dolla\Desktop\Output\Blu Ray\MainMovie\FAST_AND_FURIOUS\BDMV\STREAM\00010.m2ts, title_index=1
[11:17:04] scan: trying to open with libdvdread
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[11:17:04] dvd: not a dvd - trying as a stream/file instead
[11:17:04] file is MPEG Transport Stream with 192 byte packets offset 4 bytes
[11:17:04] hb_ts_stream_find_pids - found the following PIDS
[11:17:04]     Video PIDS : 
[11:17:04]       0x1011 type VC1 (0xea)
[11:17:04]     Audio PIDS : 
[11:17:04]       0x1100 type DTS-HD (0x86)
[11:17:04]       0x1101 type HDMV DTS (0x82)
[11:17:04]       0x1102 type HDMV DTS (0x82)
[11:17:04]       0x1103 type AC-3 (0x81)
[11:17:04]       0x1200 type Unknown (0x90)
[11:17:04]       0x1201 type Unknown (0x90)
[11:17:04]       0x1202 type Unknown (0x90)
[11:17:04]       0x1203 type Unknown (0x90)
[11:17:04]       0x1204 type Unknown (0x90)
[11:17:04] transport stream pid 0x1100 (type 0x82) may be HDMV DTS audio (id 0x1)
[11:17:04] transport stream pid 0x1101 (type 0x82) may be HDMV DTS audio (id 0x2)
[11:17:04] transport stream pid 0x1102 (type 0x82) may be HDMV DTS audio (id 0x3)
[11:17:04] transport stream pid 0x1103 (type 0x81) may be AC-3 audio (id 0x4)
[11:17:04] transport stream pid 0x1200 (type 0x90) isn't audio
[11:17:04] transport stream pid 0x1201 (type 0x90) isn't audio
[11:17:04] transport stream pid 0x1202 (type 0x90) isn't audio
[11:17:04] transport stream pid 0x1203 (type 0x90) isn't audio
[11:17:05] transport stream pid 0x1204 (type 0x90) isn't audio
[11:17:05] scan: decoding previews for title 1
[11:17:05] scan: audio 0x2: DCA, rate=48000Hz, bitrate=768000 Unknown (DTS) (5.1 ch)
[11:17:05] scan: audio 0x3: DCA, rate=48000Hz, bitrate=768000 Unknown (DTS) (5.1 ch)
[11:17:05] scan: audio 0x4: AC-3, rate=48000Hz, bitrate=192000 Unknown (AC3) (Dolby Surround)
[11:17:05] scan: audio 0x1: DCA, rate=48000Hz, bitrate=1536000 Unknown (DTS) (5.1 ch)
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
[11:17:06] scan: 10 previews, 1920x1080, 23.976 fps, autocrop = 140/140/0/0, aspect 16:9, PAR 1:1
[11:17:06] scan: title (0) job->width:1920, job->height:800
[11:17:06] stream: 5 good frames, 0 errors (0%)
[11:17:06] libhb: scan thread found 1 valid title(s)
+ title 1:
  + stream: C:\Users\dolla\Desktop\Output\Blu Ray\MainMovie\FAST_AND_FURIOUS\BDMV\STREAM\00010.m2ts
  + angle(s) 0
  + duration: 01:46:32
  + size: 1920x1080, pixel aspect: 1/1, display aspect: 1.78, 23.976 fps
  + autocrop: 140/140/0/0
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 01:46:32
  + audio tracks:
    + 1, Unknown (DTS) (5.1 ch) (iso639-2: und), 48000Hz, 1536000bps
    + 2, Unknown (DTS) (5.1 ch) (iso639-2: und), 48000Hz, 768000bps
    + 3, Unknown (DTS) (5.1 ch) (iso639-2: und), 48000Hz, 768000bps
    + 4, Unknown (AC3) (Dolby Surround) (iso639-2: und), 48000Hz, 192000bps
  + subtitle tracks:
Reading chapter markers from file C:\Users\dolla\AppData\Local\Temp\Fast And Furious-1-chapters.csv
Invalid sample rate 0, using input rate 48000
[11:17:06] 1 job(s) to process
[11:17:06] starting job
[11:17:06] Passthru requested and input codec is not the same as output codec for track 2
[11:17:06] sync: expecting 153282 video frames
[11:17:06] work: only 1 chapter, disabling chapter markers
[11:17:06] job configuration:
[11:17:06]  * source
[11:17:06]    + C:\Users\dolla\Desktop\Output\Blu Ray\MainMovie\FAST_AND_FURIOUS\BDMV\STREAM\00010.m2ts
[11:17:06]    + title 1, chapter(s) 1 to 1
[11:17:06]  * destination
[11:17:06]    + C:\Users\dolla\Desktop\Fast And Furious.mkv
[11:17:06]    + container: Matroska (.mkv)
[11:17:06]  * video track
[11:17:06]    + decoder: vc1
[11:17:06]      + bitrate 200 kbps
[11:17:06]    + frame rate: same as source (around 23.976 fps)
[11:17:06]    + loose anamorphic
[11:17:06]      + storage dimensions: 1920 * 1080 -> 1920 * 800, crop 140/140/0/0, mod 0
[11:17:06]      + pixel aspect ratio: 1 / 1
[11:17:06]      + display dimensions: 1920 * 800
[11:17:06]    + filters
[11:17:06]      + Detelecine (pullup) (default settings)
[11:17:06]      + Decomb (default settings)
[11:17:06]    + encoder: x264
[11:17:06]      + options: b-adapt=2:rc-lookahead=50
[11:17:06]      + quality: 20.00 (RF)
[11:17:06]  * audio track 0
[11:17:06]    + decoder: Unknown (DTS) (5.1 ch) (track 1, id 1)
[11:17:06]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[11:17:06]    + mixdown: Dolby Pro Logic II
[11:17:06]    + encoder: faac
[11:17:06]      + bitrate: 160 kbps, samplerate: 48000 Hz
[11:17:06] reader: first SCR 963814 id 0 DTS 1044806
[11:17:06] yadif thread started for segment 0
[11:17:06] yadif thread started for segment 1
[11:17:06] yadif thread started for segment 2
[11:17:06] yadif thread started for segment 3
[11:17:06] decomb thread started for segment 0
[11:17:06] decomb thread started for segment 1
[11:17:06] decomb thread started for segment 2
[11:17:06] decomb thread started for segment 3
[11:17:06] encx264: min-keyint: 24, keyint: 240
[11:17:06] encx264: encoding with stored aspect 1/1
[11:17:06] encx264: Encoding at constant RF 20.000000
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.1 Cache64
x264 [info]: profile High, level 4.0
Stream with high frequencies VQ coding
[16:10:33] hb_ts_stream_decode - eof
[16:10:33] stream: 153744 good frames, 0 errors (0%)
[16:10:33] reader: done. 1 scr changes
[16:10:40] work: average encoding speed for job is 8.730051 fps
[16:10:40] sync: got 153744 frames, 153282 expected
[16:10:40] vc1-decoder done: 153744 frames, 1 decoder errors, 0 drops
[16:10:40] render: lost time: 7507 (2 frames)
[16:10:40] render: gained time: 7507 (8 frames) (0 not accounted for)
[16:10:40] render: average dropped frame duration: 3753
x264 [info]: frame I:2075  Avg QP:17.48  size:127791  PSNR Mean Y:46.83 U:48.26 V:49.31 Avg:47.36 Global:46.93
x264 [info]: frame P:56074 Avg QP:20.29  size: 41570  PSNR Mean Y:45.06 U:46.17 V:47.71 Avg:45.52 Global:44.88
x264 [info]: frame B:95592 Avg QP:21.47  size: 19559  PSNR Mean Y:44.00 U:45.34 V:47.23 Avg:44.56 Global:43.95
x264 [info]: consecutive B-frames:  4.2% 20.6% 44.0% 31.2%
x264 [info]: mb I  I16..4: 13.9% 70.1% 16.0%
x264 [info]: mb P  I16..4:  5.1% 12.9%  1.4%  P16..4: 41.5% 13.7%  8.9%  0.0%  0.0%    skip:16.4%
x264 [info]: mb B  I16..4:  0.6%  2.2%  0.2%  B16..8: 46.3%  4.5%  0.8%  direct: 5.3%  skip:40.2%  L0:44.2% L1:51.9% BI: 4.0%
x264 [info]: 8x8 transform intra:68.2% inter:73.1%
x264 [info]: coded y,uvDC,uvAC intra: 64.0% 72.8% 43.4% inter: 26.1% 31.3% 6.7%
x264 [info]: i16 v,h,dc,p: 43% 17%  8% 32%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 14% 16% 30%  6%  7%  7%  7%  6%  7%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 19% 21% 20%  6%  8%  7%  8%  5%  5%
x264 [info]: i8c dc,h,v,p: 57% 18% 17%  8%
x264 [info]: Weighted P-Frames: Y:1.5%
x264 [info]: ref P L0: 63.0% 11.2% 17.4%  8.3%  0.1%
x264 [info]: ref B L0: 81.5% 18.5%
x264 [info]: SSIM Mean Y:0.9722637
x264 [info]: PSNR Mean Y:44.425 U:45.680 V:47.432 Avg:44.947 Global:44.299 kb/s:5571.52
[16:10:40] mux: track 0, 153741 frames, 4465745279 bytes, 5571.35 kbps, fifo 16
[16:10:40] mux: track 1, 300583 frames, 128078587 bytes, 159.79 kbps, fifo 256
[16:10:40] decomb: deinterlaced 108 | blended 675 | unfiltered 152958 | total 153741
[16:10:40] libhb: work result = 0

Rip done!
HandBrake has exited.
User avatar
JohnAStebbins
HandBrake Team
Posts: 5583
Joined: Sat Feb 09, 2008 7:21 pm

Re: No AC3 5.1 on some blu rays?

Post by JohnAStebbins »

Code: Select all

  + audio tracks:
    + 1, Unknown (DTS) (5.1 ch) (iso639-2: und), 48000Hz, 1536000bps
    + 2, Unknown (DTS) (5.1 ch) (iso639-2: und), 48000Hz, 768000bps
    + 3, Unknown (DTS) (5.1 ch) (iso639-2: und), 48000Hz, 768000bps
    + 4, Unknown (AC3) (Dolby Surround) (iso639-2: und), 48000Hz, 192000bps
Your source has an ac3 track, but it's not the track you selected for output and it's not 5.1 anyway. So for movies like this, you will not get the ac3 track.
nightstrm
Veteran User
Posts: 1887
Joined: Fri Mar 23, 2007 5:43 am

Re: No AC3 5.1 on some blu rays?

Post by nightstrm »

Handbrake cannot convert DTS to AC3. AFAIK, all of the Bluray discs you've mentioned feature either DTS-HD or DTS-MA audio tracks. If you need AC3 (like for AppleTV playback), you'll need to convert them with another tool (eac3to is the one I use) first. If the Bluray features Dolby TrueHD soundtracks, Handbrake should have no problem extracting the AC3 core track.
awtlaw
Posts: 4
Joined: Wed Sep 15, 2010 5:47 pm

Re: No AC3 5.1 on some blu rays?

Post by awtlaw »

I need to get the ac3 track. is there some sort of tutorial on how to use eac3to? I downloaded it but i can't figure out what i need to do with it.

So, eac3to extracts the ac3 audio and does it combine the audio and video back together or can handbrake do that?
nightstrm
Veteran User
Posts: 1887
Joined: Fri Mar 23, 2007 5:43 am

Re: No AC3 5.1 on some blu rays?

Post by nightstrm »

awtlaw wrote:I need to get the ac3 track. is there some sort of tutorial on how to use eac3to? I downloaded it but i can't figure out what i need to do with it.

So, eac3to extracts the ac3 audio and does it combine the audio and video back together or can handbrake do that?
This was something I was planning on adding to the thread I created awhile ago discussing using HDDVD and Bluray sources with Handbrake (http://forum.handbrake.fr/viewtopic.php?f=14&t=9258), but I never got around to finishing it. Now that it looks like I'm going to revisit my entire HDDVD/Bluray catalog with the release of the new AppleTV, it is on my list of things to do. Until that happens, I can only point you to the wiki that taught me the basics... http://en.wikibooks.org/wiki/Eac3to/How_to_Use.

In my workflow, I use eac3to to extract the audio, video, and chapter tracks (subtitles as well if I know the disc uses forced subtitles) and then use tsmuxer to combine the output audio and video into a m2ts container that can be fed into Handbrake. This is discussed in the first post of the thread I linked to above.
awtlaw
Posts: 4
Joined: Wed Sep 15, 2010 5:47 pm

Re: No AC3 5.1 on some blu rays?

Post by awtlaw »

I have the Blu ray disc ripped to my hard drive. I have eac3to and the gui both in the same folder and i open eac3togui. I can't import anything into ac3togui because it doesn't recognize any of the files in the blu ray folder. Do I have to convert the blu ray to a mkv file first or what am I doing wrong.

I am just following what your tutorial says and it says to rip the disc and then use eac3to to extract the audio, video, chapters, and subtitle files. I can't get eac3to to recognize the blu ray files though.
nightstrm
Veteran User
Posts: 1887
Joined: Fri Mar 23, 2007 5:43 am

Re: No AC3 5.1 on some blu rays?

Post by nightstrm »

awtlaw wrote:I have the Blu ray disc ripped to my hard drive. I have eac3to and the gui both in the same folder and i open eac3togui. I can't import anything into ac3togui because it doesn't recognize any of the files in the blu ray folder. Do I have to convert the blu ray to a mkv file first or what am I doing wrong.

I am just following what your tutorial says and it says to rip the disc and then use eac3to to extract the audio, video, chapters, and subtitle files. I can't get eac3to to recognize the blu ray files though.
They describe the best way to go about scanning a HDDVD/Bluray disc here:

http://en.wikibooks.org/wiki/Eac3to/How ... e_as_input
Post Reply