how to hardcode tamil subtitles using handbrake

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
jraju
Posts: 11
Joined: Thu Nov 07, 2019 5:05 am

how to hardcode tamil subtitles using handbrake

Post by jraju » Thu Nov 07, 2019 5:24 am

Description of problem or question:Hi, i have tried to hardcode the tamil srt subtitle, by the procedure of selecting the video and then clicking subtile, import srt and then select the srt files. i had the srt file thro online conversion from english subttile which is in ult-8 format of text.
When the encoding is finished and when i open the file, there is no subtile is seen.
Where i am missing please
The srt file of english has been converted to tamil srt in ult-8form, does this need tobe changed
Or should i totally change the font to tamil etc.





Steps to reproduce the problem (If Applicable):




HandBrake version (e.g., 1.0.0):

handbrake 1.0.7


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):

windows ultimate 7 32 bit


HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

Please replace this text with the contents of your log file between the two code tags - OR -  provide a pastebin URL in place of these 3 lines.

Woodstock
Veteran User
Posts: 3289
Joined: Tue Aug 27, 2013 6:39 am

Re: how to hardcode tamil subtitles using handbrake

Post by Woodstock » Thu Nov 07, 2019 1:32 pm

Without a log to show what handbrake saw during the encode, there is not much anyone can do to help you, other than suggest you try a more modern version of handbrake. 1.0.7 is several years old. 1.2.2 is the current release.

EDIT: I see from your other topic that you do not have a 64-bit version of Windows... While that limits you to v1.0.7, we still need to see a log.

jraju
Posts: 11
Joined: Thu Nov 07, 2019 5:05 am

Re: how to hardcode tamil subtitles using handbrake

Post by jraju » Fri Nov 08, 2019 4:16 am

Hi, ok, i will send the logs , after trying for tamil subtitles. Being open source program, i do not understand, why it stopped updates for windows 32 bit users. is it because of technicality involved in advancement of program or other reasons.
Normally, windows 32 bit users are more for earlier version of OS. I may be wrong.
But the program makers could support both version of windows.
I found this software for learning freely and then onlyl knows that the acuual menus described in the blog articles with fig differ from my version. i could not find some menus. i installed and uninstalled , thinking that i would have customize the menus.
Tamils is one of the oldest language and so i tried to hardcode subtitles. The blog articles provide me something about choosing other languages in handbrake. Accordingly i tried with tamil, but could not succeed. But language tab contains tamil as one of the languages.
if there is possibility in the vesion, then please tell where i am making mistakes.
If it is a recent addition, then .....

Woodstock
Veteran User
Posts: 3289
Joined: Tue Aug 27, 2013 6:39 am

Re: how to hardcode tamil subtitles using handbrake

Post by Woodstock » Fri Nov 08, 2019 4:31 am

It's not as simple as "they did it before why not now?" Support for 32 bit code on all operating systems is going away, and if you don't support 64 bit effectively, you can't run on newer versions of the operating system. It is not just Windows.

"Support" would mean "proper testing", and the people working on handbrake do not maintain machines with 32 bit configurations anymore. If the newer code were to cleaning compile in 32 bit mode, it would not be tested to see if it actually WORKED.

As for subtitles, I do not think handbrake really CARES about what the language is, as long as it is encoded in a supported way (UTF-8), and the system has the proper font files that support that language. It doesn't matter how new or old the language is.

That is why we need to see the logs, so we can find out what handbrake saw when it opened your files.

jraju
Posts: 11
Joined: Thu Nov 07, 2019 5:05 am

Re: how to hardcode tamil subtitles using handbrake

Post by jraju » Fri Nov 08, 2019 9:22 am

Hi, i wrote a lengthy reply . but i lost it as i failed to save as draft and went for uploading img.
Ok, thanks very much for the clue of error,
i just translated the subtitle with tamil, but as you have given me a valuable point, noticed the font change.
i changed my font to Latha, which is a tamil font and then applied this font in srt file. Then i tried the handbrake encoding. I am happy to inform that , now the encoding was successful as in the translated srt file.
thanks very much.
Kindly tell me how to correct the srt lines in my language, as the online translation was verbatim translation, so not meaning ful in some places.
In dusbtitle edit, i coud correct english translation but i do not know hot to in subtitle edit, ,can i edit continuously in any editor , the lines i wanted with the same language
the encoding completed with 3 errors. Pleas say what those , are they major or minor and how to correct those.
the link of active window is here
https://ibb.co/4gLmngh
and the active log is here

Code: Select all

HandBrake 1.0.7 (2017040900) - 32bit
OS: Microsoft Windows NT 6.1.7601 Service Pack 1 - 32bit
CPU: Intel(R) Core(TM)2 Duo CPU     E7200  @ 2.53GHz
Ram: 3062 MB, 
GPU Information:
  Intel(R) Q33 Express Chipset Family - 8.15.10.1930
Screen: 1920x1080
Temp Dir: C:\Users\sar\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake
Data Dir: C:\Users\sar\AppData\Roaming\HandBrake Team\HandBrake\1.0.7.0

-------------------------------------------


# Starting Encode ...

[13:05:09] hb_init: starting libhb thread
[13:05:09] 1 job(s) to process
[13:05:09] json job:
{
  "Audio": {
    "AudioList": [
      {
        "Bitrate": 160,
        "DRC": 0.0,
        "Encoder": 65536,
        "Gain": 0.0,
        "Mixdown": 4,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      1073807360,
      1073743872,
      1074003968,
      1073750016,
      1090519040,
      1074790400,
      1074266112,
      1107296256
    ],
    "FallbackEncoder": 2048
  },
  "Destination": {
    "ChapterList": [
      {
        "Name": "Chapter 1"
      }
    ],
    "ChapterMarkers": true,
    "File": "D:\\arphobia\\archnophobiatamilsub.mp4",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": false
    },
    "Mux": 131072
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 4,
        "Settings": {
          "mode": "7"
        }
      },
      {
        "ID": 3,
        "Settings": {
          "block-height": "16",
          "block-thresh": "40",
          "block-width": "16",
          "filter-mode": "2",
          "mode": "3",
          "motion-thresh": "1",
          "spatial-metric": "2",
          "spatial-thresh": "1"
        }
      },
      {
        "ID": 11,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "0",
          "crop-right": "0",
          "crop-top": "0",
          "height": "360",
          "width": "670"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "2",
          "rate": "27000000/900000"
        }
      }
    ]
  },
  "PAR": {
    "Num": 2880,
    "Den": 2881
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "chapter",
      "Start": 1,
      "End": 1
    },
    "Title": 1,
    "Path": "D:\\insectphobia.mp4"
  },
  "Subtitle": {
    "Search": {
      "Burn": true,
      "Default": false,
      "Enable": true,
      "Forced": true
    },
    "SubtitleList": [
      {
        "Burn": false,
        "Default": true,
        "Forced": false,
        "ID": 0,
        "Offset": 0,
        "Track": -1,
        "SRT": {
          "Codeset": "UTF-8",
          "Filename": "D:\\chandrunewsongs2019\\insectphobia.ta.srt",
          "Language": "tam"
        }
      }
    ]
  },
  "Video": {
    "Encoder": 65536,
    "Level": "3.1",
    "TwoPass": false,
    "Turbo": false,
    "ColorMatrixCode": 0,
    "Options": "",
    "Preset": "fast",
    "Profile": "main",
    "Quality": 21.0,
    "OpenCL": false,
    "HWDecode": false,
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[13:05:09] CPU: Intel(R) Core(TM)2 Duo CPU     E7200  @ 2.53GHz
[13:05:09]  - logical processor count: 2
[13:05:09] Intel Quick Sync Video support: no
[13:05:09] hb_scan: path=D:\insectphobia.mp4, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:274: failed opening UDF image D:\insectphobia.mp4
src/libbluray/disc/disc.c:352: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:352: error opening file BDMV\BACKUP\index.bdmv
[13:05:09] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[13:05:09] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'D:\insectphobia.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    encoder         : Lavf57.28.102
  Duration: 01:49:31.86, start: 0.046440, bitrate: 688 kb/s
    Stream #0:0(und): Video: h264 (High) [avc1 / 0x31637661]
      yuv420p, 670x360 [PAR 2880:2881 DAR 80:43], 535 kb/s, PAR 2880:2881 DAR 80:43
      23.98 fps, 24k tbn (default)
    Metadata:
      handler_name    : VideoHandler
    Stream #0:1(eng): Audio: aac (LC) [mp4a / 0x6134706D]
      44100 Hz, stereo, fltp, 146 kb/s (default)
    Metadata:
      handler_name    : SoundHandler
[13:05:10] scan: decoding previews for title 1
[13:05:10] scan: audio 0x1: aac, rate=44100Hz, bitrate=146444 English (AAC) (2.0 ch)
[13:05:10] scan: 10 previews, 670x360, 23.976 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 2880:2881
[13:05:10] scan: supported video decoders: avcodec qsv
[13:05:10] libhb: scan thread found 1 valid title(s)
[13:05:10] Skipping subtitle scan.  No suitable subtitle tracks.
[13:05:10] starting job
[13:05:10] decomb filter thread started for segment 0
[13:05:10] decomb filter thread started for segment 1
[13:05:10] decomb check thread started for segment 1
[13:05:10] decomb check thread started for segment 0
[13:05:10] mask filter thread started for segment 1
[13:05:10] mask filter thread started for segment 0
[13:05:10] mask erode thread started for segment 0
[13:05:10] mask erode thread started for segment 1
[13:05:10] mask dilate thread started for segment 0
[13:05:10] mask dilate thread started for segment 1
[13:05:10] yadif thread started for segment 0
[13:05:10] yadif thread started for segment 1
[13:05:10] work: track 1, dithering not supported by codec
[13:05:10] work: only 1 chapter, disabling chapter markers
[13:05:10] job configuration:
[13:05:10]  * source
[13:05:10]    + D:\insectphobia.mp4
[13:05:10]    + title 1, chapter(s) 1 to 1
[13:05:10]    + container: mov,mp4,m4a,3gp,3g2,mj2
[13:05:10]    + data rate: 688 kbps
[13:05:10]  * destination
[13:05:10]    + D:\arphobia\archnophobiatamilsub.mp4
[13:05:10]    + container: MPEG-4 (libavformat)
[13:05:10]  * video track
[13:05:10]    + decoder: h264
[13:05:10]      + bitrate 535 kbps
[13:05:10]    + filters
[13:05:10]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[13:05:10]      + Decomb (mode=39)
[13:05:10]      + Framerate Shaper (mode=2:rate=27000000/900000)
[13:05:10]        + frame rate: 23.976 fps -> peak rate limited to 30.000 fps
[13:05:10]      + Crop and Scale (width=670:height=360:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[13:05:10]        + source: 670 * 360, crop (0/0/0/0): 670 * 360, scale: 670 * 360
[13:05:10]    + Output geometry
[13:05:10]      + storage dimensions: 670 x 360
[13:05:10]      + pixel aspect ratio: 2880 : 2881
[13:05:10]      + display dimensions: 669 x 360
[13:05:10]    + encoder: H.264 (libx264)
[13:05:10]      + preset:  fast
[13:05:10]      + profile: main
[13:05:10]      + level:   3.1
[13:05:10]      + quality: 21.00 (RF)
[13:05:10]  * subtitle track 1, Tamil (track 0, id 0xff) Text [SRT] -> Passthrough, Default, offset: 0, charset: UTF-8
[13:05:10]  * audio track 1
[13:05:10]    + decoder: English (AAC) (2.0 ch) (track 1, id 0x1)
[13:05:10]      + bitrate: 146 kbps, samplerate: 44100 Hz
[13:05:10]    + mixdown: Stereo
[13:05:10]    + encoder: AAC (libavcodec)
[13:05:10]      + bitrate: 160 kbps, samplerate: 44100 Hz
[13:05:10] sync: expecting 157567 video frames
[13:05:10] encx264: min-keyint: 24, keyint: 240
[13:05:10] encx264: encoding at constant RF 21.000000
[13:05:10] encx264: unparsed options: rc-lookahead=30:subme=6:8x8dct=0:level=3.1:vbv-bufsize=14000:ref=2:weightp=1:vbv-maxrate=14000
x264 [info]: using SAR=2880/2881
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.1 Cache64
x264 [info]: profile Main, level 3.1
[13:05:10] sync: first pts audio 0x1 is 0
[13:05:10] sync: first pts video is 4179
[13:05:10] sync: "Chapter 1" (1) at frame 1 time 4179
[13:05:11] sync: first pts subtitle 0xff is 450000
[14:01:08] reader: done. 1 scr changes
[14:01:09] work: average encoding speed for job is 46.899101 fps
[14:01:09] comb detect: heavy 492 | light 1089 | uncombed 155985 | total 157566
[14:01:09] decomb: deinterlaced 492 | blended 1089 | unfiltered 155985 | total 157566
[14:01:10] vfr: 157566 frames output, 0 dropped and 0 duped for CFR/PFR
[14:01:10] vfr: lost time: 0 (0 frames)
[14:01:10] vfr: gained time: 0 (0 frames) (0 not accounted for)
[14:01:10] aac-decoder done: 283024 frames, 0 decoder errors
[14:01:10] h264-decoder done: 157566 frames, 0 decoder errors
[14:01:10] sync: got 157566 frames, 157567 expected
[14:01:10] sync: framerate min 23.981 fps, max 23.981 fps, avg 23.976 fps
x264 [info]: frame I:1747  Avg QP:16.35  size: 20448
x264 [info]: frame P:56409 Avg QP:19.25  size:  5287
x264 [info]: frame B:99410 Avg QP:22.69  size:  1450
x264 [info]: consecutive B-frames:  5.7% 27.9%  7.7% 58.7%
x264 [info]: mb I  I16..4: 27.1%  0.0% 72.9%
x264 [info]: mb P  I16..4:  9.6%  0.0% 10.2%  P16..4: 33.7% 14.8%  6.5%  0.0%  0.0%    skip:25.3%
x264 [info]: mb B  I16..4:  2.2%  0.0%  1.6%  B16..8: 24.8%  6.9%  0.6%  direct: 4.9%  skip:59.0%  L0:44.4% L1:45.3% BI:10.3%
x264 [info]: coded y,uvDC,uvAC intra: 46.8% 56.1% 10.6% inter: 9.8% 13.1% 0.2%
x264 [info]: i16 v,h,dc,p: 40% 28% 18% 14%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 30% 19% 19%  5%  6%  6%  5%  5%  4%
x264 [info]: i8c dc,h,v,p: 57% 18% 21%  4%
x264 [info]: Weighted P-Frames: Y:2.5% UV:1.7%
x264 [info]: ref P L0: 77.6% 22.4%
x264 [info]: ref B L0: 83.3% 16.7%
x264 [info]: ref B L1: 97.2%  2.8%
x264 [info]: kb/s:582.04
[14:01:10] mux: track 0, 157566 frames, 478070985 bytes, 581.96 kbps, fifo 8192
[14:01:10] mux: track 1, 283024 frames, 131599622 bytes, 160.20 kbps, fifo 8192
[14:01:10] mux: track 2, 1013 frames, 142482 bytes, 0.17 kbps, fifo 64
[14:01:10] libhb: work result = 0

# Encode Completed ...

Thanks once again for providing me a valuable clue of change of font
Last edited by Rodeo on Sat Nov 09, 2019 9:38 pm, edited 1 time in total.
Reason: Logs in between [code][/code] blocks please

jraju
Posts: 11
Joined: Thu Nov 07, 2019 5:05 am

Re: how to hardcode tamil subtitles using handbrake

Post by jraju » Fri Nov 08, 2019 9:26 am

I would like the team to upgrade the windows 32 bit version also, so that more window users could use this wonderful tool.
i could just imagine the improvements and bug fixes for those years in windows 32 bit
Some amy consider it to give.

jraju
Posts: 11
Joined: Thu Nov 07, 2019 5:05 am

Re: how to hardcode tamil subtitles using handbrake

Post by jraju » Fri Nov 08, 2019 11:57 am

Hi, Sorry, the subtitle would not show, unless , i enabled the subtitle in vlc. In other player like MPC HC, the subtitle does not show.
My query is , handbrake completed the encode, ofcourse with error.
But when i play thro vlc, the video just plays without subtitle.
Then when i enabled tract , then it plays. I think , that it stored the track and plalys., but when i play in my tv, there is no subtitle showing.
i do not know about the three errors, Did they convey something. I used general preseets of 720p30. is that wrong.
Now i am back to square one
When i checked the codec, it says stream 2 codec tx3g, language tamil ,type subtitle

User avatar
Rodeo
HandBrake Team
Posts: 12272
Joined: Tue Mar 03, 2009 8:55 pm

Re: how to hardcode tamil subtitles using handbrake

Post by Rodeo » Fri Nov 08, 2019 6:40 pm

You may have forgotten to select "burned in", so HandBrake didn't hardcode the subtitles. They're soft subtitles that you would have to enable manually in e.g. VLC.

jraju
Posts: 11
Joined: Thu Nov 07, 2019 5:05 am

Re: how to hardcode tamil subtitles using handbrake

Post by jraju » Sat Nov 09, 2019 6:57 am

Hi, Rodeo, please see the picture i enclosed, the burn in option turned on.

Woodstock
Veteran User
Posts: 3289
Joined: Tue Aug 27, 2013 6:39 am

Re: how to hardcode tamil subtitles using handbrake

Post by Woodstock » Sat Nov 09, 2019 4:01 pm

But your encode log says:
[13:05:10] * subtitle track 1, Tamil (track 0, id 0xff) Text [SRT] -> Passthrough, Default, offset: 0, charset: UTF-8

DexKen
Posts: 10
Joined: Thu Dec 11, 2014 9:08 pm

Re: how to hardcode tamil subtitles using handbrake

Post by DexKen » Sat Nov 09, 2019 6:27 pm

You have forced only also checked, there are no forced subtitles in your SRT file so none get burned in

User avatar
Rodeo
HandBrake Team
Posts: 12272
Joined: Tue Mar 03, 2009 8:55 pm

Re: how to hardcode tamil subtitles using handbrake

Post by Rodeo » Sat Nov 09, 2019 9:40 pm

jraju wrote:
Sat Nov 09, 2019 6:57 am
Hi, Rodeo, please see the picture i enclosed, the burn in option turned on.
I found the picture. You've selected burn-in for the "Foreign Audio Search" track, not the Tamil SRT file track :roll:

jraju
Posts: 11
Joined: Thu Nov 07, 2019 5:05 am

Re: how to hardcode tamil subtitles using handbrake

Post by jraju » Sun Nov 10, 2019 4:24 am

Hi, Please say, what should have been the menu for correct hardcoding the titles.
J just opened the video file and after that select , eidt , enabled subtitles, then select import srt and browse to thesrt file, select destination and then select burn in and then convert .
I have saved the tamil font to the Latha font, which is unicode font for my language in microsoft.
The procoess went for nearly an hour, but the resultant file saved with 3 errors with concellation.
what are those mistakes, please give the exact menus and how to hardcode other than english subitles.

jraju
Posts: 11
Joined: Thu Nov 07, 2019 5:05 am

Re: how to hardcode tamil subtitles using handbrake

Post by jraju » Sun Nov 10, 2019 4:26 am

Hi, dex will try to uncheck forced. Is that enough
please give menu wise

DexKen
Posts: 10
Joined: Thu Dec 11, 2014 9:08 pm

Re: how to hardcode tamil subtitles using handbrake

Post by DexKen » Sun Nov 10, 2019 7:29 am

From the picture you provided, the line with Foreign Audio Scan, uncheck the Forced and Burn In boxes. The Line below which is your Tamil subtitles, put the check in the Burn in box

Post Reply