Handbrake suddenly failing at the end of encoding

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
mantooth
Posts: 2
Joined: Thu Oct 11, 2018 2:46 am

Handbrake suddenly failing at the end of encoding

Post by mantooth » Thu Oct 11, 2018 3:00 am

Description of problem or question:

Have had no issues with Handbrake for months but suddenly in the last few days I'm experiencing an issue where Handbrake shuts down unexpectedly at the end of encoding a file. There is no crash or error dialog. Handbrake just shuts down and when reopened shows that the file didn't complete even though it looks to have when I check in the target directory. I initially thought this was only during encoding multiple files in a queue but it's also happening when trying to encode a single file. The only thing I can think that has changed about my system lately is the latest Windows update. Otherwise, nothing new that should be interfering.

Steps to reproduce the problem (If Applicable):

Start an encode, whether a single file or multiple in a queue. Handbrake encodes as normal until the very end of the first file and then shuts down.

HandBrake version (e.g., 1.0.0):

1.1.2

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):

Windows 10 Pro, Version 1809, OS Build 17763.55

HandBrake Activity Log ***required*** (see How-to get an activity log)

https://pastebin.com/vtwtA9F8

Woodstock
Veteran User
Posts: 2807
Joined: Tue Aug 27, 2013 6:39 am

Re: Handbrake suddenly failing at the end of encoding

Post by Woodstock » Thu Oct 11, 2018 12:21 pm

"QSV": {
"Decode": true,
"AsyncDepth": 0
}
Try disabling QSV decode in Tools->Preferences->Video.

All QSV stuff is driver-dependent, and QSV decode is already flaky (it breaks on many sources). A Windows update may have changed your video driver for a not-as-good version.

mantooth
Posts: 2
Joined: Thu Oct 11, 2018 2:46 am

Re: Handbrake suddenly failing at the end of encoding

Post by mantooth » Sun Oct 21, 2018 8:36 pm

I tried that but it didn't help. The result remained the same as in Handbrake would hang and then close after encoding an item before proceeding to the next in the queue. Not sure if it was a placebo effect but there was a graphics driver update from Intel that I went ahead installed. After, things seem to work slightly better but still closing unexpectedly. Sometimes I can get up to eight items before closing, other times it will crash just before finishing the first item. Not sure which logs would be most helpful in that case. Just wish I could fix it as it's becoming very frustrating to have to constantly reopen Handbrake.

Post Reply