Problem with "--mixdown stereo"

Discussion of the HandBrake command line interface (CLI)
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
lhernandezx
Posts: 3
Joined: Mon Jan 27, 2020 10:50 am

Problem with "--mixdown stereo"

Post by lhernandezx »

Description of problem or question:

Hello. I'm a novice user and I have a simple problem.

I have several small family videos recorded with several devices (Android phone, iphone, digital camera, ...) at different resolutions, diferent audio tracks, etc. and I want to convert all of them to a same format, same resolution, same audio, etc. in order to concatenate later all of them with another tool (MP4Box).

And my problem is that I am not able to convert the videos recorded in mono audio format to the standard format I need: AAC, 192 kbps, 44.1 MHz, stereo. I mean, I cannot convert my videos from mono to stereo.


Steps to reproduce the problem (If Applicable):

HandBrakeCLI -i Test.m4v -o Output.mp4 --encoder x265 --vb 10000 --rate 29.97 --cfr --aencoder av_aac --ab 192 --arate 44.1 --normalize-mix 1 --mixdown stereo 2>Log.txt



HandBrake version (e.g., 1.0.0):

HandBrakeCLI 1.3.1


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):

Windows 10 Enterprise v1809 64 bits


HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

[11:45:48] Compile-time hardening features are enabled
Cannot load nvEncodeAPI64.dll
[11:45:48] hb_init: starting libhb thread
[11:45:48] thread 1 started ("libhb")
HandBrake 1.3.1 (2020010400) - MinGW x86_64 - https://handbrake.fr
6 CPUs detected
Opening Test.m4v...
[11:45:48] CPU: Intel(R) Core(TM) i5-8500 CPU @ 3.00GHz
[11:45:48]  - Intel microarchitecture Kaby Lake
[11:45:48]  - logical processor count: 6
[11:45:48] Intel Quick Sync Video support: yes
[11:45:48]  - Intel Media SDK hardware: API 1.27 (minimum: 1.3)
[11:45:48]  - H.264 encoder: yes
[11:45:48]     - preferred implementation: hardware (any) via D3D11
[11:45:48]     - capabilities (hardware):  breftype icq+la+i+downs vsinfo opt1 opt2+mbbrc+extbrc+trellis+ib_adapt+nmpslice
[11:45:48]  - H.265 encoder: yes (8bit: yes, 10bit: yes)
[11:45:48]     - preferred implementation: hardware (any) via D3D11
[11:45:48]     - capabilities (hardware):  bpyramid icq vsinfo opt1
[11:45:48] hb_scan: path=Test.m4v, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:323: failed opening UDF image Test.m4v
src/libbluray/disc/disc.c:424: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:424: error opening file BDMV\BACKUP\index.bdmv
src/libbluray/bluray.c:2585: nav_get_title_list(Test.m4v\) failed
[11:45:48] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[11:45:48] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'Test.m4v':
  Metadata:
    major_brand     : M4V 
    minor_version   : 1
    compatible_brands: M4V M4A mp42isom
    creation_time   : 2019-11-07T12:49:54.000000Z
    location        : +36.7583+139.5950+685.208008/
    date            : 2019-10-30T11:14:15+0900
    make            : Apple
  Duration: 00:00:10.20, start: 0.000000, bitrate: 11256 kb/s
    Stream #0:0(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, mono, fltp, 98 kb/s (default)
    Metadata:
      creation_time   : 2019-11-07T12:49:54.000000Z
      handler_name    : Core Media Audio
    Stream #0:1(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709), 1080x1920 [SAR 1:1 DAR 9:16], 11151 kb/s, 30 fps, 30 tbr, 600 tbn, 1200 tbc (default)
    Metadata:
      creation_time   : 2019-11-07T12:49:54.000000Z
      handler_name    : Core Media Video
[11:45:48] scan: decoding previews for title 1
[11:45:48] scan: audio 0x0: aac, rate=44100Hz, bitrate=98366 Unknown (AAC LC) (1.0 ch) (98 kbps)

Scanning title 1 of 1, preview 1, 10.00 %
Scanning title 1 of 1, preview 5, 50.00 %
Scanning title 1 of 1, preview 9, 90.00 %[11:45:49] scan: 10 previews, 1080x1920, 30.005 fps, autocrop = 0/0/0/0, aspect 1:1.78, PAR 1:1
[11:45:49] scan: supported video decoders: avcodec qsv
[11:45:49] Title is likely interlaced or telecined (5 out of 10 previews). You should do something about that.
[11:45:49] libhb: scan thread found 1 valid title(s)
+ Using preset: CLI Default
+ title 1:
  + stream: Test.m4v
  + duration: 00:00:10
  + size: 1080x1920, pixel aspect: 1/1, display aspect: 0.56, 30.005 fps
  + autocrop: 0/0/0/0
  + chapters:
    + 1: duration 00:00:10
  + audio tracks:
    + 1, Unknown (AAC LC) (1.0 ch) (98 kbps) (iso639-2: und)
  + subtitle tracks:
  + combing detected, may be interlaced or telecined
[11:45:49] Starting work at: Mon Jan 27 11:45:49 2020

[11:45:49] 1 job(s) to process
[11:45:49] json job:
{
    "Audio": {
        "AudioList": [
            {
                "Bitrate": 192,
                "CompressionLevel": -1.0,
                "DRC": 0.0,
                "DitherMethod": "auto",
                "Encoder": "av_aac",
                "Gain": 0.0,
                "Mixdown": "mono",
                "NormalizeMixLevel": true,
                "PresetEncoder": "av_aac",
                "Quality": -3.0,
                "Samplerate": 44100,
                "Track": 0
            }
        ],
        "CopyMask": [
            "copy:aac",
            "copy:ac3",
            "copy:eac3",
            "copy:dtshd",
            "copy:dts",
            "copy:mp3",
            "copy:truehd",
            "copy:flac"
        ],
        "FallbackEncoder": "av_aac"
    },
    "Destination": {
        "AlignAVStart": false,
        "ChapterList": [
            {
                "Duration": {
                    "Hours": 0,
                    "Minutes": 0,
                    "Seconds": 10,
                    "Ticks": 917849
                },
                "Name": ""
            }
        ],
        "ChapterMarkers": false,
        "File": "Output.mp4",
        "InlineParameterSets": false,
        "Mp4Options": {
            "IpodAtom": false,
            "Mp4Optimize": false
        },
        "Mux": "m4v"
    },
    "Filters": {
        "FilterList": [
            {
                "ID": 6,
                "Settings": {
                    "mode": 1,
                    "rate": "27000000/900900"
                }
            },
            {
                "ID": 12,
                "Settings": {
                    "crop-bottom": 0,
                    "crop-left": 0,
                    "crop-right": 0,
                    "crop-top": 0,
                    "height": 1920,
                    "width": 1080
                }
            }
        ]
    },
    "Metadata": {
        "ReleaseDate": "2019-10-30T11:14:15+0900"
    },
    "PAR": {
        "Den": 1,
        "Num": 1
    },
    "SequenceID": 0,
    "Source": {
        "Angle": 0,
        "Path": "Test.m4v",
        "Range": {
            "End": 1,
            "Start": 1,
            "Type": "chapter"
        },
        "Title": 1
    },
    "Subtitle": {
        "Search": {
            "Burn": true,
            "Default": false,
            "Enable": false,
            "Forced": false
        },
        "SubtitleList": []
    },
    "Video": {
        "Bitrate": 10000,
        "ColorFormat": 0,
        "ColorMatrix": 1,
        "ColorPrimaries": 1,
        "ColorRange": 1,
        "ColorTransfer": 1,
        "Encoder": "x265",
        "QSV": {
            "AsyncDepth": 4,
            "Decode": false
        },
        "Turbo": false,
        "TwoPass": false
    }
}
[11:45:49] Starting Task: Encoding Pass
[11:45:49] Skipping crop/scale filter
[11:45:49] job configuration:
[11:45:49]  * source
[11:45:49]    + Test.m4v
[11:45:49]    + title 1, chapter(s) 1 to 1
[11:45:49]    + container: mov,mp4,m4a,3gp,3g2,mj2
[11:45:49]    + data rate: 11256 kbps
[11:45:49]  * destination
[11:45:49]    + Output.mp4
[11:45:49]    + container: MPEG-4 (libavformat)
[11:45:49]  * video track
[11:45:49]    + decoder: h264
[11:45:49]      + bitrate 11151 kbps
[11:45:49]    + filter
[11:45:49]      + Framerate Shaper (mode=1:rate=27000000/900900)
[11:45:49]        + frame rate: 30.005 fps -> constant 29.970 fps
[11:45:49]    + Output geometry
[11:45:49]      + storage dimensions: 1080 x 1920
[11:45:49]      + pixel aspect ratio: 1 : 1
[11:45:49]      + display dimensions: 1080 x 1920
[11:45:49]    + encoder: H.265 (libx265)
[11:45:49]      + bitrate: 10000 kbps, pass: 0
[11:45:49]      + color profile: 1-1-1
[11:45:49]  * audio track 1
[11:45:49]    + decoder: Unknown (AAC LC) (1.0 ch) (98 kbps) (track 1, id 0x0)
[11:45:49]      + bitrate: 98 kbps, samplerate: 44100 Hz
[11:45:49]    + mixdown: Mono
[11:45:49]    + normalized mixing levels
[11:45:49]    + dither: triangular
[11:45:49]    + encoder: AAC (libavcodec)
[11:45:49]      + bitrate: 192 kbps, samplerate: 44100 Hz
[11:45:49] sync: expecting 305 video frames
x265 [info]: HEVC encoder version 3.2.1+1-b5c86a64bbbe
x265 [info]: build info [Windows][GCC 9.2.0][64 bit] 8bit+10bit+12bit
x265 [info]: using cpu capabilities: MMX2 SSE2Fast LZCNT SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x265 [info]: Main profile, Level-4 (Main tier)
x265 [info]: Thread pool created using 6 threads
x265 [info]: Slices                              : 1
x265 [info]: frame threads / pool features       : 2 / wpp(30 rows)
x265 [info]: Coding QT: max CU size, min CU size : 64 / 8
x265 [info]: Residual QT: max TU size, max depth : 32 / 1 inter / 1 intra
x265 [info]: ME / range / subpel / merge         : hex / 57 / 2 / 3
x265 [info]: Keyframe min / max / scenecut / bias: 30 / 300 / 40 / 5.00
x265 [info]: Lookahead / bframes / badapt        : 20 / 4 / 2
x265 [info]: b-pyramid / weightp / weightb       : 1 / 1 / 0
x265 [info]: References / ref-limit  cu / depth  : 3 / off / on
x265 [info]: AQ: mode / str / qg-size / cu-tree  : 2 / 1.0 / 32 / 1
x265 [info]: Rate Control / qCompress            : ABR-10000 kbps / 0.60
x265 [info]: tools: rd=3 psy-rd=2.00 early-skip rskip signhide tmvp b-intra
x265 [info]: tools: strong-intra-smoothing lslices=8 deblock sao
[11:45:49] sync: first pts video is 0
[11:45:49] sync: Chapter 1 at frame 1 time 0
[11:45:49] sync: first pts audio 0x0 is 0
[11:45:58] reader: done. 1 scr changes
[11:46:03] work: average encoding speed for job is 27.515635 fps
[11:46:03] vfr: 306 frames output, 0 dropped and 0 duped for CFR/PFR
[11:46:03] vfr: lost time: 0 (0 frames)
[11:46:03] vfr: gained time: 0 (0 frames) (0 not accounted for)
[11:46:03] aac-decoder done: 440 frames, 0 decoder errors
[11:46:03] h264-decoder done: 306 frames, 0 decoder errors
[11:46:03] sync: got 306 frames, 305 expected
[11:46:03] sync: framerate min 30.005 fps, max 30.005 fps, avg 30.005 fps
x265 [info]: frame I:      2, Avg QP:22.61  kb/s: 149490.63
x265 [info]: frame P:     72, Avg QP:24.28  kb/s: 33460.91
x265 [info]: frame B:    232, Avg QP:31.61  kb/s: 1623.91 
x265 [info]: Weighted P-Frames: Y:27.8% UV:22.2%
x265 [info]: consecutive B-frames: 1.4% 1.4% 5.4% 66.2% 25.7% 

encoded 306 frames in 13.84s (22.11 fps), 10081.41 kb/s, Avg QP:29.83
[11:46:03] mux: track 0, 306 frames, 12867880 bytes, 10049.53 kbps, fifo 512
[11:46:03] mux: track 1, 441 frames, 260170 bytes, 203.19 kbps, fifo 512
[11:46:03] Finished work at: Mon Jan 27 11:46:03 2020

[11:46:03] libhb: work result = 0

Encode done!
HandBrake has exited.


User avatar
Rodeo
HandBrake Team
Posts: 12471
Joined: Tue Mar 03, 2009 8:55 pm

Re: Problem with "--mixdown stereo"

Post by Rodeo »

That is correct, HandBrake will not upmix Mono to Stereo.

lhernandezx
Posts: 3
Joined: Mon Jan 27, 2020 10:50 am

Re: Problem with "--mixdown stereo"

Post by lhernandezx »

Thank you @Rodeo. Are there any workaround to obtain the Stereo? For example, can I duplicate the Mono track to build a Stereo track?

Or the only solution to join all my videos would be to "downmix to Mono all of them"?

Thank you

User avatar
Rodeo
HandBrake Team
Posts: 12471
Joined: Tue Mar 03, 2009 8:55 pm

Re: Problem with "--mixdown stereo"

Post by Rodeo »

There are tools that will upmix Mono to Stereo, just not HandBrake I'm afraid.

lhernandezx
Posts: 3
Joined: Mon Jan 27, 2020 10:50 am

Re: Problem with "--mixdown stereo"

Post by lhernandezx »

Thank you @Rodeo. Can you tell me the name of one of these tools?

User avatar
Rodeo
HandBrake Team
Posts: 12471
Joined: Tue Mar 03, 2009 8:55 pm

Re: Problem with "--mixdown stereo"

Post by Rodeo »

FFmpeg should be able to do it, among others.

Post Reply