Ignoring 2 Pass and Dual Audio

Discussion of the HandBrake command line interface (CLI)
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
plittlefield
Posts: 38
Joined: Wed Nov 18, 2009 10:03 am

Ignoring 2 Pass and Dual Audio

Post by plittlefield » Thu Jul 21, 2016 12:16 pm

Hi Folks,

I am struggling to get an MakeMKV BD rip transcoded the way I want.

For some reason, HB is ignoring 2 pass and dual audio.

Here is a pastebin of the source file, HB command line, and output files shown in avconv and mediainfo.

http://pastebin.com/vu9TLyA6

What am I doing wrong?

Thanks in advance for your help.

Paully

Ubuntu 14.04.4 LTS
MakeMKV 1.10.0
HandBrake 20160716194210-39d0352-master
avconv version 12_dev0-6:12~~git20150809.1542ec9~ubuntu14.04.1
MediaInfo Command line, MediaInfoLib - v0.7.67

rollin_eng
Veteran User
Posts: 3130
Joined: Wed May 04, 2011 11:06 pm

Re: Ignoring 2 Pass and Dual Audio

Post by rollin_eng » Thu Jul 21, 2016 12:37 pm

Could you please post your encode log as well.

plittlefield
Posts: 38
Joined: Wed Nov 18, 2009 10:03 am

Re: Ignoring 2 Pass and Dual Audio

Post by plittlefield » Thu Jul 21, 2016 1:07 pm

Is the encode log kept somewhere in particular, or do I just copy and paste the terminal command line output from my screen?

I shall have to redo the test encode if it's not saved anywhere.

rollin_eng
Veteran User
Posts: 3130
Joined: Wed May 04, 2011 11:06 pm

Re: Ignoring 2 Pass and Dual Audio

Post by rollin_eng » Thu Jul 21, 2016 1:21 pm


plittlefield
Posts: 38
Joined: Wed Nov 18, 2009 10:03 am

Re: Ignoring 2 Pass and Dual Audio

Post by plittlefield » Thu Jul 21, 2016 2:13 pm

Got it, thanks. I shall do that soon and post here.

User avatar
Rodeo
HandBrake Team
Posts: 12142
Joined: Tue Mar 03, 2009 8:55 pm

Re: Ignoring 2 Pass and Dual Audio

Post by Rodeo » Thu Jul 21, 2016 2:34 pm

You're not setting a video bitrate; the default rate control method (constant rate factor) only requires one pass.

You're passing two audio encoders and audio bitrates, but only one audio track; try --audio 2,2

plittlefield
Posts: 38
Joined: Wed Nov 18, 2009 10:03 am

Re: Ignoring 2 Pass and Dual Audio

Post by plittlefield » Thu Jul 21, 2016 4:50 pm

OK, here is the encode log - http://pastebin.com/WsDCkMRm

plittlefield
Posts: 38
Joined: Wed Nov 18, 2009 10:03 am

Re: Ignoring 2 Pass and Dual Audio

Post by plittlefield » Thu Jul 21, 2016 4:53 pm

Rodeo wrote:You're not setting a video bitrate; the default rate control method (constant rate factor) only requires one pass.
Ah, that explains it, thank you.

I have watched the 5 min test and it is great quality, so I'm happy to ignore the 2 pass.

Is that OK to do?

Is it really worth the extra time?
Rodeo wrote:You're passing two audio encoders and audio bitrates, but only one audio track; try --audio 2,2
Ah, I shall try this now... third time lucky!

User avatar
Rodeo
HandBrake Team
Posts: 12142
Joined: Tue Mar 03, 2009 8:55 pm

Re: Ignoring 2 Pass and Dual Audio

Post by Rodeo » Thu Jul 21, 2016 4:57 pm

No, constant RF (single pass) is the way to go (you may adjust quality via the -q option). Only use 2-pass if you must use average bitrate encoding for some reason.

plittlefield
Posts: 38
Joined: Wed Nov 18, 2009 10:03 am

Re: Ignoring 2 Pass and Dual Audio

Post by plittlefield » Thu Jul 21, 2016 5:05 pm

Bingo, problem solved...

--audio 2,2

Code: Select all

[17:58:32]  * audio track 1
[17:58:32]    + decoder: English (DTS) (5.1 ch) (track 2, id 0x2)
[17:58:32]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[17:58:32]    + mixdown: Dolby Pro Logic II
[17:58:32]    + encoder: AAC (libavcodec)
[17:58:32]      + bitrate: 160 kbps, samplerate: 48000 Hz
[17:58:32]  * audio track 2
[17:58:32]    + decoder: English (DTS) (5.1 ch) (track 2, id 0x2)
[17:58:32]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[17:58:32]    + mixdown: 5.1 Channels
[17:58:32]    + encoder: AC3 (libavcodec)
[17:58:32]      + bitrate: 384 kbps, samplerate: 48000 Hz
Thanks!

:-)

Paully

plittlefield
Posts: 38
Joined: Wed Nov 18, 2009 10:03 am

Re: Ignoring 2 Pass and Dual Audio

Post by plittlefield » Thu Jul 21, 2016 5:06 pm

Rodeo wrote:No, constant RF (single pass) is the way to go (you may adjust quality via the -q option). Only use 2-pass if you must use average bitrate encoding for some reason.
Noted. Cheers.

Post Reply