Video & audio increasingly out of sync

Discussion of the HandBrake command line interface (CLI)
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
mdtaylor1988
Posts: 1
Joined: Tue Jul 05, 2016 11:45 pm

Video & audio increasingly out of sync

Post by mdtaylor1988 » Wed Jul 06, 2016 1:26 am

Please detail your question or problem in as much detail as possible:

I have some VHS tapes which I digitized by playing them on a VCR connected to a Sony DCR-TRV340 camcorder in pass-thru mode and capturing them with iMovie on my iMac. I'm compressing them using HandBrake (as a faster alternative to iMovie) and everything seems to work fine, except that the audio gets progressively more out-of-sync with the video, and by the end of a 2-hour movie the audio is 1-2 seconds ahead of the video. The source .dv file does not have this problem.

Attached is the log from a typical session, with the CLI version of Handbrake 0.10.5 using the "High Profile" preset.

Here are a few things I have tried, based on suggestions I have found by Googling around:
- The nightly build version of Handbrake
- The GUI version
- The "Normal" preset, with and without --deinterlace, --decomb, and --detelecine
- Various constant frame rates
- The --twopass option
- The .mkv container format
- The audio 'copy' encoder
- The mpeg4 encoder
- A newer and more powerful iMac I use at work
- Playback on both QuickTime Player and VLC 2.1.2
- And various combinations of the above

I even went back and tried an iMovie H.264 export (which takes more than 10 times as long) and it has the same problem.

Note that if I specify a '--start-at' near the end of the movie, the resulting short clip does not have the problem. It seems to be some kind of cumulative error.

At this point I hardly know what to try next. It's time consuming to try various experiments since the problem only starts to become noticeable in the second hour of the encoded video.

Tell us about your environment. What version of HandBrake? What operating system are you running. etc.

Handbrake 0.10.5, OS X 10.11.5

If there was any exception or error displayed, please copy it and paste it here: None

Please include the scan or encode log: http://pastebin.com/ZcA80t5B

Post Reply