Chromecast optimized and Audio issue

Discussion of the HandBrake command line interface (CLI)
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
robertormpc
Posts: 1
Joined: Sun Jun 12, 2016 7:16 pm

Chromecast optimized and Audio issue

Post by robertormpc » Sun Jun 12, 2016 8:15 pm

First of all hello and thanks for this awesome software! I really appreciate the development!


I own a homeserver with limited processing power (about 2.5k pm) which is able to transcode on the fly 1080p videos through Plex just fine, however whenever someone else logs in I start getting some problem due lack of processing power. Most of the streams (outside of the network) happen to a Chromecast 1. So my idea is to reencode most of my videos to a Chromecast stream friendly format. There are 3 points though,
1- I want to keep the audio untouched. The reason for that is that, if for instance a player needs to get the audio transcoded Plex will handle that and as it wont need to deal with the video stream only the audio, my server will be able to handle more streams at the same time. Also for local network play I will get the full audio support for direct play which doesnt require much processing power if any.
2- If there are embeded subtitled I want it to be kept as well.
3- I want to used my powered PC with Quick Sync to speed up the process. Even though we get better video quality on software encode I rather do it through HA encode as its MUCH faster of a process and I have about 4.5k videos to go through.

Now the issue.

1- While I´m happy with the video quality that I managed to get using the presets in use, Im not an expert so I would appreciate any input from you to make it better.
2- This preset changed the original 5.1 audio down to Stereo not sure why and what to do to keep the audio track. If its not possible to keep the original I would like to make it AC3 5.1 for compatibility across the board as some are DTS.

Im using Windows 10 with the last version of Handbrake. The batch software is called Handbreake BatchEncoder 2.3

This 2.3 version is the last version of the software as well, however it was released few years ago and it doesnt pickup the presets from handbrake automatically. However it has a text box where you can add your own query and it will use handbrakecli to do the job plus adds some little features like, scan and add subfolders to the queue, it deletes the source if i want it to, creates folders... which is nice for someone with limited knowledge in such program like me. Dont get me wrong, if you guys know a better solution by all means let me know! ;)

Just an fyi I tried to get the query sintax using viewtopic.php?f=10&t=34632 but its not a will query and i know here in the log its the handbrakecli query though I had the issues above that I would like some input and some help if possible.

Again, I really appreciate your input

Code: Select all

 HandBrake 0.10.5.0 - 64bit Version
OS: Microsoft Windows NT 6.2.9200.0 - 64bit
CPU: Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz
Ram: 8045 MB, 
GPU Information:
  Intel(R) HD Graphics 4600 - 20.19.15.4331
  AMD Radeon HD 6800 Series - 15.301.1901.0
Screen: 1920x1080
Temp Dir: C:\Users\rober\AppData\Local\Temp\
Install Dir: C:\Program Files\Handbrake
Data Dir: C:\Users\rober\AppData\Roaming\HandBrake Team\HandBrake\0.10.5.0

-------------------------------------------
CLI Query:  -i "C:\Users\rober\Desktop\test\1080 ch6 test.mp4" -t 1 --angle 1 -c 1 -o "C:\Users\rober\Desktop\1080 Ch6 Test-1.mkv"  -f mkv  -w 1280 --crop 0:0:108:6 --loose-anamorphic  --modulus 2 -e qsv_h264 -q 20 --cfr -a 1 -E av_aac -6 dpl2 -R 48 -B 160 -D 0 --gain 0 --audio-fallback ac3 --subtitle 1 --markers="C:\Users\rober\AppData\Local\Temp\1080 Ch6 Test-1-1-chapters.csv" --encoder-preset=balanced --encoder-level="4.1"  --verbose=1

[16:58:07] hb_init: starting libhb thread
HandBrake 0.10.5 (2016021100) - MinGW x86_64 - https://handbrake.fr
4 CPUs detected
Opening C:\Users\rober\Desktop\test\1080 ch6 test.mp4...
[16:58:07] CPU: Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz
[16:58:07]  - Intel microarchitecture Haswell
[16:58:07]  - logical processor count: 4
[16:58:07] OpenCL device #1: Intel(R) Corporation Intel(R) HD Graphics 4600
[16:58:07]  - OpenCL version: 1.2 
[16:58:07]  - driver version: 20.19.15.4331
[16:58:07]  - device type:    GPU
[16:58:07]  - supported:      YES
[16:58:07] Intel Quick Sync Video support: yes
[16:58:07]  - Intel Media SDK hardware: API 1.17 (minimum: 1.3)
[16:58:07]  - H.264 encoder: yes
[16:58:07]     - preferred implementation: hardware (any)
[16:58:07]  - H.265 encoder: no
[16:58:07] hb_scan: path=C:\Users\rober\Desktop\test\1080 ch6 test.mp4, title_index=1
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening C:\Users\rober\Desktop\test\1080 ch6 test.mp4/BDMV/index.bdmv
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening C:\Users\rober\Desktop\test\1080 ch6 test.mp4/BDMV/BACKUP/index.bdmv
libbluray/bluray.c:2182: nav_get_title_list(C:\Users\rober\Desktop\test\1080 ch6 test.mp4) failed
[16:58:07] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[16:58:07] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'C:\Users\rober\Desktop\test\1080 ch6 test.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    creation_time   : 2014-06-17 17:46:59
    encoder         : Lavf55.37.100
  Duration: 00:56:51.98, start: 0.021333, bitrate: 4150 kb/s
    Stream #0.0(eng): Video: h264 (High), yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], 3777 kb/s, 23.98 fps, 24k tbn, 47.95 tbc (default)
    Metadata:
      creation_time   : 2014-06-17 17:46:59
    Stream #0.1(und): Audio: aac, 48000 Hz, 5.1, fltp, 367 kb/s (default)
    Metadata:
      creation_time   : 2014-06-17 17:46:59
    Stream #0.2(eng): Subtitle: tx3g / 0x67337874, 0 kb/s (default)
    Metadata:
      creation_time   : 2014-06-17 17:46:59
[16:58:07] scan: decoding previews for title 1
[16:58:07] scan: audio 0x1: aac, rate=48000Hz, bitrate=367250 Unknown (AAC) (5.1 ch)
Scanning title 1 of 1, preview 1, 10.00 %
Scanning title 1 of 1, preview 4, 40.00 %
Scanning title 1 of 1, preview 10, 100.00 %[16:58:07] scan: 10 previews, 1920x1080, 23.976 fps, autocrop = 0/0/108/6, aspect 16:9, PAR 1:1
[16:58:07] libhb: scan thread found 1 valid title(s)
+ title 1:
  + stream: C:\Users\rober\Desktop\test\1080 ch6 test.mp4
  + duration: 00:56:51
  + size: 1920x1080, pixel aspect: 1/1, display aspect: 1.78, 23.976 fps
  + autocrop: 0/0/108/6
  + support opencl: yes
  + support hwd: yes
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 00:56:51
  + audio tracks:
    + 1, Unknown (AAC) (5.1 ch) (iso639-2: und)
  + subtitle tracks:
    + 1, English (iso639-2: eng) (Text)(TX3G)
Reading chapter markers from file C:\Users\rober\AppData\Local\Temp\1080 Ch6 Test-1-1-chapters.csv
[16:58:08] 1 job(s) to process
[16:58:08] starting job
[16:58:08] do_job: QSV: full path, removing unsupported filter 'Framerate Shaper'
[16:58:08] sync: expecting 81805 video frames
[16:58:08] work: only 1 chapter, disabling chapter markers
[16:58:08] job configuration:
[16:58:08]  * source
[16:58:08]    + C:\Users\rober\Desktop\test\1080 ch6 test.mp4
[16:58:08]    + title 1, chapter(s) 1 to 1
[16:58:08]    + container: mov,mp4,m4a,3gp,3g2,mj2
[16:58:08]    + data rate: 4150 kbps
[16:58:08]  * destination
[16:58:08]    + C:\Users\rober\Desktop\1080 Ch6 Test-1.mkv
[16:58:08]    + container: Matroska (libavformat)
[16:58:08]  * video track
[16:58:08]    + decoder: h264_qsv
[16:58:08]      + bitrate 3777 kbps
[16:58:08]    + filter
[16:58:08]      + Quick Sync Video VPP (1280:766:0:0:108:6_dei:0)
[16:58:08]        + source: 1920 * 1080, crop (0/0/108/6): 1806 * 1080, scale: 1280 * 766
[16:58:08]    + loose anamorphic
[16:58:08]      + storage dimensions: 1280 * 766, mod 2
[16:58:08]      + pixel aspect ratio: 21845 / 21829
[16:58:08]      + display dimensions: 1280 * 766
[16:58:08]    + encoder: H.264 (Intel Media SDK)
[16:58:08]      + preset:  balanced
[16:58:08]      + level:   4.1
[16:58:08]      + quality: 20.00 (ICQ)
[16:58:08]  * subtitle track 1, English (track 2, id 0x2) Text [TX3G] -> Passthrough
[16:58:08]  * audio track 1
[16:58:08]    + decoder: Unknown (AAC) (5.1 ch) (track 1, id 0x1)
[16:58:08]      + bitrate: 367 kbps, samplerate: 48000 Hz
[16:58:08]    + mixdown: Dolby Pro Logic II
[16:58:08]    + encoder: AAC (libavcodec)
[16:58:08]      + bitrate: 160 kbps, samplerate: 48000 Hz
[16:58:08] reader: first SCR 0 id 0x0 DTS -3753
[16:58:08] encqsvInit: using full QSV path
[16:58:08] encqsvInit: TargetUsage 4 AsyncDepth 4
[16:58:08] encqsvInit: GopRefDist 3 GopPicSize 24 NumRefFrame 1
[16:58:08] encqsvInit: BFrames on BPyramid off
[16:58:08] encqsvInit: AdaptiveI off AdaptiveB off
[16:58:08] encqsvInit: RateControlMethod ICQ ICQQuality 20
[16:58:08] encqsvInit: CAVLC off
[16:58:08] encqsvInit: ExtBRC off
[16:58:08] encqsvInit: MBBRC on
[16:58:08] encqsvInit: Trellis off
[16:58:08] encqsvInit: H.264 profile High @ level 4.1
[16:58:08] sync: first pts is 3753
[16:58:08] qsv_enc_init: using 'hardware (2)' implementation, API: 1.17
[17:01:52] reader: done. 1 scr changes
[17:01:52] work: average encoding speed for job is 364.783722 fps
[17:01:52] sync: got 81805 frames, 81805 expected
[17:01:52] qsv_filter[Default] done: max_surfaces: 11/80 , max_syncs: 8/60
[17:01:52] h264_qsv-decoder done: 81805 frames, 0 decoder errors, 0 drops
[17:01:52] aac-decoder done: 0 frames, 0 decoder errors, 0 drops
[17:01:52] mux: track 0, 81805 frames, 597931201 bytes, 1401.97 kbps, fifo 4096
[17:01:52] mux: track 1, 159936 frames, 68358785 bytes, 160.28 kbps, fifo 8192
[17:01:52] mux: track 2, 833 frames, 44063 bytes, 0.10 kbps, fifo 64
[17:01:52] libhb: work result = 0
Encode done!
HandBrake has exited. 

Post Reply