mkv decoding stops early

Discussion of the HandBrake command line interface (CLI)
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
earl
Posts: 3
Joined: Mon May 23, 2016 2:26 pm

mkv decoding stops early

Post by earl » Mon May 23, 2016 2:57 pm

I'm hoping to get some help figuring out why the transcoder is stopping early.

When transcoding a DVD to MKV, the transcoding task comes to a halt early with no obvious indication that an error occurred:

Code: Select all

handbrake -t 1 -E copy --keep-display-aspect --preset Normal --markers -i ./test.iso -o ./test.mkv
Encoding: task 1 of 1, 3.18 % (43.72 fps, avg 36.36 fps, ETA 00h43m32s)
I have tried several versions of handbrake, including 0.10.5, all built from source. The current version I tried is:

Code: Select all

commit 40f80f674c5c56ae72d41c72ce42b90789904829
Author: John Stebbins <jstebbins.hb@gmail.com>
Date:   Tue May 17 16:46:01 2016 -0600

    sync: estimate video frame drop duration better
I'm running on Linux, and by editing main.defs, forced the build to include the following modules from source:

Code: Select all

    MODULES += contrib/fontconfig
    MODULES += contrib/freetype
    MODULES += contrib/fribidi
    MODULES += contrib/libxml2
    MODULES += contrib/libass
    MODULES += contrib/libogg
    MODULES += contrib/libvorbis
    MODULES += contrib/libtheora
    MODULES += contrib/libsamplerate
    MODULES += contrib/lame
    MODULES += contrib/x264
    MODULES += contrib/jansson
The log of this run can be found at http://pastebin.com/xejUjZs9. I'm thinking that the key line in this log is:

Code: Select all

sync: got 3138 frames, 98117 expected

rollin_eng
Veteran User
Posts: 3022
Joined: Wed May 04, 2011 11:06 pm

Re: mkv decoding stops early

Post by rollin_eng » Mon May 23, 2016 4:05 pm

What did you use to create your ISO and/or remove decryption?

earl
Posts: 3
Joined: Mon May 23, 2016 2:26 pm

Re: mkv decoding stops early

Post by earl » Tue May 24, 2016 3:35 pm

rollin_eng wrote:What did you use to create your ISO and/or remove decryption?
This is an old ISO, so I don't remember so clearly. I have other ISOs for which I have the same issue. They all share the same characteristic: a bunch of short tracks, with no single long feature. I believe I used either DVDFab or DVDDecrypter I think.

grl
Posts: 4
Joined: Sat Jun 04, 2016 3:46 pm

Re: mkv decoding stops early

Post by grl » Sat Jun 04, 2016 3:52 pm

Any news on that? I think I came across the same errror.

Trying to convert some older mp4 for use on a tablet. The convert just stops at some point (always the same point!) and doesn't proceed. No error message, no nothing - just stops. Waited for 24h+ but it doesn't proceed.

I use as a command line (debian sid, HandbrakeCLI 0.10.5 out of repos):

Code: Select all

HandBrakeCLI -i oldvid.mp4 -o tabletvid.mp4 --preset="Android Tablet"
and the last line I see is:

Code: Select all

Encoding: task 1 of 1, 17.26 % (116.32 fps, avg 135.43 fps, ETA 00h15m33s)
Any help appreciated!

Lukas

rollin_eng
Veteran User
Posts: 3022
Joined: Wed May 04, 2011 11:06 pm

Re: mkv decoding stops early

Post by rollin_eng » Sat Jun 04, 2016 4:47 pm

Could you please post your logs, instructions can be found here:

viewtopic.php?f=6&t=31236

grl
Posts: 4
Joined: Sat Jun 04, 2016 3:46 pm

Re: mkv decoding stops early

Post by grl » Sat Jun 04, 2016 5:03 pm

Did that already in a new topic - don't want to hijack this one, as the OP starts from MKV, I start from mp4.
viewtopic.php?f=10&t=34703

earl
Posts: 3
Joined: Mon May 23, 2016 2:26 pm

Re: mkv decoding stops early

Post by earl » Sat Jun 04, 2016 9:17 pm

I try to dig around some more.

Post Reply