-O no longer with with the latest builds

Discussion of the HandBrake command line interface (CLI)
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
ramitbhalla
Regular User
Posts: 103
Joined: Sat Jan 18, 2014 12:12 am

-O no longer with with the latest builds

Post by ramitbhalla »

All of a sudden the -O option doesn't work, it says unrecognized option and fails. With SVN7149 it worked fine with SVN7172 it doesn't work. however --optimize does work
Anyone know if this is by design or a bug?
mduell
Veteran User
Posts: 7438
Joined: Sat Apr 21, 2007 8:54 pm

Re: -O no longer with with the latest builds

Post by mduell »

ramitbhalla
Regular User
Posts: 103
Joined: Sat Jan 18, 2014 12:12 am

Re: -O no longer with with the latest builds

Post by ramitbhalla »

My bad, here you go:

Code: Select all

C:\Users\rb\Desktop>HandBrakeCLI.exe -i test.ts -o test.mp4 -e x264 -E copy -O
unknown option (-O)

C:\Users\rb\Desktop>HandBrakeCLI.exe -i test.ts -o test.mp4 -e x264 -E copy --optimize
[15:39:52] hb_init: starting libhb thread
HandBrake svn7172 (2015051301) - MinGW i686 - https://handbrake.fr
4 CPUs detected
Opening test.ts...
[15:39:52] CPU: Intel(R) Core(TM) i7-3540M CPU @ 3.00GHz
[15:39:52]  - Intel microarchitecture Ivy Bridge
[15:39:52]  - logical processor count: 4
[15:39:52] OpenCL device #1: Intel(R) Corporation Intel(R) HD Graphics 4000
[15:39:52]  - OpenCL version: 1.2
[15:39:52]  - driver version: 10.18.10.3958
[15:39:52]  - device type:    GPU
[15:39:52]  - supported:      no
[15:39:52] Intel Quick Sync Video support: yes
[15:39:52]  - Intel Media SDK hardware: API 1.11 (minimum: 1.3)
[15:39:52]  - H.264 encoder: yes
[15:39:52]     - preferred implementation: hardware (any)
[15:39:52]     - capabilities (hardware):  extbrc ib_adapt nmpslice
[15:39:52] hb_scan: path=test.ts, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:251: failed opening UDF image test.ts
src/libbluray/disc/disc.c:332: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:332: error opening file BDMV\BACKUP\index.bdmv
src/libbluray/bluray.c:2373: nav_get_title_list(test.ts\) failed
[15:39:52] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[15:39:52] dvd: not a dvd - trying as a stream/file instead
[15:39:52] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[15:39:52] Found the following PIDS
[15:39:52]     Video PIDS :
[15:39:52]       0x100 type H.264 (0x1b) (PCR)
[15:39:52]     Audio PIDS :
[15:39:52]       0x101 type AC3 (0x81)
[15:39:52]     Subtitle PIDS :
[15:39:52]     Other PIDS :
[15:39:52] stream id 0x101 (type 0x81 substream 0x0) audio 0x101
[15:39:52] hb_ts_stream_getPEStype: EOF while searching for PID 0x100
[15:39:52] hb_sample_pts: couldn't find video packet near 4428765
[15:39:52] hb_ts_stream_getPEStype: EOF while searching for PID 0x100
[15:39:52] hb_sample_pts: couldn't find video packet near 4463775
[15:39:52] scan: decoding previews for title 1
[15:39:52] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[15:39:52] Broken timestamps detected.  Reordering.
[ac3 @ 04954c80] frame sync error
[15:39:52] scan: audio 0x101: ac3, rate=48000Hz, bitrate=384000 English (AC3) (5.1 ch)
Scanning title 1 of 1, preview 6, 60.00 %[15:39:52] hb_ts_stream_decode - eof
[15:39:52] Warning: Could not read data for preview 9, skipped
[15:39:52] stream: 105 good frames, 0 errors (0%)
[15:39:52] scan: 8 previews, 1920x1080, 59.940 fps, autocrop = 0/2/0/0, aspect 16:9, PAR 1:1
[15:39:52] libhb: scan thread found 1 valid title(s)
+ Using preset: Normal
+ title 1:
  + stream: test.ts
  + duration: 00:00:07
  + size: 1920x1080, pixel aspect: 1/1, display aspect: 1.78, 1.000 fps
  + autocrop: 0/2/0/0
  + support opencl: no
  + support hwd: yes
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 00:00:07
  + audio tracks:
    + 1, English (AC3) (5.1 ch) (iso639-2: eng), 48000Hz, 384000bps
  + subtitle tracks:
[15:39:52] 1 job(s) to process
[15:39:52] starting job
[15:39:52] sync: expecting 452 video frames
[15:39:52] job configuration:
[15:39:52]  * source
[15:39:52]    + test.ts
[15:39:52]    + title 1, chapter(s) 1 to 1
[15:39:52]  * destination
[15:39:52]    + test.mp4
[15:39:52]    + container: MPEG-4 (libavformat)
[15:39:52]  * video track
[15:39:52]    + decoder: h264
[15:39:52]      + bitrate 200 kbps
[15:39:52]    + filters
[15:39:52]      + Framerate Shaper (0)
[15:39:52]        + frame rate: same as source (around 59.940 fps)
[15:39:52]      + Crop and Scale (1920:1078:0:2:0:0)
[15:39:52]        + source: 1920 * 1080, crop (0/2/0/0): 1920 * 1078, scale: 1920 * 1078
[15:39:52]    + Output geometry
[15:39:52]      + storage dimensions: 1920 x 1078
[15:39:52]      + pixel aspect ratio: 1 : 1
[15:39:52]      + display dimensions: 1920 x 1078
[15:39:52]    + encoder: H.264 (libx264)
[15:39:52]      + preset:  veryfast
[15:39:52]      + profile: main
[15:39:52]      + level:   4.0
[15:39:52]      + quality: 20.00 (RF)
[15:39:52]  * audio track 1
[15:39:52]    + decoder: English (AC3) (5.1 ch) (track 1, id 0x101)
[15:39:52]      + bitrate: 384 kbps, samplerate: 48000 Hz
[15:39:52]    + AC3 Passthru
[15:39:52] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[15:39:52] encx264: min-keyint: 60, keyint: 600
[15:39:52] reader: first SCR 0 id 0x100 DTS 0
[15:39:52] encx264: encoding at constant RF 20.000000
[15:39:52] hb_apply_h264_level [warning]: framerate (59.940) too high for level 4.0 at 1920x1078 (max. 30.118)
[15:39:52] encx264: unparsed options: level=4.0:trellis=0:ref=1:rc-lookahead=10:8x8dct=0:weightp=1:subme=2:mixed-refs=0:
vbv-bufsize=25000:vbv-maxrate=20000
x264 [info]: using SAR=1/1
x264 [warning]: MB rate (489110) > level limit (245760)
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX
x264 [info]: profile Main, level 4.0
[15:39:53] h264: "Chapter 1" (1) at frame 0 time 96973
[15:39:53] Broken timestamps detected.  Reordering.
[15:39:53] sync: first pts is 96973
[15:39:53] sync: video time didn't advance - dropped 4 frames (delta 83 ms, current 12012, next 13512, dur 1500)
Encoding: task 1 of 1, 1.99 %[15:39:53] sync: adding 778 ms of silence to audio 0x101  start 70086, next 0
E15:39:53] sync: audio 0x101 time went backwards 21 ms, dropped 1 frames (start 72966, next 74880)
Encoding: task 1 of 1, 14.82 %Signal 2 received, terminating - do it again in case it gets stuck
Encoding: task 1 of 1, 15.93 %[15:39:54] work: average encoding speed for job is 0.000000 fps
[15:39:54] reader: done. 2 scr changes
[15:39:55] sync: got 75 frames, 452 expected
[15:39:55] render: lost time: 0 (0 frames)
[15:39:55] render: gained time: 0 (0 frames) (0 not accounted for)
[15:39:55] h264-decoder done: 102 frames, 0 decoder errors, 0 drops
x264 [info]: frame I:1     Avg QP:17.51  size: 82097
x264 [info]: frame P:14    Avg QP:22.82  size: 34000
x264 [info]: frame B:15    Avg QP:25.72  size:  3675
x264 [info]: consecutive B-frames: 25.8% 12.9%  9.7% 51.6%
x264 [info]: mb I  I16..4: 40.2%  0.0% 59.8%
x264 [info]: mb P  I16..4: 16.3%  0.0%  8.0%  P16..4: 24.0% 11.9%  5.2%  0.0%  0.0%    skip:34.6%
x264 [info]: mb B  I16..4:  0.4%  0.0%  0.1%  B16..8:  9.2%  1.7%  0.1%  direct: 5.5%  skip:83.0%  L0:39.1% L1:53.7% BI:
 7.1%
x264 [info]: coded y,uvDC,uvAC intra: 36.7% 61.0% 8.2% inter: 7.1% 17.2% 0.3%
x264 [info]: i16 v,h,dc,p: 32% 32% 26% 10%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 38% 27% 17%  4%  3%  3%  3%  3%  3%
x264 [info]: i8c dc,h,v,p: 37% 26% 27% 10%
x264 [info]: Weighted P-Frames: Y:0.0% UV:0.0%
x264 [info]: kb/s:7947.46
[15:39:55] ac3-decoder done: 0 frames, 0 decoder errors, 0 drops
[15:39:55] mux: track 0, 0 frames, 0 bytes, 0.00 kbps, fifo 32
[15:39:55] mux: track 1, 0 frames, 0 bytes, 0.00 kbps, fifo 128
[15:39:55] stream: 134 good frames, 0 errors (0%)

HandBrake has exited.
Last edited by Rodeo on Sat May 23, 2015 1:13 pm, edited 1 time in total.
Reason: Logs must be placed between [code][/code] blocks
User avatar
JohnAStebbins
HandBrake Team
Posts: 5588
Joined: Sat Feb 09, 2008 7:21 pm

Re: -O no longer with with the latest builds

Post by JohnAStebbins »

Should be fixed in the next nightly build
http://trac.handbrake.fr/changeset/7176
ramitbhalla
Regular User
Posts: 103
Joined: Sat Jan 18, 2014 12:12 am

Re: -O no longer with with the latest builds

Post by ramitbhalla »

thanks. BTW slightly off topic, I saw this in the timeline:

Changeset [7160] by jstebbins
cli: fix off-by-one audio track selection

I checked with SNV7149 and the audio selection works fine from the CLI, was this bug introduced later? Reason I'm asking is I'm looking for a stable SVN build and the latest 7172 build has an issue (which I'll post in a different thread), SNV7149 is working great but then I saw this message and wanted to confirm that I'm not missing something. In all my tests 7149 seemed to select the audio tracks fine.

thanks
ramitbhalla
Regular User
Posts: 103
Joined: Sat Jan 18, 2014 12:12 am

Re: -O no longer with with the latest builds

Post by ramitbhalla »

@JohnAStebbins, can you shed some light on the above fix please
User avatar
JohnAStebbins
HandBrake Team
Posts: 5588
Joined: Sat Feb 09, 2008 7:21 pm

Re: -O no longer with with the latest builds

Post by JohnAStebbins »

ramitbhalla wrote:thanks. BTW slightly off topic, I saw this in the timeline:

Changeset [7160] by jstebbins
cli: fix off-by-one audio track selection

I checked with SNV7149 and the audio selection works fine from the CLI, was this bug introduced later? Reason I'm asking is I'm looking for a stable SVN build and the latest 7172 build has an issue (which I'll post in a different thread), SNV7149 is working great but then I saw this message and wanted to confirm that I'm not missing something. In all my tests 7149 seemed to select the audio tracks fine.

thanks
The recent rash of issues in the CLI were introduced in https://trac.handbrake.fr/changeset/7158
It is a major change to how the CLI works and I made a few errors. I really appreciate the reports you've made. They have helped to quickly solve some issues.
drizzle
Posts: 9
Joined: Fri Nov 22, 2013 5:39 pm

Re: -O no longer with with the latest builds

Post by drizzle »

After svn7158 the handbrakeCLI seems to default to preset=veryfast. Is this the intended behavior?
eg. from the above listing -
[15:39:52] + preset: veryfast

pre-svc7158 the CLI seems to default more like preset=medium
ramitbhalla
Regular User
Posts: 103
Joined: Sat Jan 18, 2014 12:12 am

Re: -O no longer with with the latest builds

Post by ramitbhalla »

I understand john, I was interested specifically with SVN7160, was this a bug related to 7158 or before and is it under specific conditions or generally applicable? That would be very helpful for me. I'll continue to test and provide feedback.
User avatar
JohnAStebbins
HandBrake Team
Posts: 5588
Joined: Sat Feb 09, 2008 7:21 pm

Re: -O no longer with with the latest builds

Post by JohnAStebbins »

ramitbhalla wrote:I understand john, I was interested specifically with SVN7160, was this a bug related to 7158 or before and is it under specific conditions or generally applicable? That would be very helpful for me. I'll continue to test and provide feedback.
Yes, it was caused by 7158
User avatar
JohnAStebbins
HandBrake Team
Posts: 5588
Joined: Sat Feb 09, 2008 7:21 pm

Re: -O no longer with with the latest builds

Post by JohnAStebbins »

drizzle wrote:After svn7158 the handbrakeCLI seems to default to preset=veryfast. Is this the intended behavior?
eg. from the above listing -
[15:39:52] + preset: veryfast

pre-svc7158 the CLI seems to default more like preset=medium
The default is now HandBrake's "Normal" preset (which happens to use x264 preset "veryfast"). This makes it more consistent with the GUIs which also default to the "Normal" preset.
dstocker
Posts: 7
Joined: Tue Jan 17, 2012 4:56 am

Re: -O no longer with with the latest builds

Post by dstocker »

Hi,

Am also having trouble , on Ubuntu 15.04 and 14.04 -O and --optimize are both are being ignored, not sure if it's the version or would there be an issue with with my string?

--format mp4 --encoder x264 --optimize --markers --width 1280 --modulus 2 --vb 1575 --two-pass --turbo --optimize faac --arate Auto -B 192 --drc 3.0 --native-language eng --native-dub --h264-level 3.1 -x level=3.1:vbv-bufsize=3534:vbv-maxrate=1767 --encoder-profile=high --x264-preset=medium --verbose=1

If the string is ok, would there be a stable 0.10.1 that can be installed on Vivid/15.04?

Cheers.
D

Code: Select all

[20:19:27] hb_init: starting libhb thread
HandBrake svn7217 (2015052201) - Linux x86_64 - https://handbrake.fr
4 CPUs detected
Opening ./test_file.mkv...
[20:19:28] CPU: Common KVM processor
[20:19:28]  - logical processor count: 4
[20:19:28] OpenCL: library not available
[20:19:28] hb_scan: path=./test_file.mkv, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
disc.c:251: failed opening UDF image ./test_file.mkv
disc.c:332: error opening file BDMV/index.bdmv
disc.c:332: error opening file BDMV/BACKUP/index.bdmv
bluray.c:2373: nav_get_title_list(./test_file.mkv/) failed
[20:19:28] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[20:19:28] dvd: not a dvd - trying as a stream/file instead
Input #0, matroska,webm, from './test_file.mkv':
  Duration: 00:02:03.35, start: 0.000000, bitrate: N/A
    Stream #0.0: Video: h264 (High), yuv420p, 1280x720, PAR 1:1 DAR 16:9, 29.97 fps, 1k tbn, 59.94 tbc (default)
    Metadata:
      BPS             : 1736517
      BPS-eng         : 1736517
      DURATION        : 00:02:03.356000000
      DURATION-eng    : 00:02:03.356000000
      NUMBER_OF_FRAMES: 3697
      NUMBER_OF_FRAMES-eng: 3697
      NUMBER_OF_BYTES : 26776239
      NUMBER_OF_BYTES-eng: 26776239
      _STATISTICS_WRITING_APP: mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
      _STATISTICS_WRITING_APP-eng: mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
      _STATISTICS_WRITING_DATE_UTC: 2015-05-15 21:51:57
      _STATISTICS_WRITING_DATE_UTC-eng: 2015-05-15 21:51:57
      _STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
      _STATISTICS_TAGS-eng: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
    Stream #0.1: Audio: aac, 44100 Hz, stereo, fltp (default)
    Metadata:
      BPS             : 76090
      BPS-eng         : 76090
      DURATION        : 00:02:03.344000000
      DURATION-eng    : 00:02:03.344000000
      NUMBER_OF_FRAMES: 5312
      NUMBER_OF_FRAMES-eng: 5312
      NUMBER_OF_BYTES : 1173162
      NUMBER_OF_BYTES-eng: 1173162
      _STATISTICS_WRITING_APP: mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
      _STATISTICS_WRITING_APP-eng: mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
      _STATISTICS_WRITING_DATE_UTC: 2015-05-15 21:51:57
      _STATISTICS_WRITING_DATE_UTC-eng: 2015-05-15 21:51:57
      _STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
      _STATISTICS_TAGS-eng: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
[20:19:28] scan: decoding previews for title 1
[20:19:28] scan: audio 0x1: aac, rate=44100Hz, bitrate=1 Unknown (AAC) (2.0 ch)
Scanning title 1 of 1, preview 8, 80.00 %[20:19:28] scan: 10 previews, 1280x720, 29.970 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[20:19:28] libhb: scan thread found 1 valid title(s)
+ Using preset: Normal
+ title 1:
  + stream: ./test_file.mkv
  + duration: 00:02:03
  + size: 1280x720, pixel aspect: 1/1, display aspect: 1.78, 1.000 fps
  + autocrop: 0/0/0/0
  + support opencl: no
  + support hwd: not built-in
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 00:02:03
  + audio tracks:
    + 1, Unknown (AAC) (2.0 ch) (iso639-2: und)
  + subtitle tracks:
[20:19:28] 1 job(s) to process
[20:19:28] work: failed to initialize OpenCL environment, using fallback
[20:19:28] starting job
[20:19:28] work: sanitizing track 1 mixdown Dolby Pro Logic II to Stereo
[20:19:28] sync: expecting 3696 video frames
[20:19:28] job configuration:
[20:19:28]  * source
[20:19:28]    + ./test_file.mkv
[20:19:28]    + title 1, chapter(s) 1 to 1
[20:19:28]    + container: matroska,webm
[20:19:28]  * destination
[20:19:28]    + ./test_file.mp4
[20:19:28]    + container: MPEG-4 (libavformat)
[20:19:28]  * video track
[20:19:28]    + decoder: h264
[20:19:28]    + filters
[20:19:28]      + Framerate Shaper (0)
[20:19:28]        + frame rate: same as source (around 29.970 fps)
[20:19:28]      + Crop and Scale (1280:720:0:0:0:0)
[20:19:28]        + source: 1280 * 720, crop (0/0/0/0): 1280 * 720, scale: 1280 * 720
[20:19:28]    + Output geometry
[20:19:28]      + storage dimensions: 1280 x 720
[20:19:28]      + pixel aspect ratio: 1 : 1
[20:19:28]      + display dimensions: 1280 x 720
[20:19:28]    + encoder: H.264 (libx264)
[20:19:28]      + preset:  medium
[20:19:28]      + options: level=3.1:vbv-bufsize=3534:vbv-maxrate=1767
[20:19:28]      + profile: high
[20:19:28]      + level:   3.1
[20:19:28]      + bitrate: 1575 kbps, pass: 1
[20:19:28]      + fast first pass
[20:19:28]      + options: ref=1:8x8dct=0:me=dia:trellis=0
[20:19:28]                 analyse=i4x4 (if originally enabled, else analyse=none)
[20:19:28]                 subq=2 (if originally greater than 2, else subq unchanged)
[20:19:28]  * audio track 1
[20:19:28]    + decoder: Unknown (AAC) (2.0 ch) (track 1, id 0x1)
[20:19:28]      + samplerate: 44100 Hz
[20:19:28]    + mixdown: Stereo
[20:19:28]    + dither: triangular
[20:19:28]    + encoder: AAC (libfdk_aac)
[20:19:28]      + bitrate: 192 kbps, samplerate: 44100 Hz
[20:19:28] reader: first SCR 0 id 0x0 DTS 0
[20:19:28] encx264: min-keyint: 30, keyint: 300
[20:19:28] encx264: encoding at average bitrate 1575
[20:19:28] encx264: unparsed options: vbv-maxrate=1767:level=3.1:vbv-bufsize=3534
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2 SSE3 Cache64
x264 [info]: profile Main, level 3.1
Encoding: task 1 of 2, 97.81 % (119.23 fps, avg 115.64 fps, ETA 00h00m00s)[20:20:00] reader: done. 1 scr changes
Encoding: task 1 of 2, 100.00 % (119.23 fps, avg 115.64 fps, ETA 00h00m00s)[20:20:01] work: average encoding speed for job is 115.639015 fps
[20:20:01] sync: got 3697 frames, 3696 expected
[20:20:01] render: lost time: 0 (0 frames)
[20:20:01] render: gained time: 0 (0 frames) (0 not accounted for)
Encoding: task 1 of 2, 100.00 % (119.23 fps, avg 115.64 fps, ETA 00h00m00s)[20:20:01] h264-decoder done: 3697 frames, 0 decoder errors, 0 drops
x264 [info]: frame I:15    Avg QP:14.87  size: 59832
x264 [info]: frame P:1306  Avg QP:17.19  size: 11971
x264 [info]: frame B:2376  Avg QP:19.46  size:  3211
x264 [info]: consecutive B-frames: 13.9%  0.6%  1.5% 84.0%
x264 [info]: mb I  I16..4: 34.4%  0.0% 65.6%
x264 [info]: mb P  I16..4: 15.7%  0.0%  0.0%  P16..4: 52.1%  0.0%  0.0%  0.0%  0.0%    skip:32.2%
x264 [info]: mb B  I16..4:  2.0%  0.0%  0.0%  B16..8: 17.2%  0.0%  0.0%  direct:14.2%  skip:66.5%  L0:43.6% L1:44.8% BI:11.5%
x264 [info]: coded y,uvDC,uvAC intra: 15.5% 67.9% 17.6% inter: 6.3% 23.4% 0.2%
x264 [info]: i16 v,h,dc,p: 56% 25% 15%  4%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 35% 24% 16%  2%  6%  4%  4%  4%  5%
x264 [info]: i8c dc,h,v,p: 50% 21% 26%  3%
x264 [info]: Weighted P-Frames: Y:1.0% UV:0.8%
x264 [info]: kb/s:1566.86
[20:20:01] aac-decoder done: 0 frames, 0 decoder errors, 0 drops
[20:20:01] work: failed to initialize OpenCL environment, using fallback
[20:20:01] starting job
[20:20:01] work: sanitizing track 1 mixdown Dolby Pro Logic II to Stereo
[20:20:01] sync: expecting 3697 video frames
[20:20:01] job configuration:
[20:20:01]  * source
[20:20:01]    + ./test_file.mkv
[20:20:01]    + title 1, chapter(s) 1 to 1
[20:20:01]    + container: matroska,webm
[20:20:01]  * destination
[20:20:01]    + ./test_file.mp4
[20:20:01]    + container: MPEG-4 (libavformat)
[20:20:01]  * video track
[20:20:01]    + decoder: h264
[20:20:01]    + filters
[20:20:01]      + Framerate Shaper (0)
[20:20:01]        + frame rate: same as source (around 29.970 fps)
[20:20:01]      + Crop and Scale (1280:720:0:0:0:0)
[20:20:01]        + source: 1280 * 720, crop (0/0/0/0): 1280 * 720, scale: 1280 * 720
[20:20:01]    + Output geometry
[20:20:01]      + storage dimensions: 1280 x 720
[20:20:01]      + pixel aspect ratio: 1 : 1
[20:20:01]      + display dimensions: 1280 x 720
[20:20:01]    + encoder: H.264 (libx264)
[20:20:01]      + preset:  medium
[20:20:01]      + options: level=3.1:vbv-bufsize=3534:vbv-maxrate=1767
[20:20:01]      + profile: high
[20:20:01]      + level:   3.1
[20:20:01]      + bitrate: 1575 kbps, pass: 2
[20:20:01]  * audio track 1
[20:20:01]    + decoder: Unknown (AAC) (2.0 ch) (track 1, id 0x1)
[20:20:01]      + samplerate: 44100 Hz
[20:20:01]    + mixdown: Stereo
[20:20:01]    + dither: triangular
[20:20:01]    + encoder: AAC (libfdk_aac)
[20:20:01]      + bitrate: 192 kbps, samplerate: 44100 Hz
[20:20:01] reader: first SCR 0 id 0x0 DTS 0
[20:20:01] encx264: min-keyint: 30, keyint: 300
[20:20:01] encx264: encoding at average bitrate 1575
[20:20:01] encx264: unparsed options: vbv-maxrate=1767:level=3.1:vbv-bufsize=3534
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2 SSE3 Cache64
x264 [info]: profile High, level 3.1
Encoding: task 2 of 2, 98.40 % (36.76 fps, avg 35.43 fps, ETA 00h00m02s)[20:21:44] reader: done. 1 scr changes
Encoding: task 2 of 2, 99.97 % (39.92 fps, avg 35.52 fps, ETA 00h00m00s)[20:21:46] work: average encoding speed for job is 35.523773 fps
[20:21:46] sync: got 3697 frames, 3697 expected
Encoding: task 2 of 2, 99.97 % (39.92 fps, avg 35.52 fps, ETA 00h00m00s)[20:21:46] render: lost time: 0 (0 frames)
[20:21:46] render: gained time: 0 (0 frames) (0 not accounted for)
[20:21:46] h264-decoder done: 3697 frames, 0 decoder errors, 0 drops
x264 [info]: frame I:15    Avg QP:15.43  size: 52114
x264 [info]: frame P:1306  Avg QP:18.05  size: 11360
x264 [info]: frame B:2376  Avg QP:20.44  size:  3620
x264 [info]: consecutive B-frames: 13.9%  0.6%  1.5% 84.0%
x264 [info]: mb I  I16..4: 21.9% 57.2% 20.9%
x264 [info]: mb P  I16..4:  6.4%  7.6%  0.5%  P16..4: 36.9% 11.0%  4.8%  0.0%  0.0%    skip:32.6%
x264 [info]: mb B  I16..4:  0.8%  0.9%  0.0%  B16..8: 35.4%  2.6%  0.2%  direct: 6.2%  skip:53.8%  L0:49.4% L1:47.9% BI: 2.6%
x264 [info]: 8x8 transform intra:52.4% inter:79.4%
x264 [info]: coded y,uvDC,uvAC intra: 24.5% 65.6% 17.6% inter: 6.7% 20.7% 0.3%
x264 [info]: i16 v,h,dc,p: 49% 27% 14% 11%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 21% 16% 47%  2%  3%  3%  3%  3%  2%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 31% 17% 17%  4%  7%  9%  5%  6%  4%
x264 [info]: i8c dc,h,v,p: 50% 22% 25%  3%
x264 [info]: Weighted P-Frames: Y:1.0% UV:0.8%
x264 [info]: ref P L0: 68.0%  5.9% 18.0%  8.1%  0.0%
x264 [info]: ref B L0: 89.6%  8.1%  2.3%
x264 [info]: ref B L1: 95.3%  4.7%
x264 [info]: kb/s:1570.71
[20:21:46] aac-decoder done: 0 frames, 0 decoder errors, 0 drops
Muxing: this may take awhile...[20:21:47] mux: track 0, 3697 frames, 24219099 bytes, 1571.10 kbps, fifo 2048
[20:21:47] mux: track 1, 5312 frames, 2960405 bytes, 192.04 kbps, fifo 4096
[20:21:47] libhb: work result = 0

Encode done!

HandBrake has exited.
me@vividbox3:/srv/videos/encode-test$ 
Last edited by Rodeo on Sat May 23, 2015 1:12 pm, edited 1 time in total.
Reason: Logs must be placed between [code][/code] blocks
User avatar
Rodeo
HandBrake Team
Posts: 12757
Joined: Tue Mar 03, 2009 8:55 pm

Re: -O no longer with with the latest builds

Post by Rodeo »

dstocker wrote:[…] --optimize […] --optimize faac […]
The latter is invalid syntax and is most likely what messes with the final settings.
dstocker
Posts: 7
Joined: Tue Jan 17, 2012 4:56 am

Re: -O no longer with with the latest builds

Post by dstocker »

Hi Rodeo,

Thanks for spotting that. Not sure if copy paste error when posting; re-did the string and the encode:

Code: Select all

--format mp4 --encoder x264 --optimize --markers --width 1280 --modulus 2 --vb 1575 --two-pass --turbo --aencoder faac --arate Auto -B 192 --drc 3.0 --native-language eng --native-dub --h264-level 3.1 -x level=3.1:vbv-bufsize=3534:vbv-maxrate=1767 --encoder-profile=high --x264-preset=medium --verbose=1
Unfortunately, no difference in the result, still not web optimized:

Media

Video Resolution 720p
Duration 2:03
Bitrate 1771 kbps
Width 1280
Height 720
Aspect Ratio 1.78
Container MP4
Video Frame Rate NTSC
Web Optimized No
Has 64bit Offsets 0
Part

Duration 2:03
File s01e01 test_file.mp4
Size 26.04 MB
Container MP4
Has 64bit Offsets 0
Web Optimized No <------------
Video

Code: Select all

[06:42:28] hb_init: starting libhb thread
HandBrake svn7217 (2015052201) - Linux x86_64 - https://handbrake.fr
4 CPUs detected
Opening ./test_file.mkv...
[06:42:28] CPU: Common KVM processor
[06:42:28]  - logical processor count: 4
[06:42:28] OpenCL: library not available
[06:42:28] hb_scan: path=./test_file.mkv, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
disc.c:251: failed opening UDF image ./test_file.mkv
disc.c:332: error opening file BDMV/index.bdmv
disc.c:332: error opening file BDMV/BACKUP/index.bdmv
bluray.c:2373: nav_get_title_list(./test_file.mkv/) failed
[06:42:28] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[06:42:28] dvd: not a dvd - trying as a stream/file instead
Input #0, matroska,webm, from './test_file.mkv':
  Duration: 00:02:03.35, start: 0.000000, bitrate: N/A
    Stream #0.0: Video: h264 (High), yuv420p, 1280x720, PAR 1:1 DAR 16:9, 29.97 fps, 1k tbn, 59.94 tbc (default)
    Metadata:
      BPS             : 1736517
      BPS-eng         : 1736517
      DURATION        : 00:02:03.356000000
      DURATION-eng    : 00:02:03.356000000
      NUMBER_OF_FRAMES: 3697
      NUMBER_OF_FRAMES-eng: 3697
      NUMBER_OF_BYTES : 26776239
      NUMBER_OF_BYTES-eng: 26776239
      _STATISTICS_WRITING_APP: mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
      _STATISTICS_WRITING_APP-eng: mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
      _STATISTICS_WRITING_DATE_UTC: 2015-05-15 21:51:57
      _STATISTICS_WRITING_DATE_UTC-eng: 2015-05-15 21:51:57
      _STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
      _STATISTICS_TAGS-eng: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
    Stream #0.1: Audio: aac, 44100 Hz, stereo, fltp (default)
    Metadata:
      BPS             : 76090
      BPS-eng         : 76090
      DURATION        : 00:02:03.344000000
      DURATION-eng    : 00:02:03.344000000
      NUMBER_OF_FRAMES: 5312
      NUMBER_OF_FRAMES-eng: 5312
      NUMBER_OF_BYTES : 1173162
      NUMBER_OF_BYTES-eng: 1173162
      _STATISTICS_WRITING_APP: mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
      _STATISTICS_WRITING_APP-eng: mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
      _STATISTICS_WRITING_DATE_UTC: 2015-05-15 21:51:57
      _STATISTICS_WRITING_DATE_UTC-eng: 2015-05-15 21:51:57
      _STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
      _STATISTICS_TAGS-eng: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
[06:42:29] scan: decoding previews for title 1
[06:42:29] scan: audio 0x1: aac, rate=44100Hz, bitrate=1 Unknown (AAC) (2.0 ch)
Scanning title 1 of 1, preview 4, 40.00 %[06:42:29] scan: 10 previews, 1280x720, 29.970 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[06:42:29] libhb: scan thread found 1 valid title(s)
+ Using preset: Normal
+ title 1:
  + stream: ./test_file.mkv
  + duration: 00:02:03
  + size: 1280x720, pixel aspect: 1/1, display aspect: 1.78, 1.000 fps
  + autocrop: 0/0/0/0
  + support opencl: no
  + support hwd: not built-in
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 00:02:03
  + audio tracks:
    + 1, Unknown (AAC) (2.0 ch) (iso639-2: und)
  + subtitle tracks:
[06:42:29] 1 job(s) to process
[06:42:29] work: failed to initialize OpenCL environment, using fallback
[06:42:29] starting job
[06:42:29] work: sanitizing track 1 mixdown Dolby Pro Logic II to Stereo
[06:42:29] sync: expecting 3696 video frames
[06:42:29] job configuration:
[06:42:29]  * source
[06:42:29]    + ./test_file.mkv
[06:42:29]    + title 1, chapter(s) 1 to 1
[06:42:29]    + container: matroska,webm
[06:42:29]  * destination
[06:42:29]    + ./test_file.mp4
[06:42:29]    + container: MPEG-4 (libavformat)
[06:42:29]  * video track
[06:42:29]    + decoder: h264
[06:42:29]    + filters
[06:42:29]      + Framerate Shaper (0)
[06:42:29]        + frame rate: same as source (around 29.970 fps)
[06:42:29]      + Crop and Scale (1280:720:0:0:0:0)
[06:42:29]        + source: 1280 * 720, crop (0/0/0/0): 1280 * 720, scale: 1280 * 720
[06:42:29]    + Output geometry
[06:42:29]      + storage dimensions: 1280 x 720
[06:42:29]      + pixel aspect ratio: 1 : 1
[06:42:29]      + display dimensions: 1280 x 720
[06:42:29]    + encoder: H.264 (libx264)
[06:42:29]      + preset:  medium
[06:42:29]      + options: level=3.1:vbv-bufsize=3534:vbv-maxrate=1767
[06:42:29]      + profile: high
[06:42:29]      + level:   3.1
[06:42:29]      + bitrate: 1575 kbps, pass: 1
[06:42:29]      + fast first pass
[06:42:29]      + options: ref=1:8x8dct=0:me=dia:trellis=0
[06:42:29]                 analyse=i4x4 (if originally enabled, else analyse=none)
[06:42:29]                 subq=2 (if originally greater than 2, else subq unchanged)
[06:42:29]  * audio track 1
[06:42:29]    + decoder: Unknown (AAC) (2.0 ch) (track 1, id 0x1)
[06:42:29]      + samplerate: 44100 Hz
[06:42:29]    + mixdown: Stereo
[06:42:29]    + dither: triangular
[06:42:29]    + encoder: AAC (libfdk_aac)
[06:42:29]      + bitrate: 192 kbps, samplerate: 44100 Hz
[06:42:29] reader: first SCR 0 id 0x0 DTS 0
[06:42:29] encx264: min-keyint: 30, keyint: 300
[06:42:29] encx264: encoding at average bitrate 1575
[06:42:29] encx264: unparsed options: level=3.1:vbv-bufsize=3534:vbv-maxrate=1767
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2 SSE3 Cache64
x264 [info]: profile Main, level 3.1
Encoding: task 1 of 2, 98.19 % (82.77 fps, avg 106.00 fps, ETA 00h00m00s)[06:43:04] reader: done. 1 scr changes
Encoding: task 1 of 2, 100.00 % (82.77 fps, avg 106.00 fps, ETA 00h00m00s)[06:43:04] work: average encoding speed for job is 106.004883 fps
[06:43:04] sync: got 3697 frames, 3696 expected
[06:43:04] render: lost time: 0 (0 frames)
[06:43:04] render: gained time: 0 (0 frames) (0 not accounted for)
[06:43:04] h264-decoder done: 3697 frames, 0 decoder errors, 0 drops
x264 [info]: frame I:15    Avg QP:14.87  size: 59827
x264 [info]: frame P:1306  Avg QP:17.18  size: 11973
x264 [info]: frame B:2376  Avg QP:19.46  size:  3211
x264 [info]: consecutive B-frames: 13.9%  0.6%  1.5% 84.0%
x264 [info]: mb I  I16..4: 34.4%  0.0% 65.6%
x264 [info]: mb P  I16..4: 15.7%  0.0%  0.0%  P16..4: 52.1%  0.0%  0.0%  0.0%  0.0%    skip:32.2%
x264 [info]: mb B  I16..4:  2.0%  0.0%  0.0%  B16..8: 17.2%  0.0%  0.0%  direct:14.2%  skip:66.5%  L0:43.6% L1:44.8% BI:11.5%
x264 [info]: coded y,uvDC,uvAC intra: 15.5% 67.9% 17.6% inter: 6.3% 23.4% 0.2%
x264 [info]: i16 v,h,dc,p: 56% 25% 15%  4%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 35% 24% 16%  2%  6%  4%  4%  4%  5%
x264 [info]: i8c dc,h,v,p: 50% 21% 26%  3%
x264 [info]: Weighted P-Frames: Y:1.0% UV:0.8%
x264 [info]: kb/s:1567.11
[06:43:04] aac-decoder done: 0 frames, 0 decoder errors, 0 drops
[06:43:04] work: failed to initialize OpenCL environment, using fallback
[06:43:04] starting job
[06:43:04] work: sanitizing track 1 mixdown Dolby Pro Logic II to Stereo
[06:43:04] sync: expecting 3697 video frames
[06:43:04] job configuration:
[06:43:04]  * source
[06:43:04]    + ./test_file.mkv
[06:43:04]    + title 1, chapter(s) 1 to 1
[06:43:04]    + container: matroska,webm
[06:43:04]  * destination
[06:43:04]    + ./test_file.mp4
[06:43:04]    + container: MPEG-4 (libavformat)
[06:43:04]  * video track
[06:43:04]    + decoder: h264
[06:43:04]    + filters
[06:43:04]      + Framerate Shaper (0)
[06:43:04]        + frame rate: same as source (around 29.970 fps)
[06:43:04]      + Crop and Scale (1280:720:0:0:0:0)
[06:43:04]        + source: 1280 * 720, crop (0/0/0/0): 1280 * 720, scale: 1280 * 720
[06:43:04]    + Output geometry
[06:43:04]      + storage dimensions: 1280 x 720
[06:43:04]      + pixel aspect ratio: 1 : 1
[06:43:04]      + display dimensions: 1280 x 720
[06:43:04]    + encoder: H.264 (libx264)
[06:43:04]      + preset:  medium
[06:43:04]      + options: level=3.1:vbv-bufsize=3534:vbv-maxrate=1767
[06:43:04]      + profile: high
[06:43:04]      + level:   3.1
[06:43:04]      + bitrate: 1575 kbps, pass: 2
[06:43:04]  * audio track 1
[06:43:04]    + decoder: Unknown (AAC) (2.0 ch) (track 1, id 0x1)
[06:43:04]      + samplerate: 44100 Hz
[06:43:04]    + mixdown: Stereo
[06:43:04]    + dither: triangular
[06:43:04]    + encoder: AAC (libfdk_aac)
[06:43:04]      + bitrate: 192 kbps, samplerate: 44100 Hz
[06:43:04] reader: first SCR 0 id 0x0 DTS 0
[06:43:04] encx264: min-keyint: 30, keyint: 300
[06:43:04] encx264: encoding at average bitrate 1575
[06:43:04] encx264: unparsed options: level=3.1:vbv-bufsize=3534:vbv-maxrate=1767
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2 SSE3 Cache64
Encoding: task 2 of 2, 0.00 %x264 [info]: profile High, level 3.1
Encoding: task 2 of 2, 98.51 % (39.69 fps, avg 37.86 fps, ETA 00h00m02s)[06:44:41] reader: done. 1 scr changes
Encoding: task 2 of 2, 99.97 % (39.63 fps, avg 37.89 fps, ETA 00h00m00s)[06:44:43] work: average encoding speed for job is 37.892944 fps
[06:44:43] sync: got 3697 frames, 3697 expected
[06:44:43] render: lost time: 0 (0 frames)
[06:44:43] render: gained time: 0 (0 frames) (0 not accounted for)
[06:44:43] h264-decoder done: 3697 frames, 0 decoder errors, 0 drops
Encoding: task 2 of 2, 99.97 % (39.63 fps, avg 37.89 fps, ETA 00h00m00s)x264 [info]: frame I:15    Avg QP:15.44  size: 52093
x264 [info]: frame P:1306  Avg QP:18.05  size: 11364
x264 [info]: frame B:2376  Avg QP:20.43  size:  3620
x264 [info]: consecutive B-frames: 13.9%  0.6%  1.5% 84.0%
x264 [info]: mb I  I16..4: 21.8% 57.1% 21.1%
x264 [info]: mb P  I16..4:  6.4%  7.7%  0.5%  P16..4: 37.0% 11.0%  4.8%  0.0%  0.0%    skip:32.6%
x264 [info]: mb B  I16..4:  0.8%  0.9%  0.0%  B16..8: 35.4%  2.6%  0.2%  direct: 6.2%  skip:53.8%  L0:49.4% L1:47.9% BI: 2.6%
x264 [info]: 8x8 transform intra:52.5% inter:79.3%
x264 [info]: coded y,uvDC,uvAC intra: 24.5% 65.5% 17.6% inter: 6.7% 20.7% 0.3%
x264 [info]: i16 v,h,dc,p: 49% 27% 14% 11%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 21% 16% 47%  2%  3%  3%  3%  3%  2%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 31% 17% 17%  4%  7%  9%  5%  6%  4%
x264 [info]: i8c dc,h,v,p: 50% 22% 25%  3%
x264 [info]: Weighted P-Frames: Y:1.0% UV:0.8%
x264 [info]: ref P L0: 68.0%  5.9% 18.0%  8.1%  0.0%
x264 [info]: ref B L0: 89.6%  8.0%  2.4%
x264 [info]: ref B L1: 95.4%  4.6%
x264 [info]: kb/s:1570.94
[06:44:43] aac-decoder done: 0 frames, 0 decoder errors, 0 drops
Muxing: this may take awhile...[06:44:43] mux: track 0, 3697 frames, 24222790 bytes, 1571.34 kbps, fifo 2048
[06:44:43] mux: track 1, 5312 frames, 2960405 bytes, 192.04 kbps, fifo 4096
[06:44:43] libhb: work result = 0

Encode done!
Last edited by Rodeo on Sat May 23, 2015 1:57 pm, edited 1 time in total.
Reason: Logs must be placed between [code][/code] blocks
dstocker
Posts: 7
Joined: Tue Jan 17, 2012 4:56 am

Re: -O no longer with with the latest builds

Post by dstocker »

Found a solution for 0.10.1 on 15.04 which works with --optimize and/or -O

Install unofficial Handbrake PPA for Ubuntu 15.04/14.10/14.04/Linux Mint 17.1/17

sudo add-apt-repository ppa:mdeslaur/handbrake
sudo apt-get update

# show the versions available
apt-cache showpkg handbrake-cli

# for ubuntu 15.04 install use
sudo apt-get install handbrake-cli=0.10.1+ppa1-0.15.04.md.1

# once installed to prevent automatic upgrades till bugs are fixed
apt-mark hold handbrake-cli
User avatar
JohnAStebbins
HandBrake Team
Posts: 5588
Joined: Sat Feb 09, 2008 7:21 pm

Re: -O no longer with with the latest builds

Post by JohnAStebbins »

Post Reply