Search found 4926 matches

by JohnAStebbins
Fri Mar 24, 2017 10:21 pm
Forum: Command Line Interface
Topic: Reorder audio-tracks on headless system
Replies: 4
Views: 108

Re: Reorder audio-tracks on headless system

"copy:ac3" will only pass ac3 audio. If the source audio is not ac3, it will re-encode it to ac3. I believe what you want is the following -E copy,aac --audio-copy-mask=ac3,dts --audio-fallback=ac3 This means, pass through the first track if it matches audio-copy-mask and fallback to encoding to ac3...
by JohnAStebbins
Fri Mar 24, 2017 3:19 pm
Forum: Command Line Interface
Topic: Reorder audio-tracks on headless system
Replies: 4
Views: 108

Re: Reorder audio-tracks on headless system

What is your objective? Do you need both audio tracks? Do you have devices that can only play AAC? Do you require exactly aac and ac3 tracks, or would you rather have a DTS track when the source audio is DTS? To do exactly what you've asked (reorder the tracks), you can manually specify the audio co...
by JohnAStebbins
Wed Mar 22, 2017 7:58 pm
Forum: *nix
Topic: Handbrake GUI Custom Preset Won't Save Encoding Speed Other Than "Fast"
Replies: 2
Views: 134

Re: Handbrake GUI Custom Preset Won't Save Encoding Speed Other Than "Fast"

It's a known issue that has been fixed in the nightly builds and will be fixed in the next release.
by JohnAStebbins
Wed Mar 22, 2017 4:14 pm
Forum: Windows
Topic: Handbrake crashes after encode is 99% finished everytime
Replies: 4
Views: 227

Re: Handbrake crashes after encode is 99% finished everytime

According to the log, the encode completed. What happens if you try to encode the same video with the CLI instead of the GUI?
by JohnAStebbins
Sat Mar 18, 2017 4:02 pm
Forum: *nix
Topic: Encoder Preset-Slider has no effect
Replies: 5
Views: 169

Re: Encoder Preset-Slider has no effect

Ritsuka wrote:
Sat Mar 18, 2017 11:40 am
It's a known bug, fixed in https://github.com/HandBrake/HandBrake/ ... cabd31149d , either wait for the next release or compile directly from source.
Or use the nightly builds
by JohnAStebbins
Fri Mar 17, 2017 4:23 pm
Forum: Windows
Topic: True-HD/DTS-MA - Does Handbrake Transcode the Lossless Audio or the Lossy Core?
Replies: 8
Views: 281

Re: True-HD/DTS-MA - Does Handbrake Transcode the Lossless Audio or the Lossy Core?

TrueHD stores two data streams. One is the TrueHD lossless data in full and the other is a "regular" AC-3 track, usually at 640kbps. The tracks are completely separate and usable on their own. It's a little more convoluted than that. But you're approximately right. In BD transport streams (the most...
by JohnAStebbins
Fri Mar 17, 2017 3:33 pm
Forum: Windows
Topic: Queue Finished with errors
Replies: 12
Views: 476

Re: Queue Finished with errors

If so, can I ignore it until a workaround is available? This error causes the muxer to exit with an error. The muxer will correctly finalize and close the file, so the file is valid. But if there are additional frames in other tracks that follow the last frame of the audio, those frames will be los...
by JohnAStebbins
Thu Mar 16, 2017 11:12 pm
Forum: Windows
Topic: Queue Finished with errors
Replies: 12
Views: 476

Re: Queue Finished with errors

[mp4 @ 0000000029606a20] Application provided invalid, non monotonically increasing dts to muxer in stream 1: 153612463 >= 153612463 It's a glitch in the mp3 encoder. For some reason, the mp3 encoder gives us an extra frame at the end of the encode that has the exact same timestamp as the previous ...
by JohnAStebbins
Wed Mar 15, 2017 5:19 pm
Forum: Windows
Topic: How to convert .AVI file to .UDF format
Replies: 2
Views: 113

Re: How to convert .AVI file to .UDF format

What lead you to believe HandBrake could do this? Just curious if there's some bad advice being given out somewhere. HandBrake does not support what you want to do.
by JohnAStebbins
Wed Mar 15, 2017 5:14 pm
Forum: Windows
Topic: Ryzen 1700x Fails Mkv Encoding 2 Minutes In
Replies: 4
Views: 271

Re: Ryzen 1700x Fails Mkv Encoding 2 Minutes In

... and the encode causes PC to crash to a black screen. This is *always* either a hardware problem, OS problem, or driver problem. It is the responsibility of an OS to ensure that an application can not crash the system. So by definition, this can't be an application problem. Something you might t...
by JohnAStebbins
Sat Mar 11, 2017 1:18 am
Forum: Bugs
Topic: Yadif keeps crashing with ProRes media in v1.0.0 and above
Replies: 4
Views: 200

Re: Yadif keeps crashing with ProRes media in v1.0.0 and above

My TLDR comment was meant as an aid to *you*. I summarized the link that was provided to the github issue for you. Can you describe in more detail how the decomb setting doesn't have the "live video look"? Because decomb "Default" *is* yadif (as is "Bob"). Your probably asking yourself why we have 2...
by JohnAStebbins
Thu Mar 09, 2017 9:54 pm
Forum: Windows
Topic: HandBrake bug after v1.0
Replies: 3
Views: 415

Re: HandBrake bug after v1.0

Try disabling libdvdnav in settings and use libdvdread. I have had discs where it will either not read the titles, or read the disc at all. Tools > Prefrences > Advanced > Check the box "Disable LibDVDNav. Then scan for the file/disc again. He is not trying to read a DVD, so this will have no effect.
by JohnAStebbins
Wed Mar 08, 2017 10:03 pm
Forum: Command Line Interface
Topic: ERROR: encavcodec: codec context has uninitialized codec; skipping frame
Replies: 13
Views: 631

Re: ERROR: encavcodec: codec context has uninitialized codec; skipping frame

You didn't post the entire log. So we can't tell what version of HaneBrake you are running. But it looks like it is at best an old version of HandBrake and at worst a broken build that you got from who knows where.
by JohnAStebbins
Wed Mar 08, 2017 9:43 pm
Forum: Windows
Topic: Errors after video conversion.
Replies: 10
Views: 179

Re: Errors after video conversion.

So, I discovered it is a platform specific problem. On windows the audio encoder you are using (lame) outputs an extra packet of data for some reason.

If you don't absolutely require mp3 audio, you can work around it by using a different audio encoder until I can chase down why this happens.
by JohnAStebbins
Wed Mar 08, 2017 8:13 pm
Forum: Windows
Topic: Errors after video conversion.
Replies: 10
Views: 179

Re: Errors after video conversion.

A log would be nice, just for 100% certainty.

It's possible there is some platform specific difference. I'm running on Linux while you are on Windows. I'll see if I can fire this up on my win10 laptop.
by JohnAStebbins
Wed Mar 08, 2017 7:57 pm
Forum: Windows
Topic: Errors after video conversion.
Replies: 10
Views: 179

Re: Errors after video conversion.

I can't seem to reproduce your results. I don't get the "non monotonically increasing dts" error. [12:48:33] hb_init: starting libhb thread [12:48:33] thread 7f28c70b8700 started ("libhb") HandBrake 1.0.3 (2017030800) - Linux x86_64 - https://handbrake.fr 4 CPUs detected Opening /home/jstebbins/Vide...
by JohnAStebbins
Wed Mar 08, 2017 6:50 pm
Forum: Windows
Topic: Errors after video conversion.
Replies: 10
Views: 179

Re: Errors after video conversion.

Looks like a bug

Code: Select all

[mp4 @ 000001bb513280e0] Application provided invalid, non monotonically increasing dts to muxer in stream 1: 1464239 >= 1464239
Would it be possible for you to provide a sample I can use to reproduce and analyze the problem?
by JohnAStebbins
Wed Mar 08, 2017 5:07 pm
Forum: Windows
Topic: HandBrake works only 25% on Ryzen?
Replies: 7
Views: 434

Re: HandBrake works only 25% on Ryzen?

There may be helpful information in this doom9 thread
http://forum.doom9.org/showthread.php?t=174383
by JohnAStebbins
Wed Mar 08, 2017 5:05 pm
Forum: Bugs
Topic: Yadif keeps crashing with ProRes media in v1.0.0 and above
Replies: 4
Views: 200

Re: Yadif keeps crashing with ProRes media in v1.0.0 and above

TLDR; workaround is to use the decomb filter instead of the deinterlace yadif filter
by JohnAStebbins
Tue Mar 07, 2017 7:36 pm
Forum: Windows
Topic: Loss of Mono Audio Track for MOV file, Windows 7 64 bit
Replies: 6
Views: 131

Re: Loss of Mono Audio Track for MOV file, Windows 7 64 bit

Woodstock wrote:
Tue Mar 07, 2017 7:34 pm
There was an issue with libav not liking mono PCM tracks, but I thought someone said it was fixed. Maybe not?
The logs indicate there was no problem encoding the audio track the OP selected. This is likely just a case where one of the 2 audio tracks in the source is nothing but silence.
by JohnAStebbins
Tue Mar 07, 2017 5:20 pm
Forum: Windows
Topic: Loss of Mono Audio Track for MOV file, Windows 7 64 bit
Replies: 6
Views: 131

Re: Loss of Mono Audio Track for MOV file, Windows 7 64 bit

[11:20:30] mux: track 0, 67400 frames, 40877478 bytes, 145.56 kbps, fifo 16384 [11:20:30] mux: track 1, 70207 frames, 26959488 bytes, 96.00 kbps, fifo 16384 From the above, it appears you successfully enocded 1 video track with 67400 frames and 1 audio track with 70207 frames. Your source file has ...
by JohnAStebbins
Tue Mar 07, 2017 3:48 am
Forum: Windows
Topic: HandBrake works only 25% on Ryzen?
Replies: 7
Views: 434

Re: HandBrake works only 25% on Ryzen?

ashleylai87 wrote:
Tue Mar 07, 2017 3:00 am
--pmode
--pme

Use above.
Maybe he did. But without an activity log, there's no way to know.
by JohnAStebbins
Mon Mar 06, 2017 5:21 pm
Forum: Tiki Bar
Topic: Handbrake crashes OSX abruptly
Replies: 8
Views: 282

Re: Handbrake crashes OSX abruptly

I'm therefore tempted to believe that it is a software problem. Software issues *can* crash an OS hard. But when this happens, it is *always* a bug in the OS or an OS driver. It is the responsibility of the OS to make sure that non-privileged applications can not take the system down. So any time s...
by JohnAStebbins
Mon Feb 27, 2017 1:19 am
Forum: General
Topic: A few queries regarding settings in 1.0.3
Replies: 8
Views: 625

Re: A few queries regarding settings in 1.0.3

Automatic attempts to maximize storage resolution (while *not* upscaling) on both the x and y axis. For example, you have a source video that is 1920x1080 that is cropped to 1920x800 (for 2.4:1 display aspect). If your preset sets a max resolution of 1280x720 and uses automatic anamorphic. The resul...
by JohnAStebbins
Fri Feb 24, 2017 5:35 pm
Forum: Bugs
Topic: Audio fails to transcode on some MOV files
Replies: 3
Views: 180

Re: Audio fails to transcode on some MOV files

The fix has been committed.
https://github.com/HandBrake/HandBrake/ ... 904c4f9640

The next nightly build should have this fix.